 SAP Solution Manager

SAP Solution Manager

Цель использования

Система SAP Solution Manager может использоваться в рамках всего жизненного цикла решений: от концептуального проекта и конфигурации до продуктивной эксплуатации. Эта система предоставляет центральную точку доступа к методам инструментальных средств и предварительно сконфигурированному содержимому, которыми можно воспользоваться в ходе тестирования, внедрения и продуктивной эксплуатации решений.

Функциональные возможности

Внедрение mySAP Business Suite

· Все фазы проекта внедрения (концептуальный проект, реализация) выполняются централизованно в системе SAP Solution Manager.

· Центральный репозитарий проектной документации находится в системе SAP Solution Manager.

· Интегрированные функциональные возможности Управления проектом позволяют управлять планированием сроков, ресурсов персонала и других данных проекта.

Синхронизация настройки

· С помощью Customizing Scout можно сравнивать настройки различных компонентов mySAP, например, параметры настройки в системе R/3 и SAP CRM.

· С помощью функции Распределение настройки можно синхронизировать настройку в различных компонентах mySAP.

Тестирование

· Для организации и выполнения тестов в конце фазы проекта можно воспользоваться инструментальными средствами тестирования.

· Также поддерживается повторное использование структуры проекта для ориентированных на процессы тестов.

Глобальное развертывание

В интегрированной творческой среде клиенты и партнеры могут создавать свои собственные шаблоны, которые могут быть повторно использованы в дочерних компаниях, например, в ситуации глобального развертывания.

Управление электронным обучением

Создание учебного материала и учебных карт (интерактивных курсов самообучения) для обучения конечных пользователей после внедрения новых функций

Контроль решения

· Администрирование центральной системы

· Анализ системной среды с помощью системы отчетов по уровню сервиса

· Контроль системы в режиме реального времени

· Контроль бизнес-процессов

Сервисы

Доступ к программам и сервисам, которые служат для контроля и оптимизации производительности и доступности системных сред, а также минимизации рисков при выполнении системных операций.

Служба поддержки

Поддержка решения с помощью потока операций для создания и обработки сообщений о проблемах.

См. также:

· Использование SAP Solution Manager в проектах

· Управление решениями

· Контроль решения


 Использование SAP Solution Manager в проектах

Использование SAP Solution Manager в проектах

Цель использования

Использование SAP Solution Manager для оценки и внедрения (проект внедрения)

Система SAP Solution Manager может быть использована в целях тестирования и внедрения решений.

Использование SAP Solution Manager для разработки предварительно сконфигурированного содержимого (шаблоны)

С помощью системы SAP Solution Manager можно создать решение, которое будет играть роль шаблона для проекта внедрения. Такое решение содержит пакет предварительно сконфигурированного содержимого с возможностью его повторного использования (документация, предварительная конфигурация и контрольные примеры). В следующем разделе приводится описание только типичного процесса реализации проекта внедрения. Для получения дополнительной информации по созданию предварительно сконфигурированного содержимого и шаблонов см. Создание модели.

Выполнение

...

1. Маршрутные карты содержат информацию и процедуры для всех фаз проекта.

В системе SAP Solution Manager используются функциональные возможности Knowledge Warehouse, поставляемые с SAP Web Application Server. Система SAP Solution Manager также может функционировать в случае, если версия Knowledge Warehouse была установлена ранее. Однако наличие уже установленной версии не является обязательным условием для использования системы SAP Solution Manager.

2. Фактически, работа пользователя с системой SAP Solution Manager начинается после фазы оценки. Первым шагом является определение проекта в системе SAP Solution Manager. В транзакции Управление проектом вводятся необходимые управляющие данные, например, подробная информация о сроках проекта и ресурсах.

3. В фазе подготовки проекта устанавливается объем проекта.

4. В фазе подготовки проекта также определяется системная среда , требуемая для внедрения решения электронного бизнеса.

5. Документирование организационных единиц, основных данных, бизнес-сценариев и бизнес-процессов, необходимых для внедрения решения электронного бизнеса, выполняется при определении концептуального проекта . Во время определения концептуального проекта пользователь знакомится с документацией, предоставленной SAP и партнерами, создает свою собственную проектную документацию и присваивает индивидуальные шаги процессов транзакциям.

6. Бизнес-сценарии конфигурируются в системе разработок.

7. Проверяются контрольные примеры, поставляемые вместе с решением, и выполняется присвоение дополнительных контрольных примеров индивидуальным процессам и шагам процессов.

8. В отношении настройки бизнес-процессов выполняется проверка непротиворечивости. Другими словами, проверяется идентичность параметров настройки в различных прикладных компонентах. При помощи функции Распределение настройки выполняется синхронизация настройки.

9. затем организовывается тестирование. На этом этапе повторно используются контрольные примеры, выбранные во время конфигурации.

10. Для обучения конечных пользователей создается учебный материал и учебные карты (интерактивные курсы самообучения).

· В любое время можно ознакомиться с данными по статусу и динамике проекта при помощи функции Анализ проекта .

· В пользовательских параметрах настройки имеется возможность выбора режима показа или скрытия закладок концептуального проекта и конфигурации.


 Роли в SAP Solution Manager

Роли в SAP Solution Manager

Определение

В концепции полномочий для SAP Solution Manager используются следующие роли: руководитель проекта , консультант по приложению, консультант по разработкам и технический консультант. Каждая роль включает в себя набор задач для определенного проекта внедрения.

Использование

Следующие роли содержат необходимые центральные полномочия и могут быть адаптированы для использования в отдельных проектах:

· Руководители проекта [SAP_SOL_PM_COMP] несут ответственность за организацию и планирование проекта, а также контроль затрат и сроков.

· Консультанты по приложениям [SAP_SOL_AC_COMP] несут ответственность за бизнес-содержимое и документацию оперативных транзакций. Данной роли присвоены ограниченные полномочия, так как она предусмотрена для тех сотрудников проекта, роли которых в системе должны настраиваться в индивидуальном порядке.

· Консультанты по разработкам [SAP_SOL_BC_COMP] несут ответственность за разработку специфичных для клиента программ и полномочий.

· Технические консультанты [SAP_SOL_TC_COMP] отвечают за инсталляцию систем и предоставление технической поддержки пользователям.

· Пользователь с полномочиями только для просмотра/чтения [SAP_SOL_RO_COMP]: такие пользователи имеют права только на просмотр/чтение данных SAP Solution Manager.

Структура

Роли в SAP Solution Manager являются групповыми. Групповые роли состоят из отдельных ролей, которые, в свою очередь, содержат полномочия на выполнение отдельных функций, например, концептуального проекта .

См. также:

Для получения дополнительной информации, обзора ролей и соответствующих им полномочий см. пункт Полномочия в описании закладок и транзакций SAP Solution Manager. Данная тема также включает информацию относительно полномочий, необходимых в системах прикладных компонентов для ролей в SAP Solution Manager.


 Полномочия

Полномочия

Полномочия присваиваются проектным ролям в течение фазы внедрения проекта в SAP Solution Manager. Эти полномочия определяют уровень доступа сотрудников проекта к функциям и транзакциям проекта. Для проекта доступны следующие полномочия:

A | Пользователь с этой проектной ролью обладает всеми полномочиями на выполнение функций и транзакций.
D | Пользователь с этой проектной ролью может вызывать функции или транзакции только в режиме просмотра.
N | Пользователь с этой проектной ролью не имеет никаких полномочий; данные функции или транзакции отсутствуют в меню этой проектной роли.

Полномочия

Меню/функция | Роль |  |  |  |  | Примечания к объектам полномочий
 | Руководитель проекта SAP_SOL_PM_COMP | Консультант по приложению SAP_SOL_AC_COMP | Консультант по разработкам SAP_SOL_BC_COMP | Технический консультант SAP_SOL_TC_COMP | Пользователь с полномочиями на просмотр SAP_SOL_RO_COMP |
Управление проектом (solar_project_admin) | sap_sol_proj_admin_all | sap_sol_proj_admin_dis | sap_sol_proj_admin_dis | sap_sol_proj_admin_dis | sap_sol_proj_admin_dis |
Создание, изменение, копирование, удаление проекта | A | N | N | N | D | s_project, s_projects, s_proj_gen
Общие данные | A | D | D | D | D | s_project
Объем | A | D | D | D | D | s_proj_gen, s_hierarch
Члены проектной группы | A | D | D | D | D | s_project: act 78
Стандарты проекта | A | D | D | D | D | s_iwb_adm, s_project, s_projects
Управление пользователями (1) | N (1) | N | N | N | N | s_user*
Системная среда | D | D | D | A | D | s_proj_gen: syst (также используется с solar02 config structure); s_smsyedit, s_cd_syst
Коллектор шаблонов (solar_collection) | A | N | N | N | N | s_tcode
Сравнение и корректировка (sa_project_upgrade) | A | N | N | N | N | s_tcode; s_hierarch: act 01 только для преобразователя
Миграция проектов (sa_migration, solar_migration) | A | N | N | N | N | s_tcode; s_proj_gen: proj_func=mig
Обзор проекта (solman_project) | A | A (2) | A (2) | A (2) | A (2) | s_tcode
solar_project_create | A | N | N | N | N | s_tcode; требуется для solman_project
Быстрая настройка проекта (AI_SPS) | A | N | N | N | N | s_tcode
Анализ проекта (solar_eval) | A | A | A | A | A | s_project: act=71
 | sap_sol_transport_exe | sap_sol_transport_dis | sap_sol_transport_exe | sap_sol_transport_exe |  |
Запросы на перенос в solar_project_admin (3) | A | D | A | A | N | s_transprt, s_dataset, s_cts_admi:proj, s_c_funct
Системная среда (smsy) | sap_smsy_dis | sap_smsy_dis | sap_smsy_dis | sap_smsy_all | sap_smsy_dis | s_smsyedit, s_cd_syst, s_appl_log; s_tabu_dis:03/&NC;* для oпределения атрибута; s_develop: 03/ai…/smsy_setup для настройки меню запроса; s_gui:61
Создание, изменение, просмотр (smsy) | D | D | D | A | D |
Настройка (smsy_setup) | N | N | N | A | N |
Дистанционное чтение системных данных | N | N | N | A | N |
Список Plug-In (solman_pluginlist) | D | D | D | A | D | s_tcode, s_tabu_dis: dicbercls=pima, для A: act=02, для D: act=03
Маршрутная карта (rmmain) | sap_rmmain_all | sap_rmmain_exe | sap_rmmain_exe | sap_rmmain_exe | sap_rmmain_dis |
Структура | D | D | D | D | D |
Статус | A | A | A | A | D | s_project: act. A3
Сообщения | A | A | A | A | D |
Проектная документация | A | A | A | A | D | s_project:76, A3; s_iwb:02, iwbsolar
Акселераторы | D | D | D | D | D | s_asapiaa=03. s_asapiad=03
Члены проектной группы | A | D | D | D | D | s_gui:61; s_project: act. 78
Ключевые слова | A | A | A | A | D |
Концептуальный проект (solar01) | sap_solar01_all | sap_solar01_all | sap_solar01_exe |  | sap_solar01_dis |
Структура | A | A | D | N | D | ai_sa_tab: 90 s_develop:shi3; s_hierarch: act 01,2,3,6,21, v1, v3, v4, V5, VE,; devclas open; tree type bmbc0-bmef0, BMIMG - BMTC1, ref*, sa *; act01 только для преобразователя
Общая документация (4) | A | A | D | N | D | s_iwb, s_iwb_adm, загрузка: s_gui 61
Проектная документация | A | A | A | N | D | s_ai_tab: 02 docu; загрузка: s_gui 60, 61
Администрирование | A | A | D | N | D | s_iwb, s_doku_aut; s_gui 61; s_project
Транзакции | A | A | A | N | D | s_rfc
Сообщения | A | A | A | N | D |
Графика (5) | A | A | D | N | D | ai_sa_tab
Изменение глобальных элементов | A | A | N | N | N | s_proj_gen: proj_func=glob
Конфигурация (solar02) | solar02_all | solar02_all | solar02_exe |  | solar02_dis |
Общая документация (4) | A | A | D | N | D | s_iwb, s_doku_aut
Проектная документация | A | A | A | N | D | s_project; act 76, 23
Администрирование | A | A | D | N | D | s_project: 78, A3; s_gui: 61
Транзакции | A | A | A | N | D | s_rfc
Конфигурация | A | A | D | N | D | s_rfc; s_bcsets: act. 07, 63 только для A
Разработка | A | A | A | N | D | ai_sa_tab: tabname=dev
Контрольные примеры | A | A | A | N | D | s_twb, s_develop, s_rfc
Сообщения | A | A | A | N | D |
Структуры конфигурации | A (6) | D | D | N | D | ai_sa_tab: tabname=struct; s_proj_gen: syst
Графика (5) | D | D | D | N | D |
Изменение глобальных элементов | A | A | N | N | N | s_proj_gen: proj_func=glob
Создание учебного материала | sap_training_edit (7) | sap_training_edit (7) | N | N | N |
Учебный материал (solar02) | A | A | N | N | N |
Роли конечного пользователя (solar02) | A | A | N | N | N |
Управление учебными картами (solar_learning_map) | sap_training_edit (7) | sap_training_edit (7) | N | N | N |
 | A | A | N | N | N |
Сравнение настройки (scout) | sap_scout_all | sap_scout_all |  | sap_scout_all | sap_scout_dis |
Сравнение настройки (scout) | A | A | N | A | D | s_cd_sync: 71 для запуска scout, s_appl_log: scout s_cd_sysac:71 для создания, обработки, удаления прогонов; s_tabu_cli/dis/rfc
Удаление журнала (slg2) | A | A | N | A | N |
Распределение настройки (scdt *) | sap_scdt_dis | sap_scdt_all |  | sap_scdt_dis | sap_scdt_dis | s_cd_sysac, s_cd_sync; s_rfcacl; s_rfc: RFC_NAME = SCCA; s_bcsets: act 07, 63
Настройка (scdt_setup) | D | A | N | D | D |
Группы синхронизации (scdt_groups) | D | A | N | D | D | s_rfc: scdt_build_object_tables
Просмотр объектов синхронизации (scdt_show_mapping) | D | A | N | D | D | s_tabu_dis; s_tabu_cli
Создание объектов синхронизации (scdt_mapping) | N | A | N | N | N | s_tcode
Распределение переносов (scdt_fetch) | N | A | N | N | N | s_tabu_rfc_ s-tabu_cli; s_rfc; s_appl_log: distrib
Журналы (scdt_log) | D | A | N | D | D | s_appl_log: distrib
Удаление журналов (scdt_log_delete) | N | A | N | N | N | s_tcode
Организация тестирования (stwb_2) | sap_stwb_2_all | sap_stwb_2_all | sap_stwb_2_dis |  | sap_stwb_2_dis |
Планы тестирования | A | A | D | N | D |
Пакеты тестов | A | A | D | N | D |
Тестирование (stwb_work) | sap_stwb_work_all | sap_stwb_work_all | sap_stwb_work_all |  |  | Тестирование (stwb_work)
 | A | A | D | N | N |
Инфо-система инструментальных средств тестирования (stwb_info) | sap_stwb_info_all | sap_stwb_info_all | sap_stwb_info_dis |  | sap_stwb_info_dis |
 | A | A | D | N | D |
Центральные настройки инструментальных средств тестирования (stwb_set) | sap_stwb_set_all | sap_stwb_set_all |  |  |  |
 | A | A | N | N | N |
Сообщения базиса (dnotifwl) | sap_sv_fdb_notif_bc_process | sap_sv_fdb_notif_bc_process | sap_sv_fdb_notif_bc_process | sap_sv_fdb_notif_bc_process | sap_dnotifwl_dis |
 | A | A | A | A | D |

Примечания

№ | Описание
(1) | Роли SAP Solution Manager не включают полномочия для управления пользователями (транзакция SU01).
(2) | Только в шаблонных проектах.
(3) | Доступно только через код транзакции.
(4) | D в проектах внедрения, А в шаблонных проектах.
(5) | Необходимо активировать ActiveXControls в веб-браузере.
(6) | Из sap_proj_admin_all
(7) | Для ролей Руководитель проекта и Консультант по приложению SAP Solution Manager 3.10 SP13
(8) | Для всех ролей SAP Solution Manager 3.10 SP13


 Руководитель проекта

Руководитель проекта

Техническое имя: SAP_SOL_PM_COMP

Задачи

Руководители проекта несут ответственность за достижение требуемых результатов проекта и ежедневное управление проектом. Они предугадывают возможные отклонения в ходе выполнения проекта и немедленно вносят необходимые корректировки. Руководители проекта также должны учитывать связь бизнес-процессов с другими процессами в рамках всего предприятия.

Руководители проекта также являются членами управляющего комитета. Они обладают полномочиями для принятия решений в вопросах, касающихся программы и бюджета. Для принятия совместных решений руководитель проекта направляет стратегические вопросы заказчику.

Операции в SAP Solution Manager

Основными обязанностями руководителя проекта являются:

· Организация всего проекта;

· Разработка стратегий и операций для эффективного внедрения SAP;

· Разработка и ведение плана по срокам проекта внедрения;

· Определение и управление объемом проекта, бюджетом и сроками в соответствии с утвержденными планами;

· Распределение и управление средствами;

· Мониторинг динамики проекта по неделям;

· Выполнение отчетов и анализов;

· Выполнение официальной проверки в конце каждой фазы;

· Своевременное решение проблем;

· Регулярное уведомление комитета по проверке о динамике процесса и статусе проекта;

· Представление проекта внутри компании и на стороне;

· Уведомление об изменениях статуса всей проектной группы.

Руководитель проекта может также скопировать в проект SAP Solution Manager содержимое проекта ValueSAP версии 2. См. документацию по инструменту миграции.

Примечания по адаптации

При необходимости получения дополнительных полномочий можно воспользоваться ролью SAP_BC_CUS_ADMIN: данная роль включает полномочия для администрирования проектов настройки в системах компонентов.

Подробная информация о полномочиях, доступных в системах компонентов, содержится в руководстве по конфигурации SAP Solution Manager.

Интеграция

Руководитель проекта определяет содержимое и сроки проекта внедрения, осуществляет управление ресурсами и контроль динамики проекта. Консультант по приложению представляет отчеты руководителю проекта и оказывает ему поддержку в выполнении административных функций.


 Консультант по приложению

Консультант по приложению

Техническое имя: SAP_SOL_AC_COMP

Задачи

Консультанты по приложению несут ответственность за проверку того, адаптированы ли концептуальный проект и конфигурации программного обеспечения к бизнес-процессам, а также выполнение требований по анализу и отчетности. При выполнении этих задач консультанты по приложению эффективно используют свои знания относительно проверенных на практике бизнес-процедур. Консультанты по приложению также обеспечивают консультационную поддержку и работают в тесном сотрудничестве с остальными членами проектной группы.

При необходимости экстракции старых данных они также тесно взаимодействуют с экспертами по прежней системе.

Операции в SAP Solution Manager

Основными обязанностями консультанта по приложению являются:

· Поддержка определения и моделирования бизнес-процессов;

· Проверка совместимости бизнес-модели с продуктами SAP;

· Конфигурирование программного обеспечения в соответствии с требованиями бизнес-процессов, а также требований по анализу и отчетности;

· Определение необходимости стандартизации на глобальном и локальном уровне;

· Определение необходимости организационных изменений на предприятии;

· Поддержка распространения имеющихся знаний среди других членов проектной группы;

· Поддержка в ходе организации и выполнения тестирования;

· Определение необходимости создания профилей полномочий и полномочий доступа;

· Анализ статистической производительности и представление рекомендаций по ее оптимизации;

· Создание и разработка решений по управлению данными и стратегий, отвечающих требованиям соответствующего компонента SAP (например, APO, BW, CRM);

· Создание учебных материалов по новым функциям для конечных пользователей.

В сферу ответственности консультант по приложению не входит следующее:

· Техническое внедрение решения;

· Программирование интерфейсов и других разработок;

· Решение проблем с качеством данных (проблемами с качеством данных занимается руководитель проекта).

Примечания по адаптации

Данная роль содержит только основные функции. При необходимости получения дополнительных полномочий можно воспользоваться следующими ролями:

· SAP_BC_CUS_CUSTOMIZER содержит полномочия для работы с IMG-операциями.

Для прикладных компонентов может быть полезна следующая роль:

· SAP_BC_CUS_CUSTOMIZER

Интеграция

Консультанты по приложениям несут ответственность за разработку бизнес-содержимого и документации по выполняемым операциям согласно соответствующим стандартам. Разработка специфичных для клиента программ и полномочий осуществляется консультантом по разработкам.


 Консультант по разработкам

Консультант по разработкам

Техническое имя: SAP_SOL_BC_COMP

Задачи

Консультанты по разработкам, совместно с руководителем проекта и консультантами по приложениям, участвуют в планировании и реализации концепции полномочий. Они также выполняют задачи по разработке, в частности, созданию специфичных для клиента решений.

ОперациивSAP Solution Manager

Основными обязанностями консультанта по разработкам являются:

· Реализация концепции полномочий;

· Разработка ABAP-программ, например, интерфейсов, форм или модификаций;

· Работа с инструментальными средствами ABAP.

Примечания по адаптации

При необходимости получения дополнительных полномочий можно воспользоваться следующими ролями:

· SAP_BC_DWB_ABAPDEVELOPER: содержит полномочия для внедрения новых приложений и расширений, а также для изменения и модификации стандартных приложений с использованием инструментальных средств и сервисов, доступных в инструментальных средствах ABAP.

· SAP_BC_TRANSPORT_ADMINISTRATOR: содержит полномочия на выполнение всех функций системы изменений и переносов.

Интеграция

Консультанты по разработкам отвечают за выполнение задач по программированию, согласованных с руководителем проекта и консультантами по приложениям, в отличие от технических консультантов, которые рассматриваются как системные администраторы и несут ответственность за установку систем и предоставление технической поддержки пользователям.


 Технический консультант

Технический консультант

Техническое имя: SAP_SOL_TC_COMP

Задачи

Технические консультанты планируют технические потребности проекта вместе с руководителем проекта и менеджером технической группы и затем выполняют требуемые технические задачи в системе.

В зависимости от объема и сложности внедрения, технические консультанты могут работать в нескольких областях, например, администрирование системы, управление базой данных, администрирование сети, администрирование операционной системы, разработка общих для всех приложений компонентов или ABAP-разработки.

В международных проектах технические консультанты также предоставляют консультации в следующих областях:

· Специфичные для страны бизнес-потребности и требования к программному обеспечению SAP;

· Требования, специфические для определенного языка или кодировки;

· Проблемы, связанные с часовыми поясами.

Операции в SAP Solution Manager

Основными обязанностями технического консультанта являются:

· Установка и настройка системной среды

· Управление системной средой и соответствующей средой переносов

· Предоставление поддержки и консультаций во всех технических вопросах в течение проекта внедрения

· Ежедневные отчеты об обновлениях в технической среде проекта, включая уведомление об отклонениях;

· Разработка и реализация плана подготовки к продуктивному старту перед началом продуктивной эксплуатации;

· Организация эффективного взаимодействия с группой по бизнес-процессам;

· Эффективная передача знаний сотрудникам, отвечающим за управление системой.

Для выполнения этих задач технический консультант должен отвечать следующим требованиям:

· Углубленные знания в областях баз данных, сетей, программирования и Интернет-технологий;

· Углубленные знания решений SAP.

Примечания по адаптации

При необходимости получения дополнительных полномочий можно воспользоваться следующими ролями:

SAP_BC_RRR_SAA_ADMIN: полномочия для выполнения всех задач в системе при помощи Ассистента по системному администрированию.

Интеграция

Технический консультант действует как системный администратор и несет ответственность за установку систем и предоставление технической поддержки пользователям, в отличие от основного консультанта, который выполняет поручения руководителя проекта и консультанта по приложению и отвечает за задачи программирования.


 Маршрутная карта

Маршрутная карта

Цель использования

Маршрутные карты являются частью SAP Solution Manager. Они содержат стандартную методологию внедрения SAP и информацию о важнейших аспектах и фазах внедренияmySAP.com. Маршрутные карты предоставляют ссылки на акселераторы и инструментальные средства, предназначенные для выполнения задач проекта.

Интеграция

После присвоения проекту маршрутной карты в Управлении проектом этапы выбранной маршрутной карты будут выведены на закладке Этапы в Управлении проектом.

Функциональные возможности

Просмотр без ссылки на проект

Если проект в SAP Solution Manager еще не определен или не присвоен маршрутной карте, при первоначальном вызове SAP Solution Manager предлагает ряд маршрутных карт без ссылки на какой-либо проект.

Для перехода от маршрутной карты со ссылкой на проект к маршрутной карте без ссылки на проект выберите Другой проект ® Без проекта и затем выберите маршрутную карту.

Маршрутные карты без ссылки на проект доступны только для просмотра.

Имеются следующие возможности:

· осуществление навигации в структуре;

· поиск записей в структуре маршрутной карты;

· просмотр присвоенных документов и акселераторов;

· определение фаз проекта посредством этапов;

· идентификация ссылок на SAP Service Marketplace с информацией о подходящих SAP-сервисах посредством сервисных пакетов;

· фильтрация структуры маршрутной карты по ролям, разделам или вариантам;

· печать документов или структур с соответствующими документами;

· выгрузка оффлайн-версии маршрутной карты (HTML).

Просмотр со ссылкой на проект

Для перехода к маршрутной карте, присвоенной проекту в Управлении проектом, используется пункт меню Другой проект.

При использовании маршрутной карты в проекте внедрения, наряду с функциями маршрутная карта без ссылки на проект доступны следующие функции:

· присвоение ключевых слов структурным элементам маршрутной карты;

· присвоение статуса структурным элементам маршрутной карты;

· присвоение членов проектной группы структурным элементам;

· фильтрация структуры маршрутной карты по ключевым словами и присвоенным членам проектной группы;

· создание специфичных для проекта примечаний для структурных элементов маршрутной карты;

· создание проектной документации;

· создание сообщений;

· выгрузка маршрутной карты в MS Project для создания плана проекта .

Ограничения

Структуру маршрутной карты изменить невозможно.


 Начальный ракурс маршрутной карты

Начальный ракурс маршрутной карты

Определение

Начальный ракурс маршрутной карты представляет собой упрощенный обзор этапов проекта, необходимых для внедрения mySAP.

Использование

Начальный ракурс предоставляет членам проектной группы релевантные для определенного проекта шаги маршрутной карты. Имеются ссылки на подструктуры ракурса структуры маршрутной карты.

Структура

Фазы

На первом уровне структуры маршрутной карты фазы маршрутной карты располагаются в горизонтальном направлении.

Рабочая область

Рабочая область структурирована и содержит ссылки на пакеты работ, операции и задачи в ракурсе структуры маршрутной карты. Выберите ссылку для перехода к ракурсу структуры маршрутной карты в рамках данного режима. Для просмотра доступны маршрутная карта и документы. Возврат к начальному ракурсу осуществляется путем нажатия кнопки Назад.

Статус

Также можно просмотреть статус обработки и статус сообщений шагов или соответствующих им субшагов.

Интеграция

Фильтры, используемые в ракурсе структуры маршрутной карты, не влияют в значения в начальном ракурсе маршрутной карты.


 Ракурс структуры маршрутной карты

Ракурс структуры маршрутной карты

Определение

Ракурс структуры является общим ракурсом маршрутной карты.

Структура

Область проекта

В левой области экрана содержится структура маршрутной карты с атрибутами. Структура включает следующие элементы:

· Фаза (уровень 1)

Маршрутная карта включает фазы, каждая из которых отражает главный компонент проекта внедрения.

· Пакет работ (уровень 2)

Каждая фаза маршрутной карты включает в себя пакеты работ для достижения поставленных в рамках фазы целей. Пакеты работ содержат операции и задачи.

· Операция (уровень 3)

Каждый пакет работ включает в себя различные операции. Операции содержат задания, которые должны быть выполнены одним или более членами проектной группы для достижения определенных целей. Этот уровень содержит акселераторы, т.е. документы, шаблоны и руководства, которые могут использоваться для внедрения решения mySAP.

· Задача (уровень 4)

Каждая операция включает несколько задач. В документах маршрутной карты подробно описываются шаги, необходимые для выполнения каждой задачи. Задачи выполняются членами проектной группы. Этот уровень также содержит акселераторы для внедрения решения mySAP.

Область просмотра

В правой верхней части экрана отображается описание структурного элемента, выбранное в области проекта.

Функции фильтрации

Функции фильтрации позволяют ограничивать или разворачивать ракурс структуры и начальный ракурс маршрутной карты по ролям, тематическим областям и вариантам.

Если атрибуты, присвоенные акселератору в SAP, не удовлетворяют условиям фильтрации, акселератор становится скрытым.
Атрибуты акселератора можно просмотреть путем двойного щелчка по пиктограмме "Атрибуты" на закладке Акселератор.

Кроме того, ракурс маршрутной карты со ссылкой на проект можно ограничить или развернуть по статусу структурных элементов и присвоенным ключевым словам.

Расширенная функция поиска

Следующую информацию можно просмотреть в виде списка под шагом структуры после нажатия кнопки Перейти к:

· акселератор;

· примечания;

· сообщения;

· проектная документация.

Параметры настройки пользовательского интерфейса

· Определите, вводится ли маршрутная карта через ракурс структуры или начальный ракурс, путем выбора Параметры настройки ® Специфика пользователя.

· Для показа или скрытия нумерации структуры (структурных планов проекта, СПП) выберите Маршрутная карта ® Показать или скрыть СПП-нумерацию.


 Маршрутная карта проекта

Маршрутная карта проекта

Использование

Маршрутная карта проекта используется в проекте внедрения для документирования динамики проекта и предоставления и распространения информации для проектной группы.

Предпосылки

В Управлении проектом создан проект, которому присвоена маршрутная карта.

Функциональные возможности

Закладка "Акселератор"

На закладке "Акселератор" система приводит список акселераторов, например, документов Microsoft Word, презентаций PowerPoint и транзакций. Акселератор вызывается при помощи двойного щелчка.

Можно просмотреть список акселераторов, присвоенных каждому структурному шагу. Выберите Перейти к ® Акселераторы.

Закладка "Статус/примечания"

· На закладке Статус/примечания можно создавать примечания относительно структурных элементов. Система автоматически сохраняет введенные данные при выходе из закладки.

· Для изменения статуса структурного шага щелкните по значку статуса перед структурным шагом или установите статус при помощи экранной кнопки на закладке Статус/примечания.

Статус передается вверх по структуре. В случае изменения статуса, переданного вверх к структурному шагу более высокого уровня, система отмечает статус этого структурного шага как установленный вручную при помощи пиктограммы. Статус структурного шага можно сбросить до переданного вверх статуса при помощи экранной кнопки Статус.

Закладка "Члены проектной группы"

В Управлении проектом на закладке Члены проектной группы членам проектной группы можно присвоить структурные элементы, используемые в проекте.

Закладка Сообщения

Закладка Сообщения используется для создания и отправки сообщений. Более подробная информация содержится в описании закладки Сообщения.

Закладка "Проектная документация"

· Имеется возможность добавления документов, транзакций и URL-ссылок и присвоения структурных шагов при помощи экранных кнопок.

· Для просмотра или выполнения присвоенных элементов необходимо дважды щелкнуть по ним.

Закладка "Ключевые слова"

На закладке Ключевые слова каждому структурному шагу можно присвоить специфичные для проекта ключевые слова, присвоенные проекту на подзакладке Ключевые слова закладки Стандарты проекта в Управлении проектом. Эти ключевые слова могут использоваться для поиска структурных элементов во время анализа проекта .

При помощи экранной кнопки Внесение массовых изменений на закладке Ключевые слова можно передавать ключевые слова, присвоенные структурному шагу, вниз по структуре. Эти ключевые слова, переданные вниз до шагов более низкого уровня, могут быть удалены при помощи экранной кнопки Удалить запись.


 Выгрузка структуры проекта или маршрутной карты в MS Project

Выгрузка структуры проекта или маршрутной карты в MS Project

Использование

Выгрузка структуры проекта или маршрутной карты в MS Project выполняется с целью планирования проекта с использованием данных структуры проекта или маршрутной карты.

Предпосылки

На локальном компьютере установлен MS Project.

На фазе концептуального проекта была создана структура проекта или вызвана маршрутная карта. Выполнен переход к транзакции Концептуальный проект или ракурсу структуры маршрутной карты.

Создан, по крайней мере, один структурный элемент с данными на самом низком уровне под каждым структурным элементом в концептуальном проекте, в результате чего в MS Project данные отображаются правильно.

Последовательность шагов

...

1. В транзакции Концептуальный проект выберите Концептуальный проект ® Выгрузка в MS Project.

В ракурсе структуры маршрутной карты выберите Маршрутная карта ® Выгрузка ® Версия MS Project.

2. В следующем диалоговом окне выберите папку для файла и в случае необходимости измените имя файла.

3. Сохраните файл.

4. Подтвердите появляющееся системное сообщение нажатием кнопки Дальше.

Результат

Структура проекта или маршрутная карта создается как файл MPX и выводится для просмотра в MS Project. После этого файл можно сохранить в формате MPP и выполнить его обработку.

Следующие параметры настройки устанавливаются в MS Project, что позволяет просмотреть все требуемые поля после выгрузки маршрутной карты или структуры проекта:

...

1. Определите пользовательскую таблицу просмотра путем выбора Ракурс ® Таблица ® Другие таблицы... ® Нов.

2. При необходимости создайте одно или более из перечисленных ниже полей для таблицы просмотра:

Поля, созданные SAP

Поле | Описание
Уникальный идентификатор | Текущий номер в MS Project.
Текст 1 | SAP GUID структурного элемента.
Имя | Имя структурного элемента.
Уровень структуры | Уровень структуры структурного элемента.
Приоритет | Приоритет структурного элемента.
Этап | Флаг этапа в маршрутной карте.
Текст 2 | Статус структурного элемента.
% выполнения |
Начало нормативного срока |
Конец нормативного срока |
Продолжительность нормативного срока |
ФактическНачало |
ФактКонец |
ФактПродолжит |
Остат. продолжит. |
Имена ресурсов | Члены проектной группы


 Создание оффлайн-вариантов

Создание оффлайн-вариантов

Использование

Имеется возможность создания оффлайн-версии документации маршрутной карты, выгрузки этой версии на портативный компьютер и изучения документов в автономном режиме.

Таким образом можно просматривать документы вне SAP-системы.

Последовательность шагов

...

1. Выберите Маршрутная карта ® Выгрузка ® HTML-версия.

2. В диалоговом окне выберите виды документации (например, Акселератор). Они отображаются в виде закладок на первом экране оффлайн-версии.

3. Выберите переключатель Создать ярлык.

4. В диалоговом окне Каталог подтвердите предложенный по умолчанию каталог или выберите другой.

Шаги 2 и 3 являются необязательными. Шаг 4 является обязательным.

5. Для создания HTML-версии выберите Дальше.

Результат

Оффлайн-версия сохраняется на локальном жестком диске. После этого при помощи портативного компьютера можно просматривать содержание маршрутной карты вне SAP-системы.


 Подготовка проекта

Подготовка проекта

Цель использования

Все основные операции в транзакции подготовки проекта выполняются в следующих целях:

· Создание структуры и организация проекта

В SAP Solution Manager Для предоставления поддержки пользователям в ходе подготовки проекта и выполнения всех административных задач, релевантных для всего проекта, используется Управление проектом.

· Изучение документации по внедрению стандартных сценариев SAP.


 Управление проектом

Управление проектом

Цель использования

В транзакции управления проектом SAP Solution Manager выполняются все релевантные для проекта центральные административные задачи:

· Создание проектов;

· Определение общих данных в начале и в конце проекта;

· Определение объема проекта;

· Присвоение сотрудников проекта;

· Определение языка проекта;

· Определение стандартов проекта (значения статуса, виды документации, ключевые слова);

· Определение системной среды для проекта;

· Определение данных запросов на перенос (в зависимости от вида проекта).

Любые существующие проекты автоматически выводятся для просмотра в обзоре проектов SAP Solution Manager.

Вызовите транзакцию управления проектом путем ввода кода SOLAR_PROJECT_ADMIN.


 Виды проектов

Виды проектов

Определение

Поставляемые с SAP Solution Manager виды проектов позволяют классифицировать создаваемые проекты по их категории. В SAP Solution Manager возможно создание следующих проектов:

· Проект внедрения

Проект внедрения на основе выбора бизнес-процессов в среде mySAP.

Существует три способа выполнения проекта внедрения:

§ Создание структуры проекта одного или более сценариев пользователя или партнера, используемых в качестве шаблона;

§ Создание структуры проекта на основе существующей продуктивной среды решения;

§ Создание абсолютно новой структуры проекта.

Структура проекта внедрения не подлежит повторному использованию в других проектах.

· Шаблонный проект

Проект для создания шаблона.

Внедряемое решение может основываться на шаблонах, поставляемых SAP, а также на шаблонах партнеров или глобальных шаблонах. При создании шаблона доступны следующие возможности:

§ Изменение и добавление документации;

§ Определение и добавление предварительно сконфигурированных элементов, например, пакетов настройки бизнес-конфигурации, контрольных примеров или IMG-операций;

§ Обработка структур поставляемых сценариев.

Структура шаблонного проекта может быть повторно использована в других проектах, причем независимо от того шаблонного проекта, в котором она была создана. Шаблонные проекты предназначены для использования, в основном, в решениях партнеров SAP или при глобальном развертывании.

· Проект оптимизации

Проект, разработанный с целью оптимизации потока бизнес-процессов или использования программных решений.

Проекты оптимизации могут использоваться, например, в SAP-сервисах.

· Проект защиты

Проект, разработанный с целью разрешения критических ситуаций, возникающих в ходе внедрения или использования решения SAP.

Проекты защиты позволяют выявить причины возникновения критической ситуации и скоординировать меры, необходимые для разрешения проблемы.

Интеграция

Выбранный для проекта вид определяет опции обработки, доступные на различных фазах проекта (концептуальный проект, реализация).


 Создание/изменение проекта

Создание/изменение проекта

Предпосылки

Для создания проектов в SAP Solution Manager необходимы полномочия, описанные в разделе Концепция полномочий.

Должен быть выполнен переход к первому экрану транзакции Управление проектом в SAP Solution Manager.

Последовательность шагов

...

Выберите Проект ® Создать.

1. В диалоговом окне Создание проекта введите имя проекта и выберите Дальше.

Имя проекта может состоять из комбинации букв и цифр длиной до 10 символов.

2. Выберите Вид проекта.

Для ознакомления с обзором различных видов проектов и особенностями их использования см. Виды проектов.

В дальнейшем изменить вид проекта в том же самом проекте нельзя. Для изменения вида проекта, например, при необходимости преобразования проекта внедрения в шаблонный проект, скопируйте проект и измените вид скопированного проекта.

3. Возможно присвоение проекту среды решения.

После создания структуры проекта на фазе концептуального проекта в эту структуру можно поместить структурные элементы из выбранной среды решения.

4. Выберите Дальше.

Появится экран Ведение проекта .

5. Введите значимое название проекта и язык проекта.

6. Сохраните данные заголовка для проекта.

7. В следующем диалоговом окне введите имя контекста расширения, который будет использоваться при сохранении документов проекта в SAP Knowledge Warehouse.

8. Выберите Дальше.

9. При создании шаблонного проекта в появившемся диалоговом окне введите пакет, в котором должна быть сохранена структура проекта.

Система скопирует указанный в этом окне пакет на закладку Запросы на перенос, после чего этот пакет будет использоваться по умолчанию для последующих изменений в объеме или структуре проекта на фазе концептуального проекта. Во избежание выбора данного пакета как пакета по умолчанию удалите его из закладки Запросы на перенос.

Для получения дополнительной информации см. Запросы на перенос.

10. Сохраните введенные данные.

Результат

Сохраненный проект появляется в обзор проектов SAP Solution Manager. После этого для проекта можно определить данные заголовка:

· общие данные,

· объем,

· членов проектной группы,

· системную среду,

· стандарты проекта (значения статуса, ключевые слова, типы документов),

· этапы,

· организационные единицы,

· шаблоны (только для шаблонных проектов),

· запросы на перенос (только для шаблонных проектов).

· Для изменения данных заголовка для проекта выберите Проект ® Изменить. Изменить язык проекта после сохранения данных заголовка для проекта невозможно.

· Для распределения изменений в данных заголовка проекта в IMG проектов в систмах компонентов выберите Обработать ® Распределение данных заголовка проекта.


 Общие данные

Общие данные

Использование

Управляющие данные для проекта вводятся на закладке Общие данные.

Предпосылки

В транзакции "Управление проектом" SAP Solution Manager должны быть определены следующие данные:

· проект,

· вид проекта.

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Функциональные возможности

На закладке Общие данные можно ввести следующие данные:

· Руководитель проекта

Ў Вид руководителя, например, клиент или компания (VAR/CBS)

Ў Ответственный на стороне клиента

Для изменения идентификатора пользователя по умолчанию воспользуйтесь справкой по допустимым значениям ввода.

Ў Ответственный консультант

При создании нового проекта членом проектной группы его имя пользователя автоматически вводится в поле Ответственный.

Ответственный должен входить в управление пользователями SAP-системы. С помощью опции Подробно можно просмотреть информацию об ответственных, например, данные пользователя OSS и адрес электронной почты.

· Язык проекта

Язык проекта используется для вывода всей зависящей от языка информации (проектная документация и информация по статусу) для всех сотрудников проекта независимо от соответствующего им языка входа в систему. Документация может быть изменена только на языке проекта.

Структура проекта создается на определенном языке проекта.

В дальнейшем изменить язык проекта невозможно.

· Описание проекта

Имеется возможность загрузки или создания определенного документа, например, устава проекта.

· Статус

Значения по умолчанию для статуса устанавливаются на закладке Стандарты проекта .

· Плановые данные

На данной закладке вводятся плановые сроки начала и конца проекта и объем необходимых работ (в человеко-днях, PD).

· Фактические данные

На данной закладке вводятся фактические сроки начала и конца проекта и объем фактических работ (в человеко-днях, PD).

Плановые и фактические данные относятся ко всему жизненному циклу проекта. Любые даты, определенные для шагов процесса в концептуальном проекте или фазах реализации, должны лежать в пределах этого периода.

Требуемая остаточная работа рассчитывается из разницы между плановыми и фактическими данными и указывается в виде процентной ставки в поле Завершено. Записи об остаточных работах в любое время могут быть изменены вручную.


 Определение объема

Определение объема

Использование

Выберите маршрутную карту, которую будут использовать члены проектной группы. Эта маршрутная карта будет использоваться как значение по умолчанию каждый раз при вызове для проекта транзакции "Маршрутная карта".

Выберите шаблоны для проекта. После этого в проект будут перенесены структуры этих шаблонов и их присвоения.

Предпосылки

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Последовательность шагов

...

1. На закладке Выбор маршрутной карты выберите маршрутную карту.

2. На закладке Выбор шаблона выберите шаблоны для внедрения в проект или создайте собственный шаблон.

На экран будет выведен список всех шаблонов, каждому из которых присвоен, по крайней мере, один сценарий и идентификатор шаблона в соответствии с соглашением по присвоению имен <идентификатор шаблона> - <имя шаблона>, например, ZBANK – Банковское дело, Европа.

Шаблоны могут быть созданы в данной системе SAP Solution Manager или другой системе, например, шаблон может быть создан в головной фирме в ходе глобального развертывания и затем импортирован в системы дочерних компаний.

Логические компоненты или версия продукта, присвоенные шаблону, могут отличаться от системной среды текущего проекта.

3. Для адаптации логических компонентов и версии продукта шаблона к текущей системной среде:

a. Выберите шаблон.

b. Сохраните введенные данные.

c. Из справки по допустимым значениям ввода в следующем диалоговом окне выберите логический компонент, используемый в текущем проекте, или создайте новый логический компонент.

d. Версию продукта можно изменить.

e. Скопируйте изменения путем выбора Дальше.

4. На закладке Выбор страны можно ограничить список стран, для которых данный проект будет действительным.
С помощью стрелок скопируйте соответствующие страны из таблицы Возможные страны в таблицу Выбранные страны.

На закладке Объем можно ограничить возможности обработки концептуального проекта сотрудниками проекта:

Блокирование в концептуальном проекте:

· Обработка структуры:

Дальнейшее расширение или ограничение объема структуры проекта невозможно.

· Обработка структуры и изменений документов на закладке Администрирование:

· Дальнейшее расширение или ограничение объема структуры проекта невозможно.

· Дальнейшее изменение документации соответствующего концептуального проекта невозможно.

5. Сохраните введенные данные.

Результат

После присвоения маршрутной карты проекту можно поместить информацию о проекте, например, о статусе этапов проекта или сообщений, в маршрутной карте со ссылкой напроект.

Выбраны шаблоны, на которых будет основываться концептуальный проект. После этого в структуру проекта будут перенесены структуры этих шаблонов и их присвоения.


 Члены проектной группы

Члены проектной группы

Использование

Данная закладка используется для создания и обновления списка членов проектной группы. Каждому проекту может быть присвоено любое количество членов проектной группы. Это присвоение выполняется руководителем проекта в транзакции управления проектом.

Для присвоения пользователей могут быть использованы идентификаторы пользователей, определенные в управлении пользователями, и общие идентификаторы пользователей (не созданные в управлении пользователями). Выберите кнопку Проверить по основной записи пользователя для проверки наличия перечисленных на этой закладке членов проекта в управлении пользователями системы SAP. Cотрудники, имена которых выделены в списке, не являются пользователями SAP.

Предпосылки

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Интеграция

Штатные сотрудники, присвоенные проекту на данной закладке, выводятся на закладках Администрирование в списке выбора при вводе управляющих данных, ориентированных на конкретную задачу, в следующих фазах проекта или транзакциях:

Штатные сотрудники, присвоенные проекту на данной закладке, выводятся на закладках Администрирование в списке выбора при вводе управляющих данных, ориентированных на конкретную задачу, в следующих фазах проекта или транзакциях:

· Маршрутная карта: закладка Члены проектной группы

· Концептуальный проект: закладка Администрирование

· Конфигурация: закладки Администрирование, Конфигурация и Разработки

Операции

...

1. В столбце Член проекта введите имя сотрудника проекта. Для поиска и присвоения сотрудников, уже введенных в управлении пользователями, используется справка по допустимым значениям ввода.

Присвоение сотрудников проекту можно произвести непосредственно после их ввода в управлении пользователями. Для перехода к транзакции ведения пользователей дважды щелкните по имени сотрудника или выберите кнопку Управление пользователями. Объем доступных в транзакции ведения пользователей функций для изменения данных пользователей зависит от проектной роли и соответствующего профиля полномочий.

2. В поле Имя/Описание можно ввести описание сотрудника проекта. Это поле доступно только для внутреннего использования в рамках проекта. Например, оно может использоваться для документального подтверждения присвоения члена проектной группы подпроекту или проектной группе. При этом, если пользователь определен в системе SAP, имя пользователя подставляется автоматически.

3. Также можно определить имена и подробную информацию о партнерах SAP, вовлеченных в проект.


 Закладка "Системная среда"

Закладка "Системная среда"

Использование

На данной закладке определяется системная среда для проекта. Это дает возможность централизованно управлять всеми необходимыми для проекта логическими системами.

Здесь выполняется настройка системной среды, т. е. определение логических компонентов и логических систем для компонентов ABAP. Это обеспечивает помещение в структуру проекта или представление в концептуальном проекте только тех сценариев и процессов, которые выполнялись в указанных здесь компонентах.

Определение логических компонентов необходимо только для компонентов не на основе ABAP.

Интеграция

В зависимости от определяемой системной среды будут доступны следующие функции:

· Переход к бизнес-содержимому в системах компонентов

Из запущенных в SAP Solution Manager концептуального проекта , реализации и тестирования можно перейти к определенным логическим системам, например, к демонстрационной версии или системам разработок для проверки их бизнес-содержимого (транзакции, пакеты настройки бизнес-конфигурации, инструменты CATT, программы и т.д.). Логическую систему можно выбрать в каждой фазе в пункте Системная роль.

Для упрощения входа в системы компонентов выберите вид RFC-соединения Достоверная система . В этом случае вход в системы компонентов будет выполняться автоматически.

Предпосылками для создания соединения вида "Достоверная система" являются:

· использование одного и того же пользователя в системе SAP Solution Manager и целевой системе компонента;

· наличие полномочий для объекта полномочий S_RFCACL.

Для получения дополнительной информации см. Создание RFC-соединений.

· Создайте проекты IMG в системах компонентов и распределите центральные данные проекта.

· Сравнение и распределение настроек в локальных системах

В манданте настройки системы R/3 необходимо сконфигурировать определенный бизнес-процесс. Необходимо синхронизировать настройку этой системы с настройкой SAP CRM. Также можно выполнить сравнение настройки в SAP Solution Manager с использованием Customizing Scout. Кроме того, имеется возможность автоматической корректировки настройки при помощи функции "Распределение настройки". Информация о логических системах, настройку которых требуется сравнить при помощи Customizing Scout, берется из данных системной среды, определенный в Управлении проектом.

· Создание графики бизнес-процесса

Создание графики может осуществляться на уровне сценария или процесса. Графика включает логические компоненты процессов сценария или шаги определенного процесса.

Предпосылки

Выполнена настройка системной среды. Это позволяет использовать при выборе систем справку по допустимым значениям ввода.

Операции

...

1. Выберите логические компоненты.

2. Определите и выберите другие необходимые логические компоненты.

3. Выберите присвоенные логические системы.

4. Создайте проекты IMG и используйте их для распределения центральных данных проекта в выбранные системы.


 Определение системной среды

Определение системной среды

Использование

Для получения доступа к системам компонентов на последующих фазах проекта необходимо определить для проекта системную среду.

Предпосылки

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Выполнена настройка автоматического сбора данных для системной среды. Это позволяет использовать при выборе логических систем справку по допустимым значениям ввода.

Выполнен переход к закладке Системная среда в транзакции "Управление проектом".

Последовательность шагов

Закладка Системы

Определение логических компонентов

Логический компонент в проекте внедрения представляет собой продукт в среде SAP, для которого не определены системы или версии. Логический компонент может также быть продуктом не на основе ABAP.

· Нажмите экранную кнопку Выбор сценария для копирования на закладку Системы логических компонентов, на которых основываются выбранные на закладке Выбор шаблона сценарии.

· При необходимости копирования дополнительных логических компонентов в справке по допустимым значениям ввода для столбца Логические компоненты выберите логические компоненты, их продукты/главные инстанции.

Будет произведено копирование выбранных логических компонентов, их продуктов и главных инстанций, а также последней версии продукта.

· Для создания нового логического компонента в справке по допустимым значениям ввода выберите Создать новую запись.

В следующем диалоговом окне можно определить внешний (не SAP) продукт. Для получения дополнительной информации об определении внешних продуктов см. пунктОпределение внешних продуктов в разделе Настройка продуктов для обработки.

· В справке по допустимым значениям ввода продукту/главной инстанции можно присвоить другую версию продукта.

· Выберите Заменить журнал. Выберите Компонент для замены логического компонента другим по всей структуре проекта.

· Для получения возможности перехода к системам компонентов на различных фазах проекта присвойте логические системы логическим компонентам для системных ролей из справки по допустимым значениям ввода для системы оценки (например, столбцы).

Системы, определенные для системных ролей, используются по умолчанию на следующих фазах проекта:

Использование систем

Системная роль | Фаза
Оценка | Концептуальный проект
Разработка | Реализация
Обеспечение качества | Тестирование

Для изменения системных ролей и их присвоения фазам проекта используется опция Присвоение роли в Управлении проектом. В транзакции организации тестирования в любое время также можно изменить выбранную тестовую систему.

Обработка системных ролей

С помощью опции Присвоение роли на закладке Системы можно изменить последовательность системных ролей, выбрать дополнительные системные роли, определить до десяти системных ролей пользователя и удалить системные роли из проекта.

Удаление системных ролей, используемых в настоящее время в системной среде, невозможно.

Закладка Среда решения

На закладке Среда решения проекту можно присвоить продуктивную среду решения. После создания структуры проекта на фазе концептуального проекта в эту структуру можно поместить структурные элементы из выбранной среды решения. После присвоения продуктивной среды решения соответствующий этому решению проект будет выведен на экране "Операции" в SAP Solution Manager. На экране "Операции" в SAP Solution Manager можно скопировать процессы из проекта в среду решения.

Закладка Проекты IMG

После определения логических компонентов на закладке Системная среда на этой закладке появится список соответствующих им проектов IMG, т. е. всех подпроектов в системах компонентов, относящихся к данному проекту SAP Solution Manager.

После создания проектов IMG в системах компонентов выполните распределение в системы компонентов следующих центральных данных проекта:

· Стандарты проекта:

Ў Значения статуса, еще не существующие в системе компонентов

Ў Ключевые слова

· Члены проектной группы

· Выбор страны

После создания проектов IMG в системах компонентов вся соответствующая информация заносится в данные по объему проекта.

Зеленый и красный сигналы светофора свидетельствуют о том, было ли выполнено создание и распределение проектов IMG.

· Красный (квадрат): проект еще не существует

· Зеленый (точка): проект существует в определенных логических компонентах и присвоенных логических системах.

Создание проектов IMG в системах компонентов

Для создания и распределения данных проекта:

...

1. Выберите системную роль для проектов IMG.

2. Выберите проект IMG.

В системах компонентов будут запущены процессы создания и распределения.

После завершения создания проекта появится зеленый сигнал светофора. Также по окончании этой операции в системе компонента будет выведено системное сообщение.

3. Для обращения к проекту IMG на более позднем этапе и его повторного создания выберите подпроект.

Будет выполнен переход к данным заголовка проекта.

Для перехода к данным заголовка проекта также можно выбрать опцию Просмотр проекта в контекстном меню (после щелчка правой кнопки мыши по проекту IMG).

Присвоение другого проекта IMG в системах компонентов

Для присвоения другого проекта IMG из системы компонента вместо проекта IMG по умолчанию:

...

1. Установите курсор на проекте IMG.

2. В контекстном меню выберите Присвоить другой проект.

3. Введите имя присваиваемого проекта.

4. Войдите в систему компонентов.

5. В следующем диалоговом окне можно создать запрос на перенос. В этом запросе можно присвоить задачи другим членам проектной группы.

6. Для сохранения введенных данных выберите Дальше.

Присвоенный проект IMG появится на закладке Проекты IMG.

См. также:

Проверка системной среды

Системная среда Solution Manager


 Проверка системной среды

Проверка системной среды

Использование

Эта функция позволяет проверить непротиворечивость системной среды проекта. Благодаря ей возможен переход от одного компонента системной среды к другому.

Интеграция

Проверка системной среды может быть выполнена при помощи функций Концептуальный проект, Конфигурация, Управление планами тестирования в Управлении проектом.

Предпосылки

В Управлении проектом должны быть созданы проект и его системная среда.

Функциональные возможности

Функция проверки системной среды позволяет получить ответы на следующие вопросы:

· Определены ли логические компоненты для проекта?

· Созданы ли логические компоненты и логическая система на основе одной и той же версии продукта?

· Позволяет ли статус версий продукта и пакета поддержки логических систем осуществлять навигацию в системах компонентов из SAP Solution Manager?

· Имеются ли RFC-соединения с логическими системами?

· Корректно ли функционируют RFC-соединения?

На экране появится список систем, в которых в ходе проверки были созданы информационные сообщения или сообщения об ошибках.


 Определение системной среды для центральных объектов

Определение системной среды для центральных объектов

Использование

При определении для центральных объектов системной среды для таких объектов, как, например, выполняемые вручную контрольные примеры, внешние приложения и конфигурации тестов eCATT, можно определить центральный репозитарий. Это может потребоваться в случае, когда при работе с центральной системой SAP во время разработки тестов eCATT возникает необходимость сохранения результатов выполнения вручную контрольных примеров и внешних приложений в центральной системе SAP, а не в различных компонентах системы.

Центральной системой SAP для конфигураций тестов eCATT, выполняемых вручную контрольных примеров или внешних приложений может быть SAP Solution Manager или другие центральные системы, с которыми в SAP Solution Manager установлены RFC-соединения.

Предпосылки

По причине отсутствия необходимости в использовании SAP Solution Manager были установлены RFC-соединения с используемыми центральными системами. Выполнен переход к Управлению проектом в SAP Solution Manager, и выполняется обработка проекта.

Последовательность шагов

...

1. Выберите закладку Системная среда.

2. Выберите подзакладку Центральные объекты.

3. Присвойте логическую систему объекту типа Конфигурация тестов eCATT или Контрольные примеры вручную и внешние приложения.

4. Если все члены проектной группы должны иметь возможность размещения объектов только в центральных системах, установите флаг Использование обязательно.

Результат

Контрольные примеры eCATT , выполняемые вручную контрольные примеры и внешние приложения автоматически помещаются в центральные системы, если при создании или присвоении их структуре проекта на закладке Контрольные примеры в транзакции Конфигурация члены проектной группы не указывают систему компонента. То же самое относится к присвоению конфигураций тестов eCATT на закладке Конфигурация.


 Создание запросов на перенос в системах компонентов

Создание запросов на перенос в системах компонентов

Использование

В системах компонентов создаются запросы на перенос настройки и инструментальных средств из системы SAP Solution Manager; в этих запросах членам проектной группы присваиваются задачи. Это является обязательным условиям для активации членами проектной группы пакетов настройки бизнес-конфигурации, выполнения eCATT, импорта запросов на перенос Add-On и обработки настройки в руководстве по внедрению в транзакции Конфигурация.

Наличие запросов на перенос является необходимой предпосылкой распределения настройки. В запросах на перенос должны существовать задачи для всех членов проектной группы, которые являются авторами подлежащих распределению изменений настройки.

Предпосылки

В Управлении проектом создан проект, для которого определена системная среда ; соответствующие данные должны быть сохранены. Выполнен переход в режим обработки проекта.

Имеются полномочия S_CTS_ADMI для всех компонентов системы, в которых требуется создать запросы на перенос.

Последовательность шагов

...

...

1. Перейдите к закладке Системная среда.

2. Выберите подзакладку Проекты IMG.

3. Щелкните по заголовку проекта IMG для системы компонента, например, системы R/3.

Если в выбранной системе компонента проект IMG еще не существует, появится диалоговое окно с сообщением о том, что под именем пользователя в данном компоненте создан запрос на перенос. Выполните следующие действия:

a. Создайте задачи для членов проектной группы в этом запросе на перенос.

b. Выберите Дальше.

Будет выполнен переход к Управлению проектом в системе компонента. Перейдите к шагу 4.

Если в системе компонента проект IMG уже существует, будет выполнен переход к Управлению проектом в системе компонента .

4. Перейдите в режим обработки.

5. Выберите закладку Запросы на перенос.

Если функциональные возможности CTS не активированы, на этой закладке присутствует экранная Активация функций CTS.

6. В этом случае нажмите экранную кнопку Активация функций CTS.

7. Нажмите экранную кнопку Присвоенные запросы CTS.

8. При отсутствии подходящих запросов на перенос настройки и инструментальных средств создайте этот запрос.

9. В запросах создайте задачи для всех членов проектной группы.

10. Сохраните введенные данные и вернитесь назад.

11. Повторите эту процедуру для всех других систем, перечисленных на закладке Проекты IMG.

Результат

Созданный запрос на перенос с задачами автоматически рассылается всем членам проектной группы в запросах CTS при активации ими пакетов настройки бизнес-конфигурации, выполнении тестов CATT, импорте запросов на перенос Add-On и изменении настройки в системах компонентов.

Созданные запросы на перенос можно использовать при распределении настройки.


 Закладка "Шаблоны"

Закладка "Шаблоны"

Использование

На этой закладке осуществляется управление шаблонами; деблокирование и перенос готовых шаблонов; создание новых версий шаблонов и архивация старых версий.

Интеграция

По умолчанию обрабатываемые пользователем шаблоны не являются видимыми для всей системы. Для того, чтобы шаблон стал видимым для всей системы, измените его статус видимости на Общий. Общий шаблон можно поместить в объем любого проекта во всей системе.

Предпосылки

Выполнен переход к шаблонному проекту пользователя в Управлении проектом.

Функциональные возможности

Создание и изменение шаблонов

Создание новых шаблонов и изменение существующих выполняется с помощью экранных кнопок.

Поддержка глобального развертывания

При активной функции глобального развертывания можно полностью или частично блокировать изменение созданных им шаблонов в дочерних компаниях на этапе Концептуальный проект.

Для получения дополнительной информации см. Глобальное развертывание с использованием шаблона в разделе Определение шаблона в головной фирме компании.

Публикация шаблона

Публикация готового шаблона для всей системы выполняется с помощью экранной кнопки Изменить видимость.

При изменении пользователя статуса видимости шаблона с Частный на Общий система выполняет обновление данных системной среды шаблона. После этого по всей системе шаблон будет доступен для просмотра на закладке Объем в Управлении проектом. Текущий статус видимости обозначается соответствующей пиктограммой на закладке Шаблоны.

Перенос

Перенос шаблона выполняется с помощью экранной кнопки Перенос с использованием коллектора шаблонов.

Коллектор шаблонов позволяет корректно выполнить все шаги процедуры переноса шаблона. Выберите в коллекторе шаблонов существующий запрос на перенос вида Перенос копий или создайте новый запрос. Деблокируйте этот запрос на перенос в Организаторе переносов.

Создание новой версии

Создание новой версии общего шаблона выполняется с помощью экранной кнопки Увеличить счетчик версии, при нажатии которой выполняется сохранение статуса старого шаблона и переход к работе с новой версией.

Архивация

При создании новой версии шаблона старую версию этого шаблона можно заархивировать в целях последующего сравнения различных версий.

Просмотр журнала задания

С помощью экранной кнопки Вызвать журнал задания можно вызвать журналы фоновых заданий деблокирования (template_ship) и архивации (template_archive).

...

Результат

Шаблон пользователя был деблокирован для повторного использования. Это означает возможность повторного использования шаблона в той же самой системе SAP Solution Manager, переноса шаблона в системную среду пользователя или дочерним компаниям с целью согласования процессов, настройки и прочих системных данных для всего предприятия в целом.

См. также:

Глобальное развертывание с использованием шаблона


 Закладка "Этапы"

Закладка "Этапы"

Использование

Закладка Этапы используется для контроля динамики проекта по определенным в маршрутной карте и проекте этапам.

Интеграция

После выбора маршрутной карты для проекта на закладке Маршрутная карта на закладке Этапы появится список этапов в выбранной маршрутной карте. Возможно добавление этапов в маршрутной карте, но не их изменение.

Функциональные возможности

· Имеется возможность самостоятельного определения этапов.

· Как для самостоятельно определенных этапов, так и для этапов, заданных маршрутной картой, возможен ввод следующих данных:

Ў Плановый срок начала;

Ў Плановый срок завершения;

Ў Фактический срок начала;

Ў Фактический срок завершения.


 Закладка "Организационные единицы"

Закладка "Организационные единицы"

Использование

Эта закладка используется для ввода данных об используемых в проекте организационных единицах.

Интеграция

Эта закладка содержит данные об организационных единицах. Эти данные нельзя проанализировать в Анализе проекта.

Функциональные возможности

Позволяет вводить данные об организационных единицах, включая информацию о функциях, стране и часовом поясе.


 Закладка "Стандарты проекта"

Закладка "Стандарты проекта"

Использование

Значение статуса, ключевых слов и видов проектной документации задаются по умолчанию в транзакции управления проектом. Если проекту не присвоены эти значения, администратор может использовать шаблон, содержащий не зависящие от проекта значения статуса, ключевые слова и виды документации.

Значения в шаблоне проекта подходят ко всем проектам соответствующего типа. Решение о том, какие именно значения из шаблона следует использовать и присвоить проекту, принимается администратором проекта.

Шаблон проекта, который уже содержит значения статуса, ключевых слов и вида документации, присваивается любому типу проекта. Шаблон проекта может быть изменен в соответствии с требованиями конкретного проекта.

Интеграция

Значения, определенные на закладке Стандарты проекта, являются значениями по умолчанию для следующих функций: "Управление проектом", "Маршрутная карта", "Концептуальный проект" и "Конфигурация".

· "Управление проектом":

Ў Общие данные (значения статуса)

· "Концептуальный проект", "Конфигурация", "Маршрутная карта"

Ў Проектная документация (виды документации, ключевые слова и значения статусов)

· "Концептуальный проект" и "Конфигурация"

Ў Администрирование (значения статусов и ключевые слова),

Ў только для шаблонных проектов: Общая документация (вид документации, ключевые слова и значения статусов)

· "Конфигурация"

Ў Разработки (значения статусов)

Ў Конфигурация (значения статусов)

· "Маршрутная карта"

Ў Ключевые слова (значения статусов)

Предпосылки

Сотрудник проекта, ответственный за создание и изменение значений статусов, ключевых слов и видов документации, должен иметь соответствующую проектную роль и полномочия S_PROJECTS.

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Функциональные возможности

Закладка Стандарты проекта имеет три подзакладки:

· Статус

· Ключевые слова

· Виды документации

Закладка Значения статусов

Значения статусов позволяют получить представление о статусе проекта. Значения статусов состоят из десятизначного идентификатора статуса и описания статуса. Идентификаторы статусов должны быть значимыми.

Поставляются следующие значения статусов:

Поставляемые значения статусов

Статус | Описание | Реакция системы
01 | Открыто | Нет
02 | Выполняется | Нет
03 | Завершено | Запрет внесения изменений на закладке Администрирование
04 | Нерелевантно | Нет

Все новые значения появляются в списке Неиспользуемые значения статусов и могут быть присвоены проекту. Для поиска значений статусов используется транзакция Анализ проекта .

Закладка Ключевые слова

Для проекта могут быть определены ключевые слова, по которым позже может быть выполнен поиск в транзакции Анализ проекта . Ключевые слова должны быть краткими и точными.

Ключевые слова являются значениями по умолчанию для классификации документов на закладках Общая документация и Проектная документация (закладка Общая документация или Проектная документация ® экранная кнопка Атрибуты ® закладка Атрибуты ® Классификация).

Закладка Виды документации

В различных видах документации можно фиксировать информацию по внедрению и созданию шаблонов в любых типах проектов. В качестве шаблонов для разработки структуры проекта могут использоваться различные виды документации, поставляемые SAP. Пользователи также могут создавать собственные виды документации для проектов:

· Протоколы или резолюции

· Концептуальные проекты

· Сообщения о проблемах или ошибках

Каждый вид документации имеет уникальный идентификатор. Существует два вида проектной документации:

· Документация для одного проекта

Такая документация действительна только для того проекта, которому она присвоена.

· Документация, выходящая за рамки одного проекта

Этот вид документации можно узнать по индикатору "Глобальная документация". Этот индикатор доступен во всех проектах и появляется автоматически в списке Виды проектной документации на закладке Виды документации.

Для каждого вида документации возможно создание шаблонов проектной документации. Для этого выполните шаги, описанные в разделе Обработка шаблонов документов.

Анализ видов документации для концептуального проекта проводится в транзакции Анализ проекта .


 Присвоение и создание стандартов проекта

Присвоение и создание стандартов проекта

Предпосылки

Для создания или изменения значений статусов, ключевых слов и видов документации необходимо иметь полномочия S_PROJECTS. В транзакции управления проектом был выполнен переход в режим изменения и выбрана закладка Стандарты проекта .

Последовательность шагов

Присвоение существующих стандартов проекта новому проекту

Сценарий А:

Список Неиспользуемые значения статусов/Виды документации и список Ключевые слова уже содержат значения по умолчанию.

...

...

1. Выберите в таблицах Неиспользуемые значения статуса/Виды документации и Каталог ключевых слов записи, которые следует присвоить проекту.

2. Перенесите выбранные записи в список Проектные значения статусов/Ключевые слова/Виды документации при помощи экранной кнопки Присвоить.

Для запрета использования перечисленных значений в проекте верните их в список неиспользуемых значений при помощи пиктограммы Удалить.

3. Для определения того, какие ключевые слова будут доступны в структуре проекта, маршрутной карте и документах, установите или снимите соответствующие им флажки в столбцах Структура проекта , Маршрутная карта и Документация в левой части экрана. Эти флажки устанавливается по умолчанию.

4. Сохраните присвоения.

Создание стандартов проекта

Сценарий В:

Списки Неиспользуемые значения статусов/Виды документации и Ключевые слова не содержат значения по умолчанию.

...

1. Выберите Шаблон проекта .

Появится диалоговое окно со стандартными списками значений статусов, ключевых слов и видов документации, определенных и действительных в рамках транзакции управления проектом.

2. Если в Управлении проектом в списках Значения статусов/Ключевые слова/Виды документации уже содержатся записи, выберите и скопируйте их в список Проектные значения статусов/Ключевые слова/Виды документации при помощи кнопки Страница влево.

Если в шаблоне проекта не содержится записей:

a. Создайте новые записи в списке справа.

При определении новых видов документации можно присвоить им дополнительные атрибуты, например, возможность многократного использования или расширение файлов.

Для получения более подробной информации см. Обработка шаблонов документов.

b. Скопируйте записи в список в левой части окна.

3. Сохраните выбор.

Теперь можно присвоить проекту стандартные значения по умолчанию, как описано выше в сценарии А.


 Обработка шаблонов документов

Обработка шаблонов документов

Использование

Шаблон для проектной документации создается на закладке Виды документации. Этот шаблон позволяет определять внешний вид и формат документации.

Создание и обработка шаблонов документов могут проводиться для всех типов проектов.

Предпосылки

Выполнен переход к первому экрану транзакции Управление проектом.

Последовательность шагов

...

1. Для перехода в режим изменения шаблонов проекта можно выбрать один из двух способов:

Ў Для создания шаблонов документации, выходящие за рамки одного проекта, выберите Перейти к ® Шаблон проекта ® <Тип проекта > на первом экране транзакции Управление проектом.

Ў Для одновременного создания шаблонов для документации, выходящих за рамки одного проекта или относящейся только к одному определенному проекту:

i. Выделите проект и выберите Изменить проект.

ii. Выберите закладку Стандарты проекта ® Виды документации.

iii. Выберите Шаблон проекта .

Перейдите в режим изменения шаблона проекта.

2. На закладкеВиды документации определите название вида документации и идентификатор в поле в правом списке, ввод в которое разрешен.

3. Виду документации можно присвоить другие атрибуты:

Ў Глобальная документация

Для получения возможности использования этого вида документации в других проектах этот флаг должен быть установлен.

Ў Допустимо наличие нескольких документов

Для получения возможности многократного присвоения вида документации элементам в структуре проекта этот флаг должен быть установлен.

Это позволяет добавлять, например, несколько документов вида Microsoft Word к одному элементу.

Ў Расширение файла:

При использовании для создания или изменения шаблона документа других редакторов (кроме текстового), введите соответствующее расширение файла, например, PPT для Microsoft PowerPoint. Если расширение файла не указано, по умолчанию вызывается текстовый редактор.

Ў Релевантно для концептуального проекта

Документы того вида, для которого установлен флажок Релевантно для концептуального проекта , помещаются в концептуальный проект.

Для запрета включения документов в концептуальный проект по умолчанию снимите флажок Релевантно для концептуального проекта для этого вида документации.

4. Выберите шаблон вида документации, который требуется изменить.

5. При необходимости загрузки локально созданного шаблона из определенного каталога выберите функцию обработки, например, Создать в редакторе или Импорт, после нажатия экранной кнопки Шаблон документа.

6. Выполните обработку шаблона документа.

7. При помощи соответствующей экранной кнопки присвойте новому или измененному шаблону документа статус Деблокировано.

В проекте могут использоваться только деблокированные шаблоны документов. В справке по допустимым значениям ввода в SAP Solution Manager, например, в концептуальном проекте, доступны только деблокированные шаблоны документов.

При наличии нескольких версий шаблона документа в справке по допустимым значениям ввода указывается последняя деблокированная версия.

Для просмотра истории деблокирования версий и получения подробной информации о шаблоне документа нажмите экранную кнопку Подробный ракурс.

8. Сохраните введенные данные.

Результат

В проекте созданы шаблоны документов для различных видов документации. Выберите виды документации для дальнейшего использования их в проекте (см. описание закладки "Стандарты проекта").

Эти шаблоны используются для создания новых документов на фазах концептуального проекта и реализации.


 Запросы на перенос

Запросы на перенос

Использование

В SAP Solution Manager включены функциональные возможности переноса шаблонных проектов.

Переносимые шаблоны для шаблонных проектов содержат следующие элементы:

· Структура проекта (упорядоченные структурные элементы)

· Присвоения бизнес-содержимого, выполненные в на фазе концептуального проекта и реализации, например, пакеты настройки бизнес-конфигурации, транзакции или контрольные примеры.

Такие объекты, как пакеты настройки бизнес-конфигурации или инструменты CATT, созданные пользователем в системах компонентов из SAP Solution Manager, не переносятся вместе с шаблоном. Для переноса этих объектов из систем компонентов, например, в дочерние компании, следует выполнить последовательность действий, описанную в разделе Глобальное развертывание с использованием шаблона .

Предпосылки

Выполнен переход к транзакции "Управление проектом" в режиме изменения.

Последовательность шагов

В транзакции "Управление проектом" можно проверить запросы на изменения, относящиеся к данному проекту. На закладке Запрос на перенос для актуального манданта доступны следующие функции:

· Функция активации системы изменения и переноса (Change and Transport System, CTS)

После активации функциональных возможностей системы CTS появляется возможность создания запросов на изменение. В этом случае текст на соответствующей кнопке изменяется на Просмотр данных проекта CTS. По завершении проекта CTS текст на кнопке изменяется на Активация функций CTS.

· Присвоенные запросы CTS

Эта кнопка используется для перехода к обзору запроса в организаторе переносов. Здесь для проекта можно создать заказы.

· Список объектов проекта CTS

Список объектов проекта остается неизменным. После выполнения проекта можно экспортировать весь список объектов.

· Смена статуса проекта CTS

Эта кнопка используется для переключения статуса проекта.

· Завершение проекта CTS…

Эта кнопка используется для закрытия проекта. Его можно активировать позднее.

Пакеты для объектов

Структура проекта и ее присвоения (бизнес-содержимое) присваиваются пакету, введенному на этой закладке. После этого любые выполняемые изменения структуры проекта, например, объема проекта или концептуального проекта, автоматически присваиваются этому пакету. Требуется лишь ввести соответствующий запрос на перенос.

При отсутствии введенного на закладке Запрос на перенос пакета при каждом сохранении будет появляться сообщение о необходимости определения пакета.

Примечание относительно присвоения проекта

Автоматическое присвоение проекту запросов на перенос не поддерживается. Однако существует возможность присвоения в целях документирования. Присвоение проекта запросу на перенос обеспечивает регистрацию всех изменений, осуществляемых в отношении концептуального проекта или в процессе конфигурирования, в запросе на перенос.
Для присвоения проекта вначале необходимо активировать функциональные возможности CTS.
Информацию об активации функциональных возможностей CTS см. выше в разделе Активация функций CTS.

Для присвоения проекта:

...

1. Вызовите организатор переносов.

2. Вызовите запрос, которому были присвоены элементы в проекте.

3. Выберите запрос.

4. Выберите Запрос/задача ® Просмотреть.

5. Перейдите к закладке Свойства .

6. Перейдите в режим изменения.

7. Введите имя проекта в поле Проект.
При сохранении автоматически появится описание проекта.

8. Сохраните введенные данные.
Присвоение проекта выполнено.

Для получения дополнительной информации о системе изменений и переносов (CTS) и проектах настройки см. Использование проектов для управления переносами.


 Изменение URL в SAP Solution Manager

Изменение URL в SAP Solution Manager

Использование

Эта программа используется для изменения символьных строк в веб-ссылках (URL), которые были добавлены на закладки SAP Solution Manager Общая документация, Проектная документация и Конфигурация. Функция Изменение URL в SAP Solution Manager позволяет, например, при перемещении файлового сервера изменить имя каталога или файлового сервера во всех URL одновременно.

Все статические имена серверов и каталогов в URL должны быть заменены на переменные с использованием программы Изменение URL в SAP Solution Manager. Переменные для веб-ссылок (URL) определяются централизованно в настройке SAP Web Application Server по пути Администрирование системы ® Замена переменных в веб-адресах (URL).

Функциональные возможности

Программа Изменение URL в SAP Solution Manager (SOLAR_DOC_URL_CHANGE) заменяет символьные строки в веб-ссылках (URL) в проекте SAP Solution Manager.

Операции

...

1. Запустите программу SOLAR_DOC_URL_CHANGE.

2. Введите требуемые данные.

Указывайте только полные URL, так как программа может произвести замену только в полных адресах.

3. Сохраните изменения.


 Перенос проектов

Перенос проектов

Использование

Имеется возможность переноса проектов из одних систем в другие.

Все проектные данные, созданные в системах SAP Solution Manager, могут быть перемещены:

· данные заголовка (общие данные, объем);

· специфическая для проекта информация, например, проектная документация, данные о членах проектной группы и присвоениях статуса;

· информация, выходящая за рамки одного проекта, например, общая документация;

· структура проекта и ее присвоения.

Объекты систем компонентов, присвоенные структуре проекта, и объекты, созданные системой Solution Manager в системах компонентах, не перемещаются автоматически вместе с проектом. Для переноса этих объектов между системами следует создать отдельные запросы на перенос.

Предпосылка

Выполнен переход к первому экрану транзакции Управление проектом.

Последовательность шагов

...

1. Выберите проект в обзоре проектов.

2. Выберите экранную кнопку Перенос проекта или путь по меню Проект ® Перенос.

3. В появившемся диалоговом окне определите объем переноса. Для переноса проекта без проектной документации снимите флаг С примечаниями. По умолчанию проектная документация также подлежит переносу.

4. Выберите запрос на перенос или создайте новый запрос.

5. Сохраните введенные данные.

...


 Копирование проектов

Копирование проектов

Предпосылки

Выполнен переход к первому экрану транзакции Управление проектом.

Последовательность шагов

...

1. Выберите проект, который требуется скопировать.

2. Выберите Проект ® Скопировать.

3. Определите имя целевого проекта.

Посмотреть, какие имена проектов уже имеются в SAP Solution Manager, можно в справке по допустимым значениям ввода.

4. Тип проекта можно изменить.

5. Введите имя проекта.

6. Для предотвращения копирования данных проекта, проектной документации или контрольных примеров в новый проект снимите соответствующие флажки. По умолчанию все флажки установлены.

7. Выберите Выполнить.

Выполняется копирование проекта.


 Удаление проектов

Удаление проектов

Выполнен переход к первому экрану транзакции Управление проектом.

Последовательность шагов

...

1. Выберите проект, который требуется удалить.

2. Выберите Проект ® Удалить.

3. В появившемся диалоговом окне выберите, следует ли удалить соответствующую проектную документацию.

· Относящаяся к проекту документация удаляется только в том случае, если удаление документации по проекту отмечено флажком. В другом случае документация по удаленному проекту сохраняется.

· Документы, используемые в других проектах, удалить нельзя.

· Папка в Knowledge Warehouse системы SAP Solution Manager, содержащая проектную документацию, может быть удалена только в том случае, если она пуста.

Система удаляет документацию в фоновом режиме. Список всех неудаленных документов и проектов, в которых они использованы, можно посмотреть в журнале фонового задания.

При невозможности удаления документов:

a. Удалите все ссылки на эти документы в других проектах.

b. Снова запустите фоновое задание в транзакции SM37.

4. Подтвердите запрос системы о необходимости удаления проекта путем выбора кнопки Да .


 Сравнение с шаблоном/источником и корректировка

Сравнение с шаблоном/источником и корректировка

Использование

Эта функция используется для сравнения структуры и объектов, присвоенных проекту SAP Solution Manager, с их источником, например, шаблоном или репозитарием бизнес-процессов (Business Process Repository, BPR). В случае изменения источника эти изменения можно скопировать и, таким образом, оптимизировать структуру процессов и присвоенные объекты.

Интеграция

В проект можно скопировать структуры и присвоенные им объекты, например, документацию и объекты IMG, из шаблона или репозитария бизнес-процессов. Для получения дополнительной информации о функции копирования см. Устранение различий между источником и адресатом.

После копирования элементов из источника в проект источник может измениться, например, вследствие адаптации шаблона для новой версии программы, исправления ошибок в шаблоне или поставки новой версии сценариев иерархии бизнес-процессов.

Сравнение версии скопированных элементов в проекте с источником копирования выполняется с помощью функции Сравнение и корректировка посредством фонового задания. Система автоматически выбирает для сравнения самую новую версию источника. При определении системной среды проекта в Управлении проектом (транзакция SOLAR_PROJECT_ADMIN) в качестве источника для сравнения можно выбрать другую версию.

Копирование в проект изменений, обнаруженных в ходе выполнения фонового задания, также может быть выполнено в транзакции концептуального проекта (SOLAR01) и конфигурации (SOLAR02).

Предпосылки

В проекте имеются копии структур из одного из следующих источников:

· репозитарий для бизнес-процессов и сценариев, поставляемых SAP (репозитарий бизнес-процессов, BPR);

· шаблон;

· структура другого проекта из справки по допустимым значениям ввода на закладке Структура в транзакции концептуального проекта (SOLAR01);

· весь проект (в результате использования функции копирования в Управлении проектом).

Функциональные возможности

· Сравнение скопированных структур, включая версию SAP Solution Manager 2.20.

· Сравнение и корректировка всех объектов на следующих закладках:

Ў Общая документация,

Ў Структура,

Ў Транзакции,

Ў Конфигурация,

Ў Разработка,

Ў Контрольные примеры.

· Сравнение и корректировка изменений URL на закладке Транзакции. Изменение других объектов, например, изменение пакетов и документов настройки бизнес-конфигурации и обновление инструментов CATT/eCATT, на закладке Транзакции не указывается.

· Копирование в проект новых или измененных элементов из источника

· Копирование в проект операций по удалению, выполненных в источнике

Операции

...

1. На первом экране Управление проектом выберите Перейти к ® Сравнение и корректировка (транзакция SA_PROJECT_UPGRADE) для сравнения проекта с источником.

2. ФункцияСравнение и корректировка выполняет следующее:

Ў сравнение структуры проекта и ее элементов с их источниками, например, шаблонами, иерархией бизнес-процессов или другими проектами.

Ў обозначение тех структурных элементов адресата, которые изменились со времени их копирования в проект, в структуре проекта и на закладках в транзакциях SOLAR01 и SOLAR02 пиктограммой красного цвета.

Ў обозначение тех структурных элементов, которые не изменились, в транзакциях SOLAR01 и SOLAR02 пиктограммой зеленого цвета.

Для скрытия пиктограмм изменений в транзакциях SOLAR01 и SOLAR02 снимите флаг Режим корректировки в пользовательских параметрах настройки.

3. В системе создается журнал, который можно просмотреть при помощи транзакции SM37. В этом журнале возникшие при сравнении перечислены ошибки и количество найденных отличий в проекте.

4. Экранная кнопка Изменить на исходные в транзакциях SOLAR01 и SOLAR02 предоставляет следующие возможности:

Ў просмотра различий между источником и адресатом;

Ў выбора новых или измененных элементов в источнике и их копирования в проект;

Ў выбора операций по удалению в источнике и копирования их в проект.

· Экранная кнопка Завершено служит для изменения цвета пиктограмм с красного на зеленый. Узел структуры становится зеленым только в том случае, если статусу всех закладок соответствует зеленый цвет.

· Если узел структуры еще не имеет зеленого цвета, в левой части диалогового окна Сравнение и корректировка можно просмотреть различия для тех закладок, для которых уже был установлен зеленый цвет. Если на этом этапе будет выполнена функция Сравнение и корректировка , цвет пиктограммы закладки вновь станет красным.

· Экранная кнопка Сравнение и корректировка становится активной с момента копирования узла структуры из другого узла структуры в той же самой системе SAP Solution Manager.

Для выполнения сравнения с шаблонами вначале необходимо выполнить функцию Сравнение и корректировка , а затем нажать экранную кнопку Изменить на исходные на этой же на закладке.


 Устранение различий между источником и адресатом

Устранение различий между источником и адресатом

Использование

Эта функция позволяет скопировать изменения в структурах и структурных элементах, например, скопированных ранее из шаблона или репозитария бизнес-процессов (BPR), в проект SAP Solution Manager.

Предпосылки

· В пользовательских параметрах настройки установлен флаг Режим корректировки, и рядом со структурными элементами и на закладках после сравнения в транзакциях SOLAR01 и SOLAR02 присутствуют пиктограммы статуса.

· На закладке в транзакции SOLAR01 или SOLAR02 была выбрана экранная кнопка Изменить на исходные.

· Выполнена функция Сравнение и корректировка (SA_PROJECT_UPGRADE) для сравнения изменений в шаблонах с данным проектом.

Функциональные возможности

· Создание списка записей на текущей закладке в проекте SAP Solution Manager;

· Создание списка соответствующих записей новой версии узла источника с указанием статуса;

· Копирование всех или только выбранных изменений и операций по удалению из источника в данный проект.

Для замены всей подструктуры в проекте пользователя, например, всего сценария с подструктурой, изменившейся в источнике (например, шаблоне):

· Удалите подструктуру в своем проекте.

· Для сравнения с шаблоном вначале выполните функцию Сравнение и корректировка . Нажмите экранную кнопку Сравнить с исходными на уровне выше удаленной структуры.

Информация об удаленных элементах выводится в правой области диалогового окна Сравнение и корректировка .

· Скопируйте в проект новую запись.

· Для всех структурных элементов и закладок, источник которых был изменен, в диалоговом окне Сравнение и корректировка появится дополнительная экранная кнопка Завершено. Красные пиктограммы, отражающие изменения, можно изменить на зеленые с помощью экранной кнопки Завершено, независимо от того, были ли изменения скопированы в проект.

Для изменения цвета пиктограммы рядом со структурным элементом в проекте с красного на зеленый необходимо, чтобы такое изменение было выполнено для данного структурного элемента во всех закладках в транзакциях SOLAR01 и SOLAR02. Закладки пользовательских параметров настройки можно скрыть.

Пример

Требуется сравнить элементы в шаблоне с проектом. Для контроля изменений в проекте выполните копирование изменений последовательно по одному:

...

1. В диалоговом окне Сравнение и корректировка на закладке Конфигурация скопируйте из шаблона в проект новый пакет настройки бизнес-конфигурации. Активируйте пакет настройки бизнес-конфигурации в проекте, поскольку он содержит важные изменения.

2. Скопируйте из шаблона в проект новую операцию IMG. Проверьте ее в IMG и удалите ее из закладки Конфигурация, поскольку она не является релевантной для выполняемого процесса. Для указания на то, что дальнейшие операции сравнения не требуются, нажмите экранную кнопку Завершено в диалоговом окне Сравнение и корректировка на закладке Конфигурация.

3. Повторяйте эти шаги до тех пор, пока не будут проверены все новые данные.


 Перенос данных проекта в SAP

Перенос данных проекта в SAP

Использование

Данные по запущенным проектам передаются из SAP Solution Manager в SAP для анализа. Данные сохраняются в базе данных проектов в SAP. Эти данные позволяют SAP обеспечивать оптимальную поддержку проекта на продуктивном этапе.

Предпосылки

В SAP в базе данных проектов CPI создан проект, соответствующий продуктивному проекту в системе пользователя. Было выполнено деблокирование проекта пользователя. После создания проекту пользователю было направлено имя и уникальный идентификационный код соответствующего проектаCPI.

Операции

...

1. Выполните настройку переноса данных проекта.

2. Перенесите данные в SAP.


 Настройка переноса данных проекта

Настройка переноса данных проекта

Последовательность шагов

Установка SAP Cryptolib

Для переноса данных в SAP необходимо выполнить их шифрование при помощи SAP Cryptolib.

...

1. Установите SAP Cryptolib:

a. Выгрузите SAP Cryptolib для данной операционной системы с Service Marketplace (www.service.sap.com/swcenter ® Выгрузка ® SAP Cryptographic Software).

b. Установите SAP Cryptolib через Trust Manager (транзакция STRUST). Для получения дополнительной информации см. Trust-Manager (транзакция STRUST ® Справка ® Справка по приложению ® Trust Manager).

Более подробную информацию об установке SAP Cryptolib см. по пути Справка ® Справка по приложению ® Trust-Manager ® Пример ® Конфигурация SAP Web Application Server для поддержки SSL (транзакция STRUST).

Изменения, внесенные в Trust Manager, вступят в силу только после перезапуска монитора IC или сервера приложений (шаг 2).

2. Для перезапуска монитора ICM выберите Администрирование ® ICM ® Программный перезапуск в транзакции Монитор ICM (SMICM).

Для проверки того, был ли выполнен перезапуск монитора ICM, нажмите экранную кнопку Обновить.

В левой области экрана в Trust Manager появятся неактивная папка PSE, SSL-сервер и SSL-клиент (по умолчанию). Неактивные папки отмечены красным крестом.

3. Настройка PSE для SSL-сервера (по умолчанию):

a. Выберите папку SSL-клиента (по умолчанию) и затем выберите Создать в контекстном меню.

b. Подтвердите появившееся диалоговое окно.

Новая среда PSE появится под папкой PSE.

4. Выполните импорт сертификата клиента в папку SSL-клиент (по умолчанию):

a. Выполните вход в SAP Service Marketplace через Microsoft Internet Explorer

b. Щелкните два раза по пиктограмме блокирования в строке статусов веб-браузера внизу справа.

В диалоговом окне появится сертификат.

c. Выгрузите сертификат SSL-клиента из закладки Подробно.

d. Импортируйте этот сертификат путем выбора Сертификат ® Импорт в Trust Manager (транзакция STRUST).

5. Настройка PSE для SSL-сервера:

a. Выделите папку SSL-сервер и выберите Создать в контекстном меню.

b. Подтвердите появившееся диалоговое окно.

Новая среда PSE появится под папкой PSE.

6. Для перезапуска монитора ICM выберите Администрирование ® ICM ® Программный перезапуск в транзакции Монитор ICM (SMICM).

Для проверки того, был ли выполнен перезапуск монитора ICM, нажмите экранную кнопку Обновить.

7. Определите параметры настройки прокси:

a. Запустите программу RSPROJECT_SET_CPI_URL.

b. Введите требуемые данные и выберите Выполнить.

Указывать порт требуется только в случае отсутствия прокси-сервера.

Введите URL service.sap.com/; но не указывайте протокол (например, http).

Проверка установки SAP Cryptolib

...

1. Запустите программу SSF02

2. Установите флаг Просмотр версии.

3. Выберите Выполнить.

Система выведет для просмотра текущую версию SAP Cryptolib.

Обработка ошибок

Для исправления некорректно определенного идентификатора проектаCPI и/или идентификатор аутентификации выполните программу RSPROJECT_CHANGE_CPIS_AUTH. Система скопирует определенные значения из программы Перенос данных в SAP" (RSPROJECT_CPI) и запретит ввод в эти поля.

Результат

Появилась возможность переноса данных проекта в SAP.

См. также:

· Сервисы SAP Trust Center: www.service.sap.com/tcs

· SAP-нота 510007 о настройке SSL для SAP Web Application Server


 Процесс переноса данных проекта в SAP

Процесс переноса данных проекта в SAP

Использование

Данные по запущенным проектам передаются из SAP Solution Manager в SAP для анализа. Данные сохраняются в базе данных проектов в SAP. Эти данные позволяют SAP обеспечивать оптимальную поддержку проекта на продуктивном этапе.

Предпосылки

В SAP в базе данных проектов CPI создан проект, соответствующий продуктивному проекту в системе пользователя. Было выполнено деблокирование проекта пользователя. После создания проекту пользователю было направлено имя и уникальный идентификационный код соответствующего проекта CPI.

Последовательность шагов

...

1. Выберите Перейти к ® Перенос данных в SAP в Управлении проектом или запустите программу RSPROJECT_CPI.

2. Введите требуемые данные в области Вход в систему.

После отправки данных ввод в эти поля запрещен.

3. Введите требуемые данные в области Проект.

4. Укажите контактных лиц в области Контактные лица . Чтобы выбранные имена были доступны для проверки в SAP, введите адрес электронной почты и любой идентификатор пользователя OSS.

Если внедрение SAP выполняется партнером или на предприятии партнера, в качестве руководителя проекта SAP укажите контактное лицо в SAP, которое несет ответственность за соответствующий проект CPI.

5. Если внедрение SAP выполняется партнером, введите требуемые данные в области Партнер. Для переноса данных выбранный партнер должен быть зарегистрирован в SAP.

6. Введите плановые и фактические сроки фаз проекта в области План работ.

Для фаз "Концептуальный проект" и "Реализация" система скопирует все имеющиеся данные с корневых узлов структур. Ввести данные по этим фазам можно в закладке Администрирование.

7. При наличии критических ситуаций в проекте для уведомления об этом SAP введите соответствующее примечание в области Статус риска .

8. Определите прикладной компонент реализуемого решения.

9. В области Сценарии появится список всех сценариев, включенных в проект. После создания нескольких сценариев для категоризации можно присвоить им стандарт сценария SAP. Только после этого появляется возможность передачи данных о статусе и примечаний по этому сценарию в SAP.

Выполняется перенос текстов узлов структуры для процессов и шагов процессов, а также сценариев SAP. Данные, присвоенные узлам структуры, переносу не подлежат. Для просмотра отправленных узлов структуры нажмите экранную кнопку Объем проекта .

10. Отправка SAP пользовательских документов и системных данных осуществляется в области Документация. Для отправки в SAP документов и других данных выберите Отправить.

В системе сохраняются пути к выбранным документам, поэтому при необходимости повторной отправки, например, передачи новой версии документа, достаточно только нажать кнопку Отправить.

11. Для переноса в SAP данных проекта выберите Список ® Отправить или экранную кнопку Отправить. В появившемся диалоговом окне введите действительное имя пользователя SAP Service Marketplace и пароль. Данные сохраняются в базе данных проектов SAP с пометкой о последнем изменении этим пользователем.


 Миграция данных при обновлении версии с 2.20 на 3.10

Миграция данных при обновлении версии с 2.20 на 3.10

Использование

Версию 2.20 невозможно обновить до версии 3.10 обычным путем, так как эти версии имеют различную архитектуру системы SAP Solution Manager. Поэтому необходимо заново установить систему и выполнить миграцию существующих данных из версии 2.20 в версию 3.10 при помощи транзакции Миграция SAP Solution Manager (SOLAR_MIGRATION). Эта транзакция используется для автоматического экспорта проектов, документации, данных системной среды и синхронизации настройки из более ранней версии и импорта этих данных в новую версию.

Предпосылки

· Целевая система определена как таковая для переносов в системе управления переносами. Одна и та же система может быть определена и как исходная и как целевая, например, система ABC может быть определена как целевая система для той же самой системы ABC.

· Необходимо наличие роли SAP_SOLAR_MIGRATION в версиях 2.20 и 3.10.

Функциональные возможности

· Автоматический экспорт следующих данных из SAP Solution Manager версии 2.20:

Ў Проекты:

§ Данные заголовка и управляющие данные

§ Структура проекта с присвоениями

§ Присвоения маршрутных карт проектам

§ Проектная документация и общая документация: параметры настройки, документы и папки в Knowledge Warehouse, интегрированном в SAP Solution Manager

§ Планы тестирования с контрольными примерами и пакетами тестов

Присвоение тестеров к пакетам тестов не переносится.

Ў Основные параметры настройки логических компонентов для внедрения SAP Solution Manager:

Ў Данные системной среды

Ў Данные по синхронизации настройки

Ў Группы синхронизации для синхронизации настройки

· Измените исходную систему записей каталогов объектов путем переноса. Эта функция необходима в случае установки версии 3.10 в логической системе, отличной от системы версии 2.20.

· Выполните импорт данных в SAP Solution Manager 3.10.

· Создается журнал миграции.

Операции

...

1. Миграция данных из версии 2.20 в версии 3.10

2. Настройка системной среды SAP Solution Manager и распределения настройки в версии 3.10 после миграции

3. Настройка перенесенных проектов в версии 3.10

...

См. также:

· Руководство по миграции SAP Solution Manager

· Руководство по инсталляции SAP Solution Manager


 Миграция данных из версии 2.20 в версию 3.10

Миграция данных из версии 2.20 в версию 3.10

Предпосылки

Деблокирование всех открытых запросов на перенос в исходной версии 2.20.

Последовательность шагов

При наличии в системной среде нескольких систем SAP Solution Manager, например, системы разработок, системы обеспечения качества и продуктивной системы, их миграция выполняется по отдельности:

...

1. Экспорт данных из исходной версии 2.20:

a. Выполните транзакцию Миграция SAP Solution Manager (SOLAR_MIGRATION) в версии 2.20 и введите требуемые данные.

Миграция выполняется в отношении только явно выбранных объектов.

b. Система выполняет сбор выбранных данных и их сохранение следующим образом:

§ Данные системной среды сохраняются в формате XML в определенном каталоге.

§ Документы изменений сохраняются как текстовые файлы.

§ Примечания к тестам сохраняются в формате XML.

§ Другие данные в запросах на перенос вида "копии переносов" сохраняются в каталоге переноса системы управления переносами в исходной системе.

§ Если целевая и исходная версии установлены в различных системах, для перехода в исходной системе объектов от 2.20 в целевую версию 3.10 создается перенос перемещений, позволяющий изменить записи каталогов этих объектов. Записи каталогов объектов, исходной системой которых не является система с версией 2.20, не изменяются.

c. В определенном каталоге система создает управляющий файл, содержащий информацию об экспортированных данных, для использования при последующей операции импорта.

d. Также система создает журнал миграции. Вызов журнала миграции осуществляется с первого экрана транзакции Миграция SAP Solution Manager.

2. Установите новую версию 3.10. Более подробная информация содержится в Руководстве по инсталляции SAP Solution Manager.

3. Выполните импорт данных, экспортированных из версии 2.20, в версию 3.10:

a. Выполните транзакцию Миграция SAP Solution Manager в версии 3.10.

b. Укажите каталог, содержащий экспортируемые данные.

c. Система проверяет наличие управляющего файла, содержащего информацию об экспортированных данных.

d. Вместе с экспортом данных выполняется импорт файлов и запросов на перенос в версию 3.10.

e. В журнале миграции появляется запись об импорте данных.

В случае неудачной миграции, например, из-за отсутствия необходимых полномочий, выполните транзакцию Миграция SAP Solution Manager снова. Изменения, внесенные с момента миграции в импортированные проекты в целевой версии, при повторном импорте не сохраняются.

Результат

· Настройка системной среды и распределения настройки в новой системе

· Настройка перенесенных проектов в новой системе


 Настройка системной среды и распределения после миграции

Настройка системной среды и распределения после миграции

Использование

Для работы с системной средой SAP Solution Manager и распределением настройки после импорта данных в версию 3.10 необходимо выполнить следующие действия:

· системная среда: корректировка соединений вида "Достоверная система" между новой системой SAP Solution Manager и спутниковыми системами;

· распределение настройки: удаление не требуемых записей о распределении и выгрузка списка объектов синхронизации.

Предпосылки

· Необходима роль SAP_SOLAR_MIGRATION.

· Полномочия на выполнение транзакции SCDT_SETUP для настройки параметров функции "Распределение настройки". Эти полномочия включены в роль Консультант по приложению.

· Данные из версии 2.20 перенесены в версию 3.10 при помощи транзакции Миграция SAP Solution Manager (SOLAR_MIGRATION).

· Для переноса всех существующих данных распределения из старой системы SAP Solution Manager в новую была выбрана опция экспорта данных распределения настройки в транзакции Миграция SAP Solution Manager (SOLAR_MIGRATION).

· Данные системной среды были импортированы в новую систему.

Последовательность шагов

Создание RFC-соединений вида "Достоверная система" от новой системы SAP Solution Manager к спутниковым системам

...

1. Выполните следующую настройку полномочий:

a. Создайте пользователя SOLMAN<SidCli>, где <Sid> - системный идентификатор и <Cli> - мандант в старой системе SAP Solution Manager, для всех требуемых мандантов новых систем SAP Solution Manager.

Присвойте полномочия S_RFCACL для всех спутниковых систем и полномочия S_RFC пользователю SOLMAN<SidCli>.

b. Присвойте полномочия S_RFCACL и S_RFC пользователю SOLMAN<SidCli> в целевых мандантах спутниковых систем для всех требуемых мандантов в новой системе SAP Solution Manager.

c. Измените пользователя SOLMAN<SidCli> в спутниковых системах на диалогового пользователя.

d. Все пользователи в целевых мандантах всех спутниковых систем должны иметь полномочия для всех требуемых мандантов в новой системе SAP Solution Manager (полномочия S_RFCACL).

2. Создайте соединения вида "Достоверная система":

a. Выполните программу SMSY_REGENERATE_ALL_DESTS в каждом манданте новой системы SAP Solution Manager.

Эта программа создает все соединения вида "Достоверная система".

b. При появлении запроса о регистрации в новой системе SAP Solution Manager выполните вход в систему как пользователь SOLMAN<SidCli>.

Установка параметров распределения настройки в новой системе

...

1. Удалите в новой системе не требуемые записи о распределении, на экране настройки параметров функции Распределение настройки (транзакция SCDT_SETUP).

2. Выгрузите список объектов синхронизации для всех программных продуктов, включенных в распределение настройки, путем выбора Перейти к ® Загрузка списка объектов в транзакции SCDT_SETUP.

3. Для активации необходимых распределений в новой системе два раза щелкните по ним и сохраните их на подробном экране. Для каждого проекта требуется активация только одного распределения.

4. Запланируйте фоновые задания для распределения видов Запланированное распределение и Автоматическое повторное распределение после ошибок.


 Настройка проектов после миграции

Настройка проектов после миграции

Использование

Для получения возможности работы с проектами, созданными в версии 2.20, после миграции, следует вручную выполнить постобработку импортированных проектов в версии 3.10.

Предпосылки

· Выполнен импорт данных системной среды.

· Для пакетов с шаблонами определена среда переноса.

Последовательность шагов

...

1. Для копирования изменений в определениях продуктов, поставляемых в версии 3.10, в логические компоненты, выполните программу SOLAR_SCDTLOGCMP_MIGRATION.

2. При использовании шаблонных проектов:

a. Для активации функциональных возможностей CTS для импортированного шаблонного проекта вызовите шаблонный проект в управлении проектом и нажмите кнопку Активация функций CTS на закладке Запросы на перенос. Повторите эти шаги для всех импортированных шаблонных проектов.

b. Для адаптации шаблонов из шаблонных проектов к версии 3.10 выполняйте программу RSPROJECT_TEMPL_MIGRATION_310 после каждой новой операции импорта проектов SAP Solution Manager.

c. Если в систему версии 2.20 были импортированы шаблоны, созданные в других системах, их также следует импортировать в новую систему 3.10.

3. Присвойте пакеты тестов тестерам.

4. Для повторного присвоения члена группы проекту выполните программу RS_GET_BACK_MIGRATED_RESOURCES для каждого импортированного проекта.

Результат

Вся требуемая обработка после миграции выполнена. Можно использовать проекты и шаблоны, перенесенные из версии 2.20 в версию 3.10.


 Обзор проектов SAP Solution Manager

Обзор проектов SAP Solution Manager

Использование

Обзор проектов SAP Solution Manager предоставляет информацию по проектам внедрения и шаблонным проектам, а также позволяет просмотреть данные по этим проектам, например, их статус.

Интеграция

Из обзора проекта системы Solution Manager можно перейти ко всем необходимым операциям с проектом внедрения или шаблонным проектом путем выбора соответствующих ссылок.

Функциональные возможности

· Просмотр проектов внедрения и шаблонных проектов.

· Просмотр следующих данных проекта:

Ў Плановые данные

Ў Фактические данные

· Просмотр маршрутной карты данного проекта с этапами, статусом, плановыми и фактическими данными в Управлении проектом в случае, если маршрутная карта была присвоена проекту на закладке Объем

· Просмотр сценариев проекта

· Просмотр ракурсов компонентов сценариев и процессов


 Быстрая настройка проекта

Быстрая настройка проекта

Использование

Эта функция позволяет быстро создавать проекты SAP Solution Manager. Для упрощения процедуры пошагового создания проекта используется веб-ассистент.

Эта функция используется, например, при первой установке SAP Solution Manager или при отсутствии опыта работы с настройкой и управлением проектом в SAP Solution Manager.

Функция Быстрая настройка проекта позволяет создавать проекты независимо от конкретной системной среды.

Интеграция

Дальнейшая обработка проекта внедрения выполняется в транзакции Концептуальной проект, где на основе выбранных шаблонов и решений создается структура проекта.

Для быстрой настройки проекта наличие системной среды не является обязательным условием. В частности, создание проекта и переход к фазе концептуального проекта могут выполняться при отсутствии готовой системной среды.

Для дальнейшей обработки проекта на фазе Конфигурация определите системную среду и поместите в системную среду проекта необходимые системы компонентов в транзакции Управление проектом.

Предпосылки

Наличие роли руководителя проекта (SAP_SOLAR_PM).

Функциональные возможности

· Создание проекта внедрения

· Определение данных заголовка

· Выбор шаблонов, которые станут основой проекта

· Выбор решений из репозитария бизнес-процессов и сценариев (репозитарий бизнес-процессов)

· Выбор программных продуктов и их версий

· Выбор сценариев из списка шаблонов и решений

Операции

...

1. Выберите Быстрая настройка проекта (транзакция AI_SPS) в меню роли SAP Easy Access.

2. Появится ассистент установки, при помощи которого осуществляется выполнение дальнейших шагов настройки проекта.


 Системная среда SAP Solution Manager

Системная среда SAP Solution Manager

Использование

Системная среда централизованно создается и управляется в SAP Solution Manager для ее использования в проектах внедрения и шаблонных проектах, синхронизации настройки (Customizing Scout, распределение настройки) и при оперативной обработке (контроль решения, сервисы, служба поддержки).

Интеграция

SAP Solution Managerосновывается на системной среде. Надлежащим образом настроенная системная среда предпосылкой для реализации функций SAP Solution Manager:

· Создание IMG проекта в Управлении проектом;

· Переход к системам компонентов на фазе конфигурации;

· Синхронизация настройки (Customizing Scout, распределение настройки, редактор групп синхронизации);

· Ведение сред решений для оперативной обработки решений.

Функциональные возможности

· Создание компонентов среды (хосты, базы данных, системы);

· Определение внешних продуктов для использования при ведении системной среды;

· Автоматический просмотр и сохранение данных посредством главной инстанции ABAP;

· Обзор групп систем;

· Создание RFC-адресов для систем компонентов; регистрация ошибок RFC-соединений;

· Сбор данных вручную, например, для серверов, систем "не ABAP" и плановых систем.


 Управление системной средой

Управление системной средой

Цель использования

Системная среда создается и управляется в SAP Solution Manager для ее использования в проектах внедрения и шаблонных проектах, в синхронизации настройки (Customizing Scout, распределение настройки) и при оперативной обработке (контроль решения).

Предпосылки

· Для создания системной среды SAP Solution Manager необходимы полномочия для объекта полномочий S_SMSYEDIT.

· Необходимо обладать полномочиями на определение RFC-соединений в SAP Solution Manager и спутниковых системах.

Выполнение

...

1. Настройте автоматический сбор данных для системной среды с целью автоматического считывания данных хоста, баз данных и систем из каталога системных ландшафтов или сервера инфраструктуры среды.

2. Для использования данных предыдущего решения по оперативной обработке (транзакция SOLUTION_MANAGER) в системной среде SAP Solution Manager (транзакция SMSY) после обновления на SAP Solution Manager 3.10:

a. Система выводит сообщение о необходимости копирования данных в системную среду SAP Solution Manager (транзакция SMSY) при первом вызове предыдущего решения в транзакции SOLUTION_MANAGER после обновления.

b. Скопируйте данные.

c. Проверьте результат копирования данных. Более подробная информация содержится в Руководстве по инсталляции SAP Solution Manager.

d. Данные решения по оперативной обработке в системной среде SAP Solution Manager (транзакция SMSY) можно просмотреть путем выбора Группы систем ® Среды решений – оперативно.

3. Системная среда определяется в разделе Системная среда SAP Solution Manager (транзакция SMSY):

a. Определите атрибуты пользователя для элементов среды и настройте для них справку по допустимым значениям ввода.

b. Определите элементы системной среды:

§ Системные роли;

§ Внешние продукты;

§ Хост;

§ Базы данных;

§ Системы;

§ Группы систем для проекта внедрения и сред решения.

c. Добавьте данные элементов среды, полученные в результате автоматического сбора данных.

d. Выполняется создание RFC-соединений с системами или присвоение существующих RFC-соединений.

Результат

Для SAP Solution Manager установлена системная среда.

После этого в транзакции SOLUTION_MANAGER создается проект внедрения, выполняется синхронизация настройки или создание решений по оперативной обработке.


 Настройка автоматического сбора данных для системной среды

Настройка автоматического сбора данных для системной среды

Использование

Для получения системных данных для системной среды SAP Solution Manager следует настроить функцию автоматического переноса данных с сервера инфраструктуры среды (LIS) и из каталога системных ландшафтов (SLD).

На основе этих данных SAP Solution Manager может автоматически получить данные от хоста, баз данных и систем.

Предпосылки

Для получения возможности использования сервера инфраструктуры среды (LIS) следует присвоить SAP Solution Manager домен переноса или определить систему SAP Solution Manager в качестве нового контроллера домена в системе управления переносами (STMS).

Последовательность шагов

...

...

1. Выберите транзакцию Установка системной среды (SMSY_SETUP).

2. Выберите источник автоматического переноса данных.

При наличии в данной системной среде настроенного каталога системных ландшафтов (SLD) этот каталог следует выбрать в качестве источника при переносе данных. Для систем в домене переноса сервер инфраструктуры среды (LIS) предоставляет данные только относительно имен систем, мандантов и компонентов программного обеспечения в системах. Каталог системных ландшафтов предоставляет данные хоста и баз данных независимо от домена переноса.

3. Для доступа к каталогу системных ландшафтов (SLD):

a. Выберите Обработать ® Экспертные параметры настройки.

b. Определите хост, с которого считываются данные каталога системных ландшафтов, как Хост каталога системных сред.

c. Можно изменить и другие опции.

Эти опции также можно изменить при настройке каталога системных ландшафтов.

d. Данные могут быть записаны в каталог системных ландшафтов путем ввода значения в поле Запись данных в каталог системных сред.

e. Выберите Дальше.

Более подробная информация содержится в разделе Каталог системных ландшафтов в библиотеке SAP.

4. Выберите График автоматического переноса данных.

5. На следующем экране введите время запуска. Можно выбрать однократное или периодическое выполнение задания.

Более подробная информация содержится в разделе Автоматический сбор данных.

6. Сохраните введенные данные.

Система копирует данные в первый экран. Каждый перенос данных регистрируется в системном журнале. Файлы регистрации можно просмотреть в транзакциях Настройка системной среды (SMSY_SETUP) и Системная среда SAP Solution Manager (SMSY) путем выбора Журналы ® Обновление журналов.

Для удаления журналов переноса данных:

· В транзакциях "Настройка системной среды" (SMSY_SETUP) или "Системная среда SAP Solution Manager" (SMSY) выберите "Журналы ® Обновление журналов ® Удалить".

· Выберите необходимые опции.
Срок хранения журнала истекает через 14 дней (рамка группы Дата истечения срока ).

· Выберите Выполнить.

Результат

Настроена функция переноса данных, позволяющая автоматически получать системные данные для дальнейшего использования в системной среде SAP Solution Manager. После сбора данных автоматически опознаваемые системы и хосты в системной средеSAP Solution Manager становятся видимыми.


 Автоматический сбор данных

Автоматический сбор данных

Обработка автоматически собранных данных

Обработка вручную любых данных их автоматически определенных источников в хостах, базах данных и системах невозможна. Также невозможно удалить элементы среды или изменить связанные с ними данные, поступившие в результате автоматического сбора данных. Однако возможно добавление данных.

Для получения возможности обработки всех данных в элементе среды вручную следует определить этот источник данных какподлежащий ведению вручную.

Обновление автоматически собранных данных

В системе можно выбрать либо автоматическую перезапись введенных вручную данных, либо вывод запроса при появлении более актуальных данных. Во втором случае последний пользователь, который должен изменить подлежащие обновлению данные, получает экспресс-сообщение. В системной среде SAP Solution Manager устаревшие данные отмечаются восклицательным знаком. Можно сравнить данные и скопировать текущие значения.


 Ведение источников данных вручную

Ведение источников данных вручную

Использование

Обработка вручную любых автоматически определенных данных в хостах, базах данных и системах невозможна. Для получения возможности обработки всех данных в элементе среды вручную следует определить этот источник данных как подлежащий ведению вручную.

Определение источника данных как подлежащего ведению вручную должно осуществляться только в случае несовпадения автоматически заданных данных с фактическим определением компонента среды. Например, это может произойти при временном наличии в системе дополнительного сервера, который распознается при автоматическом сборе данных, но не входит в системное описание, поскольку является только временным.

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

...

1. Выберите Компоненты среды ® Другой объект или

2. Выберите компонент среды из справки по допустимым значениям ввода или введите имя компонента среды.

3. Выберите экранную кнопку Источник данных: ввод вручную.

4. Подтвердите запрос подтверждения.


 Создание и присвоение атрибутов компонентов среды

Создание и присвоение атрибутов компонентов среды

Использование

Атрибуты хостов, баз данных, систем и главных инстанций создаются с целью присвоения этим компонентам дополнительных свойств, например, описательной информации по аппаратным средствам или ответственного за систему.

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Определение атрибутов компонентов среды

...

1. Выберите Утилиты ® Определения атрибутов.

2. Перейдите в режим изменения.

3. Выберите Новые записи.

4. В области имен клиента присвойте код атрибута, начинающийся с Y или Z.

5. Введите требуемые данные.

6. Определите компонент среды, которому необходимо присвоить атрибут.

7. Настройте справку по допустимым значениям ввода для значений атрибутов компонентов.

8. Сохраните введенные данные.

Новые атрибуты компонентов среды выводятся для просмотра на закладке Другие атрибуты.

Присвоение значений атрибутам компонентов среды

...

1. Выберите компонент среды.

2. Выберите значение атрибута из справки по допустимым значениям ввода для столбца Значение атрибута на закладке Другие атрибуты.

3. Сохраните изменения.


 Настройка справки по допустимым значениям ввода для атрибутов компонентов среды

Настройка справки по допустимым значениям ввода для атрибутов компонентов среды

Использование

Для определяемых пользователем атрибутов в системе можно использовать существующую справку по допустимым значениям ввода. Например, в качестве справки по допустимым значениям ввода для атрибута "Ответственный" можно использовать список системных администраторов.

При определении атрибута настройка справки по допустимым значениям ввода для атрибута может осуществляться путем выбора существующей таблицы значений или использования средств поиска. Также можно самостоятельно определить все допустимые значения ввода.

При вызове справки по допустимым значениям ввода система сначала проверяет, были ли выбраны при определении атрибута таблица значений и/или средство поиска. Если они определены, в качестве допустимых значений ввода используются записи в таблице значений или средстве поиска.

В случае если таблица значений или средство поиска не определены, система вводит в справку по допустимым значениям ввода значения, выбранные индивидуально в определении атрибута. Если значения не определены, справка по допустимым значениям ввода будет недоступной.

Необходимые предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Определен, по крайней мере, один атрибут компонента среды.

Последовательность шагов

...

1. Выберите Утилиты ® Определения атрибутов.

2. Перейдите в режим изменения.

3. Выберите атрибут.

4. Для использования существующих таблиц значений и средства поиска также выбрать один из следующих вариантов:

a. Введите имя таблицы в поле Таблица значений;

b. Введите имя поля этой таблицы в поле Поле значений.

или

...

a. Определите средство поиска в поле Средство поиска .

b. Определите параметр возврата для этого средства поиска в поле Поле средства поиска .

При определении только имени средства поиска система выведет для просмотра первый параметр в средстве поиска.

5. Для самостоятельного определения значений справки по допустимым значениям ввода для атрибута:

a. В диалоговой структуре выберите Справка по допустимым значениям ввода .

b. Выберите Новые записи.

c. Введите требуемые данные.

Также можно просмотреть текст, который вводится в столбец Описание в справке по допустимым значениям ввода атрибута. Этот текст является зависимым от языка.

6. Сохраните введенные данные.


 Создание внешних продуктов

Создание внешних продуктов

Самостоятельно можно создавать только внешние (не SAP) продукты.

...

...

1. Выберите Общие определения продуктов компонента среды и Создать в контекстном меню или Компоненты среды ® Создать объект ® Создать продукт.

2. Введите требуемые данные в следующем диалоговом окне.

3. Сохраните введенные данные.

Новый продукт отображается в левой части экрана.

4. Для определения версий нового продукта определите код продукта и версии продукта на закладке Версии продукта .

5. Сохраните введенные данные.

Система автоматически присваивает версиям продукта определенную последовательность. Эту последовательность можно изменять при помощи клавиш-стрелок.

6. Определите главные инстанции нового продукта на закладке Компоненты.

7. Сохраните введенные данные.

8. Установите для продукта флаг Активно для использования продукта при определении системной среды. Для установки для продукта статуса Активно необходимо определить, по крайней мере, одну версию продукта, как описано в пункте 4.

Для определения системной среды можно использовать только активные продукты. Неактивные продукты будут скрыты при выборе продуктов в любой справке по допустимым значениям ввода в SAP Solution Manager.

Эти записи помещаются в системную настройку, где можно выбрать показ или скрытие продуктов.


 Обработка продуктов, присвоения продуктов и версий продуктов

Обработка продуктов, присвоения продуктов и версий продуктов

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

Показ/скрытие продуктов

Согласно системной настройке, продукты SAP отображаются в левой части экрана.

Конфигурация системы должна обеспечить скрытие не используемых в системной среде продуктов во всей системе. Эти продукты будут скрыты при выборе продуктов в любой справке по допустимым значениям ввода в SAP Solution Manager. Выбор показа или скрытия продуктов, скрытых для всей системы, осуществляется в настройках пользовательского фильтрасистемной среды SAP Solution Manager.

· Для показа или скрытия продуктов во всей системе:

...

a. Выберите Утилиты ® Системная настройка ® закладка "Выбор продукта".

b. Перейдите в режим изменения.

c. Выберите продукты путем установки флагов в столбце Активно.

d. Сохраните выбор.

· В персональном ракурсе можно показ или скрытие продуктов выбирается по пути Утилиты ® Пользовательский фильтр ® закладка "Продукты".

Ў При выборе "Все продукты" система игнорирует выбор, определенный в системной настройке, и отображает все существующие продукты.

Ў Для полного скрытия общего определения продукта в компонентах среды необходимо снять флаг Просмотр общих определений продуктов в дереве.

Просмотреть подробную информацию относительно версии продуктов SAP можно путем двойного щелчка по версии продукта. Эта подробная информация включает данные относительно компонентов продукта.

Изменение присвоения системы продукту и версии продукта

После обновления систем, созданных вручную и не обновляемых автоматически, можно присвоить системе другой продукт или версию продукта. Например, системное присвоение продуктов изменяется при переходе с R/3 версии 4.6C на R/3 Enterprise 4.7.

Автоматически определенные системы могут более одного раза выступать в качестве компонентов среды в случае, если их компоненты не могут быть автоматически присвоены одному продукту, например, если при автоматическом определении данных оказалось невозможным однозначно определить наличие в системе установленных компонентов SAP APO или SAP BW. В этом случае в системной среде SAP Solution Manager система выступает в качестве компонента и для SAP APO, и для SAP BW. Если необходимо присвоить системе только определенные продукты, необходимо отметить эти продукты как основные. (5).

...

1. Выберите Компоненты среды ® Другой объект…

2. Определите систему.

3. Выберите экранную кнопку Установленные версии продуктов.

4. Выберите новые данные продукта из справки по допустимым значениям ввода.

или

В случае если новый продукт/версия продукта отсутствует в справке по допустимым значениям ввода, установите флаг Произвольный выбор продукта/версии продукта и введите данные продукта.

5. Сохраните введенные данные и выберите Дальше.

Система появится в новой позиции слева, среди компонентов среды.

6. Если уже осуществлялось ведение системных серверов для другого продукта, эти серверы могут быть скопированы для новой системы:

a. Выберите продукт слева от компонентов среды и перейдите к закладке Сервер.

b. Выберите Скопировать сервер.

c. Выберите сервер.

d. Сохраните выбор.


 Создание хоста

Создание хоста

Использование

В случае настройки автоматического сбора данных для системной среды система автоматически определяет отображаемые данные. Система не может автоматически определить все данные хоста, поэтому их можно дополнить, например, путем указания частоты.

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

...

При наличии в сети маршрутизаторов или при необходимости определения имени системы доменных имен (DNS) для создания RFC-соединения требуется выполнить следующее:

· В качестве хоста создайте сервер сообщений для спутниковой системы в системной среде SAP Solution Manager.

· Определите данные маршрутизации для этого хоста.

Данные маршрутизации необходимы для создания RFC-соединений.

· Создайте систему и определите этот хост как сервер сообщений.

Дополнительная информация содержится в разделе Создание RFC-соединений.

1. Выберите компонент среды Хост и затем выберите Создать в контекстном меню или Компоненты среды ® Создать объект ® Создать хост.

2. Введите требуемые данные.

3. Определите любые данные маршрутизации.

4. Выберите значения атрибутов из справки по допустимым значениям ввода на закладке Другие атрибуты.

5. Сохраните изменения.


 Создание баз данных

Создание баз данных

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

...

1. Выберите компонент среды Базы данных и затем выберите Создать в контекстном меню или Компоненты среды ® Создать объект ® Создать базу данных.

2. Введите требуемые данные.

3. Выберите значения атрибутов из справки по допустимым значениям ввода на закладке Другие атрибуты.

4. Сохраните изменения.


 Создание систем

Создание систем

Использование

Процедура создания систем выполняется с целью обеспечения возможности использования этих систем в проектах SAP Solution Manager.

В случае настройки автоматического сбора данных для системной среды система автоматически определяет отображаемые данные для ABAP-продуктов SAP. Удаление автоматически определенных системы или данных систем невозможно. Эти данные можно дополнить, либо следует переключить источник данных на ведение вручную.

Для продуктов SAP не на основе ABAP можно самостоятельно создавать системы для использования их в среде решения при оперативной обработке.

Предпосылки

Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

Создание систем

...

1. Выберите компонент среды Системы и затем выберите Создать в контекстном меню или Компоненты среды ® Создать объект ® Создать систему.

2. В следующем диалоговом окне в качестве имени системы введите ее идентификатор. Если в системной среде существуют другие системы с тем же именем, для их отличия необходимо дополнить имена систем, например, определить их как "система AAA_1" и "система AAA_2".

3. Из справки по допустимым значениям ввода выберите продукт и версию продукта.

4. Сохраните введенные данные.

Для системы отображаются главные инстанции выбранного продукта.

5. Выберите систему, после чего можно определить другую главную инстанцию на основе ABAP как релевантную или установить флаг "Релевантно" для нескольких главных инстанций не на основе ABAP на закладке "Описание системы". При оперативной обработке в среде решения могут отображаться только релевантные главные инстанции.

6. Можно ввести дополнительную информацию относительно системы.

Можно определить систему как плановую или продуктивную. Можно, например, снять флаг Продуктивно для создания копии продуктивной системы в резервной системной среде.

7. Сохраните введенные данные.

Определение главных инстанций для ABAP-продуктов SAP

На каждую систему для ABAP-продуктов SAP должна существовать одна релевантная главная инстанция. При наличии более одной главной инстанции ABAP для этого продукта одна главная инстанция ABAP при создании системы автоматически отмечается как релевантная. Этот автоматический выбор можно изменить. Система копирует выбранные главные инстанции в левую область экрана.

...

1. Выберите определяемую главную инстанцию ABAP в левой области экрана ниже системы и введите номер инсталляции на закладке Общие данные. Ввод прочих данных необязателен.

2. На закладке Общие данные определите номер системы и сервер сообщений для обеспечения возможности создания RFC-соединений для этой системы.

3. На закладке Манданты создайте манданты для выбранной главной инстанции.

4. Введите номер манданта.

5. Можно ввести имя манданта.

6. Из справки по допустимым значениям ввода можно выбрать роль.

7. Определите логическую систему.

8. Сохраните введенные данные.

9. Существует два способа создания RFC-соединений для мандантов:

Ў Присвоение существующих RFC-соединений манданту:

i. Выберите мандант на закладке Манданты.

ii. Выберите Присвоение и проверка RFC-адресов.

iii. Из справки по допустимым значениям ввода для видов RFC-соединений выберите существующее RFC-соединение.

iv. Установите флаг Присвоить RFC-адрес для контроля системы для повторного использования RFC-адресов в этом манданте в целях контроля центральной системы SAP. Этот флаг необходимо установить только для одного манданта в системе.

v. Сохраните выбор.

Ў Для других мандантов снова выберите "Создание RFC-соединений".

Создание RFC-соединений для плановых систем невозможно.

Этот шаг также можно выполнить позже.

10. На закладке Сервер можно определить имя сервера. Справка по допустимым значениям ввода содержит хосты, ранее определенные в компоненте среды Хост.

11. На закладке Компоненты программного обеспечения можно просмотреть подробную информацию относительно установленных компонентов программного обеспечения и определить/изменить для них статус пакета поддержки.

12. Сохраните введенные данные.

При наличии RFC-соединения, по крайней мере, для одного манданта системные данные можно обновить при помощи экранной кнопки Дистанционный просмотр системных данных. Для обеспечения возможности просмотра информации, например, относительно импортированных пакетов поддержки, в SAP Solution Manager должны быть доступны актуальные системные данные. При создании RFC-соединения можно настроить автоматическое обновление системных данных.

Определение главной инстанции для продуктов SAP не на основе ABAP и внешних продуктов

...

1. На закладке Описание системы выберите систему, для которой необходимо определить главные инстанции, и установите флаг "Релевантно" для релевантных главных инстанций.

Система скопирует выбранные главные инстанции в левую часть экрана ниже системы.

2. Выберите главную инстанцию и введите требуемые данные в правой части экрана.

3. Сохраните введенные данные.


 Создание RFC-соединений

Создание RFC-соединений

Использование

Наличие RFC-соединений с системами компонентов является обязательным условием для реализации следующих функций SAP Solution Manager:

· Создание IMG проекта в Управлении проектом;

· Переход к системам компонентов на фазе конфигурации;

· Синхронизация настройки (редактор групп синхронизации, Customizing Scout, распределение настройки);

RFC-соединения могут создаваться только для главных инстанций на основе ABAP.

Предпосылки

· Имеются полномочия на вход в целевую систему и создание пользователей в этой системе. Также имеются полномочия на создание RFC-соединений вида "Достоверная система" в локальной и целевой системах (при необходимости).

· Доступны спутниковые системы.

· Под именем и номером системы, определенными на закладке "Общие данные", имеются доступные серверы сообщений.

· При наличии в сети маршрутизаторов или при необходимости определения имени системы доменных имен (DNS) для создания RFC-соединений должны быть удовлетворены следующие условия:

Ў В качестве хоста в системной среде SAP Solution Manager создан спутниковый сервер системных сообщений, для которого определены данные маршрутизации.

Ў При создании системы этот хост был определен как сервер сообщений.

· Выполнен переход к транзакции Системная среда SAP Solution Manager (SMSY), последние изменения в которой уже сохранены.

· Система, для которой необходимо создать RFC-адреса, не отмечена как плановая.

Создание RFC-адресов

...

1. В левой части экрана выберите главную инстанцию на основе ABAP системы, для которой необходимо создать RFC-соединения.

2. Перейдите в режим изменения.

3. Выберите мандант на закладке Манданты.

4. Выберите Создание RFC-адресов.

5. В следующем диалоговом окне выберите вид(ы) RFC-соединений.

Там, где это возможно, для SAP Solution Manager всегда следует выбирать вид RFC-соединения "Достоверная система". Это позволяет избежать необходимости повторного входа в систему при каждом переходе к системе компонента во время использования SAP Solution Manager.

В нижней части экрана появятся подробные данные создаваемого RFC-соединения.

6. В рамке группы Атрибуты RFC-адресов можно определить группу серверов для совместной загрузки.

7. Если спецификация сервера сообщений не позволяет создавать RFC-соединения в данной сети или при наличии в сети маршрутизаторов:

a. В рамке группы "Атрибуты RFC-адресов" выберите "Данные маршрутизации".

В появившемся диалоговом окне будут выведены данные сервера сообщений. Если сервер системных сообщений, используемый в качестве хоста, еще не создан, этот сервер создается автоматически и при перезапуске транзакции Системная среда SAP Solution Manager появляется в левой части экрана под пунктом Компонентами среды.

b. Определите любой IP-адрес.

c. Определите данные маршрутизации для направления SAP Solution Manager ® Маршрутизатор ® Хост, например, /H/1.2.3.4/H/5.6.7.8/H/9.10.11.12.

d. Определите данные маршрутизации для направления SAP Solution Manager ® Хост ® Маршрутизатор, например, /H/1.2.3.4/H/5.6.7.8/H/9.10.11.12.

Данные для создания RFC-соединений запрашиваются в транзакции Системная среда SAP Solution Manager в следующей последовательности:

· Данные маршрутизации (например, /H/1.2.3.4/H/5.6.7.8/)
В случае недоступности:

· IP-адрес хоста
В случае недоступности:

· Имя хоста.

e. Сохраните введенные данные.

8. По умолчанию для системных данных устанавливается режим дистанционного просмотра, так как в для обеспечения возможности просмотра информации, например, относительно импортированных пакетов поддержки, SAP Solution Manager должны быть доступны актуальные системные данные. Не снимайте флаг в рамке группы Операции после создания.

9. Установите флаг Присвоить RFC-адрес для контроля системы для использования RFC-адресов, созданных в системной среде SAP Solution Manager, при контроле центральной системы SAP (транзакция RZ21) и для управления средой решения в SAP Solution Manager. Этот флаг необходимо установить только для одного манданта в системе.

Данные RFC-адресов вводятся в обзор контролируемых удаленных SAP-систем при контроле центральной системы SAP (транзакция RZ21) ® Техническая инфраструктура ® Просмотр топологии.

10. Выберите Создание RFC-адресов.

Выполняется последовательный переход к экранам входа в систему для каждой из задействованных систем в зависимости от выбранного типа соединения.

11. Выполните вход в системы.

Создается журнал с информацией о выполненных проверках и всех отправленных сообщениях при установке соединения.

Журнал автоматически не сохраняется. Для получения возможность просмотра журнала в дальнейшем в виде списка без подробных текстов выполните экспорт журнала при помощи функции экспорта для просмотра журнала.

12. В случае возникновения ошибок при создании:

a. Подробная информация об ошибках содержится в подробных текстах сообщений.

b. По возможности выясните причины ошибок.
Для перехода к подробному ракурсу RFC-соединения в транзакции Обработка RFC-адресов щелкните по RFC-соединению в диалоговом окне Создание RFC-адресов или дважды щелкните по RFC-соединению на закладке Манданты. Здесь можно проверить RFC-соединение и внести все необходимые изменения.
Более подробная информация содержится в разделе Устранение ошибок при создании RFC-соединений.

c. В случае необходимости выполните повторное создание путем удаления предыдущего RFC-соединения и создания нового соединения.

13. Вернитесь назад.

На закладке Манданты появятся созданные RFC-соединения.

Обновление RFC-адресов

В SAP Solution Manager невозможно повторно создать существующие RFC-соединения. Для повторного создания существующих RFC-соединений необходимо сначала удалить их вручную при помощи транзакции Обработка RFC-адресов и затем создать их заново.

Изменение присвоения RFC-адреса

Существующие RFC-адреса можно присвоить манданту при помощи кнопки Присвоение и проверка RFC-адресов.

Удаление RFC-адресов

При нажатии кнопки Удалить строку удаляется только выбранная строка на закладке "Манданты", но не RFC-соединение с определенной системой.

Для удаления существующих RFC-соединений выберите Перейти к ® Другие инструменты ® Обработка RFC-адресов или дважды щелкните по RFC-соединению на закладке Манданты.

Более подробная информация об удалении RFC-соединений содержится в разделе Обработка RFC-адресов в библиотеке SAP.

Обработка ошибок при создании RFC-соединений

· Создание RFC-соединения может оказаться неуспешным по причине того, что пользователь, определенный в диалоговом окне Создание RFC адресов, уже существует в целевой системе и не может быть создан повторно. Существует три способа решения этой проблемы:

Ў Если этот пользователь не используется иным образом, он может быть удален в целевой системе, после чего следует повторно создать RFC-адрес.

Ў В диалоговом окне Создание RFC адресов можно изменить данные создаваемого пользователя и выполнить повторное создание RFC-адреса.

Ў Можно удалить старый пароль, присвоить новый пароль и ввести его вручную для нового RFC-адреса.

· Для этого необходимо наличие соответствующего статуса пакета поддержки в системах компонентов. Информация о требуемом статусе пакета поддержки содержится в подробном тексте журнала ошибок.

· Созданный пользователь может не иметь в целевой системе всех необходимых полномочий. Эта ошибка будет указана в журнале создания. Необходимо вручную присвоить необходимые полномочия созданному в целевой системе пользователю.

Результат

На закладке Манданты появятся созданные RFC-соединения.

Пользователи, RFC-соединения с системами компонентов которых необходимо использовать, должны получить соответствующие полномочия в системах компонентов и в системе SAP Solution Manager. В случае необходимости обновите профиль полномочий. Более подробная информация относительно необходимых объектов полномочий и профилей содержится в разделе "Системные параметры настройки для распределения настройки и Customizing Scout".


 Создание внешних систем

Создание внешних систем

Использование

Необходимо создать системы, в которых установлены внешние продукты, для непосредственного контроля над этими системами при оперативной обработке.

Последовательность шагов

...

1. Создайте внешний продукт, выполняемый в системе, которую необходимо создать.

Установите для этого продукта статус Активно. Для определения систем могут использоваться только активные продукты.

2. Создайте систему.

a. Выберите Компоненты среды ® Создать объект ® Создать систему.

b. В следующем диалоговом окне в качестве имени системы введите ее идентификатор.

c. Из справки по допустимым значениям ввода выберите продукт, созданный на шаге 1, и версию продукта.

d. Сохраните введенные данные.

Система появится в левой части экрана по пути Компоненты среды ® Системы под соответствующим внешним продуктом.

e. Для получения возможности просмотра и использования главной инстанции при оперативной обработке в среде решения установите флажок Релевантно на закладкеОписание системы для этой инстанции.

Система скопирует выбранные главные инстанции в левую часть экрана ниже системы.

f. Можно добавить дополнительную информацию относительно системы (см. "Создание систем").

g. Выберите релевантную главную инстанцию(и) в левой части экрана и введите необходимые данные в правой части экрана.

h. Сохраните введенные данные.

Результат

Создана система, в которой выполняется внешний продукт. Удовлетворены условия для обеспечения контроля этой системы при оперативной обработке.


 Присвоение систем проекту/решению

Присвоение систем проекту/решению

Использование

На экране Группы систем необходимо определить системы, которые будут использоваться в проекте SAP Solution Manager и в продуктивной среде решения.

Последовательность шагов

Присвоение систем проекту

Проекты, созданные в Управлении проектом, можно просмотреть путем выбора Группы систем ® Среды проектов. Системную среду для проекта можно определить путем выбора Управление проектом ® закладка Системная среда ® закладка Системы или в транзакции Системная среда SAP Solution Manager. Эти два экрана ведения идентичны.

Дополнительная информация содержится на закладке "Системная среда".

Присвоение систем решению

Решения, созданные в SAP Solution Manager для оперативной обработки, можно просмотреть путем выбора Группы систем ® Среды решений.

...

Выберите Группы систем ® Среды решений, а затем выберите решение.

1. Для присвоения системы решению установите для данной системы флаг Присвоено.

По соображениям системой производительности не следует присваивать одному решению более десяти систем.

2. Сохраните введенные данные.

Присвоенные системы появятся в графике решения в транзакции SOLUTION_MANAGER.


 Определение и обработка системных ролей

Определение и обработка системных ролей

Использование

В дополнение к существующим системным ролям, можно определить десять пользовательских системных ролей. Система отмечает системные роли SAP и пользовательские системные роли при помощи соответствующих пиктограмм.

Последовательность шагов

Определение/изменение системных ролей

Для изменения пользовательских системных ролей или определения новых системных ролей выберите Утилиты ® Системные параметры настройки ® закладка Системные роли.

Новые/измененные системные роли доступны для просмотра по пути Управление проектом ® закладка Системная среда ® закладка Системы или во всех справках по допустимым значениям ввода для выбора ролей в SAP Solution Manager; исключение: неизменяемые системные роли, установленные на основе определения манданта, отображаются в справке по допустимым значениям ввода для выбора ролей для главных инстанций на основе ABAP на закладке Манданты в транзакции Системная среда SAP Solution Manager.

Удаление системных ролей

В случае используемых в системной среде пользовательских системных ролей можно изменить их имена, однако удаление этих ролей невозможно.

Изменение и удаление системных ролей SAP невозможно.

Перенос системных ролей

Для переноса системных ролей используется экранная кнопка Перенос.


 Обработка/удаление элемента среды

Обработка/удаление элемента среды

· Выполните поиск системных единиц, не отображаемых в левой части экрана, путем выбора Компоненты среды ® Другой объект...

· Все хосты, базы данных и системы можно определить как Только плановые. После этого можно сразу выполнить документирование всей системной среды до технической инсталляции всех системных компонентов.

Удаление элемента среды

...

1. В режиме изменения невозможно удалить обрабатываемый объект. Перейдите к режиму просмотра.

2. Выберите Компоненты среды ® Другой объект…

3. Выполните поиск удаляемого элемента среды в справке по допустимым значениям ввода.

4. Выберите Удалить.

5. Подтвердите запрос подтверждения.

Элемент среды и все записи о его использовании удаляются.

Перед удалением систем, хостов или баз данных необходимо создать журнал использования.

Журнал использования

...

Для создания журнала использования выберите элемент среды и затем выберите Журнал использования в контекстном меню или компонент среды по пути Компонент среды ® Другой объект…, после чего выберите Журнал использования.

Журнал использования

Элемент среды | Использование
Хост | Системы, в которых данный хост используется в качестве сервера или сервера базы данных.
База данных | Системы
Система | Группы систем

В журнале использования можно просмотреть все записи об использовании систем в группе систем. Следующие группы систем, скрытые в компонентах в транзакции Системная среда SAP Solution Manager, отображается в журнале использования со статусом Устаревшее:

· Группа систем решений, деактивированных для оперативной обработки в среде решения на экране Операции SAP Solution Manager.

· Группа систем для выполненных проектов, т.е. проектов, которым в Управлении проектом присвоен статус Выполнено.


 Анализ системной среды по компонентам среды

Анализ системной среды по компонентам среды

Использование

Эта функция предоставляет обзор системной среды в виде таблицы.

Функциональные возможности

Выбор

· Хост

· Базы данных

· Системы

Варианты по умолчанию

· Для отчета можно создать собственные варианты по умолчанию, т.е. правила выбора.

· Также имеется возможность создания вариантов по умолчанию для форматов в SAP List Viewer (ALV), т.е. параметров просмотра результатов.

В ALV Grid Control необходимо создать несколько форматов для каждого компонента среды, например, для просмотра всех систем R/3 в системной среде или статусов пакетов поддержки.

Определение формата может ограничить ракурс вывода: возможно скрытие значений, выбранных на экране выбора, по причине скрытия соответствующих им столбцов в текущем формате вывода. Не следует ограничивать формат просмотра по умолчанию для всех пользователей.

Результат

Результаты анализа выводятся для просмотра при помощи SAP List Viewer (ALV). В SAP List Viewerполученные результаты можно распечатать, отфильтровать, отсортировать или экспортировать в электронную таблицу, например, в файл Microsoft Excel.

Операции

Вызовите функцию анализа системной среды путем выбора Утилиты ® Анализ.


 Настройка адаптивного вычисления

Настройка адаптивного вычисления

Использование

Функция адаптивного вычисления позволяет контролировать нагрузку на серверы путем динамического присвоения серверов системам.

Настройка функции адаптивного вычисления в SAP Solution Manager выполняется после регистрации контроллера адаптивного вычисления, пульта контроля адаптивного вычисления.

Предпосылки

Функция адаптивного вычисления инсталлирована, контроллер адаптивного вычисления зарегистрирован в SAP Solution Manager. Дополнительная информация содержится в Руководстве по инсталляции функции адаптивного вычисления.

Если функция адаптивного вычисления установлена, ее данные можно просмотреть в транзакции Системная среда SAP Solution Manager (SMSY).

Последовательность шагов

...

1. Вызовите транзакцию Системная среда SAP Solution Manager (SMSY).

2. Определите сети адаптивного вычисления:

a. В обзорном дереве выберите Адаптивное вычисление ® Сети.

b. Перейдите в режим изменения.

c. Выберите Новые записи.

d. Введите данные сети.

e. Сохраните введенные данные и вернитесь назад.

3. Добавьте серверы в группу динамически присваиваемых серверов:

a. Выберите в обзорном дереве Адаптивное вычисление – техническая среда .

b. Перейдите в режим изменения.

c. Переместите (методом перетаскивания) сервер в среду динамически присваиваемых серверов в правой части экрана.

d. Сохраните изменения.

e. Путем щелчка по хосту перейдите к подробным данным хоста.

f. Перейдите к подробному ракурсу путем выбора Переключение просмотра .

g. Введите требуемые данные на закладке Описания портов адаптивного вычисления.

h. Сохраните введенные данные.

4. Измените параметры настройки систем, для которых устанавливается динамическое присвоение серверов, следующим образом:

a. Перейдите к системе в обзорном дереве путем выбора Компоненты среды ® Системы ® <системный продукт>.

b. На закладке Общие данные установите для системы флаг Адаптивное вычисление включено.

Появится закладка Адаптивное вычисление.

c. На закладке Адаптивное вычисление определите минимальное и максимальное количество хостов, присвоение которых должно осуществляться динамически.

d. Сохраните введенные данные.

e. Перейдите к подробному ракурсу главной инстанции путем двойного щелчка по ней.

f. На закладке Сервер выберите пиктограмму изменения рядом с сервером, данные которого необходимо изменить.

g. Введите данные сервера.

h. Сохраните введенные данные.

Результат

Теперь управление нагрузкой серверов будет осуществляться динамически.

Функцию динамического присвоения серверов (Адаптивное вычисление) можно вызвать путем выбора Адаптивное вычисление ® Контроллер адаптивного вычисления в обзорном дереве в транзакции Системная среда SAP Solution Manager (SMSY).


 Создание концептуального проекта (для проектов внедрения)

Создание концептуального проекта (для проектов внедрения)

Цель использования

В процессе внедрения решения mySAP.com создается концептуальный проект, в котором документально фиксируются бизнес-процессы предприятия, и осуществляется выбор тех процессов, которые должны быть отражены в SAP-системе.

Концептуальный проект в SAP Solution Manager используется и на фазе реализации (конфигурация и тестирование). Структура проекта, созданная на фазе разработки концептуального проекта, также используется при создании и конфигурации планов тестирования. В ходе конфигурации также может осуществляться просмотр, изменение и расширение проектной документации, созданной на этапе разработки концептуального проекта.

Предпосылки

Требуется внедрить решение mySAP.com. Подготовка проекта завершена: в Управлении проектом в SAP Solution Manager уже определены проект внедрения и системная среда.

Выполнение

...

1. Создайте структуру концептуального проекта из предварительно определенных подструктур.

2. Проверьте структуру концептуального проекта, а также бизнес-сценарии, бизнес-процессы и шаги процессов, которые в него входят.

3. Выберите бизнес-сценарии, бизнес-процессы и шаги процессов для включения в концептуальный проект. Существует возможность расширения процессов и шагов процессов или корректирования названий отдельных процессов для удовлетворения потребностей компании.

4. Создайте проектную документацию и сохраните ее в концептуальном проекте.

5. Присвойте транзакции шагам процесса. Это позволяет определить, какие транзакции в системе соответствуют шагам процесса на предприятии.

6. Распечатайте документ концептуального проекта.

7. По завершении создания концептуального проекта можно начать настройку среды системы разработок.

Результат

Создан концептуальный проект и настроена среда системы разработок. Концептуальный проект и структуру проекта можно вновь использовать для конфигурирования и тестирования бизнес-процессов.


 Концептуальный проект

Концептуальный проект

Определение

Концептуальный проект позволяет документально зафиксировать требования к бизнес-процессам в компании. В совместные бизнес-процессы вовлекается несколько компаний.

Использование

В концептуальном проекте описываются общие принципы отражения бизнес-процессов в одной или нескольких SAP-системах. Концептуальный проект подробно описывает назначение бизнес-сценариев, бизнес-процессов, шагов процессов и требования по внедрению решения mySAP.com.

Структура

Концептуальный проект включает следующие структурные элементы иерархии:

· организационные единицы;

· основные данные;

· бизнес-сценарии;

· бизнес-процессы;

· шаги процессов.

Данные в концептуальном проекте - например, проектная документация, пакеты настройки бизнес-конфигурации или транзакции - присваиваются отдельным структурным элементам в SAP Solution Manager.

На уровнях ниже уровня бизнес-сценариев можно создавать структурные элементы для организационных единиц и основных данных. Эти структурные элементы используются лишь в том случае, если организационные единицы и основные данные релевантны только для бизнес-процесса, расположенного в структуре на более высоком уровне.


 Определение концептуального проекта (для проектов внедрения)

Определение концептуального проекта (для проектов внедрения)

Использование

Эта функция позволяет документально зафиксировать бизнес-процессы компании, которые должны быть отражены в системе. Создается структура проекта, в которой релевантные бизнес-сценарии, бизнес-процессы и шаги процессов организованы в иерархическую структуру. Также существует возможность создания проектной документации и присвоения созданных документов отдельным сценариям, процессам или шагам процессов. Затем для определения способов выполнения бизнес-процессов SAP-системах каждому шагу процесса присваиваются транзакции.

Концептуальный проект представляет собой подробное описание бизнес-процессов и системных требований. Его можно распечатать. Проектная документация и структура проекта, разработанные на этапе создания концептуального проекта, могут использоваться и в фазах выполнения конфигурации и тестирования.

· По завершении конфигурации бизнес-процессов в системе появится структура концептуального проекта. Структура концептуального проекта может использоваться в качестве ссылки в процессе конфигурации.

· В ходе конфигурации также может осуществляться просмотр и обработка проектной документации, созданной на этапе разработки концептуального проекта.

· Все планы тестирования, создаваемые в процессе организации тестирования, базируются на структуре концептуального проекта. В процессе создания плана тестирования транзакции, присвоенные шагам процесса в концептуальном проекте, помещаются в планы тестирования и выполняются в качестве функциональных тестов, проводимых с целью проверки выполнения транзакций.

Интеграция

После создания проекта в системе выполняется определение концептуального проекта. Концептуальный проект является необходимой предпосылкой для перехода к фазе реализации, во время которой выполняется конфигурация и тестирование бизнес-процессов.

Предпосылки

Был создан проект. Настроена системная среда разработок или анализа для использования на фазах подготовки проекта и разработки концептуального проекта.

Функциональные возможности

Структура проекта выводится на экран в его левой части. Структура представляет собой иерархию, в законченном виде включающую следующие позиции:

· организационные единицы;

· основные данные;

· бизнес-сценарии;

· бизнес-процессы;

· шаги процессов.

В этой структуре можно выполнить транзакции, присвоенные шагам процесса по умолчанию.

Транзакции выполняются в новом режиме. По завершении транзакции происходит переход к исходному экрану.

При создании нового сценария доступны все функции создания и изменения структуры проекта .

Существует возможность фильтрации по объему, статусу, членам группы и ключевым словам при помощи кнопки Структура фильтра с целью ограничения ракурса организационной структуры.

Для выбора режима показа или скрытия информации об идентификаторах присвоенных сценариям шаблонов и логических компонентах используется кнопка Показать/скрыть столбец.

На закладках в правой части экрана доступны следующие функции:

Общая документация

На этой закладке представлена вся документация и/или диаграммы совместного бизнеса, поставляемые SAP. Имеется возможность сортировки или выгрузки документов, а также их копирования на закладку Проектная документация для последующей обработки.

Для получения дополнительной информации см. описание закладки Общая документация.

Проектная документация

Эта закладка используется для создания и обработки собственных документов.

Для получения дополнительной информации см. описание закладки Проектная документация.

Структура

На этой закладке можно добавлять сценарии, бизнес-процессы и шаги процессов, а также переименовать существующие структурные элементы.

Для получения дополнительной информации о структурных изменениях см. описание закладки Структура .

Администрирование

Эта закладка используется для ввода общих административных данных на фазе концептуального проекта, например, статуса проекта, присвоенных членов группы или необходимых планируемых и фактических работ.

Для получения дополнительной информации см. описание закладки Администрирование.

Транзакции

Закладка Транзакции служит для выполнения в отношении транзакций, программ и других объектов следующих функций:

· присвоение этих объектов структурным элементам;

· отмена присвоения этих объектов структурным элементам;

· определение транзакции по умолчанию для шага процесса.

Для получения дополнительной информации см. описание закладки Транзакции.

Сообщения

Закладка Сообщения используется для создания, просмотра и обработки сообщений. Более подробная информация содержится в описании закладки Сообщения.

· На фазе концептуального проекта закладки Конфигурация, Разработка, Контрольные примеры и Учебный материал скрыты.

· В пользовательских параметрах настройки имеется возможность выбора режима показа или скрытия и сортировки закладок.

Журнал использования

Для всех присвоений, выполненных на закладках Общая документация, Проектная документация, Транзакции, Конфигурация и Контрольные примеры существует возможность создания журнала использования.

· Прочие записи об использовании в данном проекте выводятся для просмотра на синем фоне.

· Прочие записи об использовании в других проектах выводятся для просмотра на желтом фоне.

Для просмотра записи об использовании следует дважды щелкнуть по этой записи.

Перевод структуры проекта

Для многоязычных проектов имеется возможность перевода структуры проекта. Для этого используется путь по меню Перейти к ® Перевод. Для получения более подробной информации о переводе в проекте имен документов для URL см. раздел Перевод шаблона .


 Закладка "Общая документация"

Закладка "Общая документация"

Использование

На этой закладке представлены все документы и диаграммы сценариев, например, карты совместного бизнеса, поставляемые SAP. Эти документы включают в себя, например, описания сценариев, руководства по инсталляции или описания интерфейсов.

Для определения необходимости вывода документации на закладке Общая документация или в отдельном окне используется путь по меню Параметры настройки ® Специфика пользователя.

Кроме того, можно определить необходимость сохранения тех или иных данных:

При выборе Автоматическое сохранение каждый раз при изменении структурного элемента данные будут сохраняться автоматически.

Если опция Автоматическое сохранение не выбрана, то каждый раз при изменении закладок данные будут сохраняться в буфере, и для их сохранения в базе данных потребуется нажать кнопку Сохранить.

Интеграция

Документы, поставляемые SAP, хранятся в системе Knowledge Warehouse, доступ к которой можно получить после инсталляции и настройки SAP Solution Manager.

Функциональные возможности

Эта закладка содержит те же функциональные возможности для шаблонных проектов, что и закладка Проектная документация.

Функциональные возможности для проектов внедрения в этой закладке ограничены. Имеется возможность просмотра, экспорта и сортировки документов. Путем выбора Скопировать в закладку "Проектная документация" можно перенести общие документы на закладку проектной документации с целью их дальнейшей обработки и использования. При помощи журнала использования можно проверить, каким другим структурным элементам присвоен документ.

Документация по транзакциям по умолчанию в шаблонном проекте и проекте внедрения выводится на уровне шага процесса. (Для получения доступа к справке по приложению для транзакций в системах компонентов должна быть инсталлирована библиотека SAP).

Операции

Для копирования документа из закладки Общая документация в закладку Проектная документация:

...

1. Выберите один или несколько документов путем щелчка по соответствующим этим документам строкам.

2. Выберите Скопировать в закладку "Проектная документация".

3. В следующем диалоговом окне введите действительный вид документации для каждого документа.

Действительные виды документации для проекта определяются в транзакции Управление проектом внедрения на закладке Стандарты проекта .

4. Выберите Скопировать. Выбранные документы копируются в закладку Проектная документация, где их можно обработать. Изменения, внесенные в скопированные документы, не влияют на исходные тексты.


 Закладка "Проектная документация"

Закладка "Проектная документация"

Использование

Эта закладка используется для создания, добавления, просмотра или удаления документации по структурным элементам проекта внедрения.

Для определения необходимости вывода документации на закладке Проектная документация или в отдельном окне используется путь по меню Параметры настройки ® Специфика пользователя.

Кроме того, можно определить необходимость сохранения тех или иных данных:

При выборе Автоматическое сохранение каждый раз при изменении структурного элемента данные будут сохраняться автоматически.

Если опция Автоматическое сохранение не выбрана, то каждый раз при изменении закладок данные будут сохраняться в буфере, и для их сохранения в базе данных потребуется нажать кнопку Сохранить.

Интеграция

Документы хранятся в системе Knowledge Warehouse и доступны в SAP Solution Manager.

Функциональные возможности

Эта закладка используется для создания проектной документации. Всем создаваемым документам присваивается определенный вид документа. В зависимости от вида документа, вызывается соответствующий образец документа. Можно использовать только те виды документов, которые имеют либо образцы документов, либо расширения имени файла, поддерживаемые в SAP Solution Manager. Если шаблон или расширение имени файла виду документа не присвоены, запускается текстовый редактор.

При добавлении документа (создании ссылки на документ SAP Solution Manager, копирование документа SAP Solution Manager, загрузка файла, веб-ссылка) могут использоваться все виды документации, независимо от наличия присвоенного шаблона или расширения имени файла.

Расширение поставляемых SAP видов документации осуществляется на закладке Стандарты проекта в транзакции Управление проектом внедрения.

Опция Вставка документа предоставляет следующие возможности:

· создание новых документов;

· создание ссылок на документы, оригиналы которых присвоены другим структурным элементам в SAP Solution Manager;

· копирование документов, оригиналы которых присвоены другим структурным элементам в SAP Solution Manager и изменение которых может производиться вне зависимости от исходного документа;

· загрузка файла;

· создание ссылки на веб-сайт.

Для удаления проектной документации или присвоения документации структурному элементу выберите Удалить. Для документов, созданных как ссылки на другие документы, удаляются и строка в таблице, и ссылка. Если подлежащий удалению документ является единственной инстанцией данного документа, то полномочиями для его удаления обладает ответственный за этот документ (автор).

Для просмотра структурных элементов, в которых используется данный документ, выберите Журнал использования. Также имеется возможность экспорта документов.

Опция Атрибуты предоставляет следующие возможности:

· на закладке История:

Ў просмотр истории изменений документа;

Ў фильтрация по статусу документа;

Ў просмотр версий документа;

· на закладке Ссылка : создание ссылок на прочие документы.


 Создание проектной документации

Создание проектной документации

Использование

Закладка Проектная документация используется для создания, добавления, просмотра или удаления проектной документации по структурным элементам проекта внедрения.

Последовательность шагов

Создание документа

Для создания документа:

...

1. Выберите Вставка документа .

2. В диалоговом окне Вставка документа введите заголовок документа и выберите вид документации.

Будет выполнен переход к соответствующему редактору. Можно задать и другие атрибуты документа, например, статус, приоритет или релевантность для концептуального проекта.

Порядок создания документов определяет последовательность вывода этих документов в документе концептуального проекта.

3. Введите текст и сохраните введенные данные при помощи кнопки Сохранить документ на этой закладке.

4. Для возврата к обзорному экрану документов выберите Закрыть документ.

Добавление существующего документа

Для добавления к структурному элементу существующего документа:

...

1. Выберите Вставка документа .

2. В диалоговом окне Добавление объекта введите заголовок документа и выберите вид документации и статус документа.

3. Выберите источник документа. Имеются следующие возможности:

Ў Ссылка на документ SAP Solution Manager: создание ссылки на документ, который уже присвоен другому структурному элементу в SAP Solution Manager.

Ў Копирование документа SAP Solution Manager: создание копии документа, который уже присвоен другому структурному элементу в SAP Solution Manager или поставляется SAP.

Ў Загрузка файла: загрузка имеющегося документа, например, документа, созданного локально на ПК пользователя.

Ў Веб-ссылка: создание ссылки на URL-адрес.

4. Выполните ведение атрибутов и сохраните введенные данные.

Определение атрибутов документа

Для определения атрибутов документа:

...

1. Выберите в редакторе Подробный ракурс.

На закладке Документ можно ввести следующие атрибуты:

Ў Заголовок: заголовок можно изменить.

Ў Техническое имя: для документа можно выбрать техническое имя.

Ў Вид документа: вид документа можно изменить.

Ў Статус: выберите текущий статус обработки документа из списка предложенных значений.

Ў Приоритет: выберите приоритет документа из списка предложенных значений.

Ў Владелец: определите ответственного за документ из справки по допустимым значениям ввода.

Ў Релевантно для концептуального проекта: этот индикатор выбирается при необходимости вывода документа на печать вместе с документом концептуального проекта.

Ў Ключевые слова: введите ключевые слова для классификации документа.

На закладке "История" приведена подробная техническая информация, например, автор документа, дата создания, дата последнего изменения и язык оригинала документа. Имеется возможность просмотра различных версий документа.

2. Выберите Дальше.

Результат

Документы, созданные в проекте, сохраняются вместе с собственным контекстом в Knowledge Warehouse.


 Закладка "Структура"

Закладка "Структура"

Использование

Эта закладка используется для создания или изменения структуры проекта, включающей в себя иерархию организационных единиц, основных данных, бизнес-сценариев, процессов и шагов процессов.

Интеграция

Структура проекта также используется функциями Конфигурация и Управление планами тестирования. Для получения дополнительной информации см. Определение концептуального проекта .

Функциональные возможности

Закладка Структура предоставляет следующие возможности:

· Добавление к структуре проекта новых организационных единиц, основных данных, сценариев, бизнес-процессов и шагов процессов;

· Удаление из проекта или системной среды структурных элементов, определенных при помощи операций SAP Solution Manager, или выбор этих элементов из репозитария бизнес-процессов и помещение в структуру проекта;

Репозитарий бизнес-процессов представляет собой структурированное множество всех предварительно сконфигурированных структурных элементов для повторного использования.

· Корректировка имен структурных элементов в зависимости от клиента;

· Удаление из структуры проекта созданного структурного элемента;

· Перемещение структурных элементов.

Перемещение структурных элементов может осуществляться только в пределах того же уровня; например, перемещение шагов процессов выполняется только на уровне шагов процессов.


 Создание и обработка структуры проекта

Создание и обработка структуры проекта

Использование

В структуре проекта отображаются все основные данные, организационные единицы, бизнес-сценарии, бизнес-процессы и шаги процессов, принадлежащие данному шаблону. Для создания структуры проекта:

· Добавьте новые бизнес-сценарии, бизнес-процессы, шаги процессов, основные данные и организационные единицы;

· Выберите предварительно определенные бизнес-сценарии, бизнес-процессы, шаги процессов, основные данные и организационные единицы, поставляемые SAP в репозитарии бизнес-процессов;

· Выберите процессы из продуктивной среды решения.

Предпосылки

В Управлении проектом должен быть создан проект. При необходимости использования процессов из продуктивной среды решения, созданной посредством операций SAP Solution Manager, эта среда решения должна быть выбрана на закладке Системная среда в Управлении проектом.

Выполнен переход к транзакции Концептуальный проект.

Последовательность шагов

Добавление структурных элементов

...

...

1. Поместите курсор на структурный элемент Организационные единицы, Основные данные или Бизнес-сценарии.

2. Установите курсор на пустой строке списка, выведенного для структурного элемента.

3. Выберите закладку Структура .

4. При помощи справки по допустимым значениям ввода выберите источник для копирования в проект существующих структурных элементов:

Ў для выбора сценариев, процессов или шагов процессов, предварительно определенных в SAP, в справке по допустимым значениям ввода выберите Репозитарий бизнес-процессов;

Ў для выбора сценариев, процессов или шагов процессов из существующего проекта в справке по допустимым значениям ввода выберите Проекты;

Ў для копирования процессов из продуктивной среды решения, созданной посредством операций SAP Solution Manager, в справке по допустимым значениям ввода выберите Среда решения.

Опция Среда решения в справке по допустимым значениям ввода доступна только в том случае, если в Управлении проектом на подзакладке Среда решения закладки Системная среда была выбрана определенная среда решения.

5. Выберите элемент из справки по допустимым значениям ввода.

Если в репозитарии бизнес-процессов выбран структурный элемент, то его компоненты определяются системой. Исходное имя структурного элемента выводится в столбце Имя в репозитарии бизнес-процессов.

6. При необходимости создания нового структурного элемента определите его заголовок. Определите логический компонент для основных данных, организационных единиц и шагов процессов.

7. Сохраните введенные данные.

Система копирует записи в структуру и сохраняет их. Значения в справке по допустимым значениям ввода сохраняются и снова выводятся в следующем режиме.

8. Выберите структурный элемент Бизнес-процессы или структурные элементы вида Процесс, и выполните действия, описанные в шаге 1.

Перемещение структурных элементов

...

1. Перейдите к тому элементу в структуре, который требуется переместить.

2. Щелкните по значку папки перед структурным элементом и переместите его на новое место (методом перетаскивания).

3. Сохраните данные.

Запустите транзакция Концептуальный проект

Отметьте структурный элемент.

Перетащите отмеченный структурный элемент в новое местоположение в структуре.

Перемещение структурных элементов может осуществляться только в пределах того же уровня; например, перемещение шагов процессов выполняется только на уровне шагов процессов.

Также на закладке "Структура" можно изменить последовательность элементов.

Присвоение шаблонов сценариям

Для копирования структуры сценария в шаблон в шаблонном проекте необходимо присвоить шаблон сценарию. Для повторного использования доступны только те шаблоны, которые присвоены, по крайней мере, одному сценарию.

1. Выберите структурный элемент Бизнес-сценарии в структуре.

2. Выберите закладку Структура .

3. В справке по допустимым значениям ввода Выберите один или несколько шаблонов для сценариев.

4. Сохраните введенные данные.

Система копирует общий раздел основных данных и организационные единицы, т.е. основные данные и организационные единицы самого высокого уровня структуры, во все шаблоны, присвоенные на закладке Структура .

На закладке Выбор шаблона в Управлении проектом можно просмотреть присвоенные шаблоны по всей системе. Теперь можно использовать эти шаблоны в масштабе всей системы в любом проекте.

Присвоение глобального атрибута

Если на закладке Шаблоны в Управлении проектом установлен флаг Функция глобального развертывания активна , то на закладке Структура в концептуальном проекте можно структурным элементам присвоить значения глобального атрибута. Эти значения определяют возможность и способы изменения структурного элемента при повторном использовании шаблона. Для получения дополнительной информации см. раздел "Глобальный атрибут при глобальном развертывании" и справку F1 по глобальному атрибуту.

Результат

Создана структура проекта. Теперь имеются следующие возможности:

· Переименование структурных элементов;

· Удаление структурных элементов;

· Деактивация структурных элементы в проекте путем отмены их выбора в структуре (только для проектов внедрения);

· Присвоение данных отдельным структурным элементам в структуре, например, документации и транзакциям.

См. также:

Присвоение транзакций шагам процессов

Закладка "Проектная документация"


 Закладка "Администрирование"

Закладка "Администрирование"

Использование

Закладка Администрирование используется для ввода актуальных данных проекта по каждому структурному элементу в структуре проекта.

Можно ввести следующие данные проекта:

· Статус;

· Плановые данные:

Ў Начало,

Ў Завершение,

Ў Рабочие дни (в человеко-днях - MD);

· Фактические данные:

Ў Начало,

Ў Завершение,

Ў Рабочие дни (в человеко-днях - MD),

Ў Оставшиеся ресурсы (требуемые работы);

· Присвоенные сотрудники проекта;

· Имя/описание.

Введенные данные применимы только на текущей фазе проекта.

После завершения выполнения всех операций на фазе концептуального проекта для данного структурного элемента завершены, структурному элементу в этой фазе присваивается статус Завершено. В фазе реализации этому структурному элементу снова присваивается статус Открыто.

Интеграция

Административные данные для каждой фазы проекта можно проанализировать в Анализах проектов.

Предпосылки

При определении стандартов проекта должна быть выполнена проверка статуса подготовки проекта. Должны быть введены все сотрудники, присвоенные проекту в процессе подготовки проекта . Выбранные значения выводятся как значения по умолчанию на закладке Администрирование.

Функции, доступные на закладке Администрирование, зависят от полномочий проектной роли, присвоенной сотруднику проекта.

Функциональные возможности

Статус

Значение статуса можно ввести вручную или выбрать из списка предложенных значений.

Сроки

Плановые и фактические даты можно ввести вручную или выбрать из календаря. В случае ввода дат, не принадлежащих периоду проекта, появится сообщение об ошибке. Для получения дополнительной информации см. Общие данные.

Работы

Необходимые плановые, фактические и остаточные работы вводятся вручную.

Члены проектной группы

В фазах концептуального проекта и реализации можно присвоить задачам членов проектной группы, указанных в списке членов проектной группы на закладке Члены проектной группы в Управлении проектом.

Ключевые слова

Структурным элементам можно присваивать ключевые слова, заданные на закладке Стандарты проекта в Управлении проектом.

Массовые изменения

По умолчанию изменения данных проекта не наследуется автоматически структурными элементами более низкого уровня. Изменения и удаления членов проектной группы и ключевых слов могут быть переданы всем структурным элементам более низкого уровня при помощи экранной кнопки Массовые изменения.

Наследование данных подпозициями

Эта функция служит для передачи статуса и плановых данных всем зависимым структурным элементам.

История

Эта функция используется для записи изменений в данных, внесенных на закладке Администрирование. Запись об изменении создается в журнале только после сохранения изменений.


 Закладка "Транзакции"

Закладка "Транзакции"

Использование

Закладка Транзакции используется для присвоения шагам процесса транзакций, программ и других объектов. Это присвоение позволяет определить шаги процессов в SAP-системе.

Интеграция

При создании плана тестирования выбранные транзакции предлагаются в качестве контрольных примеров в организации тестирования в SAP Solution Manager.

Предпосылки

Для присвоения транзакций шагам процесса необходимо определить системную среду в транзакции управления проектом.

Функциональные возможности

Присвоение транзакций, программ и других объектов шагу процесса и выполнение этих элементов

Шагам процессов можно присвоить следующие объекты:

· BSP-приложения CRM;

· транзакции;

· программы;

В существующей системе можно присвоить даже те транзакции и программы, которые еще не созданы. Это может оказаться полезным при необходимости ввода всей информации о данном этапе проекта в текущий момент, тогда как выполнение этих транзакций или программ может быть отложено на более позднее время. Подтвердите запрос подтверждения присвоения.

· предварительно определенные URL из списка;

Можно присвоить URL-объекты, предварительно определенные в навигаторе по объектам (транзакция SE80). Для получения дополнительной информации см. Включение прочих объектов.

· веб-адрес или файл;

· Путем ввода текста описания и веб-адреса можно вставить интернет/интранет-ссылки. Также можно вставить URL-адреса с переменными компонентами.

Для определения значения переменных в веб-адресах для системы выберите путь по меню Системное администрирование ® Замена переменных в веб-адресах (URL) в пользовательской настройке SAP Web Application Server.

Например, переменную в URL можно заменить адресом сервера ITS.

Пояснения к значениям переменных, используемых в SAP Solution Manager, содержатся в SAP-ноте 541309.

· При помощи программы Изменение URL в SAP Solution Manager можно изменить строки в URL для всего проекта, например, по причине переноса файлового сервера и следующей из этого необходимости изменения имени папки или файлового сервера во всех задействованных URL.

Если используемый веб-браузер поддерживает данное приложение, можно задать имя файла.

Запуск или открытие существующих транзакций, программ или других объектов в новом режиме выполняется при помощи двойного щелчка.

Онлайн-документацию по транзакциям и программам можно вызвать в библиотеке SAP.

Включение транзакций, программ и других объектов в объем проекта и их исключение из объема

Для помещения объекта в объем проекта выберите флажок в столбце В объеме. Для удаления из объема проекта неиспользуемых транзакций удалите этот индикатор.

Определение транзакции по умолчанию

Можно выбрать объект, функции которого будут выполняться для шага процесса при щелчке по пиктограмме Выполнить. Для этого следует установить флажок в столбце По умолчанию. При отсутствии выбранного объекта по умолчанию щелчок по пиктограмме Выполнить приведет к запуску первого объекта из списка на этой закладке.

Шаблон

Флаг Шаблон указывает на то, что объект находится в шаблоне, который повторно используется в проекте. Этот флаг не устанавливается для позиций, добавленных в проект внедрения.


 Присвоение транзакций структурному элементу

Присвоение транзакций структурному элементу

Использование

Закладка Транзакции используется для присвоения структурным элементам транзакций, программ и других объектов. Это обеспечивает доступ к данным транзакциям, программам и объектам и предоставляет возможность их выполнения. Они также являются объектами по умолчанию при создании плана тестирования в фазе реализации.

На закладке Транзакции также можно присвоить структурному элементу транзакцию по умолчанию. Для вызова транзакции по умолчанию щелкните по пиктограмме Выполнить рядом со структурным элементом в ссылочной структуре.

Предпосылки

Выполнен переход к транзакции концептуального проекта или реализации.

Последовательность шагов

...

...

1. Поместите курсор на сценарий, процесс или шаг процесса.

2. Выберите закладку Транзакции.

3. В столбце Вид выберите пункт Транзакция или Программа.

4. Введите идентификатор транзакции или программы в столбце Объект.

Система автоматически заполняет поля Имя, Вид и Логический компонент.

Если имя присвоения не предлагается системой автоматически, и в столбце Имя выводится сообщение <Имя не найдено>, вызовите функцию вставки имен присвоений вручную:

Выберите "Среда ® Обновить тексты присвоений".

После обновления текстов присвоений открывается новый режим, и на экран выводится журнал.

5. В случае выбора вида "Веб-адрес или файл" введите текст описания и имя объекта, например, имя файла или URL.

6. В случае выбора вида "Предварительно определенный URL" выберите URL в следующем диалоговом окне.

7. При необходимости введите другие объекты.

8. Выберите транзакцию по умолчанию.

Этим определяется транзакция, которая запускается при щелчке по пиктограмме Выполнить рядом с заголовком шага процесса в ссылочной структуре.

9. Сохраните введенные данные.

Присвоенный объект автоматически помещается в объем проекта, т.е. в столбце В объеме для него устанавливается соответствующий флажок.


 Закладка Сообщения

Закладка Сообщения

Использование

Закладка Сообщения используется для создания и просмотра сообщений. Сообщения создаются в том случае, если в проектной документации, конфигурации или обработке контрольных примеров в транзакциях конфигурации или концептуального проекта возникли ошибки.

Интеграция

Если базисная система настроена как система сообщений для SAP Solution Manager, обработка сообщений, выполняемая данным пользователем ("обработчиком"), должна осуществляться при помощи транзакции DNOTIFWL.

Если базисная система настроена как система сообщений для SAP Solution Manager, обработка сообщений осуществляется при помощи службы поддержки.

Для поиска и обработки сообщений можно воспользоваться функцией анализа проекта SAP Solution Manager. Анализ проекта позволяет выполнять поиск и обработку сообщений.

Функциональные возможности

Имеются следующие возможности:

· просмотр и изменение сообщения;

· создание сообщений;

· присоединение документов к сообщениям.

Сообщение будет переадресовано системе сбора сообщений и соответствующим образом обработано.

Для получения более подробной информации о создании и изменении сообщений см. Создание сообщения.


 Создание сообщения

Создание сообщения

Использование

Создание сообщений выполняется с целью документирования проблем, которые возникли при создании концептуального проекта или в ходе конфигурации.

Предпосылки

Вызвана транзакция конфигурации или концептуального проекта .

Последовательность шагов

...

1. Перейдите к структурному элементу в структуре проекта, для которого требуется создать или изменить сообщение.

2. Выберите закладку Сообщения.

Появится список всех существующих сообщений.

3. Выберите экранную кнопку Создать.

Появится диалоговое окно, в которомможно ввести необходимые данные.

4. Введите компонент, приоритет, обработчика, краткий текст и текст сообщения. Для указания обработчика используйте имена пользователей в SAP-системе.

В пользовательской настройке можно скорректировать справку по допустимым значениям ввода для поля Компонент в соответствии с текущими требованиями. Выберите SAP Solution Manager ® Определение типов сообщений SAP Solution Manager" в пользовательской настройке SAP Solution Manager и добавьте новые компоненты в существующий тип сообщений slf1.

5. Также можно выбрать компонент из иерархии приложений в разделе Компоненты SAP.

Этот компонент можно использовать позже для сортировки сообщений или преобразования сообщения в сообщение, направляемое в SAP.

6. При необходимости присоединения к сообщению файла выберите закладку Приложения и загрузите файл.

7. Сохраните введенные данные.

Результат

Создано сообщение. Теперь это сообщение можно обработать в системе обработки системных сообщений.

Существующие сообщения можно изменить путем выбора Просмотреть на закладке Сообщения и перехода к режиму изменения в следующем диалоговом экране.


 Закладка "Графика"

Закладка "Графика"

Использование

Закладка Графика используется для просмотра графики на уровне сценария и процесса, в которых визуально представлены ответы на следующие вопросы:

· Какие процессы входят в сценарий, или какие шаги процесса входят в процесс?

· В каких логических компонентах выполняются процессы или шаги процесса?

· Какие внешние продукты могут использоваться?

· Каким зависимости существуют между процессами или шагами процесса (отношения "предшественник-преемник")?

· Какие деловые партнеры вовлечены в сценарий или процесс?

· Какие транзакции, документация, объекты конфигурации или сообщения присвоены сценарию, процессу или шагу процесса?

Предпосылки

· Наличие Microsoft Internet Explorer (версии 5.5 или выше).

· Активация элементов управления ActiveX в веб-браузере.

· На фазе концептуального проекта имеется возможность изменения графики на закладке Графика. В фазе проекта конфигурации графика доступа только для просмотра.

· Для просмотра транзакций, сообщений, объектов конфигурации и документации активируйте соответствующие параметры настройки в Пиктограммы в ракурсе компонентов по пути Параметры настройки ® Специфика пользователя.

Функциональные возможности

· Просмотр графики процесса;

· Создание и изменение следующих элементов графики:

Ў бизнес-процессов в графиках сценариев;

Ў шагов процесса в графиках бизнес-процессов;

Созданные шаги процесса и бизнес-процессы помещаются в структуру проекта.

Ў произвольных элементов, например, для процессов, выполняемых во внешних продуктах;

Произвольные элементы не помещаются в структуру проекта.

Ў деловых партнеров;

Ў соединений (связей) междуэлементами графики.

Эти функции доступны в контекстном меню.

· Выгрузка графики процесса в виде HTML-файла;

· Навигация в графике:

Ў Сверху вниз: от сценариев к процессам при помощи двойного щелчка по элементу текстового поля;

Ў Снизу вверх: от процессов к сценариям при помощи стрелки Перемещение на один уровень вверх.

· Просмотр транзакций, сообщений, объектов конфигурации и документации (проектной документаций и общей документации) в виде графикии переход к документу посредством щелчка по нему; Доступ к релевантному для проектов бизнес-содержимому непосредственно как из графики, так и из структуры;

· Изменение вида и размера шрифта в графике в разделе Параметры настройки;

· Изменение высоты строк путем их выбора щелчком с одновременным нажатием клавишиCTRL и перетаскивания левой кнопкой мыши.


 Создание и печать документа концептуального проекта

Создание и печать документа концептуального проекта

Использование

После создания концептуального проекта (структуры проекта, документации, присвоений транзакций) можно распечатать документ концептуального проекта для утверждения или дальнейшего использования.

Для шаблонного проекта можно выбрать общую или проектную документацию. Существует возможность интеграции общей документации в концептуальные проекты, например, для ее распространения при глобальном развертывании.

Поместить в документ концептуального проекта проектную документацию можно только для других видов проектов.

Последовательность шагов

...

1. Запустите транзакцию концептуального проекта.

2. Выберите Концептуальный проект ® Документ концептуального проекта.

3. Определите, будет ли документ создаваться в режиме оффлайн или онлайн.

a. Создание в режиме онлайн:
Во время создания режим SAP блокируется (рекомендуется только для небольших документов концептуального проекта).

b. Создание в режиме оффлайн:
Данные загружаются из SAP-системы на жесткий диск, и в документе концептуального проекта запускается макрос создания (рекомендуется для больших и небольших документов концептуального проекта).

4. В следующем диалоговом окне выберите элементы, включаемые в документ концептуального проекта, и элементы для вывода на печать. Например, можно выполнить фильтрацию по виду или по статусу документа или выбрать элементы из структуры проекта путем выбора Структура .

Если один документ встречается в концептуальном проекте несколько раз, то можно либо несколько раз включить документ целиком, либо вставить ссылку на уже включенный документ. Для этого выберите (или отмените выбор) опции Связанный документ в области Вид документа .

Для созданного документа концептуального проекта в разделе Каталог можно задать общедоступный репозитарий, что сделает этот документ концептуального проекта доступным для других членов проектной группы.

5. Введите необходимые данные и выберите Дальше.

6. Будет запущен текстовый редактор.

7. Документ концептуального проекта можно распечатать при использовании функции печати текстового редактора. При помощи функции сохранения текстового редактора можно сохранить документ в локальном каталоге.

8. Закройте текстовый редактор.

Для дальнейшей обработки документа концептуального проекта или его публикации для пользователей в SAP Solution Manager можновоспользоваться функцией загрузки на закладке Проектная документация. Для исключения документа из следующего концептуального проекта установите для этого документа статус Не релевантно для концептуального проекта.


 Реализация

Реализация

Цель использования

На этой фазе проекта осуществляется определение и тестирование параметров настройки с использованием основных данных и организационных единиц, выбранных на фазе концептуального проекта.

Предпосылки

Концептуальный проект полностью создан и утвержден.

Доступна система разработок (DEV).

Выполнение

На фазе реализации проекта в SAP Solution Manager могут быть выполнены следующие операции:

· Распределение настройки

· Конфигурация

· Проверка непротиворечивости

· Настройка систем проекта

· Организация тестирования

Результат

Все требуемые системные настройки созданы и протестированы.


 Конфигурация

Конфигурация

Использование

На этом этапе проекта в системе конфигурируются требования к процессам, определенные на фазе концептуального проекта.

Используемые в структурах объекты из репозитария бизнес-процессов могут быть уже присвоены транзакциям и пакетам настройки бизнес-конфигурации. При создании структур без использования объектов из репозитария бизнес-процессов возможно самостоятельное присвоение транзакций при помощи транзакции Концептуальный проекте и пакетов настройки бизнес-конфигурации, объектов IMG и контрольных примеров в транзакции Конфигурация.

Предпосылки

Сценарии и процессы выбраны либо созданы самостоятельно с использованием репозитария бизнес-процессов на фазе концептуального проекта.

На фазе реализации была вызвана транзакция Конфигурация.

Функциональные возможности

Эта задача включает следующие шаги:

· Присвоение транзакций/программ

Возможен вызов присвоенных транзакций, добавление новых или удаление лишних транзакций из объема проекта на закладки Транзакции.

· Присвоение/обработка пакетов настройки бизнес-конфигурации

Имеется возможность присвоения этапам проекта пакетов настройки бизнес-конфигурации, просмотра содержимого присвоенных пакетов и удаление из объема ненужных пакетов на закладке Конфигурация.

Также можно активировать один или все пакеты настройки бизнес-конфигурации, присвоенные определенному процессу.

В прикладной системе возможно создание и присвоение в SAP Solution Manager новых пакетов настройки бизнес-конфигурации для проекта или специфичных для компании параметров настройки, например, в целях развертывания в рамках концерна или для создания собственных решений.

· Присвоение IMG

Этапам проекта могут быть присвоены объекты IMG. Эти параметры настройки, а также параметры настройки, созданные при помощи пакетов настройки бизнес-конфигурации в руководстве по внедрению, можно просматривать и обрабатывать.

· Обработка контрольных примеров

После конфигурации возможно проведение начального тестирования функций. Также для проверки выполнения транзакций можно воспользоваться инструментами CATT. Также имеется возможность создания контрольных примеров.

· Параметры настройки, релевантные для конфигурации структуры проекта, сохраняются на закладке Проектная документация или в IMG.

· Создание/изменение сообщений о проблемах

Операции

...

1. Конфигурация, общая для всех сценариев:

a. Создайте структуру конфигурации для основных параметров настройки решений, например, для SAP CRM 3.1, в области Конфигурация в структуре бизнес-процессов.

b. Сконфигурируйте эти основные параметры настройки.

2. Сконфигурируйте бизнес-сценарии в области Бизнес-сценарии в структуре бизнес-процессов, например, для сценария Электронные продажи.


 Обработка конфигурации, общей для всех сценариев

Обработка конфигурации, общей для всех сценариев

Использование

Общие для нескольких процессов основные параметры настройки для решения устанавливаются в общей для всех сценариев конфигурации перед внедрением сценария.

Интеграция

Сначала создайте общую для всех сценариев конфигурацию в области Конфигурация в структуре бизнес-процессов с использованием транзакции конфигурации (SOLAR02). Затем создайте сценарий и определенную для одного процесса конфигурацию в области Бизнес-сценарии в структуре бизнес-процессов.

Функциональные возможности

· Выбор существующих структур конфигурации из репозитария бизнес-процессов (репозитарий сценариев и бизнес-процессов, поставляемых SAP)

· Создание структуры конфигурации

· Изменение элементов конфигурации

· Присвоение элементам конфигурации объектов, например, объектов IMG и документов

· Выполнение общей для всех сценариев конфигурации решений.

· Вывод на печать структуры конфигурации, включая присвоенные документы, например, руководство по конфигурации.

Операции

...

1. Вызовите транзакцию Конфигурация (SOLAR02) и перейдите к требуемому проекту.

2. Выберите Конфигурация в структуре бизнес-процессов.

3. Перейдите к закладке Структура и создайте структуру конфигурации:

Ў Для копирования существующей структуры конфигурации из репозитария бизнес-процессов выберите элементы конфигурации в столбце Элемент конфигурации при помощи справки по допустимым значениям ввода.

Ў Для создания собственной структуры конфигурации введите имя элемента конфигурации в столбце Элемент конфигурации. Структуры конфигурации могут иметь любое количество уровней.

4. Присвойте логические компоненты структурам конфигурации в появившемся диалоговом окне.

5. Структуры и элементы конфигурации могут быть изменены.

6. Присвойте объекты, например, объекты IMG, структурам конфигурации.

7. Для запрета изменения элементов конфигурации зависимых проектов внедрения в шаблонном проекте присвойте соответствующие значения глобального атрибута элементам конфигурации на закладке Структуры.

8. Для создания руководства по конфигурации к данной структуре конфигурации выберите путь по меню Конфигурация ® Руководство по конфигурации.

9. Выполните общую для всех сценариев конфигурацию.


 Закладка "Конфигурация"

Закладка "Конфигурация"

Использование

Закладка Конфигурация обеспечивает доступ к различным инструментальным средствам настройки, используемым в целях установки системных параметров или сохранения предварительной конфигурации.

Она позволяет создавать шаблоны проектов и расширять их путем предварительной конфигурации и добавления собственной документации.

Интеграция

Закладка Конфигурация являетсяцентральной начальной точной для установки системных параметров проекта внедрения. Отсюда можно перейти к транзакциям обработки пакетов настройки бизнес-конфигурации или импорта дополнений (Add-On), а также в транзакциям ведения CATT и eCATT. также на этой закладке можно ввести все транзакции и программы, необходимые для конфигурирования решений в проекте.

Предпосылки

В транзакции Управление проектом создан проект, для которого определена системная среда . В Управлении проектом созданы IMG проекта и запросы на перенос в системах компонентов в рамках системной среды .

При помощи транзакции Концептуальный проект создана структура сценариев проекта.

Функциональные возможности

· В прикладных системах можно создавать новые пакеты настройки бизнес-конфигурации, присваивать их структуре, просматривать их содержимое и удалять ненужные пакеты из проекта.

· Могут быть активированы один или более присвоенных пакетов настройки бизнес-конфигурации. На закладке можно просмотреть статус активированных пакетов настройки бизнес-конфигурации. Также можно просмотреть журнал активации.

· Имеется возможность просмотра и обработки параметров настройки в руководстве по внедрению прикладной системы (IMG). Структурным элементам могут быть присвоены IMG-операции.

· Имеется возможность присвоения конфигураций CATT и eCATT структурным элементам и последующего их вызова. Функции CATT и eCATT позволяют сохранить параметры настройки и выполнить импорт предварительной конфигурации.

· Возможно создание и выполнение eCATT. На закладке можно просмотреть статус выполнения eCATT. Также доступны журналы ошибок.

· Имеется возможность присвоения структурным элементам транзакций и программ, необходимых для конфигурации прикладных систем, и последующего их вызова.

· Онлайн-документацию по транзакциям и программам можно вызвать в библиотеке SAP.

· Отдельные шаги конфигурации могут быть сохранены в виде документа. Возможно присвоение существующей и создание новой документации.

· Кроме того, в систему можно импортировать настройку из переносов дополнений (Add-On).

· Для каждого присваиваемого объекта может быть определен статус обработки и ответственный исполнитель.


 Конфигурирование

Конфигурирование

Использование

Для конфигурирования систем компонентов в системной среде доступны следующие способы:

· импорт пакетов настройки бизнес-конфигурации, конфигураций тестов CATT и eCATT;

· обработки IMG-операций;

· импорта запросов на перенос Add-On;

· выполнения операций или программ (отчетов).

Предпосылки

Запущена транзакция Конфигурация, и выбрана закладка Конфигурация. При необходимости импорта и переноса предварительной конфигурации создайте запрос на настройку и запрос к инструментальным средствам в "Управлении проектом" систем.

Последовательность шагов

Импорт предварительной конфигурации в системы компонентов

Активация пакетов настройки бизнес-конфигурации

...

1. Для активации пакета настройки бизнес-конфигурации выберите Сконфигурировать на закладке Конфигурация. Одновременно могут быть активированы несколько пакетов настройки бизнес-конфигурации в разных системах компонентов.

2. Выберите Запуск переноса данных в диалоговом окне Сравнение и перенос данных.

Поле Статус показывает фактический статус активации пакета настройки бизнес-конфигурации. Система вносит данные по активации пакета настройки бизнес-конфигурации в журнал.

Деблокирование запроса на перенос

...

1. Для деблокирования запросов на перенос выберите запрос на перенос на закладке Конфигурация, а затем выберите Сконфигурировать. Будет выполнен переход к транзакции Инструмент инсталляции Add-On. При импорте Add-On содержимое их настройки сохраняется в запросе к инструментальным средствам для дальнейшей передачи.

2. Для возврата к закладке Конфигурация, выберите Назад.

Для получения дополнительной информации см. Инструмент инсталляции Add-On SAP.

Конфигурирование тестов CATT и eCATT

...

Для конфигурирования тестов CATT или eCATT выберите Сконфигурировать на закладке Конфигурация. После конфигурирования тестов CATT и eCATT на экран будет выведен журнал. В каждой системе компонента могут быть сконфигурированы одновременно несколько тестов CATT или eCATT.

Обработка объекта IMG

...

1. Для обработки объекта IMG дважды щелкните по столбцу Объект.

Будет выполнен переход к пункту Реализация проекта в руководстве по внедрению системы компонента (IMG). Теперь можно проверить и изменить конфигурацию, импортированную при активации пакетов настройки бизнес-конфигурации.

2. Выполните обработку IMG-операции.

3. Сохраните статус и документацию пользовательской настройки.

4. Сохраните записи и выберите Назад для возврата к закладке Конфигурация.

Для получения дополнительной информации см. Присвоение IMG-документации.

Обработка документации

...

1. Выберите Документ в поле Вид.

2. Введите заголовок документа. Выберите вид документации и источник документа в диалоговом окне Добавление объекта .

Можно создавать ссылки к документу, копировать существующий документ SAP Solution Manager, загружать локальный документ или создавать ссылки к URL.

3. Для создания нового документа введите заголовок документа и выберите вид документа. Система запускает редактор в новом окне.

4. После нажатия кнопки Атрибуты можно изменить статус документа и ответственное лицо.

Для получения дополнительной информации см. Создание проектной документации.

Просмотр/изменение административной информации

· Выберите ответственного для шага конфигурации из справки по допустимым значениям ввода для поля Ответственный. Появится список членов проектной группы, определенных в Управлении проектом.

· Для изменения статуса обработки шага конфигурации вызовите справку по допустимым значениям ввода для поля Статус обработки. Появится список статусов, определенных в Управлении проектом.

Вставка строк

Для того чтобы вставить строки, выделите строку и выберите Вставка нескольких строк. Система переместит строку выше выбранной вверх и скроет все другие строки. Строки при этом не удаляются. Для просмотра скрытых строк выберите Ввод.

Вставка имен присвоений

Как правило, система автоматически вводит имена присвоений структурному элементу, например, в случае операций и объектов IMG.

Если имя присвоения не предлагается системой автоматически, и в столбце Имя выводится сообщение <Имя не найдено>, вызовите функцию вставки имен присвоений вручную:

Выберите "Среда ® Обновить тексты присвоений".

После обновления текстов присвоений открывается новый режим, и на экран выводится журнал.

Результат

Для проекта внедрения установлены системные параметры настройки.

Параметры настройки можно проверить на закладке Контрольные примеры; для планирования или выполнения более обширного тестирования воспользуйтесь Инструментальными средствами тестирования.

См. также:

Создание и присвоение предварительной конфигурации


 Закладка "Разработки"

Закладка "Разработки"

Использование

Закладка Разработки используется для размещения собственных разработок и модификаций в проекте внедрения для обеспечения центрального доступа к этим элементам. На этой закладке можно выбрать разработки и модификации, связанные с данным проектом внедрения.

Предпосылки

В Управлении проектом создан проект, для которого определена системная среда .

При помощи транзакции Концептуальный проект создана структура сценариев проекта.

Имеются полномочия для объекта полномочий AI_SA_TAB. Поля должны иметь следующие значения: закладка в SAP Solution Manager (имя закладки) = DEV, операция (ACTVT) = 02.

Функциональные возможности

· Присвоение пакетов, программ, транзакций, интернет-сервисов, BSP-приложений и BSP-расширений структурным элементам.

· Доступ к объектам инструментальных средств (пакетам, программам, транзакциям, интернет-сервисам, BSP-приложениям и BSP-расширениям) в спутниковых системах.

· Присвоение запросов на перенос структурным элементам на закладке Разработки, например, внесение модификаций в запрос на перенос в проект внедрения. Доступ к запросам на перенос в спутниковых системах.

· Определение статуса обработки и ответственного для присвоения.

Пример

...

1. Объект настройки изменен так, чтобы текущие параметры настройки отвечали требованиям системы, а изменения сохранены в запросе на перенос.

2. На закладке Разработки для документирования модификации выполняется присвоение этого запроса на перенос.

3. Если модификация перезаписывается при импорте пакета поддержки, повторите операцию модификации при помощи присвоенного запроса на перенос.


 Закладка "Контрольные примеры"

Закладка "Контрольные примеры"

Использование

Эта закладка используется для присвоения контрольных примеров, сценариев или шагов процессов. Контрольные примеры, присвоенные на этой закладке, могут использоваться в качестве значений по умолчанию для данного проекта при создании планов тестирования.

Функциональные возможности

Присвоение новых или уже существующих контрольных примеров структуре сценария

На этой закладке имеется возможность присвоения контрольных примеров, сценариев, процессов или шагов процессов для последующего использования в ориентированных на процессы тестах. Возможно присвоение существующих контрольных примеров или создание новых. Для создания, изменения и просмотра доступны следующие виды контрольных примеров:

· Описание контрольного примера в форме документа Microsoft Word;

Выполните шаги, описанные в пункте Создание проектной документации в разделе Последовательность действий.

Для описания контрольных примеров им могут быть присвоены атрибуты:

· Просмотрите историю изменений описаний контрольных примеров на закладке История.

· Создайте ссылки на другие существующие документам, относящиеся к описанию контрольных примеров, на закладке Ссылки.

· Описание контрольного примера в форме веб-ссылки (URL);

· Контрольные примеры, выполняемые вручную;

· Внешние приложения, например, внешние инструментальные средства тестирования с сертифицированным интерфейсом или документы Microsoft Word;

· Автоматические контрольные примеры, например, конфигурации тестов CATT или eCATT;

· Тесты функциональных модулей.

Для определения структурного элемента, которому присвоен контрольный пример, просмотрите журнал использования. Выполните шаги, аналогичные описанным для Создания журнала использования на закладке Транзакции.

Сохранение контрольных примеров

Выберите компонент для контрольных примеров вида CATT или тестов функциональных модулей, после чего эти контрольные примеры будут сохранены в присвоенной системе компонента.

Контрольные примеры, выполняемые вручную, внешние приложения и конфигурации тестов eCATT можно также сохранять в центральной системе SAP, а не в системе компонента. Определите системы для таких "центральных объектов" в Управлении проектом. Если такая центральная система SAP уже определена, компоненты на закладке Контрольные примеры выбирать не требуется. Контрольные примеры автоматически сохраняются в центральной системе SAP.

Соединение выполняемых вручную контрольных примеров с транзакцией или программой

Если контрольный пример, выполняемый вручную, служит для тестирования транзакции или программы, его можно соединить с этой транзакцией. В таком случае тестер может прочитать описание контрольного примера теста и вызвать связанную транзакцию непосредственно из рабочего списка в транзакции Тестирование.

Для соединения выполняемого вручную контрольного примера с транзакциями или программами на закладке Транзакции необходимо выполнить их присвоение и установку индикаторов В объеме.

Другие функции

· Просмотр описаний контрольных примеров и выполнение автоматических контрольных примеров вида CATT и eCATT могут осуществляться по отдельным контрольным примерам или по группам примеров.

· Также можно просмотреть журналы ошибок контрольных примеров.

Для получения дополнительной информации о создании контрольных тестов и инструментальных средствах тестирования см. описание компонента Инструментальные средства тестирования в библиотеке SAP.


 Организация тестирования

Организация тестирования

Цель использования

· Организатор тестирования может создать один или более планов тестирования для присвоенных ему проектов. Также имеется возможность обработки планов тестирования и присвоения пакетов тестов тестерам.

· Кроме того, организатор тестирования получает информацию по статусу плана тестирования.

Тест выполняется с использованием инструментальных средств тестирования. Инструментальные средства тестирования являются средой тестирования SAP и доступны во всех SAP-системах. Послевызова тестером инструментальных средств тестирования на экран выводится обзор контрольных примеров, присвоенных этомутестеру в его рабочем списке. Он можетвыполнить тесты, установить статусобработки и просмотреть открытые позиции.

Предпосылки

Необходимо создать концептуальный проект и сконфигурировать системы.

Схема: тестирование на фазе реализации

Выполнение

Организация тестирования включает следующие шаги:

...

1. Создание планов тестирования в управлении планами тестирования. При создании планов тестирования для проекта все контрольные примеры и транзакции, присвоенные проектув Конфигурации, выбираются по умолчанию. Можно отменить выбор некоторых контрольных примеров и транзакций по умолчанию и затем создать план тестирования.

2. В случае необходимости можно также просмотреть, изменить, скопировать или удалить планы тестирования.

3. Выбор контрольных примеров для включения в пакет тестов и присвоение его тестеру.

4. Использование информационной системы статусов для просмотра, печати и обработки анализов статуса плана тестирования.

Функциональные возможности инструментальных средств тестирования системы SAP Solution Manager доступны в Организации тестирования. Для получения дополнительной информации об инструментальных средствах тестирования см. Инструментальные средства тестирования в системе R/3.


 Управление планами тестирования

Управление планами тестирования

Использование

Эта функция предоставляет следующие возможности:

· создание,

· изменение, копирование или удаление планов тестирования.

Интеграция

Тесты проводятся после создания структуры проекта при создании концептуального проекта . Установлена определенная конфигурация, которую необходимо протестировать по процессам. При создании плана тестирования для проекта структура плана тестирования по умолчанию создается на основе структуры концептуального проекта, предварительно созданного для этого проекта.

Предпосылки

Для использования этой функции в Управлении проектом должен быть определен проект, концептуальном проекте должна быть создана структура проекта; этому проекту в конфигурации должны быть присвоены контрольные примеры или транзакции, либо в инструментальных средствах тестирования должен быть создан каталог тестов. Также до вызова транзакции "Организация тестирования" необходимо настроить тестовую системную среду при помощи транзакции Среда SAP Solution Manager.

Функциональные возможности

Управление планами тестирования предоставляет следующие возможности:

· создание, изменение, копирование или удаление планов тестирования,

· перенос планов тестирования,

· разделение планов тестирования на пакеты тестов и присвоение этих пакетов тестерам,

· контроль динамики процесса при помощи инфо-системы статусов и экспорт результатов тестирования.

Управление планами тестирования позволяет создавать планы тестирования на основе следующего:

· структуры проекта, созданной в концептуальном проекте;

· одного или более каталогов тестов.

Планы тестирования включают в себя все контрольные примеры, необходимые для определенной фазы тестирования, т.е. состоят из следующих объектов:

· контрольные примеры, вводимые вручную;

· внешние приложения, например, внешние инструментальные средства тестирования, или документы Microsoft Word;

· инструменты CATT;

· конфигурации тестов eCATT;

· тесты функциональных модулей.

В меню Утилиты доступны функции для выполнения следующего:

· проверки рабочих списков тестеров;

· получения информации по загрузке и выгрузке;

· просмотра данных проекта для проекта с присвоенным планом тестирования;

· проверки системной среды проекта , которой присвоен план тестирования.


 Создание плана тестирования для проекта

Создание плана тестирования для проекта

Использование

План тестирования для проекта в системе SAP Solution Manager создается для повторного использования структуры проекта, созданной в концептуальном проекте для ориентированного на процессы тестирования. Для плана тестирования выбираются все контрольные примеры и транзакции, присвоенные структуре проекта. Данные контрольные примеры выполняются тестерами путем вызова соответствующих транзакций и запуска в них этих контрольных примеров.

Предпосылки

Для создания плана тестирования на основе структуры проекта SAP Solution Manager должен быть создан проект. Для проекта должна быть определена системная среда. Также в транзакции Конфигурация должен быть определен концептуальный проект, на закладке Контрольные примеры должны быть созданы и присвоены структуре контрольные примеры.

Планы тестирования могут создаваться на основе каталогов тестов, присвоенных иерархии прикладных компонентов.

Последовательность шагов

...

1. Запустите Управление планами тестирования.

Выберите План тестирования ® Создать.

2. В диалоговом окне введите следующие данные:

Ў Выберите проект SAP Solution Manager и системную роль из справки по допустимым значениям ввода.

Ў Для размещения в плане тестирования конфигураций eCATT можно определить контейнер системных данных. Можно также указать целевую систему, в которой должна выполняться конфигурация eCATT.

Определяемые значения выводятся как значения по умолчанию на первом экране конфигурации eCATT. Эти значения можно изменить.

Ў Введите заголовок для плана тестирования.

Ў Можно определить группу тестов.

При вводе того же самого ключевого слова в поле Группа тестов для соответствующих планов тестирования по данному ключевому слову можно выполнить поиск и выбрать данные планы тестирования в инфо-системе статусов.

Система проверяет, существует ли эта группа тестов в таблице twb_sequ. В противном случае появится предупреждающее сообщение. Для помещения группы тестов в таблицу twb_sequ используется транзакция ведения ракурса/таблицы (SM30).

Ў Устанавливается индикатор Копирование транзакций (Copy Transactions) Для переноса транзакций, присвоенных структуре проекта, на закладку Транзакции в плане тестирования установите флаг Скопировать транзакции. Присвоенные на закладке Контрольные примеры транзакции автоматически помещаются в план тестирования.

3. Выберите Дальше.

На экране появится структура проекта.

4. Выберите контрольные примеры или транзакции для плана тестирования.

Также можно отфильтровать контрольные примеры по атрибутам и составить, таким образом, план тестирования на основе этих критериев выбора.

5. Выберите Создать.

Если для выбранного проекта существует переносимый пакет, он используется для создания плана тестирования. В противном случае появится диалоговое окно для ввода каталога объектов.

6. Определите пакет в диалоговом окне для ввода каталога объектов и выберите Дальше.

На основе выбранных параметров создается план тестирования, после чего выполняется возврат к первому экрану.

Результат

На основе введенных пользователем критериев выбора создан план тестирования. Теперь имеются следующие возможности:

· изменение, копирование или удаление планов тестирования;

· комбинирование контрольных примеров и транзакции в пакетах тестов и присвоение этих пакетов тестерам.

Позже план тестирования можно изменить. Можно, например, выбрать дополнительные контрольные примеры или транзакции и повторно создать план тестирования без потери информации по статусу для уже выполненных контрольных примеров.


 Изменение плана тестирования для проекта

Изменение плана тестирования для проекта

Изменение плана тестирования со ссылкой на проект

Данная функция используется для включения в план тестирования контрольных примеров или транзакций, помещенных в структуру проекта после создания этого плана тестирования. Данная функция не позволяет изменить в плане тестирования последовательность контрольных примеров или структурных элементов.

...

1. Запустите Управление планами тестирования.

2. Выберите план тестирования.

3. Выберите Изменить.

4. Появится структура проекта, лежащая в основе данного плана тестирования. Разверните структуру проекта для просмотра соответствующей области.

В плане тестирования выделены контрольные примеры и транзакции.

5. Выберите подразделы, релевантные для плана тестирования.

6. Для дальнейшего ограничения выбора контрольных примеров по их атрибутам или статусу выберите опцию Фильтрация по атрибутам контрольных примеров или Фильтрация по статусу контрольных примеров.

Введите необходимые данные на следующем экране выбора и выберите Выполнить. При этом выбираются только те контрольные примеры, которые были выбраны на шаге 5 и удовлетворяют определенным условиям выбора.

7. Выбор контрольных примеров или транзакций или их исключение из выбора может быть выполнено вручную.

8. Для создания плана тестирования в соответствии с критериями выбора нажмите экранную кнопку Создать.

Последовательность контрольных примеров не изменяется.

При повторном создании плана тестирования уже находящаяся в нем информация по статусу для контрольных примеров или транзакций не утрачивается.

По завершении операции создания выполняется переход к первому экрану Управление планами тестирования.

Изменение плана тестирования без ссылки на проект

С помощью данной функции структура планов тестирования можно изменить независимо от структуры проекта. Например, можно добавить в структуру плана тестирования дополнительные контрольные примеры или структурные элементы или изменить последовательность контрольных примеров.

...

1. Запустите Управление планами тестирования.

2. Выберите план тестирования.

3. Выберите План тестирования ® Изменение без ссылки на каталог тестов.

4. Внесите необходимые изменения. Имеются следующие возможности:

Ў добавление контрольных примеров или структурных элементов;

Ў удаление узлов;

Ў изменение последовательности контрольных примеров методом перетаскивания.

5. Сохраните изменения.

Выполнять повторное создание плана тестирования не рекомендуется, так как в этом случае структурные изменения плана тестирования не сохраняются.


 Изменение атрибутов плана тестирования проекта

Изменение атрибутов плана тестирования проекта

Использование

Изменение атрибутов плана тестирования осуществляется в случае изменения организационной или технической информации при планировании тестирования. Примерами таких изменений являются смена ответственного за планирование тестирования или добавление в план тестирования контейнера системных данных для дополнительных конфигураций eCATT.

Также можно изменить системную роль плана тестирования. Это может стать причиной несогласованности уже обработанных результатов тестирования по планам тестирования, т.к. теперь в них будут указаны контрольные примеры в других системах. Изменение системной роли должно производиться с особой осторожностью только в исключительных случаях.

Последовательность шагов

...

1. Запустите транзакцию Организация тестирования.

2. Выберите план тестирования.

3. Выберите [image].

Будет выполнен переход к экрану просмотра атрибутов плана тестирования.

4. Для изменения атрибутов перейдите в режим изменения с помощью кнопки [image].

5. Измените атрибуты, например, заголовок, группу тестов, ответственного за план тестирования или его версию.

6. При использовании в плане тестирования "ссылочных" контрольных примеров необходимо в поле Логический адрес определить удаленное соединение с целевой системой, в которой определены ссылочные контрольные примеры.

7. Сохраните изменения.


 Перенос плана тестирования

Перенос плана тестирования

Предпосылки

План тестирования должен быть включен в переносимый пакет.

Последовательность шагов

...

1. Запустите Управление планами тестирования.

2. Выберите подлежащий переносу план тестирования.

3. Выберите План тестирования ® Перенос.

В выбранных контрольных примерах появится список объектов в каталоге тестов.

4. Выберите объекты.

5. Выберите Перенос.

Появится список присвоенных данному пользователю запросов на перенос.

6. Выберите запрос, в который должны быть помещены выбранные объекты, и нажмите Дальше.

Результат

Все объекты помещены в определенный запрос на перенос.

Объекты, еще не включенные в переносимые пакеты, должны быть в них включены. Перенос этих объектов возможен только после выполнения этой операции.


 Создание пакета тестов для проектов в системе SAP Solution Manager

Создание пакета тестов для проектов в системе SAP Solution Manager

Использование

Контрольные примеры для тестера группируются в пакеты тестов. Пакет тестов составляется на основе плана тестирования. Контрольные примеры для пакета тестов выбираются из плана тестирования. При наличии созданного плана тестирования для проекта в системе SAP Solution Manager для пакета тестов из плана тестирования также можно выбрать подлежащие тестированию транзакции.

Последовательность шагов

...

1. Запустите Управление планами тестирования.

2. Выберите план тестирования и нажмите экранную кнопку Управление пакетами тестов.

3. Выберите Создать.

Появится структура проекта, лежащая в основе плана тестирования.

4. Выберите подразделы, которые являются релевантными для пакета тестов.

5. Для ограничения выбора контрольных примеров по их атрибутам или статусу выберите опцию Атрибуты контрольных примеров или Статус контрольных примеров соответственно.

На следующем экране введите критерии выбора. При этом выбираются только те контрольные примеры, которые были выбраны на предыдущем шаге и удовлетворяют определенным условиям выбора.

6. Выбор контрольных примеров или транзакций или их исключение из выбора может быть выполнено вручную.

7. Выбрать Создать.

8. В следующем диалоговом окне введите краткое описание для пакета тестов и выберите Дальше.

Результат

После создания пакета тестов его можно просмотреть. Пакет тестов теперь можно присвоить тестеру.


 Присвоение пакета тестов тестеру

Присвоение пакета тестов тестеру

Использование

Как правило, один пакет тестов присваивается одному тестеру. Тестер получает данный пакет тестов в виде рабочего списка в транзакции тестирования. Можно также блокировать или удалить пакет тестов данного тестера.

Присвоение пакета тестов выполняется в зависимости от манданта.

Предпосылки

Вызвана транзакция Управление планами тестирования.

Последовательность шагов

Присвоение пакета тестов тестеру

Для присвоения пакета тестов тестеру:

...

1. Выделите план тестирования и выберите Управление пакетами тестов.

2. Выберите пакет тестов.

3. Выберите [image].

4. В диалоговом окне Присвоение пакета тестов введите имя пользователя тестера и выберите Дальше.

Присвоение тестеру заносится в иерархию.

Для отмены присвоения тестера подведите курсор к имени тестера и выберите [image].

При присвоении контрольного примера нескольким тестерам результат контрольного примера отображается следующим образом:

· Если несколько тестеров выполнили один и тот же контрольный пример автоматически в том же пакете тестов, выводится статус последнего тестера.

· Если несколько тестеров выполнили один и тот же контрольный пример вручную в том же пакете тестов, выводятся самые низкие результаты.

· Если несколько тестеров должны выполнить один и тот же контрольный пример вручную в том же пакете тестов, и тесты имеют статусы "OK" и "открыто", результатом будет "OK".

Для выполнения одного контрольного примера дважды независимо друг от друга необходимо скопировать пакет тестов и присвоить каждый пакет разным тестерам. Для автоматических контрольных примеров, работающих в фоновом режиме, принцип "четырех глаз" (двойная проверка) является излишним, т.к. тест определен таким образом, что любой тестер получает один и тот же результат.

Удаление пакета тестов из рабочего списка тестера

Для удаления пакетов тестов из рабочего списка тестера без потери присвоения можно заблокировать соответствующие присвоения. Это целесообразно в том случае, когда тест закончен, и изменение статуса тестером больше выполняться не будет.

...

1. Выделите план тестирования и выберите Управление пакетами тестов.

2. Отметьте тестера в пакетах тестов.

3. С помощью экранной кнопки [image] или Перейти к ® Блокирование присвоения заблокируйте пакеты тестов.

Символ статуса присвоения изменяется с [image] (Присвоение деблокировано) на [image] (Присвоение блокировано).

Для разблокирования присвоения отметьте тестера и выберите экранную кнопку [image] или путь по меню Перейти к ® Деблокирование присвоения.

Удаление присвоения пакета тестов

...

1. Выделите план тестирования и выберите Управление пакетами тестов.

2. Отметьте тестера в пакетах тестов.

3. Выберите Перейти к ® Удалить присвоение.

Удалять присвоение тестеру пакета тестов, который уже был обработан, не рекомендуется, так как в противном случае эта информация будет потеряна.


 Analyze Status

Analyze Status

You can analyze the status for one test plan or across test plans. The status of one test plan is usually the result of a particular test. Test plan-independent status analyses combine the results of several test plans, and can be considered as the overall result of a complex test, which comprises several test plans.

Status analysis of one test plan

Procedure

  1. Go to the test plan management via Tools ® ABAP Workbench ® Test ® Test Workbench ® Test Organizer ® Manage Test plans in the SAP menu.
  2. Choose a test plan. Use the F4 help or choose a test plan from your Favorites.
  3. Choose Status Analysis.
  4. You can specify a period in which the statuses are analyzed with [image].
  5. Select an object, depending on whether the status of one test package or the entire test plan is to be analyzed.
  6. Choose Create detail view.

An overview of the test progress appears. The left-hand column contains information about the test case, and the right-hand column contains the test status.

If a test case was assigned to several test packages, each test package has a separate test case status. You can see all statuses of a test case by clicking on the Overview symbol after the test case.

To display all test statuses assigned to all test cases, choose View ® Additional information. Other status analysis display types are under the menu item View.

Test plan-independent status analysis

Procedure

  1. Go to the status info system initial screen Tools ® ABAP Workbench ® Test ® Test Workbench ® Test Organizer ® Status Info System in the SAP menu.
  2. Restrict the status analysis with selection conditions and choose Execute.

    3. The Test Session field is a useful way of restricting selections. Test Session combines several test plans for the status analysis. To do this, enter a Test Session name in Test Plan Attributes .

  3. A list of selected test plans and condensed status information is displayed.

    4. This analysis uses status information from previous status analyses for individual test plans. These statuses could be obsolete (e.g. a tester has changed a test case status in the meantime). This is indicated by a flag in the Obsolete result column and an entry in the list header. You can update this information by selecting the test plans and choosing Goto ® Refresh Status Analysis.

  4. To see detailed status information for a test, select it and choose Status information detail view.

Result

You get an up-to-date status analysis of all test packages in the selected test plan.

  • To send the status analysis, choose [image]. You can send it with a comment via the Office mail system.
  • You can use the general list functions to further analyze the list. You can for example:
    • pass the data to a spreadsheet program
    • export the data to a text processing program
    • display the results graphically.

You can also display a problem message overview for your test plans in the Status Info System.


 Обзор проблем с планами тестирования

Обзор проблем с планами тестирования

Использование

Обзор всех сообщений о проблемах в плане тестирования. Сообщения о проблемах создаются тестерами в случае невозможности выполнения теста.

Предпосылки

В системе SAP Solution Manager должны быть созданы планы тестирования, и тестеры уже приступили к выполнению теста.

Имеется система сообщений о проблемах, в которой тестеры могут создавать сообщения о проблемах. Подключение системы сообщений о проблемах осуществляется во время установки системы SAP Solution Manager. В системе сообщения о проблемах необходимо создать идентификатор пользователя.

Функциональные возможности

В обзоре проблем содержится следующая информация:

· статус сообщения о проблеме,

· приоритет сообщения о проблеме,

· автор сообщения,

· текущий обработчик,

· краткий текст сообщения,

· связанный контрольный пример и план тестирования.

В обзоре проблем можно обработать список всех сообщений о проблемах, относящихся к определенному плану тестирования. Доступны следующие функции:

· просмотр,

· печать,

· фильтрация,

· экспорт в приложения Microsoft Office,

· сохранение в локальный файл,

· передача по электронной почте.

Любое сообщение о проблеме можно открыть путем двойного щелчка, а затем просмотреть и обработать его в системе сообщений о проблемах.

· Если системой сообщений о проблемах для SAP Solution Manager является базисная системой, то обработка сообщений, выполняемая данным пользователем ("обработчиком"), осуществляется с помощью транзакции DNOTIFWL.

· Если системой сообщений для SAP Solution Manager является система CRM, обработка сообщений осуществляется в службе поддержки.

Операции

...

1. В системе SAP Solution Manager запустите транзакцию Управление планами тестирования.

2. Запустите анализ статуса в Инфо-системе статусов.

3. Появится обзор всех выбранных до этого планов тестирования и их общие результаты.

4. Выберите план тестирования и Сообщения о проблемах.

5. Система выведет обзор сообщений обо всех проблемах, связанных с данным планом тестирования. Путем двойного щелчка можно открыть любое сообщение о проблеме и просмотреть его подробные данные.


 Синхронизация настройки

Синхронизация настройки

Цель использования

В системной среде могут присутствовать несколько компонентов SAP, например, системы R/3 и SAP CRM. В основе операций в системе SAP CRM лежат данные, уже имеющиеся в системе R/3; эти системы взаимодействуют во многих бизнес-сценариях. Параметры пользовательской настройки, определяющие бизнес-процессы в системах, должны быть синхронизированы для обеспечения корректного и бесперебойного обмена данными. Области, в которых должны быть синхронизированы настройки систем R/3 и SAP CRM, включают клиента и группы продуктов, рынки сбыта, условия платежа, условия поставки, группы комиссионных, валюты, страны, регионы и единицы измерения.

SAP предоставляет два инструментальных средства, поддерживающих синхронизацию настройки: функции "Распределение настройки" иCustomizing Scout. Функция "Распределение настройки" позволяет перенести настройку из одной системы в другую ("Начальное распределение") или обновить настройку в различных системах одновременно каждый раз при изменении этих параметров в ссылочной системе ("Дельта-распределение"). Распределение настройки предоставляет следующие возможности:

· быстрое конфигурирование учебных, демонстрационных и тестовых систем посредством начального распределения настройки;

· синхронизация систем R/3, SAP CRM и SAP APO посредством дельта-распределения для обеспечения корректной совместной работы всех компонентов;

· синхронизация настройки в различных системах R/3 с целью подготовки к ALE-распределению основных данных.

Распределение настройки позволяет системным администраторам контролировать операции настройки в нескольких системах посредством определенных проверок, автоматически регистрировать все распределения настройки и выполнять обработку ошибок. Распределение настройки дополняет Customizing Scout - инструмент, используемый для сравнения настройки различных систем.

Примечания по внедрению

Для распределения настройки требуется определенный статус пакета поддержки в системах, доступ к которым необходимо осуществить. Проверьте правильность статуса пакета поддержки в соответствующих системах при помощи следующих SAP-нот:

· SAP-нота 552457: Предпосылки для целевых систем распределения настройки;

· SAP-нота 552494: Предпосылки для исходных систем распределения настройки.

Интеграция

Синхронизация настройки входит в пакет функций SAP Solution Manager.

Существующее промежуточное программное обеспечение CRM позволяет загрузить данные настройки непосредственно в продуктивную среду. Распределение настройки используется для переноса настройки из системы разработок (система R/3) в другую систему (SAP CRM). После этого можно выполнить управляемый перенос данных в систему обеспечения качества и продуктивную систему. Таким образом, эти данные настройки проходят тот же путь по системам разработок и тестирования, как и все другие данные настройки. Распределение настройки имеет другие дополнительные функции по сравнению с промежуточным программным обеспечением CRM: прежде всего это сравнение, распределение изменений настройки и создание журналов.

Функциональные возможности

Возможно использование следующих инструментов:

· Customizing Scout для сравнения настройки в двух системах;

· Распределение настройки для синхронизации настройки в исходной и различных целевых системах.

· Объекты настройки, которые должны быть синхронизированы в системной среде, можно определить при помощи инструмента определения объектов синхронизации.

Ограничения

Возможно использование предварительно определенных в распределении настройки и Customizing Scout объектов синхронизации - объектов настройки, которые должны быть синхронизированы в разных компонентах. Для синхронизации настройки также можно выбрать любой переносимый объект настройки вида Область (табличная область), V (ракурс), S (табличная область с таблицей текстов), C (кластер ракурсов), T (транзакция) и L (логический объект переноса). Эти объекты настройки должны удовлетворять предпосылкам, приведенным в описании объектов, релевантных для синхронизации настройки.

Распределение настройки может выполняться только в гармонизированных системах. Распределение настройки в негармонизированных системных средах может привести к противоречивости данных.

Не совмещайте функции распределения настройки и структуры мэппинга пользовательских идентификаторов при пользовательской настройке объекта и его системы. Это может также привести к противоречивости данных причиной противоречивости данных. Распределение настройки и структура мэппинга пользовательских идентификаторов представляют собой компоненты SAP Solution Manager, однако между собой они не интегрированы. Поэтому следует либо выполнить распределение объекта настройки между двумя системами при помощи функции распределения настройки, либо выполнить мэппинг идентификаторов.


 Быстрое руководство: настройка параметров распределения настройки

Быстрое руководство: настройка параметров распределения настройки

Цель использования

Быстрое руководство предоставляет минимальный список операций, которые следует выполнить для установки основных параметров распределения настройки. Оно может быть использовано для быстрого получения справки, как справочник или контрольный список.

За дополнительной информацией следует обратиться к другим источникам, в которых перечисленные операции описаны более подробно.

Предпосылки

Наличие следующих полномочий (в зависимости от роли):

· Установка параметров распределения настройки в качестве системного администратора;

· Пользовательская настройка исходной и целевой системы в качестве настройщика.

Системные параметры позволяют записать настройку в запросах на перенос в исходном манданте (транзакция SCC4).

Для получения дополнительной информации о полномочиях и зависящей от манданта системной настройке см. Системные параметры настройки для распределения и сравнения настройки.

Выполнение

Следующие операции позволяют выполнить начальное распределение, автоматическое распределение и распределение настройки вручную при помощи функции "Распределение настройки", кроме случаев, где указано иначе.

Обязательные операции

Подробная информация

Проверка соблюдения обязательных технических требований

Руководство по конфигурации: SAP Solution Manager 3.1 в SAP Service Marketplace /instguides® SAP Solution Manager: глава с описанием использования примера "Внедрение и распределение", ключевое слово: распределение настройки

Системная среда
(транзакция SMSY)

· Компонент среды Системы: централизованный ввод систем, задействованных в распределении

· Закладка Манданты: создание зависящих от манданта RFC-соединений через главную инстанцию:

Ў При отсутствии информации о манданте для обновления системных данных см. описание создания RFC-адресов и пользователей с доступом только для чтения

Ў Настройка RFC-адреса вида "Достоверная система" для синхронизации настройки

Ў Возвратные RFC для проверки блокирования:
Выбор RFC-адресов с <SYS_ZIEL> по <SYS_SOLMAN>, мандант XY Z

Системные параметры распределения и сравнения настройки

SAP Solution Manager: Управление проектом
(транзакция:SOLAR_PROJECT_ADMIN)

· Создание проекта SAP Solution Manager (вид: Проект внедрения)

· Закладка: Системная среда/Системы:

Ў Определение логических компонентов с продуктами/версиями продуктов

Ў Присвоение логических систем для системной роли к системе разработок (соответствует исходным и целевым системам при распределении)

· Закладка: Системная среда/Проекты IMG:

Ў Создание проектов IMG с идентичными именами для логических систем (системы разработок)

Ў Создание запросов на перенос для проектов IMG и задач для настройщиков в исходном и целевом запросах одновременно.

Для начального распределения требуется только запрос на перенос в целевой системе.

Создание/изменение проекта ;
особенно Закладка "Системная среда"

Установка параметров распределения настройки: Обзор
(транзакция SCDT_SETUP)

При наличии определенных объектов синхронизации, например, для мэппинга специфичных для клиента объектов
(транзакция SCDT_MAPPING в целевой системе)

Инструмент определения объектов синхронизации

Для распределения во всех компонентах (например, из системы R/3 в SAP CRM) или для определенных пользовательских объектов: загрузка объектов синхронизации из целевой системы (путь по меню "Перейти к ® Загрузка списка объектов" на первом экране "Установка параметров распределения настройки: Обзор")

Создание и загрузка объектов синхронизации

При использовании групп синхронизации, которые не были предварительно определены SAP: определение групп синхронизации в редакторе (выберите Перейти к ® Редактор групп синхронизации на первом экране "Установка параметров распределения настройки: Обзор")

Создание группы синхронизации

Рекомендация: при наличии нескольких запросов на перенос в целевом манданте присвойте исходные и целевые запросы на перенос по проекту IMG
(Обработать ® Присвоение запрос на перенос на подробном экране "Установка параметров распределения настройки: Подробные данные")

Присвоение запросов на перенос исходной и целевой системам

Установка параметров распределения настройки: Подробные данные – выбор автоматического распределения или распределения вручную:

Ў Выбор группы синхронизации из справки по допустимым значениям ввода

Ў Выбор исходного проекта IMG релевантных для распределения переносов

Ў Определение вида распределения и исходной системы

Ў Определение целевых систем распределения

При возникновении проблем с автоматическим (управляемым запросами) распределением установите параметры настройки распределения на экране "Распределение настройки: Подробные данные":

Ў Инициируйте распределение переносов вручную (Перейти к ® Распределение настройки: Отдельный перенос) или

Ў Инициируйте повторное распределение в случае неуспешных операций распределения для проекта (Обработать ® Автоматическое повторное распределение после ошибок).

Настройка параметров автоматического распределение настройки

Запуск начального распределения

Распределение отдельных переносов вручную

Автоматическое повторное распределение после ошибок

Анализ журналов распределения настройки
(путь по меню Перейти к ® Распределение настройки на первом экране Установка параметров распределения настройки: Обзор)

Журнал распределения настройки


 Распределение настройки

Распределение настройки

Использование

Часто возникает необходимость в сопоставлении выбранных параметров пользовательской настройки в различных системах в рамках определенной системной среды. Для синхронизации выбранных параметров пользовательской настройки в исходной системе (например, системе R/3) с параметрами пользовательской настройки в целевых системах (например, системе SAP CRM) можно воспользоваться функцией "Распределение настройки".

Система, представляющая собой ссылочную систему для распределения настройки, также упоминается ниже как исходная система. Все другие системы в системной среде называются целевыми и синхронизируются с исходной системой.

Интеграция

Процедура распределения настройки используется для синхронизации пользовательской настройки при внедрении или обновлении системной среды. Прежде чем синхронизировать пользовательскую настройку, можно выполнить сравнение параметров настройки с помощью другого инструментального средства, а именно Customizing Scout.

Предпосылки

Установлены все требуемые параметры системой настройки для распределения настройки. Выполнена проверка того, что структура мэппинга пользовательских идентификаторов не используется в более чем в одном объекте настройки и системе одновременно.

Функциональные возможности

Автоматическое распределение настройки

Компонент "Распределение настройки" позволяет выполнять в отношении параметров пользовательской настройки в среде разработок следующие функции:

· начальная выгрузка из исходной системы в целевую систему (начальное распределение);

· запланированное распределение;

· автоматическое распределение после каждого деблокирования переноса или изменения настройки (из системы R/3 4.6C);

· распределение вручную.

Распределение настройки инициирует процесс переноса параметров настройки в целевые системы. При распределении настройки выполняется запись всех распределенных изменений настройки в запросы на перенос для перемещения соответствующих изменений из систем разработок в системы обеспечения качества и продуктивные системы.

Существует возможность выбора только одного вида распределения для проекта SAP Solution Manager и исходного манданта, т. е. необходимо определить вид выполняемого распределения: распределение по времени или же распределение после деблокирования переноса или изменения настройки. В случае распределения настройки без указания конкретного проекта также допустим только один вид распределения для определенного исходного манданта.

Предварительно определенные объекты для распределения настройки

В системе предварительно определены конкретные объекты настройки, которые должны быть синхронизированы в среде разработок (Объекты синхронизации). Объекты синхронизации и другие объекты настройки для распределения могут быть выбраны с помощью редактора групп синхронизации.

Для получения дополнительной информации о том, какие объекты настройки подлежат распространению, см. раздел Объекты, подлежащие синхронизации настройки.

Просмотр распределения настройки в Руководстве по внедрению

Факт изменения настройки IMG-операций при распределении отражается в системе при помощи пиктограммы в системе компонента "Руководство по внедрению" (IMG). Для вывода этой пиктограмм в IMG системы компонентов должны включать в себя компонент программного обеспечения SAP_BASIS со следующими пакетами поддержки:

Пакеты поддержки базиса, необходимые для вывода пиктограмм в IMG

SAP_BASIS | Пакет поддержки базиса
6.10 | 24
6.20 | 7
6.30 и выше | -

Блокирование релевантных для распределения объектов настройки в целевых системах

Можно автоматически заблокировать объекты настройки или ключевые сферы, которые могут быть изменены при выполнении распределения настройки. Блокируется весь объект настройки целиком. Можно выполнить фильтрацию блокируемых элементов для их ограничения только определенными ключевыми записями, что позволит добавлять различные, например, специфичные для системы, записи в целевую систему.

Допустимо блокирование только стандартных объектов настройки, т. е. объектов типа "Ракурс" (V), "Кластер ракурсов" (C) и "Табличная область с таблицей текстов" (S). Прочие объекты настройки можно блокировать только организационно.

Запись в журнал

После распределения настройки можно просмотреть журналы распределения настройки.


 Объект синхронизации

Объект синхронизации

Определение

Объект настройки в SAP-компоненте, которому присвоен объект настройки с аналогичным содержимым в другом компоненте. Содержимое объектов настройки в различных системах в рамках системной среды должно быть синхронизировано.

Объекты синхронизации создаются в том случае, если объекты настройки в различных системах имеют одно и то же содержимое, но различаются по структуре, например, имеют различные имена таблиц и имена полей.

Использование

Объекты синхронизации являются основанием для сравнения в Customizing Scout, а также для корректировки настройки в распределении настройки. Также возможен выбор отдельных объектов синхронизации для сравнения в Customizing Scout или для корректировки в распределении настройки с помощью редактора групп синхронизации.

Предварительно определенные объекты синхронизации в настоящее время доступны для следующих компонентов SAP:

Компоненты с доступными объектами синхронизации

Целевой компонент | Компонент программного обеспечения | Исходный компонент | Компонент программного обеспечения
SAP CRM | BBPRCRM 3.1, 4.0 | Система R/3 | SAP_APPL 3.1 и выше
SAP HR (отдельная система управления персоналом) | SAP_HR 6.10 | Система R/3 | SAP_APPL 6.10
Система R/3 (отдельная система управления персоналом) | SAP_APPL 6.10 | SAP HR | SAP_HR 6.10
SAP MDM | MDM 2.0, 3.0 | Система R/3, а также пары объектов для SAP CRM и SAP MDM | SAP_APPL 3.1 и выше

При выполнении функций Customizing Scout и "Распределение настройки" сначала осуществляется сбор информации о компонентах системной среды, включая версию (например, SAP CRM 3.1, система R/3 4.0B). Эта информация является важной, поскольку мэппинг объектов настройки из исходного и целевого компонентов является зависящим от времени.

Структура

В простейшем случае объект синхронизации включает один объект настройки в исходном компоненте, который соответствует только одному объекту настройки с тем же самым именем в целевом компоненте. Если объекты не идентичны, в системе должны существовать описания мэппинга этих объектов. Это описание определяет то, какой объект настройки в целевом компоненте соответствует тому или иному объекту настройки в исходном компоненте, т. е. отображение объекта настройки в целевом компоненте на объект настройки в исходном компоненте. Начальной точкой присвоения всегда является объект в целевом компоненте, т. е. сначала определяются таблицы и имена полей объекта в целевом компоненте, и затем они присваиваются именам полей соответствующего объекта в исходном компоненте.

В настоящее время поддерживаются следующие формы мэппинга:

· Без мэппинга (идентичные данные): имена таблиц и имена полей в целевых и исходных компонентах полностью совпадают. В обеих таблицах не обязательно должны присутствовать все поля.

· Различные имена таблиц: в целевом и исходном компоненте имена полей идентичны, тогда как имена таблиц различаются. В обеих таблицах не обязательно должны присутствовать все поля.

· Различные имена таблиц и имена полей: в целевом и исходном компонентах различаются как имена полей, так и имена таблиц. В обеих таблицах не обязательно должны присутствовать все поля.

· Программный мэппинг: присвоение настройки в целевом и исходном компонентах осуществляется согласно функциональным модулям.

В объектах синхронизации CRM_PAYMENTTERMS и CRM_PAYPLAN_CARD часть настройки SAP CRM реализуется посредством кодирования, тогда как соответствующие параметры настройки системы R/3 не содержат кодирования. Для таких объектов данные по настройке системы R/3 определяется на основе настройки SAP CRM при помощи определенного функционального модуля. Функциональный модуль помещает записи, созданные в SAP CRM посредством кодирования, в систему R/3 в качестве виртуальных записей. Поэтому некоторые записи в таблице системы R/3, доступные для просмотра в Customizing Scout, нельзя просмотреть путем непосредственного их вызова.

Интеграция

Объекты синхронизации могут представлять собой объекты настройки следующих типов:

· таблица (табличная область);

· ракурс (V);

· табличная область с таблицей текстов (S);

· кластер ракурсов (C);

· транзакции (T);

· логические объекты переноса (L).

Кластеры ракурсов могут быть развернуты в отдельные ракурсы, а транзакции – в соответствующие таблицы.


 Просмотр определения объекта синхронизации

Просмотр определения объекта синхронизации

Использование

Просмотр определения объекта синхронизации выполняется с целью проверки необходимости использования данного объекта в распределении настройки.

Предпосылки

После вызова транзакции scdt_show_mapping выполнен переход к первому экрану транзакции просмотра объекта синхронизации. При необходимости просмотра объектов синхронизации для SAP CRM 3.1 выполните их выгрузку путем выбора Перейти к ® Загрузка списков объектов.

Последовательность шагов

...

1. Выберите целевой компонент и выполните деблокирование.

Появится список объектов синхронизации.

2. Выберите объект синхронизации.

3. Выберите Просмотреть.

Будет выполнен переход к экрану Просмотр объектов синхронизации.

Результат

На экране появится следующая информация:

· Исходный компонент, как правило, представляет собой систему R/3 (компонент программного обеспечения: SAP_APPL); целевая система работает в среде этого компонента программного обеспечения, например, BBPCRM.

· Каждому объекту синхронизации обычно присваивается IMG-операция.

· Система оригинала для объекта синхронизации представляет собой систему, из которой этот объект был выгружен в систему SAP Solution Manager.

· Для каждого объекта синхронизации определяется следующее:

Ў возможность использования только для сравнения в Customizing Scout (объект, релевантный только для сравнения);

Ў возможность использования как для сравнения в Customizing Scout, так и для распределения настройки (объект, релевантный для сравнения и распределения);

Ў возможность использования только при распределение настройки вручную путем переноса (объект, релевантный только для распределения путем переноса );

Ў возможность использования только для начального распределения (объект, релевантный только для начального распределения);

Ў возможность использования только для начального распределения и сравнения в Customizing Scout.

· Тип мэппинга определяется в области Структурные различия:

Без мэппинга: таблицы имеют идентичные имена таблиц и имена полей.

Различные имена таблиц

Различные имена таблиц и имена полей

Программный мэппинг: преобразование данных настройки исходной системы в данные настройки целевой системы посредством функционального модуля.

· В случае различия имен таблиц или имен полей соответствующие имена таблиц или имена полей содержатсяв таблице Присвоения.

· Наличие у объекта синхронизации ограничений по его использованию при распределении или сравнении (как для исходной системы, так и для целевой системы) в соответствии с условиями фильтрации можно просмотреть в области Условия фильтрации.

· СтолбецФиксированное значение поля/переменная также может содержать фиксированные значения полей или переменные.

Фиксированные значения полей являются необходимыми для таблицы исходного компонента, например, в случае если одна или несколько таблиц в целевом компоненте содержат дополнительные поля, не имеющие соответствующих полей в исходном компоненте. В настоящее время доступны следующие переменные: $LOGSYS, $SYLANGU, $MANDT, $UNAME, $SYDATUM, $SYUZEIT.


 Системные параметры распределения и сравнения настройки

Системные параметры распределения и сравнения настройки

Цель использования

Перед использованием инструмента Распределение настройки или сравнением настроек при помощи Customizing Scout необходимо удовлетворить технические предпосылки для выполнения этих функций во всех задействованных в процессе системах. Далее описывается процесс установки требуемых системных параметров настройки.

Предпосылки

Инсталляция и настройка системной среды

Система SAP Solution Manager была установлена в соответствии с описанием, приведенным в Руководством по инсталляции.

Присвоение полномочий

Системный администратор

Для получения возможности установки параметров распределения настройки системный администратор или руководитель проекта в системах компонентов должны обладать следующими полномочиями:

Полномочия в системах компонентов

Полномочия | Описание | Примечание
S_USER_AUT S_USER_GRP S_USER_PRO | Создание идентификатора пользователя |
S_PROJECT S_PROJECTS | Управление проектом |
S_CTS_ADMI | Управление переносом | Только "Распределение настройки"
S_TRANSPORT | Создание запросов на перенос | Только "Распределение настройки"
S_RFCACL | Соединения вида "Достоверная система" | Только "Распределение настройки"

Системные полномочия в SAP Solution Manager:

Системные полномочия в SAP Solution Manager

Полномочия | Описание | Примечание
S_CD_SYSAC | Системный доступ к сравнениям | Только Customizing Scout
S_CD_SYST | Настройка системной среды |
S_PROJECT S_PROJECTS | Управление проектом |
S_RFCACL | Соединения вида "Достоверная система" | Только "Распределение настройки"

Настройщик

Все настройщики в системах компонентов имеют следующие полномочия:

Полномочия в системах компонентов

Полномочия | Описание | Примечание
S_TABU_CLI S_TABU_DIS | Ведение ракурса |
S_TABU_LIN | Полномочия строк |
S_TABU_RFC | Перенос данных при помощи RFC |
S_BCSETS | Создание и активация пакетов настройки бизнес-конфигурации | Только "Распределение настройки"

Все настройщики в системе SAP Solution Manager имеют следующие полномочия:

Системные полномочия в SAP Solution Manager

Полномочия | Описание | Примечание
S_CD_SYNC | Проверка полномочий на сравнение или распределение |
S_TABU_RFC | Перенос данных при помощи RFC | Только Customizing Scout
S_TABU_DIS S_TABU_CLI | Ведение ракурса |

В системах компонентов также можно использовать профиль полномочий S_CUS_CMP. В случае если в процессе инсталляции SAP Solution Manager обработка этого профиля не выполнялась, следует выполнить его обработку. См. SAP-ноту 492908.

Роль Консультант по приложению обладает всеми полномочиями для настройки параметров функции "Распределение настройки" в системе SAP Solution Manager.

Параметры настройки манданта

Для распределения настройки необходимо автоматическое помещение всех изменений настройки в запрос на перенос. Установите для мандантов систем компонентов статус Автоматическое сохранение изменений при помощи транзакции SCC4. При помощи транзакции SE06 определите для всех мандантов систем компонентов возможность изменения и выполните в транзакции SCC4 настройку для разрешения внесения изменений в общую для всех мандантов настройку.

Выполнение

Проверка статуса пакета поддержки

Для распределения настройки требуется определенный статус пакета поддержки в системах, доступ к которым необходимо осуществить. Проверьте правильность статуса пакета поддержки в соответствующих системах при помощи следующих SAP-нот:

· SAP-нота 552457: Предпосылки для целевых систем распределения настройки;

· SAP-нота 552494: Предпосылки для исходных систем распределения настройки.

Настройка RFC-соединений в транзакции Системная среда

...

1. Проверьте, запланировано ли фоновое задание для автоматического сбора данных всех систем в домене переноса, в транзакции Настройка системной среды (SMSY_SETUP). Следуйте подробным указаниям справки по параметрам настройки технической системной среды.

2. В транзакции Системная среда (SMSY) проверьте, что все требуемые системы были автоматически выбраны. Вручную добавьте другие системы, если это необходимо. Следуйте подробным указаниям справки по системной среде.

3. Если требуется только сравнить параметры настройки, то следует создать RFC-адреса для обеспечения доступа к считыванию данных этих систем и для SAP Solution Manager. При необходимости распространения настроек следует создать RFC-соединения вида Достоверная система для синхронизации настроек. Следуйте подробным указаниям в разделе Создание RFC-адресов в транзакции Системная среда .

4. Система автоматически создает RFC-адреса со следующими именами:

Ў SM_<идентификатор системы> CLNT <мандат>_ READ для чтения данных

Ў SM_<идентификатор системы>CLNT<мандат>_TRUSTED для интерактивного доступа к распределению настроек

Ў SM_<идентификатор системы>CLNT<мандат>_BACK для проверки включенных в проект распределения настроек объектов настройки, которые должны быть блокированы.

Эти адреса вводятся в таблицу scdtsysrfc. Также существует возможность их просмотра и изменения при помощи транзакции ведения RFC-соединений (SM59).

Для автоматического создания RFC-адресов как соединений вида "Достоверная система" или для обеспечения доступа к считыванию в целевых системах должен быть установлен соответствующий статус пакета поддержки. Если статус пакета поддержки целевых систем отличается от требуемого, это указывается в транзакции ведения системной среды.

5. При слишком низком статусе пакета поддержки системы следует либо импортировать требуемые пакеты поддержки и заново создать RFC-соединения, либо добавить требуемые данные в целевые системы, как описано далее в разделе "Создание RFC-соединений вручную".

6. Проверьте, внесены ли RFC-адреса в таблицу scdtsysrfc.

7. Если RFC-адреса были созданы для системы R/3 3.1I или 4.0, введите их в таблицу scdtsysrfc при помощи транзакции SE16 (автоматически эта процедура не выполняется).

Создание RFC-соединений вручную

Шаги, описанные в этом разделе, следует выполнять только в том случае, если автоматически создать все RFC-соединения в транзакции ведения системной среды не удалось.

Соединение "Достоверная система" от системы SAP Solution Manager

RFC-соединения для распределения (SM_< идентификатор системы>CLNT<мандат>_trusted)должны иметь вид "Достоверная система". Измените вид RFC-адресов на Соединение "Достоверная система". Далее выполните действия, описанные в SAP-нотах, посвященных соединениям вида "Достоверная система":

· SAP-нота 0128447;

· SAP-нота 0131387;

· SAP-нота 0204039;

· SAP-нота 0524193.

Соединение "Достоверная система" от исходной системы в распределении настройки к системе SAP Solution Manager

Необходимо создать RFC-соединение от исходной системы к системе SAP Solution Manager. Рекомендуется использовать вид соединения "Достоверная система". В случае стандартных соединений настройка целевой системы и создание журналов осуществляется под именем пользователя данного соединения, что сильно сокращает воспроизводимость. В случае RFC-адресов с экраном входа в систему при каждом изменении настройки потребуется снова выполнять вход в целевую систему.

...

1. Для выяснения имени логической системы SAP Solution Manager выполните транзакцию Ведение манданта (SCC4), откройте таблицу T000 и выберите манданта активной системы SAP Solution Manager.

На следующем экране будет выведено имя логической системы.

2. Перейдите к транзакции SM59 (Ведение RFC-адресов).

3. Создайте RFC-соединение от исходной системы к системе SAP Solution Manager с использованием вида соединения "Достоверная система" и имени логической системы мандата SAP Solution Manager.

RFC-соединение для доступа к считыванию

...

1. Перейдите к целевой системе, доступ к считыванию данных которой требуется получить, с использованием Customizing Scout для сравнения настройки.

2. В транзакции ведения пользователей (SU01) создайте идентификатор пользователя, для которого создается доступ к считыванию данных целевой системы.

3. Присвойте пользователю профиль полномочий S_CUS_CMP. Ознакомьтесь с SAP-нотой 492908 для проверки полноты профиля полномочий и, при необходимости, дополните его.

4. При отсутствии уже созданных RFC-адресов, в транзакции ведения RFC-соединений (SM59) создайте RFC-соединение к системе SAP Solution Manager.

5. Сохраните в этом RFC-адресе имя созданного пользователя и пароль для обеспечения доступа к считыванию данных в системе под именем этого пользователя.

Создание проекта распределения настройки

Выполните следующие шаги, руководствуясь подробными указаниями в справке по Управлению проектом (транзакция solar_project_admin):

...

1. Создайте проект в Управлении проектом.

2. Определите системную среду для этого проекта. Проверьте, что для всех компонентов определены системы разработок.

3. Создайте IMG проекта для всех систем разработок.

Будет выполнен переход к Управлению проектом в системе. Для этого проекта в системах компонентов должны быть созданы переносы, которые также используются в процессе настройки.

4. Создайте для этого проекта запросы на перенос настройки и инструментальных средств.

5. При необходимости распространения изменений настройки после изменения или деблокирования переноса, создайте в запросах на перенос в задействованных системах задачи для всех настройщиков.

6. При необходимости распространения настройки путем начального распределения или синхронизации, создайте в запросах на перенос в задействованных системах задачи для системного администратора (пользователя, выполняющего описываемые операции). При необходимости повторного распределения настройки после устранения ошибок в запросах на перенос в задействованных системах также должна быть создана соответствующая задача.

7. Выберите Назад и сохраните введенные данные в системе SAP Solution Manager.

Загрузка объектов синхронизации для SAP CRM

Если в решении задействована система SAP CRM, то для корректировки структурных различий между системой R/3 и SAP CRM необходимо загрузить объекты синхронизации CRM.

Перейдите в редактор групп синхронизации и загрузите объекты синхронизации, используя путь "Перейти к" ® Загрузка списков объектов.

Результат

Теперь существует возможность сравнения настройки различных систем при помощи Customizing Scout. Также можно выполнить распределение настройки.


 Присвоение запросов на перенос исходным и целевым системам

Присвоение запросов на перенос исходным и целевым системам

Использование

Управляемое переносами распределение с использованием нескольких запросов на перенос в целевой системе требует управляемого присвоения целевых запросов исходным запросам. Это позволяет синхронизировать данные настройки запроса на перенос в исходной системе с запросами на перенос в целевых системах и манданте.

Присвоение применимо только к открытым запросам в исходных и целевых системах; деблокированные запросы присвоению не подлежат.

Для каждой комбинации "система-мандант" может существовать быть одна активная пара присвоения, т. е. один источник и один целевой запрос со статусом "открыто".

Присвоение должно быть специфическим для типа запроса на перенос, т. е. возможно только присвоение запросов на настройку запросам на настройку, либо запросов к инструментальным средствам - запросам к инструментальным средствам. Для распределения общей для всех мандантов настройки требуются запросы к инструментальным средствам.

При необходимости можно присвоить несколько исходных запросов целевому запросу, но не наоборот.

Последовательность шагов

Автоматическое распределение с минимальным вмешательством администратора/пользователя

По умолчанию, т. е. без предварительного присвоения исходных и целевых запросов на перенос, при распределении настройки используется первый открытый целевой запрос, содержащий открытую задачу пользователя. Если такой запрос не найден, то пользователю предлагается создать и присвоить запрос или задачу. Корректный проект предлагается по умолчанию автоматически.

Централизованное присвоение запросов до распределения настройки

Эта опция используется в случае централизованного присвоения запросов на перенос администратором.

Предпосылки:

В случае распределения для определенных проектов соответствующие запросы уже присвоены проектам настройки в исходной и целевой системе.

Для выполнения присвоения для данного пользователя должна существовать, по крайней мере, одна задача в исходном и целевом запросах на перенос.

...

1. Путем двойного щелчка выберите активное распределение в параметрах настройки функции "Распределение настройки".

Выберите Обработать ® Присвоение запросов на перенос.
На экране появятся открытые запросы в исходных и целевых системах для исходных/целевых системи мандантов выбранного проекта, а такжесуществующие присвоения открытых запросов на перенос для данной комбинации "система-мандант".

2. В рамке Запросы в целевой системе выберите целевой запрос для присвоения и переместите его (методом перетаскивания) из пиктограммы папки к запросам в рамке Запросы в исходной системе.

Присвоение запросов пользователем во время распределения настройки

...

1. Если используемый сценарий не позволяет выполнить централизованное присвоение запросов на перенос по организационным причинам, имеется возможность выполнения этого присвоения в ходе распределения настройки; в противном случае это будет выполнено автоматически. Для корректного выбора целевого запроса рекомендуется выбрать опцию Всегда подтверждать целевой запрос на подробном экране распределения настройки по пути Обработать ® Экспертные параметры настройки. Выполнение присвоения запроса осуществляется следующим образом:

2. Опция активна:

Произвольный запрос пользователя, соответствующий произвольной задаче в целевой системе, присваивается автоматически в фоновом режиме. В противном случае, можно выбрать или создать запрос в диалоговом режиме.

3. Опция не активна:

Произвольный запрос пользователя, соответствующий произвольной задаче в целевой системе, присваивается автоматически в фоновом режиме. При отсутствии задачи пользователя в произвольном запросе запрос на перенос может быть выбран в диалоговом режиме. При отсутствии целевого запроса выполняется проверка присвоения пользователя в целевой системе другому открытому запросу, и если это так, то присвоение осуществляется в фоновом режиме. Если при выполнении проверки другой открытый целевой запрос не найден, то можно выбрать другой целевой запрос в диалоговом режиме.

Включение разработок нескольких запросов источника в один целевой запрос

Для выполнения нескольких присвоений следуйте шагам, описанным в разделах "Централизованное присвоение запросов до распределения настройки" или "Присвоение запросов во время распределения настройки".

Результат

Присвоенный запрос появляется в присвоениях запросов на перенос в рамках выбранной опции. Присвоения переносов, выполненные во время распределения настройки, можно просмотреть в обзоре присвоений запросов на перенос.

После сохранения присвоения его отмена или удаление невозможны. В случаенеправильного присвоения запроса допустима перезапись присвоения посредством присвоения нового запроса.


 Распределение настройки

Распределение настройки

Цель использования

Функция "Распределение настройки" позволяет переносить параметры настройки или изменения в настройках из одной системы разработок в другие системы разработок в определенной системной среде. В частности, распределение настройки выполняется в следующих целях:

· выгрузка выбранной настройки из системы R/3 во вновьустановленную систему SAP APO;

· синхронизация настройки в системах с управлением персоналом и системах другого типа с последующим использованием распределения ALE в отдельной системе управления персоналом;

· синхронизация настройки в системе R/3 и системе SAP CRM ввиду наличия бизнес-процессов, выполняемых как в системе R/3, так и в системе SAP CRM.

Предпосылки

Установлены все требуемые параметры системой настройки для распределения настройки.

Выполнение

Подготовка к распределению настройки

...

1. Выберите объекты настройки или IMG-операции, релевантные для распределения настройки. Создайте группусинхронизации в редакторе групп синхронизации. Группа синхронизации включает все объекты настройки, подлежащие распределению из исходного компонента в целевой компонент.

2. Запустите начальное распределение для первоначальной синхронизации выбранной настройки в исходной системе с настройкой в целевых системах. Определите следующее:

Ў группу синхронизации, которая должнабыть активирована для распределения настройки;

Ў исходную систему разработок,

Ў целевую систему разработок.

3. Настройке автоматическое распределение настройки для переноса выбранных изменений настройки из исходной системы в целевые системы. Определите времявыполнения распределения настройки: во времянастройки, после деблокирования переноса или периодически в определенное время.

Автоматическое распределение настройки путем переноса

...

1. В исходной системе в настройку вносятся изменения.

2. Исходная система сообщает об изменениях в систему SAP Solution Manager. В системе SAP Solution Manager выполняется проверка следующего:

Ў принадлежат ли изменения настройки группе синхронизации, для которойраспределение настройки является активным;

Ў в какую целевую систему переносятся изменения.

3. Система SAP Solution Manager преобразовывает данные настройки, подлежащие распределению, в данные настройки для целевой системы.

4. Система SAP Solution Manager выполняет перенос изменений настройки в целевые системы.

5. Функция "Распределение настройки" осуществляет запись изменений, подлежащих переносу в целевые системы, в запросына перенос, посредством которыхновые параметры настройки переносятся в последующие системы по установленному маршруту переноса.

6. Целевые систем сообщают о возникающих ошибках распределения настройки в систему SAP Solution Manager.

7. Для проверки результатов распределения настройки просмотрите журналы распределения настройки в системе SAP Solution Manager.

8. Сравните настройку в различных системах с помощью Customizing Scout для проверки того, что в ходе выполнения распределения настройки данные были синхронизированы.

Результат

В системах разработок выполнено распределение настройки. Для последующего переноса данных в систему обеспечения качества и продуктивную систему необходимо деблокировать соответствующие запросы на перенос. Таким образом, обеспечивается синхронизация пользовательской настройки во всех последующих системах, а не только в системе разработок.

Можно в любой момент изменить или скопировать распределение настройки посредством меню. После копирования возможно изменение, например, опций распределения или проекта распределения.


 Редактор групп синхронизации

Редактор групп синхронизации

Использование

Редактор позволяет определить группы объектов настройки (группы синхронизации), для которых должны быть выполнены корректировка с помощью распределения настройки или сравнение с помощью Customizing Scout.

Предпосылки

Для получения возможности работы с редактором групп синхронизации необходимо наличие полномочий для объекта полномочий s_cd_sync. Необходимы операция 3 для вызова и операция 2 для изменений (для системных ролей "Разработка/Настройка", т. е. scdtsysrol = "c").

Функциональные возможности

Редактор предоставляет следующие возможности:

· создание,

· обработка,

· копирование;

· удаление и

· перенос групп синхронизации.

Группа синхронизации может включать следующие объекты:

· Объекты настройки, которые определены в системе как релевантные для синхронизации для компонента программного обеспечения (объекты синхронизации);

Система содержит информацию о том, какие объекты настройки в системе R/3 соответствуют этим объектам синхронизации (мэппинг).

· Объекты настройки, выбираемые посредством IMG-операции;

· Объекты настройки, для которых название объекта и тип вводится вручную;

· Другие группы синхронизации.

Для группы синхронизации можно выбрать объекты настройки следующих типов: V(ракурс), S (табличная областьс таблицей текстов), Т (транзакция) или С (кластер ракурсов). Система разворачивает кластеры ракурсов в отдельные ракурсы, а объектытипа T и L - в соответствующие им базовые таблицы.

При выборе объектов настройки система выполняет проверку существования этих объектов в руководстве по внедрению (IMG) исходных и целевых систем и предоставляет обзор любых объектов, которые не удалось включить в группу синхронизации. Также возможно предварительное выполнение проверки того, какие объекты настройки или IMG-операции могут использоваться в распределении настройки. См. примечания в пункте Ограничения в разделе Синхронизация настройки.

Для конкретной группы синхронизации также можно определить условия фильтрации. В этом случае определяется необходимость учета записей таблицы только в Customizing Scout или в распределении настройки в случае, если указанные поля удовлетворяют определенным условиям. Кроме того, в группу синхронизации можно включить таблицы клиентов. Следует либо включить эти таблицы в таблицу SOBJ (транзакция sobj), либо создать таблицы клиентов как объекты синхронизации с соответствующим мэппингом.


 Группа синхронизации для отдельных систем управления персоналом

Группа синхронизации для отдельных систем управления персоналом

Определение

Ряд объектов настройки, предварительно определенных SAP, которые должны быть синхронизированы в системной среде, включая SAP-системы управления персоналом и системы другого типа.

Использование

Группы синхронизации для SAP HR могут использоваться в "отдельной системе управления персоналом" (т. е. в обычной ситуации, когда требуется использовать одну систему R/3 в качестве системы управления персоналом и еще одну систему R/3 в качестве системы другого типа). "Отдельная система управления персоналом" с одним компонентом HR и одной системой другого типа подразделяется на сценарии, из которых клиенты могут выбрать подходящие им варианты. Для каждого сценария существует одна или две группы синхронизации, предварительно определенные SAP.

Структура

Группа синхронизации включает предварительно определенные объекты синхронизации для компонентов программного обеспечения SAP_HR и SAP_APPL. Каждый объект синхронизации соответствует таблице настройки в системе R/3, которая должна быть синхронизирована для одного или нескольких сценариев в системе управления персоналом и системе другого типа в целях корректной интерпретации данных, тиражируемых посредством ALE.

Существуют различные типы групп синхронизации:

Группы синхронизации HRCA-Kapseln и HR-ALE-Grundtabellen содержат основные параметры настройки для направления синхронизации. Распределение ALEосновано на базовых таблицах, которые должны быть синхронизированы независимо от используемых сценариев. Эти две группы синхронизации находятся в шаблоне COPY_FOR_USE (для распределения в системы управления персоналом из систем другого типа) и COPY_FOR_USE_A (для распределения из систем управления персоналом в системы другого типа). Возможно копирование групп в собственную область имен (с последующей обработкой в этой области), после этого можно методом перетаскивания скопировать туда группы для сценариев.

Некоторые сценарии отдельных систем управления персоналом требуют определенных инфо-типов. Для этой цели используются инфо-типы групп синхронизации, начинающиеся с IT. Группа синхронизации IT <nnnn> принадлежит инфо-типу <nnnn>. Эти группы синхронизации являются подгруппами групп синхронизации сценария.

Имеется также три группы синхронизации для типов сообщений:

· COAMAS (настройка для тиражирования видов операций);

· COELEM (настройка для тиражирования видов затрат);

· COELEM (настройка для тиражирования мест возникновения затрат).

Эти группы синхронизации уже принадлежат группам синхронизации сценария ALE, для которых необходимо тиражирование основных данных.

См. также:

Обзор сценариев интеграции ALE

IMG-документация для ALE-IMG: транзакция SALE, путь IMG: Моделирование и внедрение бизнес-процессов ® Конфигурация предварительно определенных бизнес-процессов ALE ® Персонал ® Управление персоналом <-> LO или HR <-> AC, а также Моделирование и внедрение бизнес-процессов ® Конфигурация предварительно определенных бизнес-процессов ALE ® Автонастройка.


 Использование групп синхронизации для отдельных систем управления персоналом

Использование групп синхронизации для отдельных систем управления персоналом

Цель использования

Этот процесс предназначен для сравнения и синхронизации настройки в "отдельной системе управления персоналом" (одна система управления персоналом и одна система другого типа) с использованием групп синхронизации, предварительно определенных SAP. Отдельная система управления персоналом подразделяется на различные сценарии ALE. Для каждого из этих сценариев можно использовать одну или несколько групп синхронизации. При использовании этих групп синхронизации не требуется вручную выполнять поиск и определение объектов настройки, необходимых для различных ALE-сценариев.

Этот процесс применим в стандартной ситуации, т.е. при наличии одной системы управления персоналом и одной системы другого типа. В случае другой системной среды необходимо создать соответствующие группы синхронизации с помощью редактора групп синхронизации.

Предпосылки

Проведена проверка сценариев, используемых для отдельной системы управления персоналом. Эта операция выполняется с помощью тестового отчета в руководстве по внедрению ALE (ALE IMG), доступного по пути по меню Моделирование и внедрение бизнес-процессов ® Конфигурация предварительно определенных бизнес-процессов ALE ® Автонастройка, в котором представлена информация о том, какие параметры настройки являются активными в IMG, и какие интерфейсы в настоящее время используются.

Выполнение

...

1. Запустите редактор групп синхронизации.

В редакторе можно просмотреть все предварительно определенные группы синхронизации SAP.

2. Выберите группы синхронизации COPY_FOR_USE и COPY_FOR_USE_A и скопируйте их.

Группы синхронизации копируются системой в область имен клиента. Эти копии можно обработать. Обе группы синхронизации уже содержат объекты синхронизации для общих параметров настройки.

3. Выберите предварительно определенные группы синхронизации, соответствующие реализованным интерфейсам.

Группы синхронизации имеют те же имена, что и соответствующие интерфейсы, указанные в IMG для ALE.

4. Переместите (методом перетаскивания) выбранные группы синхронизации в область групп синхронизации, созданных в шаге 2, с учетом направления синхронизации.

Результат

Группу синхронизации можно использовать для сравнения настройки в системе управления персоналом и системе другого типа с помощью Customizing Scout или для распределения с помощью функции Распределение настройки.


 Создание группы синхронизации

Создание группы синхронизации

Использование

Группа синхронизации содержит набор объектов настройки, имеющихся в двух системах и подлежащие сравнению при помощи Customizing Scout или синхронизации в системной среде с помощью функции распределения настройки.

Предпосылки

Установлены все требуемые параметры системой настройки для распределения настройки. Выполнен переход к параметрам настройки функции "Распределение настройки".

Последовательность шагов

Создание группы синхронизации

...

Вызовите редактор групп синхронизации путем выбора Перейти к ® Редактор групп синхронизации.

Для вызова редактора также может использоваться путь по меню SAP Инструменты ® Пользовательская настройка ® Распределение ® Группы синхронизации.

1. Выберите Создать.

2. В диалоговом окне введите техническое имя в собственной области имен, исходный и целевой компонент и краткий текст описания.

После создания группы синхронизации присвойте ее соответствующим исходному и целевому компонентам. Исходная система, настройку которой требуется распределить, должна содержать компоненты программного обеспечения, определенные в области исходного компонента. Целевые системы, в которые требуется распределить настройку, также должны содержать компоненты программного обеспечения, определенные в области целевого компонента.

В справке по допустимым значениям ввода для исходного и целевого компонентов можно просмотреть все компоненты программного обеспечения, присутствующие в системной среде.

3. В диалоговом окне укажите исходную и целевую систему.

Редактор групп синхронизации обращается к руководствам по внедрению (IMG) этих систем.

4. Если в диалоговом окне установлен индикатор отсутствия существующих объектов синхронизации, загрузите эти объекты путем нажатия экранной кнопки Загрузка списка объектов.

5. При необходимости ограничения выбора объекта из соответствующего IMG SAP одним IMG проекта, установите флаг Выбор проекта из IMG проекта и выберите проект настройки с тем же самым именем в списке проектов SAP Solution Manager (при наличии такого списка) или определите проект настройки вручную, если этот список отсутствует.

6. Выберите Дальше.

7. В следующем диалоговом окне определите пакет и нажмите кнопку Сохранить.

В правой области окна появится новая группа синхронизации. Теперь в группу синхронизации можно поместить объекты.

Вставка объектов настройки на основе операций IMG

...

1. Выберите группу синхронизации из списка в левой части окна с помощью двойного щелчка.

2. Перейдите к режиму обработки группы синхронизации.

3. Щелкните по группе синхронизации правой кнопкой мыши.

4. В контекстном меню выберите Вставить объекты из целевого IMG или Вставить объекты из исходного IMG. Если при создании групп синхронизации был установлен флажок Выбор проекта из IMG проекта, выбор операций IMG ограничен IMG проекта.

5. При появлении экрана входа в систему введите имя пользователя и пароль для исходной или целевой системы.

Появится диалоговое окно с IMG исходной или целевой системы.

6. Отметьте одну или несколько операций IMG и выберите Дальше.

Система проверяет, имеют ли операции IMG объекты синхронизации, и при их наличии заменяет простые объекты настройки объектами синхронизации.

7. Подтвердите системное сообщение о том, что объекты настройки были заменены объектами синхронизации.

Система проверяет, имеются ли объекты настройки в руководствах по внедрению исходной и целевой систем и при их отсутствии выдает соответствующее сообщение.

Объекты настройки, не отвечающие условиям проверки, выводятся в диалоговом окне и не помещаются в группу синхронизации.

8. Выберите Дальше.

9. Сохраните введенные данные.

Поиск и вставка объектов настройки по техническому имени

...

1. Выберите группу синхронизации из списка в левой части окна с помощью двойного щелчка.

2. Перейдите к режиму обработки группы синхронизации.

3. Щелкните по группе синхронизации правой кнопкой мыши.

4. В контекстном меню выберите Вставить объект настройки из целевой системы.

5. Появятся первые 500 объектов настройки в целевой системе в алфавитном порядке.

6. Для поиска других объектов настройки щелкните по пункту Ограничения правой кнопкой мыши и выполните поиск требуемых объектов. Можно также выполнить поиск объектов клиентов, если они присутствуют в таблице SOBJ.

7. Выберите Дальше.

Система проверяет, имеются ли объекты настройки в руководствах по внедрению исходной и целевой систем и при их отсутствии выдает соответствующее сообщение.

Объекты настройки, не отвечающие условиям проверки, выводятся в диалоговом окне и не помещаются в группу синхронизации.

8. Выберите Дальше.

9. Сохраните введенные данные.

Помещение объектов синхронизации в группу синхронизации

...

1. В списке в правой части окна выберите группу синхронизации с помощью двойного щелчка.

2. Перейдите к режиму обработки группы синхронизации.

3. Щелкните по группе синхронизации правой кнопкой мыши.

4. В контекстном меню выберите Вставить объекты синхронизации <версия целевого компонента>.

Появится диалоговое окно со всеми объектами синхронизации, определенными SAP-системой для целевого компонента, и версиями. В нем также выводятся описания операций IMG в объектах синхронизации.

Для получения более подробной информации о просмотре объектов синхронизации выберите Перейти к ® Просмотр объектов синхронизации.

5. Отметьте объект синхронизации и выберите Скопировать.

6. Сохраните введенные данные.

Результат

В правой области окна появится список всех объектов, помещенных в группу синхронизации. В столбце Тип указывается, является ли данный объект объектом синхронизации, предварительно определенным SAP (в этом случае также выводятся данные мэппинга таблицы и имен полей), или простым объектом настройки. В этом списке также можно просмотреть ракурсы, входящие в кластеры ракурсов, и таблицы, относящиеся к объектам настройки типов T или L. В столбце Описание отображается краткий текст описания операции IMG.

Теперь имеются следующие возможности:

· Вставьте существующие группы синхронизации в группу синхронизации пользователя в качестве подгрупп методом перетаскивания.

· Измените структуру группы синхронизации путем перемещения объектов методом перетаскивания.

Изменение группы синхронизации затрагивает все области, в которых она используется.

· Выполните фиксацию группы синхронизации путем выбора Группа синхронизации ® Документация к изменению.

· Определите для группы синхронизации условия фильтрации или импортируйте фильтры CRM.

Впоследствии также можно выполнить поиск и удаление тех объектов настройки в группе синхронизации, которые отсутствуют в исходной и целевой системах, путем выбора Обработать ® Проверка. Можно также удалить из группы синхронизации все объекты настройки, не предназначенные для распределения настройки, путем выбора Обработать ® Удаление несовместимых с пакетом настройки БК объектов.


 Определение условий фильтрации

Определение условий фильтрации

Использование

Если для сравнения или распределения настройки требуется использовать лишь отдельные столбцы таблицы, для группы синхронизации или объекта настройки можно определить условия фильтрации. Поля в этих столбцах таблицы должны удовлетворять этим условиям фильтрации.

Предпосылки

Выбрана группа синхронизации для обработки.

Последовательность шагов

...

1. Отметьте корневой узел группы синхронизации или объект настройки с помощью правой кнопки мыши.

2. В контекстном меню выберите Условия фильтрации.

Появится диалоговое окно.

3. Если была выбрана вся группа, введите объект настройки, для которого требуется определить условия фильтрации, в столбце Объект настройки в диалоговом окне.

4. Введите поля, для которых требуется определить условия фильтрации, в столбце Имя поля.

5. Выберите оператор. Примечания:

Ў Образец: все символы в поле должны соответствовать шаблону. Допускаются символы-заменители '_' (один символ) и '%' (любое число символов).

Ў равно, не равно, меньше чем, больше чем, между, меньше нижней границы, больше верхней границы, в соответствии с последовательностью знаков в таблице ASCII. В качестве констант указывайте только значения типов символ (char) и целое число (int).

6. Определите одну или две константы для каждого оператора так, как требуется.

7. Сохраните введенные данные.


 Импорт фильтра CRM

Импорт фильтра CRM

Использование

SAP поставляет для SAP CRM предварительно определенные условия фильтрации. Они ограничивают объекты настройки системы R/3 определенными записями таблицы, которые должны распределяться в систему SAP CRM. Ограничение по записям таблиц вместо использования целых таблиц предотвращает импорт ненужных данных из системы R/3 в систему SAP CRM и повышает эффективность распределения настройки. Изначально имеются предварительно определенные условия фильтрации для записей таблиц, которые необходимо синхронизировать в системах R/3 и SAP CRM 3.1.

В системе SAP CRM можно также определить собственные условия фильтрации. В меню SAP выберите Промежуточное ПО ® Обмен данными ® Управление объектами ® Объекты настройки. Эти условия фильтрации можно также импортировать и использовать в SAP Solution Manager. Более подробную информацию об определении условий фильтрации в SAP CRM см. в справке по приложению Объекты настройки.

Предпосылки

Выполнены предпосылки для использования редактора групп синхронизации. В частности, в редакторе групп синхронизации выбрана системная среда, содержащая систему SAP CRM 3.1 и систему R/3.

Выполнен переход к первому экрану редактора.

Последовательность шагов

...

1. Выберите для обработки группу синхронизации, для которой требуется использовать фильтр CRM.

2. Выберите Обработать ® Фильтр ® Импорт фильтра CRM.

Результат

Для группы синхронизации определен фильтр CRM. Для просмотра и обработки условий фильтрации CRM выберите путь по меню Обработать ® Фильтр ® Условия фильтрации. Появятся условия фильтрации с индикатором Импортировано.


 Журналы распределения настройки

Журналы распределения настройки

Использование

Журналы распределения настройки предоставляют обзор успешно выполненных и не выполненных распределений настройки. Эта функция позволяет выяснить причины ошибок в неуспешно выполненных распределениях настройки и повторно запустить распределение настройки вручную.

Функциональные возможности

Имеется возможность проверки всех журналов распределения настройки и трассировки операций по этим журналам. Можно просмотреть следующее:

· Журналы распределения настройки с системными сообщениями для этого распределения

· Пакеты настройки бизнес-конфигурации, активированные для данного распределения настройки

· Журналы активации пакета настройки бизнес-конфигурации

· Журналы релевантных для распределения процедур системе SAP Solution Manager (Просмотр трассировки).

Поиск журналов можно выполнять по следующим критериям:

· Проект;

· Целевая система;

· Использованные целевые запросы на перенос (на первом экране журналов в меню Перейти к ® Использованные целевые запросы на перенос);

· Запрос на перенос или начальное распределение;

· Периоды времени;

· Пользователь.

Можно также выполнить следующие действия:

· Перезапуск неуспешно выполненных распределений настройки;

· Проверка RFC-адресов;

· Переход к просмотру подробных данных по следующим элементам: группа синхронизации, запрос на перенос, проект, системная среда;

· Анализы распределения настройки: поиск объектов настройки, запросов на перенос и их журналов.


 Просмотр трассировки входящих запросов на распределение

Просмотр трассировки входящих запросов на распределение

Использование

Функция "Просмотр трассировки" позволяет просмотреть все зафиксированные в журналах процедуры в системе, которые были вызваны в ходе распределения настройки. Эта функция позволяет провести анализ ошибок в случае неуспешного распределения настройки.

Для упрощения поиска ошибок предусмотрены различные функции анализа распределения настройки.

Интеграция

Функцией трассировки регистрируются все процедуры, вызываемые в ходе распределения настройки в системе SAP Solution Manager.

Функциональные возможности

Функция "Просмотр трассировки" позволяет выполнять следующее:

· просмотр всех полученных запросов на распределение в системе SAP Solution Manager;

Запросы на распределение создаются в случае изменения настройки в исходной системе и внесения соответствующей записи в запрос на перенос. Система SAP Solution Manager проверяет действительность этих изменений настройки для целевых систем в проекте.

· просмотр журналов распределения настройки, созданных для запроса на перенос в исходной системе;

· просмотр исходных запросов на перенос в распределении настройки.

При просмотре трассировки доступны следующие данные:

· запрос на перенос;

· исходная система распределения настройки;

· время запроса на распределение;

· автор запроса на распределение;

· количество измененных объектов настройки;

· количество целевых систем, в которые объекты настройки были или должны быть распределены;

· последняя операция распределения настройки или сообщение об ошибке.

Операции

...

...

1. Запустите просмотр трассировки путем выбора Перейти к ® Просмотр трассировки в меню журнала распределения настройки.

2. Найдите на появившемся экране запрос на перенос, распределение настройки по которому требуется проверить.

3. Проверьте, отмечена ли данная операция распределения настройки как успешно выполненная.

4. Если для этого запроса на перенос имеется журнал, дважды щелкните по нему.

5. Если журнал отсутствует, просмотрите последнюю операцию в системе или сообщение об ошибке в обзоре и проверьте возможные причины ошибки.

Отсутствие журнала означает, что настройка не была распределена. Причиной этого может быть следующее:

Настройка в исходной системе была изменена, но изменение не является релевантным для распределения, например, из-за того, что объекты настройки не входят ни в одну группу синхронизации.

Не найдена целевая система для распределения настройки.


 Анализ распределения настройки

Анализ распределения настройки

Использование

Эти функции используются для поиска отдельных объектов настройки или запросов на перенос в параметрах настройки функции "Распределение настройки" или журналах, а также для просмотра их журналов. Это часто требуется в случае возникновении ошибок в распределении настройки. Такой анализ можно выполнить с целью трассировки маршрута для отдельных распределений и поиска причин ошибок.

Предпосылки

Установлены все параметры распределения настройки. Выполнен переход к первому экрану выбора журнала распределения настройки.

Функциональные возможности

Просмотр всех активных объектов

Путем выбора Перейти к ® Просмотр всех активных объектов можно просмотреть список всех объектов, для которых распределение настройки является активным.

Можно просмотреть следующее:

· определение связанных объектов синхронизации;

· связанная группа синхронизации в редакторе групп синхронизации;

· связанный проект в Управлении проектом.

Этот список также можно вызвать из параметров настройки функции "Распределение настройки".

Просмотр использованных запросов на перенос

Путем выбора Перейти к ® Использованные запросы на перенос можно просмотреть список всех запросов на перенос, использованных в распределении настройки. С помощью опций фильтрации и сортировки можно, например, определить следующее:

· какой запрос на перенос исходной системы послужил источником содержимого для запроса на перенос целевой системы;

· в какой запрос на перенос целевой системы поступило содержимое запроса на перенос исходной системы.

Можно просмотреть следующее:

· все журналы к целевому запросу;

· целевой или исходный запрос на перенос в системе переноса;

· данные проекта в Управлении проектом для связанного проекта SAP Solution Manager.

Просмотр распределенных объектов

Путем выбора Перейти к ® Распределенные объекты можно просмотреть список всех объектов, распределенных в системной среде в результате распределения настройки. Выводимые данные изначально фильтруются по периоду, указанному на первом экране журнала распределения настройки. Имеются следующие возможности:

· сортировка выведенных данных и фильтрация по другим периодам времени;

· просмотр подробной технической информации по объекту синхронизации;

· выполнение перехода непосредственно к операции IMG для объекта (в исходной или целевой системе);

· просмотр связанного исходного запроса на перенос;

· просмотр всех журналов для выбранного объекта за выбранный период времени.

На экран выводятся все журналы данного объекта и все журналы, распределенные по данному объекту (для сравнения), поэтому просмотр может включать и те журналы, в которых выбранный объект отсутствует.


 Автоматическое повторное распределение после ошибок

Автоматическое повторное распределение после ошибок

Использование

Эта функция используется для автоматического повторного запуска неуспешно выполненных операций распределения настройки в фоновом режиме.

Предпосылки

В запросах на перенос участвующих в процессе систем имеется соответствующая задача.

Функциональные возможности

После планирования повторного распределения выполняется сбор всех тех операций распределения настройки для проекта, которые:

· содержат ошибки;

· были сторнированы.

Успешно выполненные операции повторного распределения настройки исключаются из процесса. Эти операции распределения выполняются повторно в указанные пользователем моменты времени. Можно запланировать периодическое выполнение повторного распределения в фоновом режиме.

Операции

...

1. Вызовите транзакцию Параметры распределения настройки.

2. Выберите активную группу синхронизации и соответствующий ей проект, затем выберите Просмотреть или Обработать.

3. Выберите в меню Обработать ® Автоматическое повторное распределение после ошибок.

4. Введите данные планирования фонового задания.

Система планирует фоновое задание DISTR. CORRECTION <имя проекта>.

5. По проекту будет выполнено повторное распределение в соответствии с указанными параметрами.


 Просмотр журналов распределения настройки

Просмотр журналов распределения настройки

Использование

В системной среде было выполнено распределение настройки, после чего необходимо проверить, было ли распределение выполнено успешно, с помощью журналов.

Предпосылки

Выполнен переход к параметрам настройки функции "Распределение настройки".

Последовательность шагов

Выбор журналов

...

...

1. Выберите Перейти к ® Журналы распределения или вызовите транзакцию scdt_log.

Появится диалоговый экран Выбор журналов распределения настройки.

2. Выбор журналов можно ограничить одним или несколькими условиями выбора.

3. Можно установить флаг просмотра только журналов, созданных после последнего выполненного распределения.

Этот флаг следует установить. После успешного и полного выполнения распределения запроса на перенос предыдущие журналы, как правило, становятся устаревшими. Общий статус распределения в структуре обзора журналов отражает наихудший отдельный результат среди всех выведенных для просмотра журналов.Если в списке присутствуют устаревшие журналы, они влияют на общий статус распределения в обзоре журналов. Поэтому общим статусом может оказаться "ошибка", несмотря на то, что все объекты были успешно распределены при более позднем распределении.

4. Выберите Просмотр журналов по выбору или Просмотр только журналов с ошибками.

Появится список всех журналов по выбору.

Если установлен соответствующий флажок, при следующем обращении к журналам диалоговый экран Выбор журналов распределения настройки может быть пропущен. Впоследствии можно вновь изменить параметры настройки путем выбора Обработать ® Опции.

Просмотр журнала

...

1. Для поиска отдельных журналов по определенной дате выполните навигацию по структуре в левой области окна.

2. Дважды щелкните по дате в левой области окна.

В правой области окна появятся все сообщения, содержащиеся в журнале.

3. Выполните следующие действия:

Ў Для просмотра подробного текста сообщения щелкните по вопросительному знаку рядом с сообщением.

Журналы распределения настройки, не присвоенные проектам, отмечаются символом *.

Ў Для просмотра журналов для всех целевых систем, в которые была распределена настройка в запросе на перенос или при начальном распределении, выберите Просмотр связанных журналов.

Ў Для просмотра журналов активации пакета настройки бизнес-конфигурации, активированного для распределения настройки, выберите Просмотр журнала активации пакета настройки БК.

Перезагрузка журнала

· Для перезагрузки одного журнала выделите его и нажмите кнопку Перезагрузка журнала .

· Для просмотра журналов, созданных за время просмотра, выберите Загрузка новых журналов.

При загрузке новых журналов ранее выведенные на экран журналы не обновляются, даже если они были изменены.

· Для перезагрузки всех журналов и загрузки дополнительных журналов выберите Обновить все.

Результат

Выполнен просмотр журналов. Теперь имеются следующие возможности:

· повторное распределение настройки вручную для запроса на перенос;

· удаление нескольких журналов путем выбора Перейти к ® Удаление журналов.


 Удаление журналов распределения настройки

Удаление журналов распределения настройки

Использование

Удаление устаревших журналов выполняется с целью обеспечения лучшего обзора текущих журналов при просмотре журналов. К устаревшим журналам относятся все журналы, для которых существуют более новые журналы следующих видов:

· в более новом журнале указано, что связанная группа синхронизации была успешно распределена при начальном распределении.

· в более новом журнале указано, что распределение настройки было полностью и успешно выполнено в запросе на перенос (полностью путем деблокирования переноса или путем полного распределения по запросу на перенос вручную).

Неустаревшие журналы можно удалять по одному на экране просмотра журналов.

Предпосылки

Наличие полномочий для объекта полномочий S_APPL_LOG со следующими значениями полей: Объект = cust_sync, Подобъект = distrib, Операция = 6(Удаление).

Выполнен переход к первому экрану выбора журнала распределения настройки.

Последовательность шагов

...

...

1. Выберите Перейти к ® Удаление журналов или вызовите транзакцию SCDT_LOG_DELETE.

2. Выбор журналов можно ограничить одним или несколькими условиями выбора.

3. Выберите Немедленное удаление журналов или Создание списка выбора .

ФункцияНемедленное удаление журналов используется для удаления всех устаревших журналов, соответствующих критериям выбора.

Функция Создание списка выбора позволяет просмотреть все устаревшие журналы, соответствующие критериям выбора.

4. После выбора функции Создание списка выбора отметьте журналы, которые требуется удалить, и выберите Удалить выбранные журналы.

5. Подтвердите запрос.


 Настройка параметров автоматического распределения настройки

Настройка параметров автоматического распределения настройки

Использование

Требуется отметить группу синхронизации в SAP Solution Manager как подлежащую распределению настройки. Таким образом обеспечивается распространение всех изменений, вносимых в настройку исходной системы, на целевые системы.

При необходимости предварительного согласования настройки в исходной системе с настройкой в целевых системах перед распределением изменений настройки выполните начальное распределение.

Предпосылки

Установлены все требуемые системные параметры настройки для распределения настройки. При необходимости распределения настройки в проекте с помощью SAP Solution Manager, следует выполнить настройку для проекта системной среды в Управлении проектом. В системе распределение настройки поддерживается для проектов внедрения в SAP Solution Manager.

При необходимости ограничения распределения настройки определенными объектами настройки следует создать группу синхронизации в редакторе групп синхронизации. Группа синхронизации представляет собой группу объектов настройки, которые должны быть синхронизированы. Если группа синхронизации не определена, для распределения настройки определяется набор объектов настройки, предварительно определенных SAP, которые должны быть синхронизированы для компонентов в системной среде данного проекта (объекты синхронизации).

В случае установки параметров для нового распределения можно перейти к редактору групп синхронизации или ведению системной среды с помощью двойного щелчка по группе синхронизации или системам.

Последовательность шагов

...

1. Выберите Инструменты ® Пользовательская настройка ® Распределение ® Параметры распределения настройки в меню SAP или вызовите транзакцию scdt_setup.

Появятся все группы синхронизации, для которых было установлено распределение настройки, и соответствующие им проекты.

2. Выберите Создать.

Появится диалоговый экран, на котором можно ввести данные распределения настройки.

3. При необходимости ограничения распределения определенными объектами определите группу синхронизации.

В случае отсутствия группы распределения выполняется распределение всех объектов, предварительно определенных SAP как объекты синхронизации.

4. Определите следующее:

Ў следует ли выполнить распределение по всем запросам на перенос, созданным для проектов SAP Solution Manager в исходной системе;

Ў следует ли выполнить распределение только по запросам на перенос для конкретного проекта SAP Solution Manager (в этом случае необходимо указать имя проекта).

5. Выберите вид распределения:

Ў Запланированное распределение: распределение настройки планируется как фоновое задание CUSTOMIZING DIST. для <имя проекта>, выполняемое в указанное пользователем время.

Ў Синхронизация по деблокированию переноса: при каждом деблокировании запроса на перенос, относящегося к данному проекту, выполняется распределение соответствующей настройки.

Ў Синхронизация по изменениям переносов: при каждом деблокировании или изменении запроса на перенос, относящегося к данному проекту, выполняется распределение соответствующей настройки.

6. В поле Исходная система определите логическую систему, из которой необходимо распределить настройку в другие системы.

После указания логической системы в SAP Solution Manager на экране автоматически появятся система, мандант, RFC-адрес, версия базиса и пакет поддержки. Система проверяет, достаточна ли версия и статус пакета поддержки для выбранного вида распределения, и если это не так, переходит к выполнению запланированного распределения.

7. Введите целевые логические системы в таблицу Целевые системы.

Логические системы, созданные для данного проекта в Управлении проектом в SAP Solution Manager, включены в справку по допустимым значениям ввода.

Для тестирования RFC-адресов, установленных в системной среде для распределения настройки, выберите путь по меню Перейти к ® Тестирование RFC-адресов.

8. При необходимости запрета изменений в настройке целевой системы после выполнения распределения настройки установите флаг Блокирование обработки в целевой системе.

9. Сохраните введенные данные.

Результат

Выполняется проверка следующих условий:

· все выбранные системы существуют и доступны;

· объекты в группе синхронизации являются релевантными для распределения настройки;

· требуемые RFC-соединения существуют;

· настройка для этого проекта и исходной системы уже распределена через другую центральную систему.

При положительных результатах проверки все изменения объектов настройки в группе синхронизации распространяются из исходной системы в целевые системы (только системы разработок) посредством распределения настройки. Теперь эти изменения можно переместить настройки в системы обеспечения качества и продуктивные системы путем деблокирования соответствующих запросов на перенос.


 Начальное распределение

Начальное распределение

Использование

Начальное распределение выполняет однократный перенос настройки из исходной системы в целевые системы.

Настройка записывается в таблицы целевой системы без проверки внешнего ключа.

Предпосылки

Удовлетворение необходимых условий для настройки параметров автоматического распределения настройки.

Последовательность шагов

...

1. Выберите Инструменты ® Пользовательская настройка ® Распределение ® Параметры распределения настройки в меню SAP или вызовите транзакцию scdt_setup.

Появятся все группы синхронизации, отмеченные для распределения настройки, и соответствующие им проекты и исходные системы.

2. Выберите Создать.

Появится диалоговый экран, на котором можно ввести данные распределения настройки.

3. При необходимости ограничения распределения определенными объектами определите группу синхронизации.

В случае отсутствия группы распределения выполняется распределение всех объектов, предварительно определенных SAP как объекты синхронизации.

4. Выберите Вид распределения: без автоматического распределения.

5. В поле Исходная система определите логическую систему, из которой необходимо распределить настройку в другие системы.

6. Введите целевые логические системы в таблицу Целевые системы.

Логические системы, созданные для данного проекта в Управлении проектом в SAP Solution Manager, включены в справку по допустимым значениям ввода.

7. Нажмите экранную кнопку Начальное распределение.

Результат

Данные переносятся из исходной системы в целевые системы. Теперь можно деблокировать соответствующие запросы на перенос и передать данные, например, в систему обеспечения качества.

При начальном распределении вводимые пользователем данные не сохраняются, однако непосредственно после начального распределения можно настроить параметры автоматического распределения настройки и выполнить сохранение с целью распространения всех изменений объектов настройки в исходной системе на целевые системы.


 Распределение отдельных переносов вручную

Распределение отдельных переносов вручную

Использование

После изменения настройки в исходной системе требуется выполнить ее автоматическое и одновременное распространение во все целевые системы при помощи отдельной операции переноса.

Предпосылки

Установлены все требуемые системные параметры настройки для распределения настройки. В запросах на перенос участвующих в процессе систем имеется соответствующая задача.

Выполнен переход к параметрам настройки функции "Распределение настройки".

Последовательность шагов

...

1. Выберите Перейти к ® Распределение переноса вручную или вызовите транзакцию scdt_fetch.

Распределение настройки вручную также можно выполнить из экрана журнала распределения настройки.

2. Введите задачу запроса на перенос, содержащую те изменения настройки, которые требуется распределить.

3. Введите проект для этого запроса на перенос.

Из проекта для системы извлекается информация о системной среде, в которую необходимо распределить настройку, и соответствующие запросы на перенос в целевых системах.

4. Введите RFC-адрес для исходной системы, из которой требуется распределить настройку в целевые системы.

5. Выберите Распределить запрос на перенос в целевые системы.

Результат

Изменения настройки в исходной системе, указанной в запросе на перенос, перенесены в целевые системы.


 Распределение языков

Распределение языков

Использование

Имеется возможность распределения переводов, например, ракурсов настройки, а также записей на языке входа в систему. Логика распределения зависит от видов распределения. Можно распределять переводы стандартных объектов настройки (ракурсов, кластеров ракурсов, табличных областей с таблицами текстов) и нестандартных объектов (отдельных транзакций, логических объектов переноса).

Интеграция

Для переноса распределяемых текстов вместе с их переводами в пределах среды разработки, т.е. из системы разработок в систему обеспечения качества и продуктивную систему, должна быть активна соответствующая опция системы переноса, осуществляющей перенос записей настройки независимо от языка оригинала. Эта опция активна по умолчанию при поставке SAP-систем.

Функциональные возможности

Начальное распределение

· Посредством начального распределения осуществляется распределение всех языков, для которых тексты на языке входа в систему не совпадают в исходной и целевой системе или не существуют для ключа в целевой системе.

· Если данные языка входа в систему в исходной и целевой системах совпадают, повторное распределение не выполняется. Таким образом, переводы, существующие до начального распределения, не распределяются.

Эти тексты, тем не менее, можно распределить путем выбора другого языка для начального распределения. Если переводы на данный момент отсутствуют в целевой системе, они распределяются в эту систему.

Можно также изменить тексты на языке входа в систему и затем распределить их вместе с их переводами. После этого следует вернуть текст к исходному состоянию.

· Полное удаление записей данных (текстов и их ключей) или только текстов может быть распределено только для языка входа в систему. Если выполняется удаление всей записи данных, доступ к другим языкам, на которые были переведены тексты, будет невозможен, поскольку ключ доступа перестанет существовать.

Дельта-распределение

При дельта-распределении (распределение при деблокировании переноса, записи переноса, запланированном распределении) тексты распределяются на всех языках в том случае, если они помещены в запрос на перенос как новые или измененные.

Можно распределить отсутствующие переводы путем их изменения и явного помещения в запрос на перенос. Вероятно, впоследствии потребуется отменить изменения. В этом случае также распределяются только те записи, которые были изменены на языке входа в систему, и явно измененные переводы. Неизмененные (и, таким образом, не записанные) переводы не распределяются.

Операции удаления в этом случае также распределяются только для полных записей данных или текстов на языке входа в систему. Для распространения удаленных переведенных текстов эти тексты должны быть явно помещены в запрос на перенос. После удаления полных записей данных доступ к их переводам будет невозможен, поскольку ключ доступа перестанет существовать.

Если требуется удалить запись данных и ее переводы, вначале удалите переведенные тексты, а затем всю запись данных.


 Экспертные параметры настройки

Экспертные параметры настройки

Использование

Управление взаимодействием между распределением настройки и пользователем осуществляется посредством экспертных параметров настройки.

Функциональные возможности

Можно установить следующие экспертные параметры настройки:

· Всегда подтверждать целевой запрос:
Всегда выводится окно для подтверждения запроса целевой системы – независимо от того, был ли он уже присвоен. После этого появляются следующие возможности:

Ў подтверждение целевого запроса;

Ў присвоение другого целевого запроса;

Ў создание нового целевого запроса.

Последние две опции влияют на присвоение переноса: создается новое присвоение переноса, специфичное для проекта. См. также:
Присвоение запросов на перенос исходной и целевой системам

· Пользовательская отладка:
Активация отладки для одного или нескольких пользователей. При каждом вызове SAP Solution Manager из внешней системы, например, исходной системы, автоматически запускается отладчик.

· Распределение в фоновом режиме:
(значение по умолчанию)
При сохранении пользователем в объекте настройки несколько записей эти записи обрабатываются несколькими процессами в фоновом режиме. Это обеспечивает возможность незамедлительного продолжения синхронизации посредством деблокирования переноса в исходной системе до завершения процедуры распределения. Вышесказанное справедливо и в том случае, когда несколько пользователей сохраняют записи в одном исходном запросе на перенос.

· Отправка сообщения пользователю в исходной системе в случае ошибки
(значение по умолчанию)
Если пользователь, выполнявший настройку в исходной системе, не завершил режима работы в системе, сообщения об ошибках распределения настройки направляются непосредственно этому пользователю. Если выполняющий настройку пользователь уже вышел из системы, информация об ошибках распределения вносится в журнал распределения настройки.

Операции

Для изменения экспертных параметров настройки на первом экране распределения настройки для активного сценария распределения выберите Обработать ® Экспертные параметры настройки.


 Сравнение общих для всех компонентов настроек

Сравнение общих для всех компонентов настроек

Цель использования

При внедрении и конфигурировании системной среды mySAP.com выполняется настройка различных прикладных компонентов mySAP.com. Системная среда mySAP.comвключает различные компоненты, имеющие собственные (независимые) таблицы настройки (с технической точки зрения). Для компонентов также требуется совместная настройка (по практическим соображениям).

Например, при внедрении программного обеспечения электронного бизнеса используется системная среда, в которой система SAP R/3 взаимодействует с SAP CRM. В идеальном случае система CRM использует данные системы SAP R/3. В частности, в определенных областях конфигурация этих двух систем должна совпадать. Совместная настройка должна быть синхронизирована. В частности, изменения в системе R/3 могут потребовать изменений в прикладном компоненте SAP.

Таким образом, необходимо регулярно проверять непротиворечивость настройки с целью обеспечения синхронизации настройки системы R/3 с настройкой прикладного компонента. SAP Solution Manager включает в себя инструмент, позволяющий сравнить различные параметры настройки в mySAP.com. Этим инструментом является Customizing Scout.

Предпосылки

На фазе реализации проекта были сконфигурированы бизнес-процессы. Также возможно использование функции Распределение настройки для распространения и синхронизации настроек в системной среде.

Выполнение

...

1. Инструмент Customizing Scout используется для сравнения объектов настройки в выбранных компонентах системной среды mySAP.com с объектами настройки в системе R/3.

2. Сравнение может проводиться с целью устранения различий в настройке систем, например, при использовании руководства по внедрению (IMG) или путем повторного распределения настройки после сравнения.


 Customizing Scout

Customizing Scout

Использование

Этот инструмент позволяет сравнивать объекты настройки в системе в системной среде mySAP.com с объектами настройки в системе R/3. Сравнение проводится в отношении только тех объектов настройки, которые необходимо синхронизировать в системной среде mySAP.com.

Объекты настройки, которые должны быть синхронизированы в среде разработки, определяются в системе заранее для выбранных компонентов (объекты синхронизации). Для выбора объектов синхронизации и других объектов настройки для сравнения можно воспользоваться редактором групп синхронизации.

Система, представляющая собой ссылочную систему для сравнения, также упоминается ниже как исходная система в системной среде mySAP.com. Это система R/3. Все другие системы в среде mySAP.com называются целевыми и сопоставляются только с исходной системой.

Интеграция

Процедура сравнения используется для синхронизации пользовательской настройки при внедрении или обновлении системной среды. Сравнение может проводиться с целью устранения различий в настройке систем, например, при использовании руководства по внедрению (IMG) или путем повторного распределения настройки после сравнения.

Предпосылки

Системная среда, полномочия и RFC-адреса

Установлены требуемые параметры системной настройки.

Защита

Для исходной и целевой системы при сравнении должны быть установлены следующие уровни защиты (выбор одного из указанных значений):

· 0 (без ограничений);

· 1 (без перезаписи).

Это значение можно установить при ведении манданта. Дополнительная информация содержится в разделе Ведение мандантов и логических систем и справке F1 в транзакции Ведение манданта.

Функциональные возможности

Выбор системной среды

Перед сравнением можно выбрать системную среду, в которой должно выполняться сравнение:

· системную среду, определенную в проекте в SAP Solution Manager;

· системную среду по умолчанию;

· весь домен переноса.

При выборе всего домена переноса отображаются все результаты сравнений - независимо от того, какому проекту они присвоены.

Сравнения

Просмотр или выполнение сравнений осуществляются следующим образом:

· просмотр, обработка и удаление существующих сравнений;

· сравнение целевой и исходной систем в диалоговом или в фоновом режиме;

· сравнение нескольких целевых систем с исходной системой в фоновом режиме;

· периодическое сравнение одной или более целевых систем в фоновом режиме.

Также можно настроить функцию сравнения только для тех систем, параметры настройки которых подлежат сравнению с использованием инструмента Распределение настройки.

Просмотр результатов сравнения

Можно выбрать один из нескольких ракурсов результатов сравнения:

· Сравнения в системной среде: обзор всех систем, выбранных для сравнения. Также можно просмотреть все существующие сравнения для каждой системы в списке.

· Обзор объектов: можно просмотреть список всех объектов, по которым выполняется сравнение, и их статусы сравнения и обработки для определенной системы.

· Отдельное сравнение: можно выбрать объект настройки в обзоре объектов и выполнить сравнение и анализ подробных данных объекта по значениям полей.

Утилиты и другие функции в обзоре объектов:

· просмотр журнала сравнения для выявления сторнированных отсутствующих сравнений;

· изменение статуса обработки определенных объектов;

· фильтрация списка объектов по статусу обработки, статусу сравнения и виду объекта;

· выбор объектов и переход к соответствующей IMG-операции в исходной или целевой системе для внесения изменений.


 Загрузка списков объектов

Загрузка списков объектов

Использование

Перед выполнением сравнения прикладного компонента (например, SAP CRM) и системы R/3 необходимо создать для Customizing Scout список объектов настройки, которые будут синхронизированы в системной среде mySAP.com. Некоторые прикладные компоненты содержат поставляемые вместе с ними списки объектов. Списки объектов становятся доступными после выгрузки списков объектов из прикладного компонента в систему, в которой выполняется Customizing Scout.

Дополнительная информация о компонентах, для которых предоставляются списки объектов, содержится в разделе Объект синхронизации.

Предпосылки

Удовлетворение необходимых условий для выполнения Customizing Scout, в частности, должна быть создана системная среда. Для загрузки списков объектов также необходимы следующие полномочия:

· операция (ACTVT) 02 для объекта полномочий s_cd_sync;

· поля полномочий sysdlvunit, project_id и scdtsysrol не проверяются; таким образом, необходимы только полномочия для проекта, типа системы (например, система разработок, продуктивная система) и прикладного компонента.

Полномочия также заранее определены для некоторых ролей в SAP Solution Manager. Можно использовать вышеупомянутые полномочия.

Последовательность шагов

...

1. Для запуска Customizing Scout выберите в меню SAP Инструменты ® Пользовательская настройка ® Распределение ® Customizing Scout или введите код транзакции "scout".

2. Выберите Дополнительная информация ® Списки объектов.

3. В следующем диалоговом окне введите логическую систему, из которой необходимо выгрузить списки объектов.

Если список объектов был выгружен ранее, можно установить флаг Только новые объекты, что позволит выгрузить только новые объекты, отсутствующие в предыдущих списках объектов.

4. Выберите Дальше.

Результат

Выполняется выгрузка списка объектов, после чего на экран выводится обзор со следующими данными:

· логическая система, для которой производилась выгрузка списка объектов;

· количество объектов, измененных при последней выгрузке;

· количество объектов, измененных при последней выгрузке.


 Сравнение настройки

Сравнение настройки

Использование

Имеется системная среда mySAP.com с системой R/3 и, по крайней мере, еще одна система, например, SAP CRM. Необходимо сравнить настройку одной или более целевых систем с настройкой исходной системы.

Предпосылки

Создана системная среда и, возможно, группа синхронизации, как описано в подразделе Предпосылки раздела Customizing Scout.

Перед первым сравнением необходимо выгрузить из прикладной системы список объектов настройки, которые будут синхронизированы. Только после этого можно использовать Customizing Scout.

Для сравнения можно использовать полномочия ролей, определенные в SAP Solution Manager, или полномочия, описанные в подразделе Предпосылки раздела Customizing Scout.

Последовательность шагов

...

1. Для запуска Customizing Scout:

Ў В меню SAPвыберите Инструменты ® Пользовательская настройка ® Распределение ® Customizing Scout.

Ў Введите транзакцию SCOUT.

Появится первый экран Customizing Scout.

2. Выберите системную среду и одну или более системных ролей.

Из справки по допустимым значениям ввода можно выбрать проект SAP Solution Manager. После этого для сравнения будет использоваться системная среда выбранного проекта.

3. Выберите Просмотреть критерии выбора .

Появится список всех систем, относящихся к выбранной системной среде или домену переноса. Просмотреть все существующие сравнения, включая сравнения с системами, не используемыми в выбранном проекте, можно при помощи двойного щелчка по системе.

4. Для сравнения объектов настройки в одной или более целевых системах с объектами настройки в исходной системе отметьте одну или более целевых систем в списке для просмотра и выберите Сравнить.

В следующем диалоговом окне будут представлены все выбранные логические системы. В фоновом режиме проверяется наличие RFC-адреса. При его отсутствии отображается журнал.

5. Определите группу синхронизации или выберите все объекты синхронизации для компонента.

6. Введите исходную систему и исходный мандант.

7. При сравнении только одной логической системы с системой R/3 выберите диалоговый или фоновый режим. Сравнение нескольких логических систем с одной системой R/3 выполняется в фоновом режиме.

8. При выполнении сравнения в фоновом режиме:

...

a. В случае необходимости определите сервер для фонового задания в следующем диалоговом экране.

b. Определите и сохраните время запуска фоновой обработки.

Система проверяет наличие полномочий для сравнения и существование RFC-адреса. При их отсутствии отображается журнал.

Результат

Отдельное сравнение в диалоговом режиме

Отображается список объектов для сравнения. В список включен как статус обработки, так и результат сравнения для каждого объекта.

Выполнение сравнения в фоновом режиме

После выполнения сравнения можно выбрать систему и нажать кнопку Обновить. После этого можно просмотреть данные по последнему сравнению.

Предоставляется обзор всех объектов настройки в целевой системе. При необходимости получения обзора объектов настройки в исходной системе, соответствующих объектам настройки в целевой системе, на экране Customizing Scout: Отдельное сравнения выберите Перейти к ® Просмотр структуры сравнения.

Обзор объектов

В обзоре объектов для каждого объекта настройки отображается техническое имя и описание в целевой системе. При наличии для объекта настройки соответствующего объекта синхронизации также указывается техническое имя объекта синхронизации.

Каждый объект настройки имеет два значения статуса:

· Статус сравнения

тип любых обнаруженных различий; присваивается автоматически.

· Статус обработки

Позволяет различать обработанные и необработанные объекты.

Статус обработки может быть присвоен вручную. При выполнении следующей операции сравнения статус обработки объектов без различий изменяется с Открыто ( [image]) на Завершено ( [image]).

Возможные значения статуса:

Значения статуса

Статус | Символ | Описание
Статус обработки |  | Открыто
 |  | В обработке
 |  | Завершено
Статус сравнения |  | Сравнение ракурсов/таблиц еще не выполнено
 |  | Содержимое ракурса/таблицы идентично
 |  | Содержимое ракурса/таблицы идентично при наличии структурных различий
 |  | Содержимое ракурса/таблицы не идентично
 |  | Содержимое ракурса/таблицы не идентично при наличии структурных различий
 |  | Сравнение невозможно (см. ниже)

Эти значения также перечислены в легенде рабочего списка.

Сравнение может оказаться невозможным по следующим причинам:

· отмена процесса;

· отсутствие у пользователя полномочий на просмотр в исходной или целевой системе;

· ошибка связи (RFC);

· сбой исходной или целевой системы.


 Просмотр последнего сравнения

Просмотр последнего сравнения

Предпосылки

Должно быть выполнено сравнение настроек системы R/3 с другой системой при помощи Customizing Scout. Для системы необходимо просмотреть результаты последней операции сравнения. При работе с Customizing Scout можно использовать полномочия ролей, определенные в SAP Solution Manager и поставляемые с этим решением, или полномочия, описанные в подразделе Предпосылки раздела Customizing Scout.

Последовательность шагов

...

1. Для запуска Customizing Scout:

Ў Введите транзакцию SCOUT.

Ў В меню SAP выберите Инструменты ® Пользовательская настройка ® Распределение ® Customizing Scout.

Появится первый экран Customizing Scout.

2. Выберите системную среду и одну или более системных ролей.

Из справки по допустимым значениям ввода можно выбрать проект SAP Solution Manager. После этого для сравнения будет использоваться системная среда выбранного проекта.

3. Выберите Просмотреть критерии выбора .

Система проверяет полномочия для выбранных систем. Появится список всех логических систем, относящихся к выбранной системной среде или домену переноса.

4. Дважды щелкните по логической системе.

В таблице под системой появятся результаты последней операции сравнения с исходными системами (при их наличии).

5. Выберите Просмотр результатов сравнения.

Для начала обработки результатов последней операции сравнения можно также дважды щелкнуть по целевой системе.

Результат

Отображается список объектов для сравнения.

В этом списке для каждого объекта указывается статус обработки, статус сравнения и результаты сравнения. Можно выполнить сравнение по одному или более объектам в списке или изменить статус обработки объектов.

См. также:

Изменение статуса обработки объекта сравнения


 Изменение статуса обработки объекта сравнения

Изменение статуса обработки объекта сравнения

Использование

Было выполнено сравнение одной или более систем с исходной системой (например, системой R/3) и изменение объектов настройки на основе результатов этого сравнения. Следовательно, необходимо изменить статус обработки некоторых объектов настройки.

Предпосылки

Выполнено сравнение настроек системы или проведен просмотр существующего сравнения.

Последовательность шагов

Щелкните по статусу обработки объекта в списке. Повторный щелчок приведет к изменению статуса обработки.

Возможные значения статуса обработки:

Значения статуса обработки

Символ | Описание
 | Открыто
 | В обработке
 | Завершено

Статус обработки определяется заново после каждого сравнения. В частности, для всех объектов с разницами снова устанавливается статус обработки Открыто, даже если при последнем сравнении статус обработки этих объектов был изменен. При наличии в списке объектов с разницами, не релевантными для настройки, можно ограничить выбор только релевантными объектами при помощи редактора групп синхронизации.

Результат

Статус обработки одного или более объектов изменен.


 Создание и загрузка объектов синхронизации

Создание и загрузка объектов синхронизации

Цель использования

В ходе этого процесса в системе создаются объекты синхронизации, которые необходимо использовать в дальнейшем для сравнения при помощи Customizing Scout или функции "Распределение настройки". Объекты синхронизации создаются в том случае, если объекты настройки в различных системах имеют одно и то же содержимое, но различаются по структуре, например, имеют различные имена таблиц и имена полей.

Предпосылки

В исходном и целевом компонентах определены объекты настройки для присвоения друг другу. Проверка подтвердила, что эти объекты включены в транзакцию SOBJ. Выполнена проверка на совместимость объектов с синхронизацией настройки.

Для инструмента определения объектов синхронизации установлены RFC-соединения.

Выполнение

Создание объектов синхронизации

...

1. Войдите в целевую систему распределения настройки. При необходимости создания, например, объектов синхронизации для компонента программного обеспечения BBPCRM 4.0, войдите в систему, включающую в себя этот компонент.

2. Вызовите инструмент определения объектов синхронизации.

3. Создайте объект синхронизации согласно следующим правилам:

Ў В случае использования таблицы в нескольких объектах настройки, создайте объект синхронизации для каждого из этих объектов.

Необходимо создать объект синхронизации для таблицы TSAD5. В транзакции SOBJ таблица отображается как исходная в списке, состоящем из двух объектов: ракурса V_TSAD5 и объекта TSDAD5 (текстовая таблица). Создаются два объекта синхронизации: для ракурса V_TSAD5 и для объекта TSDAD5.

Ў Таблицы и ракурсы для совместного переноса помещаются в объект синхронизации. Например, все таблицы, являющиеся подобъектами ракурса или кластера ракурсов в исходной системе, комбинируются в целевой системе.

4. При создании объекта синхронизации можно присвоить таблицы и имена полей друг другу. Примечание:

Ў Типы данных полей должны быть совместимы с присвоением, но не обязательно идентичны.

Ў В случае различной длины полей в компонентах выполняется усечение полей.

Ў Поля данных, отсутствующие в компоненте, игнорируются.

Ў Для целевой системы должны быть определены все ключевые поля таблиц и ракурсов объекта настройки. Для исходной системы можно использовать любые поля в таблицах и использованных ракурсах.

Ў В случае использования нескольких таблиц или ракурсов для исходной системы система связывает записи таблиц/ракурсов согласно следующему алгоритму:

§ Одна таблица отмечается как первичная.

§ Ключевые поля вторичных таблиц связываются с полями первичной таблицы с тем же именем через внутреннее соединение (InnerJoin).

§ Вторичная таблица может иметь другие ключевые поля, соответствующие полям целевой структуры.

§ В случае использования текстовой таблицы текстовое поле также автоматически отмечается системой как текстовое.

Ў В случае присвоения текстовой таблицы в исходной системе ракурсу в целевой системе необходимо определить условия фильтрации исходных объектов: создается фильтр для поля языка со значением $SPRAS или $SLANGU.

Ў В случае присвоения таблицы/ракурса другой таблице/ракурсу без мэппинга полей в исходном объекте, для полей целевого объекта необходимо определить условия фильтрации исходных объектов: создается фильтр для неиспользованных ключевых полей, имеющих постоянное или общее значение.

5. Проверьте все созданные и существующие объекты синхронизации, которые необходимо использовать.

Загрузка объектов синхронизации

...

1. Войдите в систему SAP Solution Manager.

2. Запустите транзакцию Редактор групп синхронизации и загрузите объекты синхронизации из системы, в которой они были созданы, в систему SAP Solution Manager.

Результат

Объекты синхронизации доступны для распределения настройки и Customizing Scout. Можно выполнить распределение настройки или сравнение настройки по всем компонентам.


 Инструмент определения объектов синхронизации

Инструмент определения объектов синхронизации

Использование

Инструмент определения объектов синхронизации (транзакция scdt_mapping) является дополнительным инструментом синхронизации настройки (Customizing Scout, распределение настройки) в SAP Solution Manager.

В Customizing Scout и распределении настройки используется список объектов настройки, которые должны быть синхронизированы в компонентах. Эти объекты настройки здесь называются объектами синхронизации. Ряд объектов синхронизации поставляется SAP с прикладными компонентами SAP CRM и SAP APO.

В системах прикладных компонентов при помощи инструмента определения создайте список объектов синхронизации и их атрибутов. Эти списки определяют, какие объекты настройки в целевом компоненте (например, BBPCRM) соответствуют объектам настройки в исходном компоненте (например, SAP_APPL) для определенной версии (мэппинг).

Для просмотра существующих объектов синхронизации, загруженных в систему SAP Solution Manager, воспользуйтесь транзакцией SAP Solution Manager Просмотр объектов синхронизации.

Предпосылки

Для использования инструмента определения необходимо наличие следующего:

· RFC-адреса во всех используемых системах: как правило, используется инструмент определения системы разработок прикладного компонента, например, SAP CRM. Для всех исходных систем, т.е. для всех систем R/3, для которых создаются объекты настройки, необходимы RFC-адреса.

Идеальная системная среда выглядит следующим образом:

Необходимо заранее установить RFC-адрес в системе R/3; предпочтительно для всех возможных версий системы R3.

· Профиль полномочий: для входа в вышеупомянутые системы R/3 необходим профиль полномочий s_cus_cmp. К этому профилю следует добавить некоторые полномочия; см. SAP-ноту 383704. Также необходимы полномочия s_tabu_all для объекта полномочий s_tabu_dis в системе разработок, например, в системе SAP CRM, в которой используется инструмент определения.

Функциональные возможности

При помощи инструмента определения можно создать список всех объектов настройки в системной среде, которые должны быть синхронизированы, т.е. иметь одни и те же записи в полях. В результате создается список объектов синхронизации, т.е. подлежащих синхронизации объектов настройки. Объекты синхронизации в таком компоненте, как система R/3, и в таком прикладном компоненте, как SAP CRM, часто имеют различные таблицы или даже имена полей. В этих случаях при помощи инструмента определения можно присвоить друг другу соответствующие таблицы или поля с различными именами. Если значения должны быть отображены взаимно, можно определить функциональный модуль, в котором данные настройки исходной системы преобразовываются в данные настройки целевой системы.

Также имеются следующие возможности:

· копирование;

· обработка;

· просмотр;

· ограничение срока действия версии;

· сортировка и фильтрация;

· проверка непротиворечивости;

· удаление объектов синхронизации в списке.

Также имеются следующие возможности:

· документирование объектов;

· определение того, подлежит ли объект только сравнению при помощи Customizing Scout или также может быть распространен в системной среде при помощи распределения настройки;

· определение того, подлежит ли объект распределению только из системы R/3 в другой компонент mySAP.com или также в обратном направлении (обратное распределение);

· присвоение объектам IMG-операций.

Присвоение объекта IMG-операции позволяет выбирать объекты для распределения в функции распределения настройки путем выбора IMG-операций. Это присвоение также позволяет связать IMG с Customizing Scout.


 Определение RFC-адресов

Определение RFC-адресов

Использование

Для систем с версиями исходных и целевых и компонентов плановых объектов синхронизации необходимо определить RFC-адреса. Это необходимо для получения возможности определения объектов синхронизации в инструменте определения и выполнения проверок.

Предпосылки

Для компонентов при помощи транзакции SM59 созданы RFC-адреса. Выполнен переход к первому экрану инструмента определения.

Последовательность шагов

...

1. Выберите Перейти к ® Изменение RFC-адресов.

Появится диалоговый экран Изменение поддерживаемых компонентов, версий и RFC-адресов.

2. Выберите экранную кнопку Новые записи или путь по меню Обработать ® Новые записи.

3. Введите требуемые данные.

Система проверяет, какие компоненты программного обеспечения находятся в децентрализованной системе SAP, и присваивает им RFC-адрес "NONE". Эти компоненты могут быть использованы.

4. Сохраните введенные данные.


 Создание объекта синхронизации

Создание объекта синхронизации

Использование

Необходимо сравнить или откорректировать настройку в таблицах/ракурсах исходной и целевой систем. Объекты синхронизации создаются в том случае, если объекты настройки в различных системах имеют одно и то же содержимое, но различаются по структуре, например, имеют различные имена таблиц и имена полей. Информация в объектах синхронизации используется в Customizing Scout и распределении настройки для сравнения и корректировки настройки.

Предпосылки

Выполнен вход в целевую систему распределения настройки.

Необходимо создать объекты синхронизации в системе, содержащей целевой компонент распределения настройки. Как правило, эта система не является системой SAP Solution Manager.

В транзакции ведения RFC-адресов SM59 созданы необходимые RFC-адреса; имеются требуемые полномочия, описанные в пункте "Предпосылки" раздела Инструмент определения объектов синхронизации. RFC-адреса выбраны в инструменте определения.

Выполнена проверка на совместимость объектов настройки с синхронизацией настройки и видами объектов настройки. Пользователь ознакомлен с примечаниями в разделе Создание и загрузка объектов синхронизации. Примечание:

· кластеры ракурсов (вид C) должны быть развернуты в отдельные ракурсы, которые затем вводятся в инструменте определения;

· объекты настройки вида T (отдельная транзакция) или L (логический объект переноса) должны быть развернуты в таблицы (область, V, S), которые затем вводятся в инструменте определения.

Последовательность шагов

...

1. Выберите в меню SAP Инструменты ® Пользовательская настройка ® Распределение ® Изменение объектов синхронизации или вызовите транзакцию scdt_mapping.

Появится первый экран инструмента определения объектов синхронизации.

2. Выберите компонент программного обеспечения, который будет использоваться как целевой компонент, а также целевую версию.

Появится список существующих объектов синхронизации.

Символ * в поле Версия означает "все версии".

3. Выберите Создать.

4. Появится диалоговый экран Создание объектов синхронизации.

5. При необходимости присвойте имя объекту синхронизации и измените исходный компонент или версии для исходного и целевого компонентов.

Имена в TADIR должны быть уникальными, поэтому необходимо соблюдать соглашение по присвоению имен для объектов синхронизации.

6. В области Релевантность выберите одну из следующих опций:

Ў Релевантно для сравнения и распределения: объект используется в Customizing Scout и распределении настройки.

Ў Релевантно только для сравнения: объект синхронизации используется только в Customizing Scout, но не в распределении настройки.

Ў Релевантно только для распределения на основе переноса: объект синхронизации может использоваться при распределении настройки, выполняемом в случае изменения переноса, версии переноса или запланировано, но не при начальном распределении.

Ў Релевантно только для начального распределения

Ў Релевантно только для сравнения и начального распределения: объект синхронизации может использоваться только для начального распределения и сравнения при помощи Customizing Scout.

7. Повторное распределение активно: при установке этого флажка можно поменять местами исходную и целевую системы распределения настройки, т.е. распределение настройки может выполняться как из прикладного компонента, такого как SAP CRM, в систему R/3 и наоборот, из системы R/3 в другие прикладные компоненты.

Этот флаг устанавливается автоматически при выборе опции Без мэппинга.

8. Определите тип мэппинга в области Структурные различия:

Ў Без мэппинга: таблицыимеют идентичные имена таблиц и имена полей.

Ў Различные имена таблиц

Таблицы также могут отличаться по структуре, например, одна таблицаможет содержать больше полей, чем другая, или поля с одним именем могут иметь различные виды. При выборе"Без мэппинга" или "Различные имена таблиц" в Customizing Scout и распределении настройки обрабатываются только поля с одним именем в обоих компонентах и при совместимости видов.

Ў Различные имена таблиц/полей: таблицы/ракурсы имеют различные имена таблиц и полей. При синхронизации настройки обрабатываются только те поля, для которыхопределены присвоения.

Ў Программный мэппинг: преобразование данных настройки исходной системы в данные настройки целевой системы посредством функционального модуля.

9. В случае различия имен таблиц или имен полей соответствующие имена таблиц или имена полей вводятся поля в области Присвоения.

При помощи опций Целевое ключевые поля и Целевые текстовые поля определяется, содержит ли объектсинхронизации ключевые поля или поля в текстовой таблице.

10. При необходимости введите фиксированное значение поля или переменную в столбце Фиксированное значение поля/переменная.

Фиксированные значения полей являются необходимыми для таблицы исходного компонента, например, в случаеесли одна или несколько таблиц в целевом компоненте содержат дополнительные поля, не имеющиесоответствующих полей в исходном компоненте. В настоящее время доступны следующие переменные: $LOGSYS, $SYLANGU, $MANDT, $UNAME, $SYDATUM, $SYUZEIT.

11. В случае необходимости определите условия фильтрации целевых объектов или условия фильтрации исходных объектов при помощи экранной кнопки Изменение в столбце Просмотр/изменение условий фильтрации.

12. В случае выбора типа мэппинга Программный мэппинг определите функциональный модуль исходной системы для преобразования данных настройки исходной системы в данные настройки целевой системы. При установке флажка Повторное распределение активно такжеследует определить функциональный модуль целевой системы.

13. Присвойте исходную и целевую IMG-операцию данному объекту синхронизации. Возможно использование справки по допустимым значениям ввода.

14. Для документирования объекта синхронизации используется экранная кнопка Документация.

Документация создается в редакторе SAPscript. Она имеет вид Общий текст.

15. Сохраните данные.

Выполняется проверка введенных данных. См. Проверка объектов синхронизации.

16. Определите пакет и запрос на перенос.

Результат

Теперь имеются следующие возможности:

· Изменение объекта синхронизации;

· Ограничение срока действия версии объекта синхронизации;

· Копирование или удаление объекта синхронизации.

Можно загрузить объект синхронизации в систему SAP Solution Manager для его использования при распределении настройки или в Customizing Scout.


 Изменение объекта синхронизации

Изменение объекта синхронизации

Использование

Объект синхронизации подлежит изменению при необходимости определения дополнительных данных или внесения исправлений.

Корректировка объектов синхронизации необходима в случае внесения в определения ракурса и таблиц следующих изменений:

· в список объектов настройки добавлена новая таблица, например, новаятаблица добавлена в ракурс;

· изменено ключевое поле в таблице списка объектов, например, ключевое поле добавлено или удалено, либо изменена его длина.

Последовательность шагов

...

1. Выберите в меню SAPИнструменты ® Пользовательская настройка ® Распределение ® Изменение объектов синхронизации или вызовите транзакцию scdt_mapping.

Появится первый экран инструмента определения объектов синхронизации.

2. Выберите целевой компонент и выполните деблокирование.

Появится список существующих объектов синхронизации.

3. Выберите Изменить.

Будет выполнен переход к диалоговому экрану Изменение объекта синхронизации.

4. Внесите изменения. См. примечания в разделе Создание объекта синхронизации.

5. Сохраните данные.


 Ограничение версии объекта синхронизации

Ограничение версии объекта синхронизации

Использование

Присвоения таблиц и полей объекта синхронизации могут отличаться в зависимости от версии. Необходимо ограничить срок действия определения объекта синхронизации с присвоениями таблиц и полей до ряда версий. Можно ограничить определение как для исходных, так и для целевых компонентов.

Имеются следующие возможности:

· создание нескольких объектов синхронизации с одним именем, но с различными отображениями для различных версий;

· изменение ряда версий для объекта синхронизации.

Во избежание противоречивости данных в распределении настройки, в случае изменения целевой таблицы в зависимости от исходной версии необходимо создать два объекта синхронизации.

Предпосылки

Выполнен переход к первому экрану инструмента определения объектов синхронизации.

Последовательность шагов

...

1. Выберите целевой компонент и исходную версию.

Появится список существующих объектов синхронизации.

2. Выберите объект и затем выберите Обработка ряда версий.

Будет выполнен переход к диалоговому экрану Объекты синхронизации: Управление интервалами.

3. Разделение интервала: для создания различных мэппингов объекта синхронизации для различных версий:

Выберите Разделение интервала и затем выберите верхний лимит версии, до которого применим объект синхронизации, для исходного или целевого компонента.

Выбрать Проверка.

Если проверка выполнена успешно, новый объект синхронизации создается автоматически выше верхней границы и выводится в таблице в верхней части диалогового окна.

Эту операцию можно повторить любое количество раз для определения объекта синхронизации с различными мэппингами для различных версий.

4. Перемещение пределов интервалов: для перемещения пределов версий для объекта синхронизации:

a. Выберите объект в таблице в диалоговом окне.

b. Выберите предел, который необходимо изменить.

c. Выберите версию.

d. Выберите Проверка.

Система корректирует пределы рядов версий других объектов синхронизации с этим именем для обеспечения непрерывности интервалов.

5. Сохраните данные.

Результат

Система содержит два объекта синхронизации одним именем и одним определением мэппинга, но для различных версий, либо определения объектов синхронизации изменены. После этого можно в случае необходимости выполнить обработку объектов синхронизации, например, изменить тип мэппинга для некоторых версий или присвоить таблицы и поля.

Необходимо проверить объекты синхронизации.


 Проверка объекта синхронизации

Проверка объекта синхронизации

Использование

При сохранении объект синхронизации проверяется на непротиворечивость. В случае изменения системной среды после создания объекта синхронизации или срока деблокирования версии изменения объекта необходимо выполнить проверку объекта синхронизации.

Предпосылки

Выполнен переход к первому экрану объекта синхронизации.

Последовательность шагов

...

1. Выберите объект в списке объектов на первом экране.

2. Выберите в меню"Объект ® Проверка .

Система выполняет проверку непротиворечивости объекта синхронизации и выводит появляющиеся системные сообщения:

Ў Имеются ли в исходной и целевых системах определенные таблицы и поля?

Ў Совпадают ли типы данных исходных и целевых полей или они могут быть взаимно преобразованы? Совпадает ли длина полей?

Ў Является ли объект совместимым с пакетом настройки бизнес-конфигурации?

3. При появлении системных сообщений необходимо повторно обработать объект и проверить, корректно ли определены вид мэппинга и присвоения таблиц и полей для определенных версий. В противном случае следует внести соответствующие изменения.


 Определение условий фильтрации для целевого объекта

Определение условий фильтрации для целевого объекта

Использование

Условия фильтрации можно использовать для определения ключевых областей в таблице, содержащих данные для одного объекта настройки. Например, можно определить, что поле должно иметь определенное фиксированное значение. При помощи условий фильтрации можно ограничить распределение настройки только определенными данными (выбор строк объекта настройки).

Предпосылки

Выполнен переход к экрану обработки объекта синхронизации.

Последовательность шагов

...

1. Выберите экранную кнопку Изменение в столбце Просмотр/изменение условий фильтрации.

2. Введите необходимые данные: имя поля, оператор и константу.

В случае определения нескольких условий для одного имени поля в различных строках эти условия автоматически связываются оператором "ИЛИ". В случае определения нескольких условий в различных именах полей эти условия автоматически связываются оператором "И".

3. Выберите Дальше.


 Определение условий фильтрации исходных объектов

Определение условий фильтрации исходных объектов

Использование

Условия фильтрации для исходного объекта можно определить в том случае, если они относятся к исходному полю, не существующему в целевом объекте. Прежде всего, это относится к ситуациям, когда исходный объект имеет больше полей, чем целевой объект.

Предпосылки

Выполнен переход к экрану обработки объекта синхронизации.

Последовательность шагов

...

1. Выберите экранную кнопку Изменение в столбце Просмотр/изменение условий фильтрации в области Исходный объект.

2. Определите имя и значение поля или системную переменную.

В настоящее время доступны следующие переменные: $LOGSYS, $SYLANGU, $MANDT, $UNAME, $SYDATUM, $SYUZEIT.

3. Выберите Дальше.


 Объекты, релевантные для синхронизации настройки

Объекты, релевантные для синхронизации настройки

В SAP определены объекты настройки, которые можно использовать в распределении настройки и при сравнении при помощи Customizing Scout (объекты синхронизации). Также в случае удовлетворения следующим предпосылкам для распределения или сравнения настройки можно выбрать другие объекты настройки.

Объекты настройки, релевантные для сравнения в Customizing Scout

Имена таблиц и полей в исходных и целевых системах должны быть одинаковыми. В противном случае создайте объект синхронизации.

Объекты настройки, релевантные для распределения настройки

Общие предпосылки

Имена таблиц и полей в исходных и целевых системах должны быть одинаковыми. В противном случае создайте объект синхронизации. Объекты настройки не должны содержать методы "Перед экспортом" и должны быть, по крайней мере, переносимыми вручную.

Предпосылки для автоматического распределения изменений настройки

Объекты настройки, которые необходимо использовать при автоматическом распределении изменений настройки, должны быть автоматически связаны с переносом и совместимы с пакетом настройки бизнес-конфигурации в целевой системе. При настройке параметров функции "Распределение настройки" система проверяет, являются ли выбранные объекты совместимыми с пакетом настройки бизнес-конфигурации в целевой системе.

Также можно самостоятельно проверить в IMG совместимость объектов с пакетом настройки бизнес-конфигурации перед выполнением распределения настройки:

· При помощи программы Проверка IMG на совместимость с пакетом настройки БК можно проверить объекты во всех системах на основе компонента программного обеспечения SAP_BASIS версии 4.6C и выше. В частности, эту проверку можно выполнить в системах R/3 с версией 4.6C. Дополнительная информация о программе проверки IMG содержится в SAP-ноте 398178.

· Во всех системах на основе компонента программного обеспечения SAP_BASIS 6.20 (например, система R/3 Enterprise) и выше в транзакции SOBJ и в руководстве по внедрению (IMG) можно вызвать функцию проверки на совместимость с пакетом настройки бизнес-конфигурации.

Объекты, для которых устанавливается зеленая пиктограмма, обозначающая активацию без контроля, являются релевантными для распределения настройки.

Ограничения для SAP CRM

В настоящее время при помощи распределения настройки невозможно переносить из системы R/3 в систему SAP CRMследующие объекты настройки:

· Данные настройки техники условий;

· Условия варианта в объекте настройки DNL_CUST_SCE (основные данные);

· Основную запись банка (объект настройки DNL_CUST_BNKA);

· Валютные курсы (TCURR);

· Типы курсов (TCURV) и использование видов тарифов (TCURW) в версии соответствующей системы R/3 4.5 или ранее;

· Подпрограммы адресов с именами (таблицы T005A и T005B).

В распределении настройки не обрабатываются данные продуктов, отмеченные как основные данные в CRM (объекты настройки DNL_CUST_PROD1 и DNL_CUST_SRVMAS и T178 и T178T из DNL_CUST_SPROD, Условия: группы материалов).

Объекты синхронизации SAP CRM, релевантные только для начального распределения

Некоторые объекты синхронизации не могут быть перенесены и поэтому должны загружаться в продуктивную среду при начальном распределении:

· Данные региональной структуры:

Ў Объект синхронизации CRM_CITIES с таблицами ADRCITY, ADRCITYPRT, ADRCITYT, ADRPCDCITY и ADRPOBOX;

Ў Объект синхронизации CRM_POSTAL_CODES с таблицей ADRPSTCODE;

Ў Объект синхронизации CRM_REGIONAL_STRUC_GROUPS с таблицей ADRREGGRP;

Ў Объект синхронизации CRM_STREETS с таблицами ADRSTREET, ADRSTREETT и ADRSTRPCD;

Ў Объект синхронизации CRM_STREET_TYPES с таблицей ADRSTRTYPE (включая текстовую таблицу);

· Управляющие ключевые данные продукта: объект синхронизации COM_PRODUCT_ID_STORAGE_FORM;

· Единицы измерения: объект синхронизации CRM_UNITS_OF_MEASUREMENT.

Также можно выполнить распределение настройки из системы SAP CRM в систему R/3 ("Обратное распределение"), начиная с SAP CRM 3.1 SP03. Некоторые объекты синхронизации не релевантны для этого распределения. Эти объекты определяются в транзакции SAP Solution Manager Просмотр объектов синхронизации.


 Структура мэппинга пользовательских идентификаторов

Структура мэппинга пользовательских идентификаторов

Цель использования

Структура мэппинга пользовательских идентификаторов в SAP Solution Manager используется для обмена сообщениями между негармонизированными системами. В негармонизированных системах одной и той же сущности соответствуют различные идентификаторы.

...

Требуется осуществить обмен сообщениями между негармонизированными системами через сервер интеграции. Сервер интеграции представляет собой компонент SAP-инфраструктуры обмена (SAP XI). Сервер интеграции содержит базу данных мэппинга идентификаторов, в которой различные идентификаторы в различных системах ставятся в соответствие друг другу. Идентификаторы присваиваются друг другу в том случае, если они представляют одну и ту же сущность в различных системах. При обмене сообщениями с сервером интеграции для сообщений также используются параметры пользовательской настройки. Для выполнения мэппинга следует знать, каким пользовательским идентификаторам одной системы соответствуют идентификаторы других систем.

Структура мэппинга пользовательских идентификаторов позволяет это выяснить.

Структура мэппинга пользовательских идентификаторов: обзор

Внедрение

Структура мэппинга пользовательских идентификаторов предназначена для экспертов по информационным технологиям, системных администраторов и консультантов, устанавливающих в проекте системную среду. Структуру мэппинга пользовательских идентификаторов можно использовать в проекте внедрения для конфигурации и соединения негармонизированных систем.

Дополнительная информация о конфигурации SAP-инфраструктуры обмена содержится в руководстве по конфигурации SAP-инфраструктуры обмена 2.0, расположенном в Интернете по адресу www.service.sap.com/instguides ® SAP-инфраструктура обмена.

Интеграция

Сервер интеграции

Для структуры мэппинга пользовательских идентификаторов используется сервер интеграции SAP-инфраструктуры обмена.

· Определения мэппинга идентификаторов в SAP Solution Manager тиражируются на соответствующий сервер интеграции (системы разработок, системы обеспечения качества и продуктивные системы).

· Определенные в SAP Solution Manager типы идентификаторов, которые должныиспользоваться, необходимо разместить на сервере интеграции в формате XSL. Для этого либо используются инструменты сервера интеграции, либо в редакторе выполняется обработка файлов с расширением XSL вручную.

При использовании Управления основными данными (SAP MDM) можно воспользоваться функциями для создания XSL, доступными в этом компоненте. Для получения более подробной информации об управлении основными данными см. SAP NetWeaver ® Управление основными данными SAP в библиотеке SAP и www.service.sap.com/instguides ® Руководства по инсталляции и апгрейду ® SAP MDM в руководстве по конфигурации управления основными данными.

Отличия от SAP CRM Content Integrator

В отличие от Content Integrator, в процессе мэппинга идентификаторов сопоставление и присвоение эквивалентных объектов может выполняться для всех объектов настройки, тогда как при помощи Content Integrator выполняется сопоставление и присвоение основных данных. Для получения более подробной информации о Content Integrator см. раздел SAP Content Integrator в библиотеке SAP.

Функциональные возможности

При помощи структуры мэппинга пользовательских идентификаторов можно создавать типы идентификаторов и глобальные типы идентификаторов. Также имеется возможность использования в SAP Solution Manager типов идентификаторов, поставляемых SAP (дополнение ST).

При помощи сервера интеграции можно настроить структуру мэппинга пользовательских идентификаторов для приложения. Имеются следующие возможности:

· подключение сервера интеграции кSAP Solution Manager для мэппинга идентификаторов;

· выбор типов пользовательских идентификаторов, систем и серверов интеграции для обмена идентификаторами;

· определение мэппингов идентификаторов и их тиражирование в соответствующие серверы интеграции.

Структура мэппинга пользовательских идентификаторов: определение мэппингов идентификаторов и их тиражирование в сервер интеграции

Все параметры настройки структуры мэппинга пользовательских идентификаторов являются зависящими от манданта, за исключением типов идентификаторов и глобальных типов идентификаторов, которые являются общими для всех мандантов.

Ограничения

Структура мэппинга пользовательских идентификаторов служит только для настройки; при помощи этой функции невозможно выполнить мэппинг основных данных и других объектов.

Если один сервер интеграции используется для всех сред систем разработок, обеспечения качества и продуктивных систем, существует вероятность того, что для каждой системной среды потребуется отдельно создавать мэппинги идентификаторов.

Структура мэппинга пользовательских идентификаторов не интегрирована с функцией распределения настройки.

Не совмещайте функции распределения настройки и структуры мэппинга пользовательских идентификаторов при пользовательской настройке объекта и его системы. Это можетпривести к противоречивости данных причиной противоречивости данных. Распределение настройки и структура мэппинга пользовательских идентификаторов представляют собой компоненты SAP Solution Manager, однакомежду собой они не интегрированы. Поэтому следуетлибо выполнить распределение объекта настройки между двумя системами при помощи функции распределения настройки, либо выполнить мэппинг идентификаторов.


 Использование структуры мэппинга идентификаторов с сервером интеграции

Использование структуры мэппинга идентификаторов с сервером интеграции

Цель использования

Требуется выполнить обмен сообщениями между негармонизированными системами через сервер интеграции. В различных системах идентичная настройка была сохранена с различными идентификаторами в системной среде. Между системами через сервер интеграции необходимо осуществить обмен сообщениями, относящимися к настройкам с различными идентификаторами, но обозначающими одну и ту же сущность. Для этого необходим мэппинг идентификаторов.

Мэппинг идентификаторов позволяет осуществлять обмен сообщениями между негармонизированными системами без согласования идентификаторов в настройках и всех приложениях основных данных.

Далее приводится описание обработки сервером интеграции данных о структуре мэппинга идентификаторов в целях обмена данными. Для получения дополнительной информации о настройке структуры мэппинга идентификаторов см. Настройка структуры мэппинга пользовательских идентификаторов.

Выполнение

Обмен данными через сервер интеграции с мэппингом идентификаторов

...

1. Система A отправляет серверуинтеграции сообщение, относящееся к настройке, для его передачи системе B. Сообщение содержит пользовательские идентификаторы, которые обозначают сущности пользовательской настройки.

2. Сервер интеграции преобразовывает сообщение в соответствующий формат для системы-получателя B. Одновременно сервер интеграции преобразовывает пользовательские идентификаторы для системы-получателя при помощимэппинга идентификаторов.

3. Сервер интеграции переадресовывает сообщение системе B.

4. Система B получает сообщение и выполняет его дальнейшую обработку. После корректного преобразования пользовательского идентификатора на сервере интеграции в системе B появится возможность правильного считывания и интерпретации ссылок на этот параметр настройки в сообщении.

Пример

...

1. Система разработок R/3 отправляет запроссерверу интеграции относительно настройки для семейного положения для переадресации системе разработок SAP CRM.

2. Сервер интеграции преобразовывает запрос в подходящий для системы-получателя SAP CRM формат. Одновременно сервер интеграции преобразовывает пользовательские идентификаторы семейного положения в идентификаторы, подходящие для системы SAP CRM, при помощи мэппинга идентификаторов.

3. Сервер интеграции переадресовывает сообщение системе SAP CRM.

4. Система SAP CRM получает сообщение и выполняет его дальнейшую обработку. После корректного преобразования пользовательского идентификатора семейного положения на сервере интеграции в системе SAP CRM появится возможность правильного считывания и интерпретации ссылок на семейное положение в запросе.


 Настройка мэппинга пользовательских идентификаторов

Настройка мэппинга пользовательских идентификаторов

Цель использования

Этот процесс позволяет настроить системы для определения мэппинга идентификаторов и их использования с целью обмена данными с сервером интеграции или распределения настройки.

Предпосылки

Необходимы полномочия на использование структуры мэппинга пользовательских идентификаторов.

Выполнение

...

1. Скопируйте системную среду, определенную в каталоге системных ландшафтов, в SAP Solution Manager. Следуйте рекомендациям руководства по инсталляции SAP Solution Manager и инструкций из раздела Настройка автоматического сбора данных длясистемной среды.

2. В системной среде, для которойдолжен быть выполнен мэппинг идентификаторов, сервер интеграции должен быть подключен к SAP Solution Managers. Создайте RFC-соединения в ведении системной среды или в транзакции Ведение RFC-адресов" (SM59) для бизнес-систем или сервера интеграции.

Для получения более подробной информации о соединении систем для структуры мэппинга пользовательских идентификаторов см. Создание адреса сервера интеграции для ведения таблицы мэппинга значений в разделе Руководство по конфигурации: SAP-инфраструктура обмена 2.0 в Интернете по адресу http://www.service.sap.com/instguides ® SAP-инфраструктура обмена.

3. Запустите мэппинг пользовательских идентификаторов с помощью транзакции SCIDM_CONFIG.

4. Можно выбрать другие бизнес-системы, не являющиеся ABAP-системами, в функции обработки бизнес-систем, отметить серверы интеграции и создать другие RFC-адреса.

5. Типы идентификаторов создаются при помощи редактора типов пользовательских идентификаторов.

6. Редактор глобальных типов идентификаторов используется для создания глобальных типов идентификаторов.

7. Создайте группы типов для определения связей между типами пользовательских идентификаторов, бизнес-системами и сервером интеграции:

Ў бизнес-системы;

Ў эквивалентные типы идентификаторов, не согласованные между бизнес-системами;

Ў сервер интеграции, через которыйбизнес-системы обмениваются сообщениями.

Группа типов может основываться на глобальных типах пользовательских идентификаторов.

8. Определите мэппинги идентификаторов.

9. Экспортируйте мэппинги идентификаторов в сервер интеграции.

Результат

Возможность выполнения мэппинга идентификаторов путем преобразования сообщений на сервере интеграции.


 Мэппинг идентификаторов

Мэппинг идентификаторов

Определение

Присвоение кодов одной системы кодам другой системы.

Использование

Мэппинг идентификаторов может использоваться для различных систем, вовлеченных в бизнес-процесс и имеющих различные коды для эквивалентных объектов. Данные должны быть смоделированы так, чтобы обеспечить возможность корректного копирования, например, проводок из системы R/3 в систему SAP CRM. Мэппинги идентификаторов позволяют соотнести идентификаторы посредством обмена сообщениями между системами.

Интеграция

Отличие от распределения настройки и объектов синхронизации

При мэппинге идентификаторов выполняется присвоение кодов, тогда как определения объектов синхронизации в распределении настройки отражают только структуры.

Не совмещайте функции распределения настройки и структуры мэппинга пользовательских идентификаторов при пользовательской настройке объекта и его системы. Это можетпривести к противоречивости данных причиной противоречивости данных. Распределение настройки и структура мэппинга пользовательских идентификаторов представляют собой компоненты SAP Solution Manager, однакомежду собой они не интегрированы. Поэтому следуетлибо выполнить распределение объекта настройки между двумя системами при помощи функции распределения настройки, либо выполнить мэппинг идентификаторов.

Пример

Для описания структуры идентификаторов, содержащих данные о семейном положении, создается тип идентификатора Семейное положение.

Система AAA, тип идентификатора: Семейное положение

Код/идентификатор | Текст
01 | Холост/не замужем
02 | Женат/замужем
03 | Вдовец(ва)
04 | Разведен(а)
... | ...

Система BBB, тип идентификатора: Семейное положение

Код/идентификатор | Текст
LE | Холост/не замужем
VH | Женат/замужем
VW | Вдовец(ва)
GS | Разведен(а)
... | ...

Этот тип идентификатора используется для определения следующих мэппингов идентификаторов:

Мэппинг идентификаторов для типа идентификатора Семейное положение

Система AAA | Система BBB
01 | LE
02 | VH
03 | VW
04 | GS


 Тип идентификатора

Тип идентификатора

Определение

Техническое представление структуры кода (идентификатора) в компоненте или системе.

Использование

Типы идентификатора описывают структуру идентификатора и объекты настройки, в которых он используется.

Мэппинги идентификаторов выполняются на основе типов идентификаторов.

Структура

Тип идентификатора содержит следующую информацию:

· структура идентификатора;

· длина поля(ей);

· объект настройки в системе, в которойиспользуется идентификатор;

· использование идентификатора в других объектах настройки;

· раздел имен Interface Repository (IFR) SAP-инфраструктуры обмена (XI).

Тип идентификатора не является объектом IFR. Раздел имен IFR предназначен только для документирования и для проверки полномочий. Можно настроить полномочия так, чтобы пользователь мог обрабатывать типы идентификаторов только в определенном разделе имен.

Использование идентификатора в других объектах настройки задается таким образом, что при создании группы типов можно проверить, настроено ли уже распределение настройки для данного объекта. Для получения более подробной информации см. Ограничения в разделе Структура мэппинга пользовательских идентификаторов.

Типы идентификаторов представляют собой блокируемые логические объекты переноса вида SCI1 в транзакции SOBJ.

Интеграция

Различные типы идентификаторов, которые являются эквивалентными и могут встречаться в различных компонентах, помещаются в один глобальный тип идентификаторов.

Пример

Тип пользовательских идентификаторов R3MaritalStatusID содержит данные о семейном положении сотрудников в системе R/3. Этот тип идентификатора основан на поле FAMST в объекте настройки V_T502T. Определение идентификатора R3MaritalStatusID содержит обзор всех объектов настройки, в которых этот идентификатор используется.


 Глобальный тип идентификаторов

Глобальный тип идентификаторов

Определение

Класс эквивалентных, но не идентичных типов идентификаторов, которые могут использоваться в нескольких компонентах или системах.

Использование

Группы типов могут основываться на глобальных типах идентификаторов.

Структура

Различные типы идентификаторов, которые являются эквивалентными и могут содержаться в различных компонентах, помещаются в одну классификацию.

Глобальные типы идентификаторов представляют собой блокируемые логические объекты переноса вида SCI2 в транзакции SOBJ.

Глобальный тип идентификаторов не является объектом IFR. Разделимен IFR предназначен толькодля документирования и для проверки полномочий. Можно настроить полномочия так, чтобы пользователь мог обрабатывать типы идентификаторов только в определенном разделе имен.

Пример

Глобальный вид пользовательского идентификатора: Семейное положение

Тип пользовательских идентификаторов | Компонент программного обеспечения
BuPaMaritalStatusID | SAP_ABA
R3MaritalStatusID | SAP_APPL

Глобальный тип пользовательских идентификаторов Семейное положение включает два эквивалентных типа пользовательских идентификаторов BuPaMaritalStatusID и R3MaritalStatusID. Идентификаторы BuPaMaritalStatusID используются в компоненте программного обеспечения SAP_ABA, а идентификаторы R3MaritalStatusID - в SAP_APPL.


 Мэппинг пользовательских идентификаторов

Мэппинг пользовательских идентификаторов

Использование

Этот раздел представляет собой основу для настройки и определения мэппинга пользовательских идентификаторов. Можно определить следующее:

· типы идентификаторов и глобальные типы идентификаторов;

· бизнес-системы или серверы интеграции, в которых требуется выполнить мэппинг идентификаторов;

· группы типов, относящиеся к видам пользовательских идентификаторов и бизнес-системам;

· мэппинги идентификаторов.

Предпосылки

Имеются полномочия наиспользование структуры мэппинга пользовательских идентификаторов.

Операции

...

1. Вызовите структуру мэппинга пользовательских идентификаторов с помощью кода транзакции SCIDM_CONFIG.

2. Появится первый экран, из которого можно перейти ко всем транзакциям в структуре мэппинга пользовательских идентификаторов.


 Редактор типов пользовательских идентификаторов

Редактор типов пользовательских идентификаторов

спользование

Эта функция позволяет создавать и обрабатывать типы пользовательских идентификаторов. SAP предоставляет ряд предварительно определенных типов пользовательских идентификаторов.

Интеграция

Редактор типов пользовательских идентификаторов является компонентом структуры мэппинга пользовательских идентификаторов.

Предпосылки

Необходимы полномочия на использование структуры мэппинга пользовательских идентификаторов.

Функциональные возможности

Редактор предоставляет следующие возможности:

· создание,

· просмотр,

· изменение,

· удаление типов пользовательских идентификаторов.

Можно также определить, является ли тип идентификатора структурированным или простым.

Операции

...

1. Определите техническое имя, описание и область имен в SAP Interface Repository (IFR) компонента SAP XI.

2. Определите объект настройки для типа идентификатора, основанного на объекте настройки в ABAP-системе.

Наборы значений для типа идентификатора считываются из системы через объект настройки при определении мэппинга идентификаторов.

3. Другие способы использования идентификаторов определяются в других объектах настройки. Определение других способов использований имеет важное значение, поскольку в структуре мэппинга пользовательских идентификаторов выполняется проверка использования объекта настройки в функции распределения настройки для той же самой системы. В этом случае использовать этот объект в структуре мэппинга пользовательских идентификаторов невозможно. И наоборот, функция распределения настройки также выполняет проверку использования объектов в структуре мэппинга пользовательских идентификаторов для тех же самых систем.

4. Определите длину полей идентификаторов. Это важно, так как сервер интеграции сохраняет идентификаторы в неструктурированном поле.


 Редактор глобальных типов идентификаторов

Редактор глобальных типов идентификаторов

Использование

Эта функция позволяет просматривать глобальные типы идентификаторов, поставляемые SAP, а также создавать и обрабатывать глобальные типы пользовательских идентификаторов. SAP предоставляет ряд предварительно определенных глобальных типов идентификаторов.

Интеграция

Глобальные типы пользовательских идентификаторов используются для эквивалентных, но не идентичных типов идентификаторов, которые могут использоваться в нескольких компонентах или системах. Глобальные типы пользовательских идентификаторов определяют то, какие типы идентификаторов являются эквивалентными.

Группа типов может основываться на глобальном типе пользовательских идентификаторов. Они не являются обязательными для создания группы типов, но позволяют зафиксировать отношения между типами пользовательских идентификаторов.

Предпосылки

Созданы требуемые типы идентификаторов.

Имеются полномочия на использование структуры мэппинга пользовательских идентификаторов.

Функциональные возможности

Редактор предоставляет следующие возможности:

· создание,

· просмотр,

· изменение,

· удаление глобальных типов идентификаторов.


 Обработка бизнес-систем

Обработка бизнес-систем

Использование

Эта функция позволяет просматривать системы при ведении системной средыSAP Solution Manager. Такие системы отмечены в SAP-инфраструктуре обмена как "бизнес-системы". С помощью этой функции также можно определить бизнес-системы как серверы интеграции.

Просмотр и создание бизнес-систем и их определение как серверов интеграции являются предварительными шагами для последующего определения мэппинга индикаторов, необходимого для этого сервера интеграции. RFC-адреса сервера интеграции в дальнейшем используются для экспорта определений мэппингов идентификаторов в серверы интеграции.

Интеграция

Для систем, отмеченных в качестве серверов интеграции, можно создать группы типов.

Предпосылки

Бизнес-системы должны быть определены в каталоге системных ландшафтов (SLD) связанной системы SAP Solution Manager, и данные из каталога системных ландшафтов должны быть скопированы в системную среду SAP Solution Manager.

Дополнительная информация о каталоге системных ландшафтов и настройке системной среды SAP Solution Manager содержится в Руководстве по инсталляции SAP Solution Manager.

При ведении системной среды уже созданы RFC-адреса считывания для стандартных бизнес-систем.

Кроме того, при ведении системной среды создан также RFC-адрес для синхронизации настройки или для SAP Solution Manager для серверов интеграции. Должны быть сохранены данные о созданном идентификаторе пользователе и пароле для RFC-адресов, либо созданы соединения вида "Достоверная система" без отображения экрана входа в систему. Это важно, так как некоторые системные операции структуры мэппинга пользовательских идентификаторов, например, экспорт мэппинга идентификаторов в сервер интеграции, выполняются в фоновом режиме. Необходимо также проверить, что сохраненному идентификатору пользователю, наряду с пользователями, имеющими полномочия на вход в систему с использованием соединений вида "Достоверная система", присвоены полномочия на использование объекта полномочий S_RFC для группы функций SKMP. Дополнительная информация о RFC-адресах сервера интеграции содержится в Руководстве по конфигурации SAP-инфраструктуры обмена 2.0 по адресу: http://www.service.sap.com/instguides ® SAP-инфраструктура обмена.

Функциональные возможности

В системной среде SAP Solution Manager отображаются все бизнес-системы.

Имеются следующие возможности:

· определение бизнес-систем как серверов интеграции;

· присвоение RFC-адресов ABAP-бизнес-системам.

· определение RFC-адреса для сервера интеграции или бизнес-системы вручную в случае невозможности определения RFC-адреса в системной среде SAP Solution Manager или необходимости использования другого RFC-адреса.

· добавления не основанных на ABAP системы вручную, так как они не копируются автоматически из каталога системных ландшафтов.

Таким образом, в структуре мэппинга пользовательских идентификаторов могут использоваться внешние (не SAP) системы.


 Обработка системных отношений

Обработка системных отношений

Использование

Для определения предпосылок для тиражирования мэппингов идентификаторов необходимо выполнить ведение системных отношений. Определите бизнес-системы с конкретными функциями, например, систему разработок, систему обеспечения качества или продуктивную систему, для каждого сервера интеграции. Присвойте бизнес-системы серверу интеграции, при помощи которого они обмениваются данными.

Предпосылки

Серверы интеграции, для которых должно выполняться ведение системных отношений, были определены как серверы интеграции при обработке бизнес-систем. Бизнес-системы, подлежащие присвоению, включены в обзор бизнес-систем.

Функциональные возможности

Обработка системных отношений может выполняться двумя способами:

· Системные отношения для отдельных системных сред:
Все бизнес-системы, при осуществлении функций которых необходим обмен данными посредством мэппинга пользовательских идентификаторов, могут быть определены как Стандартные отношения.

· Системные отношения для более сложных (по структуре) системных сред:
В дополнение к Стандартным присвоениям, можно определить исходные и целевые серверы интеграции в тех случаях, когда одна исходная бизнес-система обслуживает нескольким целевых бизнес-систем, как Расширенные присвоения.

Системы, участвующие в обмене данными, перечислены в соответствующих столбцах. Соответствующие бизнес-системы отображаются последовательно строка за строкой согласно их функциям.

В пределах одной строки следует присваивать один и тот же тип системы согласно системным функциям.

Пример 1: Неправильное присвоение бизнес-систем строкам (выделено красным)

Сервер интеграции | FKTstDev | FKTstQual | FKTstPrd
Бизнес-системы | FKTstDev_R3 | FKTstQual_R3 | FKTstPrd_MDM
 | FKTstDev_MDM | FKTstQual_MDM | FKstPrd_R3
 | FKTstDev_CRM | FKTstQual_CRM | FKstPrd_CRM

Пример 2: Правильное присвоение бизнес-систем строкам

Сервер интеграции | FKTstDev | FKTstQual | FKTstPrd
Бизнес-системы | FKTstDev_R3 | FKTstQual_R3 | FKTstPrd_R 3
 | FKTstDev_MDM | FKTstQual_MDM | FKstPrd_MDM
 | FKTstDev_CRM | FKTstQual_CRM | FKstPrd_CRM

Операции

...

1. Выберите Перейти к ® Системные отношения.

2. Для обработки бизнес-систем, обменивающихся данными через определенный сервер интеграции, отметьте этот сервер в списке серверов интеграции на закладке Стандартные отношения, после чего добавьте или удалите бизнес-системы.

Можно добавлять только не присвоенные другим серверам интеграции бизнес-системы.

Возможен просмотр до 10 последовательно перечисленных системных отношений. Для получения возможности ведения большего количества системных отношений следует удалить уже проверенные системные комбинации путем удаления флажка сервера интеграции. Этот флажок влияет только на просмотр.

3. Для ввода большего количества бизнес-систем (обслуживаемых одним и тем же источником) в дополнение к стандартным отношениям выполните присвоение источника на закладке Расширенные присвоения.

Возможен только ввод новых бизнес-систем; удаление существующих стандартных присвоений запрещено.


 Создание группы типов для сервера интеграции

Создание группы типов для сервера интеграции

Использование

Эта функция позволяет связать типы пользовательских идентификаторов с их системной средой (включая сервер интеграции). Типы идентификаторов и бизнес-системы принадлежат к одной и той же группе типов в следующих случаях:

· между бизнес-системами осуществляется обмен сообщениями;

· эти сообщения содержат соответствующие типы пользовательских идентификаторов;

· типы пользовательских идентификаторов в этих системах эквивалентны, но не согласованы.

Эквивалентные типы идентификаторов принадлежат одной и той же группе типов, т. е. группа типов определяет объем мэппинга идентификаторов.

Комбинация типа идентификаторов и бизнес-системы для сервера интеграции может относиться только к одной группе типов.

Интеграция

После создания группы типов для сервера интеграции можно определить мэппинг идентификаторов для этой группы типов и сервера интеграции.

Предпосылки

Определены типы идентификаторов, возможные глобальные типы идентификаторов и бизнес-системы, выбраны серверы интеграции.

Операции

...

1. Выберите сервер интеграции, для которого требуется создать группу типов.

2. Определите существующий тип пользовательских идентификаторов или скопируйте тип из глобального типа пользовательских идентификаторов.

Пример

...

1. Выберите сервер интеграции IntServerDev, для которого требуется определить мэппинг пользовательских идентификаторов.

2. Определите техническое имя для группы типов: gruppe_familienstand.

3. Добавьте типы пользовательских идентификаторов BuPaMaritalStatusID и R3MaritalStatusID из глобального типа идентификаторов Familienstand.

4. Выполните присвоение соответствующих бизнес-систем типам пользовательских идентификаторов.


 Определение мэппинга пользовательских идентификаторов

Определение мэппинга пользовательских идентификаторов

Использование

Эта функция позволяет выполнять взаимное присвоение различных идентификаторов из различных систем. Идентификаторы присваиваются друг другу в том случае, если они представляют одну и ту же сущность в различных системах. Структура мэппинга пользовательских идентификаторов передает информацию серверу интеграции, который, в свою очередь, использует данные мэппинга для переадресации сообщений.

Предпосылки

Бизнес-системы определены, и созданы группы типов для соответствующих серверов интеграции.

Функциональные возможности

Система выводит для просмотра все серверы интеграции с соответствующими группами типов. В структуре мэппинга пользовательских идентификаторов выполняется проверка типов идентификаторов и систем выбранной группы типов. В частности, проверяется возможность доступа к системам по RFC-соединению и существование объектов настройки, на которых основаны типы идентификаторов. При возникновении ошибок можно просмотреть журнал, содержащий соответствующую информацию.

Имеются следующие возможности:

· считывание всех идентификаторов в бизнес-системе для типа пользовательских идентификаторов;

· считывание и просмотр текстов идентификаторов из систем;

· взаимное присвоение считанных идентификаторов методом перетаскивания;

· создание наборов значений для объектов настройки из систем, не основанных на ABAP, вручную;

· поиск идентичных идентификаторов;

· поиск мэппинга, которому присвоен идентификатор;

· изменение статуса обработки групп типов;

· персонализация представления мэппинга идентификаторов;

· экспорт мэппингов идентификаторов в сервер интеграции;

· переключение между просмотром мэппинга идентификаторов, как активных в сервере интеграции, так и измененных на локальном уровне в SAP Solution Manager;

· удаление всех идентификаторов определенного типа из мэппингов идентификаторов;

· удаление мэппингов идентификаторов для группы типов из сервера интеграции.

В случае удаления мэппинга идентификаторов из сервера интеграции мэппинг идентификаторов для соответствующих сообщений в сервере интеграции до экспорта нового мэппинга не функционирует.

· Просмотрите журналы удаления и экспорта.


 Определение и экспорт мэппинга идентификаторов

Определение и экспорт мэппинга идентификаторов

Предпосылки

Была выполнена обработка бизнес-систем и создание групп типов. Имеются полномочия на использование структуры мэппинга пользовательских идентификаторов.

Выполнен переход к структуре мэппинга пользовательских идентификаторов.

Последовательность шагов

Определение мэппинга идентификаторов

...

1. Выберите Определение мэппинга идентификаторов.

Появится обзор всех существующих серверов интеграции и соответствующих групп типов.

2. Выберите группу типов в левой части экрана.

В структуре мэппинга пользовательских идентификаторов выполняется проверка типов идентификаторов и систем данной группы типов. В частности, проверяется возможность доступа к системам по RFC-соединению и существование объектов настройки, на которых основаны типы идентификаторов. При возникновении ошибок можно просмотреть журнал, содержащий соответствующую информацию.

3. При появлении журнала проверок вернитесь к предыдущему шагу.

4. Существует возможность переключения между режимами просмотра и обработки.

5. В правой части экрана выберите тип пользовательских идентификаторов, затем выберите Просмотр идентификаторов из системы.

6. После выбора первого типа пользовательского идентификатора выделите все идентификаторы и скопируйте их в список мэппингов идентификаторов методом перетаскивания.

7. Повторите эту процедуру для всех других типов пользовательских идентификаторов:

Ў Выберите идентификаторы и присвойте их существующим идентификаторам в списке методом перетаскивания.

Ў Помещайте эквивалентные идентификаторы в одной и той же строке, так как каждая строка соответствует отдельному мэппингу идентификаторов.

При определении мэппинга идентификаторов для гармонизированных или частично гармонизированных систем возможен просмотр идентичных идентификаторов с помощью опции Выбор идентичных идентификаторов и их автоматическое присвоение путем выбора опции Присвоение идентификаторов ® Присвоить идентичные идентификаторы.

Все типы пользовательских идентификаторов имеют статус Нов. или Удалено. Значения статусов можно уточнить посредством справки F1.

8. Для присвоения идентификаторов из объектов настройки из не-ABAP-систем выберите Создать набор значений вручную, и затем выполните присвоение созданных вручную идентификаторов.

9. Сохраните введенные данные.

Экспорт мэппинга идентификаторов

...

1. Выберите группу типов.

2. Выберите Экспорт в сервер интеграции.

3. В следующем диалоговом окне определите режим экспорта: диалоговый или фоновый.

4. В случае экспорта в фоновом режиме введите требуемые данные в следующие диалоговые окна.

Система экспортирует выбранные группы типов в сервер интеграции. Статус обработки изменяется на Завершено.

Результат

Мэппинги идентификаторов сохраняются в сервере интеграции и могут использоваться для преобразования сообщений.


 Экспорт мэппинга идентификаторов для нескольких групп типов

Экспорт мэппинга идентификаторов для нескольких групп типов

Использование

При определении мэппинга идентификаторов возможен выборочный экспорт данных мэппинга только для одной определенной группы типов. Эта функция позволяет выполнять экспорт мэппингов идентификаторов в целевой сервер интеграции одновременно для нескольких групп типов.

Предпосылки

Мэппинг идентификаторов, подлежащий экспорту для определенных групп типов, должен быть определен в соответствии с описанием в разделе Определение мэппинга идентификаторов.

Операции

...

1. Выберите Перейти к ® Экспорт мэппинга идентификаторов или воспользуйтесь экранной кнопкой Экспорт мэппинга идентификаторов на первом экране.

2. Выберите целевой сервер интеграции, в который должны экспортироваться данные мэппинга идентификаторов.

3. Выберите одну или несколько групп типов для экспорта.

4. Проверьте правильность выбора.

5. Запустите экспорт путем выбора Экспорт.

6. Запланируйте фоновое задание. Ввиду возможного большого объема данных экспорт выполняется только в фоновом режиме.

Для просмотра или удаления журналов выберите Утилиты ® Просмотр журналов экспорта или Удаление журналов экспорта .


 Тиражирование мэппингов идентификаторов

Тиражирование мэппингов идентификаторов

Использование

Копирование мэппингов идентификаторов позволяет повторно использовать мэппинг идентификаторов в других серверах интеграции.

Предпосылки

Выполнен экспорт мэппингов идентификаторов, для который необходимо выполнить тиражирование с использованием соответствующих групп типов так, чтобы они имели статус Активно.

Выполнено ведение системных отношений.

Функциональные возможности

Тиражирование позволяет выполнить следующее:

· корректировку групп типов для целевой системы в SAP Solution Manager;

· копирование мэппингов идентификаторов для целевой системы в SAP Solution Manager;

· запуск экспорта мэппингов идентификаторов из SAP Solution Manager в целевой сервер интеграции.

Подробные данные выбора предоставляют обзор типов пользовательских идентификаторов и бизнес-систем в группе типов.

Операции

...

1. Выберите Перейти к ® Тиражирование мэппинга идентификаторов или воспользуйтесь экранной кнопкой Тиражирование мэппинга идентификаторов на первом экране.

2. Выберите исходный и целевой сервер интеграции для тиражирования.

3. Определите мэппинг идентификаторов, подлежащий тиражированию, путем выбора соответствующих групп типов.

4. Определите операции тиражирования:

Ў Выполните корректировку групп типов:
При отсутствии группы типов в целевом сервере ее необходимо создать. Если группа типов уже существует, то в случае каких-либо несоответствий с источником ее следует расширить согласно определенным системным отношениям. Группы типов удалению не подлежат.

Ў Мэппинг идентификаторов:
Тиражирование мэппинга идентификаторов.

Если в целевом сервере уже существует мэппинг идентификаторов, то существующий мэппинг идентификаторов следует удалить и установить для него соответствующий статус в случае повторного тиражирования. Тиражируемые мэппинги идентификаторов добавляются к удаленным; для них устанавливается статус Нов.

5. С помощью соответствующей пиктограммы выполните проверку наличия необходимых полномочий для тиражирования, а также возможность выполнения тиражирования согласно определенным системным отношениям.

6. Определите необходимость экспорта данных мэппинга в целевой сервер интеграции после тиражирования. При наличии такой необходимости задание для данной операции должно выполняться в фоновом режиме.

При экспорте происходит замена существующих данных мэппинга идентификаторов в целевом сервере интеграции соответствующими новыми данными. Эта операция может временно нарушить перенос данных, осуществляемый сервером интеграции.

7. Выберите Тиражирование.

8. Тиражируемые группы типов появятся в обзоре групп типов для выбранного целевого сервера интеграции.

Существует возможность просмотра или удаления журналов путем выбора Утилиты ® Просмотр журналов тиражирования или Удаление журналов тиражирования.


 Полномочия для структуры мэппинга идентификаторов

Полномочия для структуры мэппинга идентификаторов

Объекты полномочий и их функции

Объект полномочий | Функция
S_SCIDMREP | Создание/просмотр/изменение (глобальных) типов идентификаторов
S_SCIDMCFG | Просмотр/обработка бизнес-систем Определение групп типов Корректировка групп типов при тиражировании
S_SCIDMASG | Присвоение типов идентификаторов и бизнес-систем группам типов Корректировка групп типов при тиражировании
S_SCIDMMAP | Определение мэппинга идентификаторов и его экспорт в сервер интеграции Тиражирование мэппинга идентификаторов


 Создание учебного материала и учебных карт

Создание учебного материала и учебных карт

Цель использования

При внедрении новых решений и функций конечные пользователи должны получать знания о новых функциях, которые они будут использовать. С помощью системы SAP Solution Manager на основе существующей структуры проекта создаются учебные карты по задачам конечного пользователя, например, новым функциям, которые будет использовать закупщик в компании. Учебная карта представляет собой структурированное оглавление интерактивного курса для самостоятельного изучения, содержащее краткую информацию о рассматриваемых темах и ссылки на учебный материал в формате HTML. В курсы самообучения можно внести материалы электронного обучения, например, обучающие программы SAP.

Предпосылки

На фазе концептуального проекта создана структура проекта.

Имеются полномочия на выполнение транзакции Конфигурация или роль Консультант по приложению или Руководитель проекта.

Существует возможность заказа бесплатной неограниченной лицензии на использование обучающей программы SAP и доступ к документам по наиболее успешной практике для обучения пользователей; для этого следует перейти по ссылке в меню Операции ® Управление изменением программного обеспечения ® Обновление ® Документы по наиболее успешной практике в транзакции SOLUTION_MANAGER.

Выполнение

...

1. Если соответствующая роль отсутствует, определите роли для тех групп пользователей, которым требуется впоследствии отправить учебные карты, например, закупщика или бухгалтера.

2. На фазе реализации выполняется присвоение учебного материала структурным элементам в транзакции Конфигурация в проекте, например, материала для электронного обучения, такого как обучающие программы SAP, презентации или контрольные примеры.

3. Выполните присвоение этих ролей структурным элементам в транзакции Конфигурация для получения возможности фильтрации структуры проекта по группам пользователей (ролям), для которых предназначены определенные учебные разделы.

4. По окончании тестирования проекта создайте учебные разделы на основе структуры проекта и присвоенного ей учебного материала, также создайте на его основе учебные карты в формате HTML для различных групп пользователей (ролей) в транзакции Управление учебными картами.

5. Отправьте ссылку на учебную карту конечному пользователю.

6. Конечные пользователи самостоятельно изучают учебный материал.

7. Конечные пользователи предоставляют свою оценку учебных материалов и учебной карты.

8. Выполняется анализ оценок конечных пользователей.


 Создание ролей конечных пользователей

Создание ролей конечных пользователей

Использование

Требуется отправить учебную карту группе пользователей, имеющих одинаковую деловую роль, например, всем бухгалтерам в компании или отделу закупок. В SAP Solution Manager используются деловые роли Должность и Организационная единица из HR. Если эти деловые роли не определены, их необходимо создать.

Организационные единицы CRM совпадают с организационными единицами в Управлении персоналом.

Предпосылки

Для создания ролей необходимы полномочия на объект полномочий PLOGU. Для получения дополнительной см. SAP Web Application Server ® Экономика и организация производства ® Организационная структура ® Организационный менеджмент в библиотеке SAP.

Последовательность шагов

Если используется центральная система управления персоналом, роли следует создавать в ней и распространять их в систему SAP Solution Manager. Для получения дополнительной информации см. Распределение организационной модели управления персоналом.

...

1. Выберите Среда ® Ведение ролей конечных пользователей в транзакции Конфигурация (SOLAR02).

2. Перейдите к экрану Ведение объектов (PP01).

3. Создайте задание.

4. Выполните присвоение позиций заданию.

5. Выполните присвоение пользователей позициям.

Затем учебная карта отправляется по адресам электронной почты, указанным в адресных данных этих пользователей.

6. Создайте организационную единицу.

7. Выполните присвоение позиций организационной единице.

8. Выполните присвоение пользователей позициям.

9. Выполните распределение ролей в данную систему SAP Solution Manager.

В SAP Solution Manager используется актуальная плановая версия, т.е. организационная структура компании, действительная в настоящее время.

Результат

Теперь можно создавать структуру проекта и присваивать организационные единицы в качестве ролей конечных пользователей в транзакции Конфигурация в SAP Solution Manager.


 Создание учебного материала

Создание учебного материала

Использование

Выполняется создание учебного материала или присвоение существующего учебного материала структуре данного проекта с целью создания учебной карты на основе структуры проекта.

Предпосылки

В проекте выполнен переход к транзакции Конфигурация (SOLAR02).

Последовательность шагов

...

1. Перейдите к закладке Учебный материал.

2. Выберите структурный элемент.

3. Выполните действия, описанные в разделе Создание проектной документации. В транзакции Учебный материал имеются те же опции, что и на закладке Проектная документация. Также имеются следующие возможности:

Ў Создание и присвоение обучающих программ SAP

Ў Определение подробных данных документа, выводимых в учебной карте:

i. Определение времени, необходимого для изучения той или иной темы, в поле Необходимое время в мин. на закладке Документ в атрибутах учебных материалов;

ii. Определение атрибутов учебных материалов на закладке Примечания.

4. Сохраните введенные данные.

Результат

Для проекта создан учебный материал. Теперь можно выполнить присвоение ролей конечных пользователей структуре проекта .


 Присвоение ролей конечных пользователей

Присвоение ролей конечных пользователей

Использование

Для получения возможности фильтрации учебного материала по группам пользователей, для которых предназначаются определенные темы, при создании учебной карты, эти группы пользователей (роли конечных пользователей) должны быть присвоены структуре проекта.

Предпосылки

Выполнены операции создания ролей конечных пользователей и/или их распределение в системе SAP Solution Manager.

Последовательность шагов

...

1. Перейдите к закладке Роли конечных пользователей.

2. Выберите структурный элемент.

3. Выберите вид роли конечного пользователя, например, "должность" и "организационная единица", в справке по допустимым значениям ввода. В справку по допустимым значениям ввода включены все роли, созданные в транзакции Ведение объекта (PP01) или распределенные из центральной системы управления персоналом в системе SAP Solution Manager.

4. Выберите роль конечного пользователя, например, бухгалтер, в справке по допустимым значениям ввода.

5. Сохраните введенные данные.

Результат

Теперь на основе структуры проекта можно создавать учебные карты.


 Создание учебной карты

Создание учебной карты

Использование

С помощью системы SAP Solution Manager на основе существующей структуры проекта создаются интерактивные курсы самообучения по задачам конечного пользователя, например, новым функциям, которые будет использовать закупщик в компании. Готовые курсы самообучения и учебная карта могут быть отправлены конечным пользователям в формате HTML.

Предпосылки

· Наличие присвоенного учебного материала в Конфигурации структуры проекта.

· Наличие присвоенных ролей конечных пользователей в конфигурации структуре проекта для фильтрации структуры проекта по ролям конечного пользователя.

· Наличие роли SAP_SOL_TRAINING_EDIT. Эта роль содержится в ролях Руководитель проекта и Консультант по приложению.

Последовательность шагов

Структура учебной карты

...

Создание учебной карты

1. Вызовите транзакцию управления учебным материалом (SOLAR_LEARNING_MAP).

2. Выберите Создать.

3. Введите заголовок.

4. Выберите проект, на основе структуры которого создается учебная карта.

Изменение учебной карты

...

1. Создайте заголовок учебной карты:

a. В дереве структуры в левой области экрана выберите узел Заголовок учебной карты.

b. В верхней правой области экрана введите описание в текстовое поле.

c. Для добавления дальнейшей информации к заголовку учебной карты выделите узел заголовка и выберите функцию из контекстного меню. В правой области экрана введите требуемые данные.

В заголовок учебной карты может быть помещена следующая информация:

§ логотип, например, рисунок, который используется для всех учебных карт;

§ ссылка, например, URL интранет-страницы FAQ учебного раздела;

§ ссылка на службу поддержки.

2. Создание глав:

a. В дереве структуры в левой области экрана выберите начальный узел структуры учебной карты.

b. В контекстном меню выберите Создать главу.

c. В верхней правой области экрана введите заголовок для узла структуры.

d. В верхней правой области экрана введите описание в текстовое поле.

Главы являются только узлами структуры и не содержат учебный материал. Учебный материал можно присвоить только учебным разделам.

3. Создание учебного раздела в главе:

a. В дереве структуры в левой области экрана выберите главу.

b. В контекстном меню выберите Создать раздел.

c. В верхней правой области экрана введите требуемые данные.

4. Присвоение учебного материала учебным разделам:

a. Структуру проекта можно отфильтровать по ролям конечных пользователей, присвоенным этой структуре проекта на закладке Роли конечного пользователя в транзакции Конфигурации с помощью экранной кнопки Фильтрация по ролям.

b. Выберите учебный материал в структуре проекта в нижней правой области экрана и методом перетаскивания поместите его в учебный раздел структуры учебной карты в левой области экрана.

Новый учебный материал можно создать только в транзакции Конфигурация. Существующий учебный материал можно только присвоить структуре учебной карты в Управлении учебными картами.

5. Сохраните введенные данные.

Просмотр учебной карты в формате HTML

С помощью кнопки Открыть в браузере учебную карту можно просмотреть в формате HTML.

Результат

Был создан интерактивный курс самообучения (учебная карта). Затем этот курс можно отправить конечным пользователям.


 Отправка учебной карты

Отправка учебной карты

Последовательность шагов

Отправка учебной карты

...

1. Выберите кнопку Отправить учебную карту.

2. Выберите роли конечных пользователей, которым следует отправить учебную карту. Этот выбор можно ограничить определенными критериями.

3. Нажмите экранную кнопку E-Mail и затем создайте электронное письмо почту в программе электронной почты.

Система скопирует текстовый шаблон со ссылкой на учебную карту в буфер обмена. Затем вызывается локальная программа электронной почты.

4. Скопируйте текстовый шаблон в электронное письмо.

5. Отправьте электронное письмо в почтовой программе.

Создание шаблона текста электронного письма

Для создания текстового шаблона электронных писем для отправки учебной карты создайте Текст в диалоге (Text in Dialog) Z_LEARNING_MAP_DEPLOY_MAIL в транзакции ведения документа (SE61).

Имеются следующие возможности:

· Копирование шаблона текста SAP SA_LEARNING_MAP_DEPLOY_MAIL в Z_LEARNING_MAP_DEPLOY_MAIL, а затем его изменение;

· Перевод текстового шаблона.

Результат

Конечные пользователи самостоятельно изучают учебный материал и оценивают его. Выполняется анализ оценок.

Учебная карта находится на веб-сервере системы SAP Solution Manager. Для вызова учебной карты конечные пользователи не обязательно должны иметь собственный идентификатор пользователя в системе SAP Solution Manager, т.к. для на веб-сервере используется роль анонимного пользователя с полномочиями только на просмотр. Оценки конечных пользователей сохраняются анонимно.


 Анализ учебных карт

Анализ учебных карт

Использование

После изучения созданного для них учебного материала конечные пользователи могут анонимно оценить этот учебный материал. Просмотреть результаты такой оценки можно в Управлении учебными картами.

Предпосылки

Создана учебная карта.

Функциональные возможности

Результат

· Количество обращений к учебной карте

· Индивидуальные оценки

· Средние оценки

· Обратная связь по отдельным учебным разделам и всей карте изучения; просмотр подробных данных обратной связи при помощи соответствующей пиктограммы.

Операции

Вызов результатов оценки осуществляется с помощью кнопки Анализ в Управлении учебными картами.


 Анализы проектов

Анализы проектов

Использование

Существует возможность сохранения информации о проекте по фазам или операциям проекта, например, по статусу, по календарному планированию или по членам проектной группы. Анализ проекта позволяет проанализировать данную информацию. Чем подробнее сохраненная информация, тем большее количество опций анализа проекта имеется в наличии. Анализ можно выполнять по одному или нескольким проектам одновременно в зависимости от выбранного вида проекта.

Функциональные возможности

Анализы проекта включают следующие программы:

· Концептуальный проект:

Ў Администрирование: анализ информации по администрированию (классифицируется в общем анализе статуса) и рабочих списков, которые могут быть присвоены одному или нескольким членам проектной группы. В анализах рабочих списков можно анализировать определенные данные, например, статус или плановый срок завершения.

Ў Присвоения: анализ присвоений в структуре проекта.
Это может быть документация (общая или проектная), а также поставляемые или добавленные на фазе реализации проекта транзакции.

· Конфигурация:
анализ аналогичен таковому на фазе концептуального проекта. Также можно анализировать присвоения объектов конфигурации (например, пакеты настройки бизнес-конфигурации, инструменты CATT, IMG-операции), контрольных примеров и сообщений о проблемах. Кроме этого, возможен общесистемный анализ IMG проекта, т. е. в компонентах системы на локальном уровне.

· Организация тестирования: анализ планов тестирования (по отдельности или совместно).

Анализ проекта и опции просмотра результата анализа обладают гибкой конфигурацией. Для ограничения объема анализа и определения способа представления его результатов можно использовать критерии выбора. Существует возможность создания стандартных анализов и их сохранения в качестве вариантов выбора для видов программ на фазах концептуального проекта и конфигурации.

В зависимости от критериев выбора, доступны следующие виды анализа проектов:

· Информация по проекту:
информация по статусу и анализ видов документации.

· Контроль динамики,
например, путем установки различных комбинаций информации по статусу (например, члены проектной группы и определенный статус) или путем агрегирования информации по проекту.

· Общие анализы,
например, ежедневные анализы.

Можно ограничить анализы одним или несколькими проектами (в зависимости от вида проекта).

Возможен вызов выведенных элементов структуры проекта или IMG-операций непосредственно в результатах анализа.

Для получения полной информации в результатах анализа можно просмотреть всю информацию или содержимое, а не только те элементы структуры проекта, которые удовлетворяют критериям выбора. Таким образом, при анализе члена проектной группы Meier будут также отображены данные по члену проектной группы Schulze, если данный член группы также присвоен данному элементу. Если критерии выбора не определены, анализируются все данные проекта.

Операции

Возможны два подхода к анализу проекта:

· по всем проектам и фазам: вызовите транзакцию Анализ проекта.

· для конкретной фазы: можно выполнить анализ для определенной фазы выбранного проекта в концептуальном проекте или конфигурации. Выберите Среда ® Анализы проекта и вид программы.


 Концептуальный проект

Концептуальный проект

Использование

Анализ проекта производится на основе выбранной информации. Соответствующие данные для определенных элементов структуры проекта могут быть сохранены на закладках Администрирование и Структура.

Анализ данных может выполняться как для отдельного проекта, так и для нескольких проектов, в зависимости от объема проекта или назначения анализа.

Определенные критерии выбора анализируются совместно.

Существует два способа перехода к анализу концептуального проекта :

· по всем проектам и фазам:

...

a. Вызовите транзакцию Анализ проекта.

b. Выберите в дереве структуры Концептуальный проект.

· для конкретной фазы:

Можно выполнить анализ для конкретной фазы выбранного проекта в концептуальном проекте (SOLAR01). Выберите меню Среда ® Анализ проекта.

Для просмотра административной информации по проекту выберите подменю Администрирование; для выполнения проверки присвоений выберите подменю Присвоения.


 Администрирование

Администрирование

Использование

Программы, перечисленные в подменю Администрирование, позволяют выполнять анализ административных данных. Наряду с общим анализом статуса, можно проанализировать рабочие списки одного или нескольких членов проектной группы, уделяя особое внимание статусу и плановому сроку завершения. В разделе Объем перечислены виды анализа, выполняемые с помощью той или иной программы.

Обратите внимание на следующие различия, в зависимости от точки входа для анализа проекта:

 | Для конкретной фазы | Для всех фаз
Точка входа | Меню: Среда ® Анализ проекта ® Администрирование | Транзакция: Анализ проекта ® Концептуальный проект или Конфигурация ® Администрирование
Объем анализа | Текущий проект Зарегистрированный пользователь (член проектной группы) | Выбранные проекты Один или несколько членов проектной группы

Функциональные возможности

Общий анализ статуса

Критерии выбора

Анализ одного или нескольких проектов выполняется по следующим критериям:

Критерии выбора | Описание
Структура проекта | Выбор подструктуры или структурных элементов, рассматриваемых в аналитическом отчете.
Логический компонент | Анализ логических компонентов выполняется на следующих структурных уровнях: · Организационные единицы · Основные данные · Бизнес-процессы (для отдельных шагов процесса)
Члены проектной группы | Введите одного или нескольких членов проектной группы.
Сроки | Сроки проекта: · Плановый срок начала · Конец нормативного срока · Фактическое начало · Фактический конец
Работы | Плановые ресурсы Фактические ресурсы Остаточные ресурсы (разница между плановыми и фактическими ресурсами)
Статус | Статус Процент выполнения
Ключевые слова | Ключевые слова, определенные в Управлении проектом и присвоенные в структуре проекта.

Пример

Возможны следующие сценарии анализа проекта:

· Плановые элементы без учета фактических данных

Система анализирует все элементы структуры проекта, для которых плановый срок начала находится в рамках периода, определенного для планового срока начала, и для которых еще не существует фактических данных об операциях.

Критерии анализа: номер(а) проекта(ов), период планового срока начала , фактические ресурсы = начальные значения (значения отсутствуют), остаточные ресурсы = начальные значения (значения отсутствуют).

· Незавершенные элементы

Система анализирует все элементы структуры проекта, для которых плановый срок конца находится в рамках периода, определенного для планового срока конца, и которые еще не выполнены на 100 %.

Критерии анализа: номер(а) проекта(ов), период планового срока конца , процент выполнения <100.

· Все запущенные элементы

Система анализирует все элементы структуры проекта, для которых фактический срок начала проекта (из фактических данных операций) находится в пределах периода, определенного для запуска проекта, и для которого срок фактического завершения проекта еще не наступил.

Критерии анализа: номер(а) проекта(ов), начало проекта , конец проекта = начальные значения (значения отсутствуют).

· Все выполненные элементы

Система анализирует все операции, для которых фактический срок завершения проекта (из фактических данных по статусу) находится в рамках определенного периода анализа.

Критерии анализа: номер(а) проекта(ов), период фактического завершения.

· Отдельные анализы

Можно выполнить отдельные анализы, а также сценарии анализов, описанные выше, и определить их в качестве анализов по умолчанию. Для сравнения отдельных значений, полученных в результате анализа, возможно вычисление сумм столбцов.

Например, это необходимо в случае реализации нескольких проектов при обнаружении ошибок в расчете плановых ресурсов и, следовательно, возможном увеличении требуемого количества времени.

Для выполнения проверки отношения между плановыми и фактическими ресурсами следует проанализировать все элементы или операции, которые еще не выполнены на 100 %. Затем необходимо вычислить итог для столбцов Плановые ресурсы, Фактические ресурсы и Остаточные ресурсы на основе результатов анализа.

Критерии анализа: номер(а) проекта(ов), плановые ресурсы, фактические ресурсы, остаточные ресурсы, процент выполнения <100.

(Мой) Рабочий список

Выполните просмотр всех структурных элементов, присвоенных одному или нескольким членам проектной группы как исполнителям.

Критерии выбора

Значение для конкретной фазы

Критерии выбора отсутствуют. Анализ выполняется в контексте проекта относительно зарегистрированного пользователя.

Значение для всех фаз

· Проект: анализируемый проект.

· Член проектной группы: один или несколько членов проектной группы, для которых следует выполнить поиск рабочих списков.

Результат

Структура проекта со статусом, членом проектной группы и логическим компонентом.

(Мой) Рабочий список по статусу

Выполните просмотр всех структурных элементов, присвоенных одному или нескольким членам проектной группы как исполнителям, согласно их статусу.

Критерии выбора

Значение для конкретной фазы

Статус: анализируемые значения статуса.
Анализ выполняется в контексте проекта относительно зарегистрированного пользователя.

Значение для всех фаз

· Проект: анализируемый проект.

· Член проектной группы: один или несколько членов проектной группы, для которых следует выполнить поиск рабочих списков.

· Статус: анализируемые значения статуса.

Результат

Структура проекта со статусом, членом проектной группы и плановым сроком завершения.

(Мой) Рабочий список по плановому сроку завершения

Выполните просмотр всех структурных элементов согласно плановому сроку завершения, т. е. дате, на которую планируется завершение обработки данным членом проектной группы.

Критерии выбора

Значение для конкретной фазы

Плановый срок завершения: плановое завершение обработки.

Анализ выполняется в контексте проекта относительно зарегистрированного пользователя.

Значение для всех фаз

· Проект: анализируемый проект.

· Член проектной группы: один или несколько членов проектной группы, для которых следует выполнить поиск рабочих списков.

· Статус: анализируемые значения статуса.

Результат

Структура проекта с плановым сроком завершения, статусом, членом проектной группы и необходимыми остаточными ресурсами.

Для получения дополнительной информации об использовании списка результатов см.:

Результаты обработки анализов проектов


 Присвоения

Присвоения

Использование

Все ссылочные структуры должны содержать определенные для концептуального проекта и соответствующие конфигурации присвоения в структурных элементах. Ссылочная структура предоставляет ракурс существующих присвоений только для конкретного элемента. Вышестоящий ракурс доступен из системы отчетов по присвоениям.

Можно выполнить следующие анализы присвоений:

На фазе концептуального проекта:

· анализ документации (общей и проектной);

· анализ транзакций в проекте внедрения и шаблонном проекте.

На фазе конфигурации:

В дополнение к присвоениям на фазе концептуального проекта:

· анализ объектов конфигурации (IMG-операций, пакетов настройки бизнес-конфигурации, инструментов CATT, документации к конфигурации);

· анализ объектов разработок (функциональных модулей, транзакций, программ, пакетов);

· анализ контрольных примеров в проекте внедрения и шаблонном проекте;

· анализ сообщений о проблемах в Управлении проблемами.

Анализы, которые могут быть выполнены в отношении объектов присвоения, перечислены в разделе Объем.

Обратите внимание на следующие различия, возникающие в зависимости от точки входа в систему отчетов:

 | Для конкретной фазы | Для всех фаз
Точка входа | Меню: Среда ® Анализ проекта ® Присвоения | Транзакция: Анализ проекта ® Концептуальный проект или Конфигурация ® Присвоения
Объем анализа | Для текущего проекта (можно перезаписать значение по умолчанию) Один или несколько членов проектной группы | Выбранные проекты Один или несколько членов проектной группы

Функциональные возможности

Критерии выбора для всех отчетов

Критерии выбора, относящиеся во всем отчетах по присвоениям:

Выбор
Критерии выбора | Описание
Проект | Необходимо определить проект в качестве значения ввода для всех фаз; дополнительно можно определить проект в качестве значения ввода для конкретной фазы (по умолчанию: текущий проект)
Системная роль | Значения статуса активации пакета настройки бизнес-конфигурации зависят от конкретной системной роли. Выберите системную роль, для которой требуется выполнить проверку статуса активации. Этой ролью, в зависимости от конфигурации, может являться роль Разработка/Пользовательская настройка.
Структура проекта | Выбор подструктуры или структурных элементов, рассматриваемых в аналитическом отчете.
Логический компонент (не для документации и сообщений о проблемах) | Анализ логических компонентов выполняется на следующих структурных уровнях: Организационные единицы Основные данные Бизнес-процессы (для отдельных шагов процесса)
Члены проектной группы | Введите одного или нескольких членов проектной группы.
Ключевые слова (не для транзакций и сообщений о проблемах) | Ключевые слова, определенные в Управлении проектом и присвоенные в структуре проекта.

Документация

Выбор
Критерии выбора | Описание
Атрибуты объектов | Введите атрибут из закладки Общая документация, Проектная документация или Конфигурация (Документация). Автор: автор последнего изменения.
Выберите закладку: · Общая документация · Проектная документация · Документация по конфигурации · Описания контрольных примеров · Учебный материал | Анализ может быть ограничен поставляемыми/созданными в шаблоне документами или определенной для проекта документацией.
Результат

Структура проекта с объектом (имя/заголовок документа), видом документа, автором, статусом и видом документа.

Транзакции

Выбор

Критерии выбора

Описание

Атрибуты объектов

Введите атрибуты из закладки Транзакции.

Выбор шаблона

Шаблоны, созданные в шаблонном проекте; только для транзакций в шаблонном проекте.

Прочие критерии выбора транзакций

· Стандартная или нестандартная транзакция

Можно ограничить анализ только стандартными транзакциями или только нестандартными транзакциями, в соответствии с классификацией на фазе концептуального проекта.

При выполнении анализа конкретной транзакции, о которой не известно, была ли она определена в качестве стандартной, не вводите данный критерий выбора. В этом случае анализируются оба альтернативных варианта.

· Транзакция, включенная в объем или не включенная в объем (только для проекта внедрения)

Ограничение анализа объемом проекта внедрения.

· Транзакция из шаблона или добавленная в проект транзакция (только для проекта внедрения)

Анализ транзакций, первоначально определенных в шаблоне, или же только транзакций, добавленных в процессе внедрения проекта.
Результат

Структура проекта с видом объекта, объектом, именем, транзакциями: определенными в объеме, стандартными, определенными в шаблоне, а также с членами проектной группы.

Транзакция в объеме проекта, отмеченная как транзакция по умолчанию, а также транзакция, определенная в шаблоне, имеет индикатор "X".

Объекты конфигурации

Выбор
Критерии выбора | Описание
Атрибуты объектов | Введите атрибуты из закладки Конфигурация.
Результат

Структура проекта с объектом, логическим компонентом, именем, статусом, членами проектной группы.

Объекты разработок

Выбор
Критерии выбора | Описание
Атрибуты объектов | Введите атрибуты из закладки Разработки.
Результат

Структура проекта с объектом, логическим компонентом, именем, статусом, членами проектной группы.

Присвоение контрольных примеров

Выбор
Критерии выбора | Описание
Атрибуты объектов | Введите атрибуты из закладки Контрольные примеры; тестовые объекты и тип тестовых объектов.
Прочие критерии выбора контрольных примеров Транзакция из шаблона или добавленная в проект транзакция (только для проекта внедрения) | Анализ контрольных примеров, первоначально определенных в шаблоне, или же только контрольных примеров, добавленных в проекте внедрения.
Ключевые слова | Ключевые слова, определенные в Управлении проектом и присвоенные в структуре проекта.
Результат

Структура проекта с видом проекта, объектом, именем, статусом, членами проектной группы.

Анализ статусов контрольных примеров

Выбор
Критерии выбора | Описание
Атрибуты объекта | Введите атрибуты из закладки Контрольные примеры; тестовые объекты и тип тестовых объектов.
Ключевые слова | Ключевые слова, определенные в Управлении проектом и присвоенные в структуре проекта.
Результат

Список анализа статусов контрольных примеров.

· Для перехода к выбору пакетов тестов для контрольного примера дважды щелкните по статусу. Теперь можно перейти к пакетам тестов, статусы которых были сгруппированы в анализе статусов при проведении тестирования (STWB_WORK).

· Для перехода к контрольному примеру дважды щелкните по имени контрольного примера.

· Для перехода к закладке Контрольный пример конфигурации структурного элемента (SOLAR02) дважды щелкните по структурному элементу.

Для получения дополнительной информации об использовании списка результатов см.:

Результаты обработки анализов проектов


 Конфигурация

Конфигурация

Использование

Существует возможность анализа данных, созданных на фазе Конфигурации, по аналогии с методом, описанным для фазы Концептуальный проект.


 Анализ IMG для всех систем

Анализ IMG для всех систем

Использование

Анализ проекта основан на информации, которая может быть записана для каждой операции проекта настройки (IMG). Необходимо заметить, что кроме вышесказанного относительно IMG-операций, также существует возможность записи и анализа информации по статусу для узлов структуры IMG-проекта.

Анализ данных может выполняться как для отдельного проекта, так и для нескольких проектов, в зависимости от объема проекта или назначения анализа.

Для перехода к анализу проекта настройки:

...

1. Вызовите транзакцию Анализ проекта .

2. В дереве структуры выберите Анализ IMG для всех систем или существующий вариант.

Также анализ проекта настройки можно выполнить в Управлении проектом.

...

1. В обзоре проектов выберите требуемый проект.

2. Выберите Перейти к ® Анализ проекта.

3. В дереве структуры выберите IMG или существующий вариант.

Функциональные возможности

Критерии выбора

Анализ одного или нескольких проектов выполняется по следующим критериям:

Критерии выбора | Описание
Общие данные проекта | Текст узла структуры IMG
Ресурсы | Руководитель проекта Члены проектной группы
Ключевые слова | Ключевые слова
Статус | Статус Процент выполнения
Сроки | Плановый срок начала Конец нормативного срока Запуск проекта Завершение проекта
Рабочие ресурсы | Плановые ресурсы Фактические ресурсы Оставшиеся ресурсы (требуемые работы);
Документация | Виды документации
Текст примечания | Примечание
Административные данные | Дата создания Автор Дата последнего изменения Автор последнего изменения

Возможны следующие сценарии анализа проекта:

· Плановые операции без учета фактических данных

Система анализирует все операции, для которых плановый срок начала находится в рамках периода, определенного для планового срока начала, и для которых еще не существует фактической информации по статусу.

Критерии анализа: номер(а) проекта(ов), период планового срока начала , фактические ресурсы = начальные значения (значения отсутствуют), остаточные ресурсы = начальные значения (значения отсутствуют).

· Незавершенные операции

Система анализирует все операции, для которых плановый срок конца проекта находится в рамках периода, определенного для планового срока конца , и которые еще не выполнены на 100 %.

Критерии анализа: номер(а) проекта(ов), период планового срока конца , процент выполнения <100.

· Все запущенные операции

Система анализирует все операции, для которых фактический срок начала проекта (из фактической информации по статусу) находится в пределах периода, определенного для запуска проекта , и для которого срок фактического завершения проекта еще не наступил.

Критерии анализа: номер(а) проекта(ов), период запуска проекта , конец проекта = начальные значения (значения отсутствуют).

· Все выполненные операции

Система анализирует все операции, для которых фактический срок завершения проекта (из фактических данных по статусу) находится в рамках определенного периода анализа.

Критерии анализа: номер(а) проекта(ов), период фактического срока завершения.

· Отдельные анализы

Можно выполнить отдельные анализы, а также сценарии анализов, описанные выше, и определить их в качестве анализов по умолчанию. Для сравнения отдельных значений, полученных в результате анализа, возможно вычисление сумм столбцов.

Например, это необходимо в случае реализации нескольких проектов при обнаружении ошибок в расчете плановых ресурсов и, следовательно, возможном увеличении требуемого количества времени.

Для выполнения проверки отношения между плановыми и фактическими ресурсами следует проанализировать операции, которые еще не выполнены на 100 %. Затем необходимо вычислить итог для столбцов Плановые ресурсы, Фактические ресурсы и Остаточные ресурсы на основе результатов анализа.

Критерии анализа: номер(а) проекта(ов), плановые ресурсы, фактические ресурсы, остаточные ресурсы, процент выполнения <100.


 Сообщения о проблемах

Сообщения о проблемах

Использование

Можно выполнить отчет по созданным сообщениям о проблемах и просмотреть статус этих сообщений. Эта задача может включать в себя, например, следующие сценарии использования:

· Анализ всех сообщений о проблемах со статусом Открыто.

· Анализ сообщений о проблемах, созданных определенным пользователем, например, непосредственно выполняющим анализ сотрудником.

· Проверка статуса обработки всех сообщений с приоритетом Очень высокий.

Интеграция

В ходе анализа используются данные, созданные на фазе конфигурации на закладке Сообщения о проблемах.

Функциональные возможности

Критерии выбора

Критерии выбора | Описание
Структура проекта | Выбор подструктуры или структурных элементов, подлежащих анализу.
Члены проектной группы | Введите одного или нескольких членов проектной группы.
Атрибуты объектов · Сообщение · Описание · Статус · Приоритет · Тема · Автор · Обработчик · Время создания Время изменения | · Номер сообщения · Краткий текст сообщения · Приоритет сообщения от Низкий до Высокий · Компонент – Тип сообщения

Результат

Структура проекта с существующими значениями критериев выбора.

· Для перехода непосредственно к обработке сообщений о проблемах дважды щелкните по строке в списке результатов (не является структурным элементом).

· Для перехода непосредственно к закладке Сообщения о проблемах структурного элемента на фазе конфигурации в структуре проекта дважды щелкните по структурному элементу.


 Организация тестирования: Анализ с помощью инфо-системы статусов

Организация тестирования: Анализ с помощью инфо-системы статусов

Использование

Эта функция позволяет контролировать динамику процесса одного или нескольких планов тестирования.

Предпосылки

Планы тестирования уже созданы.

Функциональные возможности

Инфо-система статусов может использоваться в следующих целях:

· просмотр результатов выполнения планов тестирования в графическом или табличном представлении;

· просмотр анализа статусов отдельных планов тестирования, экспорт в приложения Office или печать;

· просмотр и анализ сообщений о проблемах планов тестирования.

Операции

Способы вызова инфо-системы статусов:

· Из транзакции Анализ проекта:

...

a. Вызовите транзакцию Анализ проекта .

b. В дереве структуры выберите вариант отчета Тест ® Анализ статуса плана тестирования.

c. Выберите проект, подлежащий анализу, и затем выберите Выполнить.

· Из транзакции Конфигурация:

В Конфигурации выберите функцию меню Среда -> Анализ проекта ® Тест.

· Из Управления планами тестирования:

В Управлении планами тестирования выберите экранную кнопку Инфо-система статусов.

См. также:

Анализ статуса тестирования

Обзор проблем с планами тестирования

Организация тестирования: Анализ тестов по процессам


 Организация тестирования: Анализ тестов по процессам

Организация тестирования: Анализ тестов по процессам

Использование

Функция Анализ статуса проекта используется для контроля динамики тестирования в проекте по процессам для всех планов тестирования. Она позволяет выяснить, в каком плане тестирования и пакете тестов используется данный контрольный пример (если используется вообще).

Интеграция

Функция Анализ инфо-системы статусов (анализ статуса плана тестирования) позволяет выполнять анализ статуса контрольных примеров по планам тестирования или пакетам тестов, в которых встречается конкретный контрольный пример. Анализ тестов по процессам (анализ статуса проекта ) позволяет просмотреть статусы контрольных примеров для всех планов тестирования.

Предпосылки

· Контрольные примеры присвоены структуре проекта.

· Контрольные примеры включены в созданный план тестирования.

· Контрольные примеры включены в пакет тестов.

Функциональные возможности

Выбор

Критерии выбора

Критерии выбора | Описание
Структура проекта | Выбор подструктуры или структурных элементов, подлежащих анализу.
Логический компонент | Анализ логических компонентов, присвоенных структурным элементам.
Члены проектной группы | Введите одного или нескольких членов проектной группы.
Атрибуты объектов | Введите атрибуты из закладки Контрольные примеры; тестовые объекты и тип тестовых объектов.
Статус | Статус контрольного примера
Ключевые слова | Ключевые слова, определенные в Управлении проектом и присвоенные в структуре проекта.

Операции

Вызовите анализ тестов по процессам в транзакции Анализ проекта (SOLAR_EVAL) ® Тест ® Анализ статуса проекта.


 Системная среда

Системная среда

Использование

Функция Системная среда в анализе проекта (SOLAR_EVAL) используется для определения порядка присвоения компонентов определенным шагам процессов.

Функциональные возможности

Критерии выбора

Критерии выбора | Описание
Структура проекта | Выбор подструктуры или структурных элементов, подлежащих анализу.
Логические компоненты | Как правило, логический компонент соответствует продукту, например, SAP CRM.

Результат

Структура проекта с логическими компонентами и логическими системами.


 Анализ проекта

Анализ проекта

Предпосылки

Для обеспечения возможности анализа проектов следует сохранить информацию о фазах проекта на этапе Реализация проекта.

Подробные данные организации тестирования здесь не рассматриваются. Для получения дополнительной информации см. Анализ статуса тестирования.

Предпосылки

Выполнен переход к первому экрану выполняемой программы.

Последовательность шагов

...

1. Введите номер проекта, который требуется проанализировать.

Для выполнения анализа, выходящего за рамки одного проекта, можно определить диапазон номеров проектов.

2. Рекомендуется ограничить анализ проекта определенными критериями.
Если критерии выбора не определены, по умолчанию выполняется анализ по всем критериям выбора.

Можно осуществить выбор по начальным значениям по пути Обработать ® Критерии выбора.

Требуется выбрать все элементы, обработка которых была запущена, но еще не завершена. Введите срок начала проекта (фактический срок начала) и путем двойного щелчка по полю выбора установите срок завершения проекта (фактический срок завершения) на его начальное значение. Появится диалоговое окно Выбор по начальному значению. Выберите = (Отдельное значение) и Дальше. Оставьте поле выбора незаполненным.

3. Для запуска анализа проекта выберите Выполнить.

Можно сохранить данные выбора в качестве варианта на первом экране соответствующего типа программы для дальнейшего использования в качестве стандартного анализа.

Ў Выберите Перейти к ® Варианты ® Сохранить как вариант…

Ў Присвойте варианту соответствующее имя и описание (краткий текст) и сохраните его.
Этот вариант присваивается в качестве варианта типа программы в диалоговом окне Анализ проекта.

Ў Пиктограмма варианта на первом экране типа программы указывает на наличие вариантов программы.
Для просмотра выбора стандартных вариантов для определенный программы используется путь по меню Перейти к ® Варианты ® Просмотреть…; вызов варианта также возможен путем двойного щелчка непосредственно в диалоговом окне Анализ проекта.

Для получения дополнительной информации относительно использования экрана выбора выберите Перейти к ® Справка/Экран выбора.

Результат

Результаты анализа выводятся на экран в виде иерархии. С помощью экранной кнопки Таблица можно перейти к просмотру результатов в виде таблицы.

В этом формате просмотра появляется Тип узла, содержащий тип структурного элемента (сценарий, бизнес-процесс, шаг процесса, основные данные, организационная единица). Эта информация также доступна при работе с иерархическим представлением.

Общая информация

Навигация осуществляется путем двойного щелчка по элементу в иерархии или в таблице, в зависимости от типа программы:

· Тип программы Анализ IMG для всех систем:
Переход к IMG проекта, после чего работа осуществляется в обычном порядке.
Выделяется выбранный заголовок структуры в IMG проекта.

· Программы фаз Концептуальный проект или Конфигурация:
Переход к структурному элементу в структуре проекта, для которого возможна обработка данных по статусу или другим элементам бизнес-содержимого (особая ситуация при обработке: сообщениях о проблемах).

В случае изменения информации по статусу или присвоениям бизнес-содержимого после выполнения анализа проекта следует выполнить этот анализ еще раз с целью обновления списка результатов.


 Обработка результатов анализов проектов

Обработка результатов анализов проектов

Использование

Существует несколько способов обработки результатов анализа проекта, а именно:

· сортировка результатов анализа проекта (только в табличном представлении);

· фильтрация результатов при их просмотре (только в табличном представлении);

· суммирование числовых столбцов с выводом промежуточных сумм (только в табличном представлении);

· определение и вывод на экран вариантов просмотра (только в табличном представлении);

· выгрузка результатов анализа (только в табличном представлении);

· экспорт результатов анализа в Microsoft Excel (только в табличном представлении).

Сортировка

Выполните следующие действия:

...

1. Выберите Обработать ® Сортировка по восходящей или Сортировка по нисходящей или щелкните по пиктограмме Сортировка по восходящей или Сортировка по нисходящей в аналитическом списке.

Появится список всех доступных полей.

2. Включите поля из данного списка в список полей сортировки. Последовательность полей также учитывается.

Верхнее поле сортировки в списке Поля сортировки является первым критерием сортировки.

3. Выберите Скопировать.

Аналитический список будет отсортирован в соответствии с определением.

Фильтрация

Выполните следующие действия:

...

1. В аналитическом списке выберите заголовки всех столбцов, подлежащих фильтрации.

2. Выберите Обработать ® Установить фильтр или щелкните по пиктограмме Установить фильтр.

Выберите критерии фильтрации из числа выбранных столбцов.

3. Введите значение или условие в качестве критерия фильтрации.

Можно определить интервал ограничения с помощью пиктограммы Многократный выбор. Можно воспользоваться операторами сравнения.

4. Выберите Дальше.

Список будет отфильтрован согласно выбранным критериям.

Для удаления фильтра выберите Обработать ® Удалить фильтр или воспользуйтесь экранной кнопкой Удалить фильтр.

Итоги

Выполните следующие действия:

...

1. В аналитическом списке выберите заголовки столбцов, по которым следует выполнить суммирование.

2. Выберите Обработать ® Суммировать значения или щелкните по пиктограмме Суммировать значения.

К списку будет добавлена новая строка с итоговыми суммами для выбранных столбцов.

Возможно вычисление промежуточных сумм для сортируемых столбцов.

Выполните следующие действия:

...

1. В аналитическом списке выделите заголовок столбца, содержащего значения, не подлежащие суммированию, например, заголовок столбца Члены проектной группы.

2. Выберите Обработать ® Промежуточная сумма или щелкните по пиктограмме Промежуточная сумма .

После каждого изменения в выбранном столбце будет появляться новая строка, содержащая промежуточные суммы по предварительно просуммированным значениям.

Определение и вывод на экран вариантов просмотра

Измененный формат просмотра списка результатов можно сохранить в качестве варианта просмотра для дальнейшего использования.

Выполните следующие действия:

...

1. Выберите:
Для шаблонных проектов и проектов внедрения: Параметры настройки ® Варианты просмотра ® Сохранить варианты просмотра…
Параметры настройки ® Вариант просмотра ® Сохранить…
Для проектов настройки:воспользуйтесь экранной кнопкой Сохранить вариант просмотра.

...

1. Введите имя и описание для варианта просмотра.

2. Для ограничения доступа других пользователей к этому варианту просмотра установите индикатор СпецифДляПользов.

3. При определении варианта просмотра также укажите необходимость сохранения критериев сортировки и вывода промежуточных сумм.

4. Выберите Сохранить.

Определенные параметры настройки сохранены в качестве варианта просмотра. Для его просмотра на более позднем этапе выберите:
Для шаблонных проектов и проектов внедрения: Параметры настройки ® Варианты просмотра ® Выбор варианта просмотра…

Информация о функциях ALV Grid Control содержится в документации ABAP List Viewer (ALV) в разделе Функции контекстного меню и инструментальной панели.

Ракурс проекта

Для каждого проекта в списке результатов можно создать ракурс проекта. Выполните следующие действия:

...

1. В списке результатов установите курсор на строке проекта, для которого требуется создать ракурс проекта.

2. Введите имя ракурса проекта.

3. Для перехода к ракурсу проекту выберите Просмотр ракурсов проектов/немедленно.

В ракурсе проекта можно выполнять операции в обычном порядке и вносить необходимые изменения.

4. Для возврата к аналитическому списку выберите Назад.

5. При изменении ракурса проекта необходимо выполнить анализ еще раз.

Выгрузка результатов анализа

Выполните следующие действия:

...

1. Выберите пиктограмму Локальный файл.

2. Выберите формат сохранения списка/таблицы.

3. Определите имя файла и каталог для сохранения результатов анализа.

Явно определите расширение имени файла.

4. Сохраните введенные данные.

Экспорт результатов анализа в Microsoft Excel

Существует возможность экспорта результатов анализа непосредственно в Microsoft Excel для их обработки. Выполните следующие действия:

...

1. Выберите ЭлектрТаблица .

2. В следующем диалоговом окне выберите Таблица и Microsoft Excel.

3. Экспортированную таблицу можно сохранить.


 Использование шаблонов

Использование шаблонов

Цель использования

Этот процесс содержит описание использования шаблона. Шаблоны используются следующими способами:

· Клиентом:

Ў Создаваемый пользователем шаблон может использоваться в одном или более проектах внедрения в качестве основы для концептуального проекта.

Ў Созданные в системе шаблон переносится в другие системы как основа концептуального проекта для определенного проекта клиента, например, в рамках глобального развертывания.

· Партнером:

Имеется возможность создания шаблонов и их поставки в качестве партнерских шаблонов для проектов клиентов.

Новые шаблоны можно создавать на основе любого другого шаблона, как поставляемого SAP, так и собственного.

Предпосылки

Выполнена настройка системной среды.

Для получения подробной информации об ограничениях при использовании шаблонов и шаблонных проектов см. SAP-ноту 603336.

Выполнение

Определение шаблона

...

1. В Управлении проектом SAP Solution Manager создайте проект вида Шаблонный проект.

Присвойте шаблонам имя из области имен клиента. Рекомендуется использовать область имен /…/. Для объектов в проекте следует использовать только одну область имен.

2. В качестве основы для нового шаблона можно использовать один из существующих шаблонов, которые можно просмотреть на закладке Объем в Управлении проектом.

3. Создайте структуру проекта в транзакции Концептуальный проект и присвойте транзакции, URL и документацию структурным элементам.

4. Например, присвойте элементам структуры проекта пакеты настройки бизнес-конфигурации, операции IMG и контрольные примеры, в транзакции Конфигурация.

Другие объекты создаются в системах компонентов SAP Solution Manager. Они включают в себя пакеты настройки бизнес-конфигурации, пользовательские транзакции, программы и инструменты CATT. В системах компонентов выполните следующее:

· Создайте переносимый пакет с записью переноса для каждого шаблона и логической системы.

Присвойте имена в области имен / .../, если она существует. Используйте ту же самую область имен для наименования пакетов.

· Создайте отдельный пакет и отдельный запрос на перенос для тех объектов, которые должны использоваться в нескольких шаблонах.

· После создания объектов присвойте их пакету.

· Создайте запрос на перенос для каждого шаблона и логической системы и включите в них объекты, что позволит впоследствии перенести эти объекты в правильные системы компонентов.

5. Создайте один или несколько шаблонов в этом шаблонном проекте на закладке Шаблоны в Управлении проектом.

6. На закладке Структура в транзакции Концептуальный проект с помощью справки по допустимым значениям ввода присвойте шаблоны сценариям для копирования структур сценариев в создаваемый шаблон. Для каждого сценария можно присвоить несколько шаблонов.

7. На закладке Шаблоны в Управлении проектом выберите статус видимости Общий, что приведет к возможности просмотра этого шаблона во всей системе.

8. Перенесите созданный шаблон на закладку Шаблоны в Управлении проектами.

Если шаблон будет использоваться в той системе Solution Manager, в которой он был создан, выполнять это действие не требуется.

9. Создайте новую версию шаблона в Управлении проектом для дальнейшей ее разработки.

Повторное использование шаблона в одной системе SAP Solution Manager

Общие шаблоны являются видимыми по всей системы и могут быть использованы в любом проекте в системе (см. закладку Шаблоны).

...

1. Создайте проект в Управлении проектом той системы SAP Solution Manager, в которой был создан шаблон.

2. Выполните действия, описанные в шагах 4-6 в разделе Реализация проекта внедрения с использованием шаблона в целевой системе.

Повторное использование шаблона в другой системе SAP Solution Manager

Например, в ходе глобального развертывания шаблон и его объекты могут переноситься в другие системы в качестве шаблонов для содержащегося в этой системе концептуального проекта.

Перенос шаблона в другую системную среду

...

1. В рамках глобального развертывания выполните перенос объектов, например, пакетов настройки бизнес-конфигурации или инструментов CATT, созданных ранее в исходных системах компонентов SAP Solution Manager, в целевые системы компонентов SAP Solution Manager, например, из систем компонентов в штаб-квартире в системы компонентов дочерних компаний:

a. Проанализируйте проект в исходной системе SAP Solution Manager и определите виды объектов, созданных в системах компонентов, а также компоненты, используемые для конфигурирования и присвоения контрольных примеров в шаблонном проекте.

b. Протестируйте шаблон в тестовой системе:

i. Перенесите запросы на перенос из систем компонентов в тестовую систему, в которой установлены те же продукты, что и в целевых системах компонентов, и те же их версии.

ii. Для проверки того, были ли объекты присвоены структуре проекта, выберите в тестовой системе транзакцию Концептуальный проект (SOLAR01) ® Среда ® Обновить буфер. Появится журнал ошибок со списком ошибок присвоения.

c. При положительных результатах тестирования переместите запросы на перенос из тестовой системы в целевые системы компонентов.

2. Деблокируйте перенос с использованием шаблона и передайте его в целевую систему.

Реализация проекта внедрения в целевой системе с использованием шаблона

...

1. Выполните импорт переноса с использованием шаблона в целевую систему SAP Solution Manager.

2. Выполните импорт запросов систем компонентов для данного шаблона в системы компонентов.

3. Создайте проект внедрения в Управлении проектом целевой системы.

4. Выполните поиск шаблона или шаблонов, которые требуется внедрить, на закладке Выбор шаблонов в Управлении проектом.

5. Выберите сценарии, созданные в исходной системе для этого шаблона, на закладке Выбор шаблонов в Управлении проектом.

Структура и присвоения копируются из шаблонов при выполнении транзакций Концептуальный проект и Конфигурация.

6. Выполните конфигурацию в целевых системах компонентов SAP Solution Manager.

7. Если шаблон был изменен, сравните новую версию шаблона со структурой проекта и присвоенными объектами целевой системы и при необходимости скопируйте изменения.


 Создание шаблонного проекта

Создание шаблонного проекта

Использование

При необходимости создания нового шаблона для других проектов выберите вид проекта "Шаблон". Основными шагами процесса создания шаблона являются создание структуры нового проекта и присвоение структуре бизнес-содержимого, например, предварительной конфигурации и документации.

Предпосылки

· Необходимы полномочия на изменение в транзакции Управления проектом в SAP Solution Manager (SOLAR_PROJECT_ADMIN). Эти полномочия присвоены роли руководителя проекта (SAP_SOLAR_PM).

· В SAP Solution Manager и системах компонентов должны быть созданы переносимые пакеты.

· Для получения возможности переноса шаблонов в другие системы по отдельности, например, дочерним компаниям в рамках глобального развертывания, в системе SAP Solution Manager и в системах компонентов должны быть выполнены следующие условия:

...

a. Для каждого шаблона и логической системы создан переносимый пакет с записью переноса.

Присвойте имена в области имен / .../, если она существует. Используйте ту же самую область имен для наименования пакетов.

b. Для тех объектов, которые должны использоваться в нескольких шаблонах, создан отдельный пакет и отдельный запрос на перенос.

После создания объектов присвойте их пакету.

c. Для каждого шаблона и логической системы создан запрос на перенос.

Включите объекты в запрос на перенос для обеспечения их корректного переноса в целевые системы.

· Для получения возможности создания объектов, например, пакетов настройки бизнес-конфигурации или инструментов CATT, в системах компонентов, к которым обращается SAP Solution Manager, в мандантах систем компонентов должна быть активирована запись объектов в запросы на перенос.

Последовательность шагов

...

1. Запустите транзакцию управления проектом в SAP Solution Manager.

2. Выберите пиктограмму Создать проект или путь по меню Проект -> Создать.

3. Введите имя проекта, затем выберите и подтвердите Шаблонный проект.

4. Выполните обработку данных на следующих закладках:

Закладка

Действия

Общие данные

Проверьте данные в полях Ответственный и Язык проекта и при необходимости измените эти значения.
Примечание: впоследствии изменить язык проекта будет невозможно.

Шаблоны

Создайте шаблон. Структуры, присвоения, продукты и т.д. создаваемого шаблонного проекта помещаются в шаблон, после чего шаблон передается в дочерние компании при его деблокировании в головной фирме или повторном использовании в той же системе.

Присвойте код в столбце Шаблоны и имя шаблона в столбце Имя.

После импорта шаблонов в дочерние компании все шаблоны, которым был присвоен, по крайней мере, один сценарий, выводятся на закладке Выбор шаблонов в соответствии со следующим соглашением по присвоению имен: <код> - <имя шаблона>, например, ZBANK - BANKING.

Для полного или частичного блокирования изменений шаблона в дочерних компаниях для глобального развертывания выберите Функция глобального развертывания активна на закладке Шаблоны.

См. Глобальное развертывание с использованием шаблона .

Объем

Если в качестве основы шаблона требуется использовать существующие шаблоны, выберите один или несколько шаблонов.

При необходимости создания нового шаблона выбирать существующий шаблон не требуется.

Системная среда

Определите требуемую системную среду.

Стандарты проекта

Определите значения статуса по умолчанию, ключевые слова и виды документации для шаблона.

5. Сохраните проект.

6. Определите контекст документации в Knowledge Warehouse в следующем диалоговом окне.

Контекст документа проекта определяет возможность обработки документов со стороны более чем одного проекта. При изменении пользователем документа в контексте, отличном от того, в котором этот документ был создан, документ копируется системой в новый контекст.

Во всех проектах, кроме шаблонных проектов, следует использовать один и тот же контекст и контролировать доступ посредством полномочий.

Для шаблонных проектов следует использовать отдельный контекст. Имеются следующие возможности:

· Выбор существующего префикса области имен (/.../) в справке по допустимым значениям ввода для поля Расширение и добавление текста его после второй наклонной черты вправо.

· Определение нового префикса области имен в поле Расширение. Система создает этот префикс имен с определенной версией расширения. Область имен должна иметь следующие характеристики:

· действительная лицензия в данной системе;

· роль P (продукция);

· изменяемость в данной системе.

· Создание новой версии для существующего расширения. Ограничений на версии не существует.

7. Выберите переносимый пакет или создайте такой пакет на следующем диалоговом экране.

8. Выберите Дальше.

Результат

Создан шаблонный проект. Этот шаблон можно использовать в транзакции Концептуальный проект.


 Создание и присвоение предварительной конфигурации

Создание и присвоение предварительной конфигурации

Использование

На закладке Конфигурация можно выполнить присвоение структурным элементам предварительной конфигурации в форме пакетов настройки бизнес-конфигурации, инструментов CATT или конфигураций тестов eCATT, а также присвоение транзакций или программ операциям IMG. Можно создать шаблон с предварительной конфигурацией или с операциями IMG в шаблонном проекте, который затем будет использоваться в проекте глобального развертывания для компании. Эти присвоения можно также использовать для получения возможности последующей трассировки операций IMG пользователя, а также транзакций и программ, используемых в процессе конфигурирования в проекте внедрения.

Предпосылки

Запущена транзакция Конфигурация, и выбрана закладка Конфигурация.

Последовательность шагов

Присвоение существующей предварительной конфигурации, транзакций или отчетов

...

1. Перейдите к тому структурному элементу, которому требуется присвоить предварительную конфигурацию, в структуре проекта.

2. В столбце Вид выберите Пакет настройки БК, CATT, Конфигурация тестов eCATT, Транзакция, Программа или Запрос на перенос Add-On.

3. Если структурный элемент не является шагом процесса, введите компонент из справки по допустимым значениям ввода для поля Компонент.

4. Введите значение в столбец Объект или выберите его из справки по допустимым значениям ввода для поля Объект.

5. Сохраните введенные данные.

Присвоенные объекты находятся в системах компонентов. Также можно сохранить только объекты вида "Конфигурация тестов eCATT", централизованно и в специально назначенной системе. Для получения более подробной информации см. Закладка "Контрольные примеры".

Присвоение объектов IMG

...

1. Перейдите к структурному элементу в той ссылочной структуре, которой требуется присвоить объект IMG.

2. В поле Вид выберите Объект IMG.

3. Если структурный элемент не является шагом процесса, введите компонент из справки по допустимым значениям ввода для поля Компонент.

4. Вызовите справку по допустимым значениям ввода для поля Объект. Произойдет переход к руководству по внедрению (IMG) выбранной системы компонентов.

5. Выберите один или несколько узлов объектов IMG и нажмите Выбрать.

6. Выберите Скопировать выбранные узлы.

Теперь объект IMG присвоен структурному элементу. Происходит возврат к закладке Конфигурация и автоматическое заполнение столбцов Объект и Описание.

Создание и присвоение предварительной конфигурации

...

1. Перейдите к тому структурному элементу, которому требуется присвоить предварительную конфигурацию, в структуре проекта.

2. Выберите Вид.

3. Для создания нового пакета настройки бизнес-конфигурации, инструмента CATT или конфигурации тестов eCATT на закладке Конфигурации введите имя в поле Объект и выберите Создать.

4. В зависимости от вида объекта, будет выполнен переход к одной из следующих транзакций:

Ў Пакет настройки бизнес-конфигурации: Ведение пакета настройки БК;

Ў Конфигурация тестов eCATT: Конфигурация тестов (инструмент eCATT);

Ў CATT: Изменение контрольного примера.

5. Введите данные, необходимые для создания нового пакета настройки бизнес-конфигурации, конфигурации тестов eCATT или инструмента CATT.

См. также:

· Создание пакетов настройки бизнес-конфигурации

· Создание/обработка контрольных примеров

· Создание объектов eCATT

Для получения дополнительной информации об использовании пакетов настройки бизнес-конфигурации см. Пакеты настройки бизнес-конфигурации в библиотеке SAP. Для получения дополнительной информации об использовании CATT и eCATT см. Инструментальные средства тестирования в библиотеке SAP.


 Глобальное развертывание с использованием шаблона

Глобальное развертывание с использованием шаблона

Цель использования

При глобальном развертывании в головной фирме выполняется определение одного или более шаблонов, содержащих сценарии, документы концептуальных проектов и конфигурацию.

Можно определить, какие компоненты шаблона релевантны для дочерних компаний, а также то, могут ли эти дочерние компании изменять шаблон в проектах развертывания, и в какой степени.

Централизованно определенный шаблон переносится в дочерние компании. В дочерних компаниях этот шаблон используется в проекте внедрения для реализации решений в соответствии с инструкциями, полученными от вышестоящих инстанций.

Предпосылки

В Управлении проектом создан шаблонный проект.

Этому шаблонному проекту был присвоен переносимый пакет и запрос на перенос вида "Запрос к инструментальным средствам".

Выполнение

Определение шаблона в головной фирме

1. Создайте один или более шаблонов в шаблонном проекте в Управлении проектом головной фирмы.

2. На закладке Шаблоны в Управление проектом установите флажок Функция глобального развертывания активна .

Это означает, что дочерние компании могут в определенных рамках изменять структуры и бизнес-содержимое, полученные из этого шаблона, в соответствующих локальных проектах развертывания.

3. Присвойте значения в столбце Глобальный атрибут структурного элемента на закладке Структуры в концептуальном проекте для определения того, должен ли каждый структурный элемент в системах дочерних компаний быть обязательным, изменяемым или не изменяемым.
Для получения дополнительной информации о влиянии значения атрибута на структурный элемент в дочерних компаниях см. Глобальный атрибут при глобальном развертывании.

4. Для передачи глобального атрибута подузлам структурного элемента выберите его на закладке Структура в концептуальном проекте и нажмите кнопку Перенос глобального атрибута .

Для предотвращения наследования глобального атрибута выберите в справке по допустимым значениям ввода пустую строку для столбца Глобальный атрибут на уровне сценария.

5. Выполните требуемые операции на фазе Концептуальный проект, например, присвойте транзакции и общую документацию.

6. Выполните требуемые операции на фазе Конфигурация, например, присвойте пакеты настройки бизнес-конфигурации.

7. При необходимости внедрения шаблона в дочерних компаниях, язык проектов в которых отличается от языка проекта в шаблонном проекте головной фирмы, выполните перевод шаблона .

8. Выполните отправку шаблона.

Импорт шаблона в дочерние компании

...

1. Переместите объекты, созданные в системах компонентов SAP Solution Manager головной фирмы, в системы компонентов дочерних компаний (см. Перенос шаблона в другую системную среду в разделе Использование шаблонов).

2. Отправьте шаблон дочерним компаниям.

3. Импортируйте шаблон в дочерних компаниях (см. Импортирование шаблона в целевые системы в разделе Использование шаблона ).

4. Если шаблон был изменен, сравните новую версию шаблона со структурой проекта и присвоенными объектами целевой системы и при необходимости скопируйте изменения.

Результат

Шаблон для реализации единой конфигурации головной фирмы и дочерних компаний централизованно создан и успешно внедрен.


 Пример глобального развертывания с использованием шаблона

Пример глобального развертывания с использованием шаблона

Предпосылки

Дочерние компании включают в себя банки и страховые компании.

Выполнение

...

1. В шаблонном проекте в головной фирме создаются шаблоны ZBANK и ZINS, которые присваиваются следующим сценариям:

Шаблонный проект в головной фирме

Ў Сервис клиентов: банковское дело (ZBANK)

Ў Сервис клиентов: страхование (ZINS)

Ў Внешние службы и планирование (ZINS)

Ў Планирование сбыта: банковское дело (ZBANK)

Ў Планирование сбыта: страхование (ZINS)

Ў MSS: планирование адаптации окладов (ZBANK, ZINS)

Поскольку сценарий MSS: планирование адаптации окладов должен быть внедрен одинаково во всех дочерних компаниях, этому сценарию присвоены оба шаблона.

2. Шаблоны и их объекты, например, пакеты настройки бизнес-конфигурации и контрольные примеры, импортируются в системы дочерних компаний.

3. Дочерние компании выбирают соответствующие им сценарии в своих проектах внедрения, и присваивают им шаблон, полученный из головной фирмы:

a. Проект внедрения "Банк 1" получает шаблон ZBANK:

§ Сервис клиентов: банковское дело (ZBANK)

§ Планирование сбыта: банковское дело (ZBANK)

§ MSS: планирование адаптации окладов (ZBANK)

b. Проект внедрения "Банк 2" получает шаблон ZBANK:

§ Сервис клиентов: банковское дело (ZBANK)

§ Планирование сбыта: банковское дело (ZBANK)

§ MSS: планирование адаптации окладов (ZBANK)

c. Проект внедрения "Страхование 1" получает шаблон ZINS:

§ Сервис клиентов: страхование (ZINS)

§ Внешние службы и планирование (ZINS)

§ Планирование сбыта: страхование (ZINS)

§ MSS: планирование адаптации окладов (ZINS)


 Глобальный атрибут при глобальном развертывании

Глобальный атрибут при глобальном развертывании

Значение глобального атрибута структурного элемента определяет возможность полного или частичного изменения дочерними компаниями этого структурного элемента или запрет любых изменений этого элемента.

В нижеприведенной таблице показано влияние значений глобального атрибута (транзакция Концептуальный проект ® закладка Структура ), присвоенного структурному элементу в головной фирме, на возможность обработки структурных элементов в дочерних компаниях.

Для получения дополнительной информации о значениях глобального атрибута см. справка F1.

Глобальный атрибут при глобальном развертывании

Значение глобального атрибута | Выбор/отмена выбора структурных элементов | Структура | Изменение последовательности/вырезание/вставка | Общая документация | Проектная документация
Глобальный | Запрещено | Изменение запрещено | Изменение запрещено | Просмотр **) | Релевантный концептуальному проекту: просмотр Не релевантный концептуальному проекту: все полномочия **)
Полностью стандартный | Запрещено | Может быть расширено | Та же проверка полномочий, что и на закладке Структура *) | Просмотр | Релевантный концептуальному проекту: может быть расширен Не релевантный концептуальному проекту: все полномочия
Частично стандартный | Разрешено | Может быть расширено | Та же проверка полномочий, что и на закладке Структура *) | Просмотр | Все полномочия
Согласованный | Разрешено | Может быть расширено | Та же проверка полномочий, что и на закладке Структура *) | Просмотр | Все полномочия
Локальный | Разрешено | Может быть расширено | Та же проверка полномочий, что и на закладке Структура *) | Просмотр | Все полномочия
Начальный | Разрешено | Все полномочия | Все полномочия | Просмотр | Все полномочия

*) В случае сокращения или изменения последовательности в структуре система проверяет те же полномочия, что и полномочия для удаления структурных элементов из шаблона. Удалить структурные элементы можно только с использованием роли Руководитель проекта (SAP_SOLAR_PM).

**) При помещении шаблона в проект система копирует документацию, релевантную концептуальному проекту, из закладки Общая документация на закладку Проектная документация, для обеспечения возможности ее помещения в документ концептуального проекта.

Глобальный атрибут при глобальном развертывании (продолжение)

Значение глобального атрибута | Транзакции | Конфигурация | Разработка | Контрольные примеры | Сообщения
Глобальный | Выполнение, выбор/отмена выбора запрещены | Просмотр, активация | Просмотр, выполнение | Может быть расширено | Все полномочия
Полностью стандартный | Может быть расширено | Может быть расширено | Может быть расширено | Может быть расширено | Все полномочия
Частично стандартный | Все полномочия | Все полномочия | Все полномочия | Все полномочия | Все полномочия
Согласованный | Все полномочия | Все полномочия | Все полномочия | Все полномочия | Все полномочия
Локальный | Все полномочия | Все полномочия | Все полномочия | Все полномочия | Все полномочия
Начальный | Все полномочия | Все полномочия | Все полномочия | Все полномочия | Все полномочия

Удаление элементов из шаблона

Все полномочия на изменение и удаление элементов из шаблона имеются только у руководителю проекта . Для получения возможности удаления из шаблона структурных элементов необходимо иметь полномочия на объект полномочий S_PROJ_GEN со значением GLOB в поле PROJ_FUNC. Эти полномочия содержатся в роли Руководитель проекта (SAP_SOLAR_PM).

Члены проектной группы могут удалять из шаблона следующие элементы:

· Элементы со значениями атрибута Глобальный или Полностью стандартный:

Из шаблона не может быть удален ни один элемент.

· Элементы со значениями атрибута Частично стандартный, Согласованный или Локальный:

Ў Имеется возможность удаления из шаблона присвоений после запроса подтверждения.

Ў Члены проектной группы не могут удалять структурные элементы.


 Перевод шаблона

Перевод шаблона

Цель использования

Структура проекта и документы в проекте всегда выводятся на языке проекта, определяемом при создании проекта, и могут быть изменены только на этом языке.

Если в головной фирме был создан шаблон на языке проекта, и этот шаблон требуется предоставить дочерней компании на другом языке проекта, этот шаблон следует сначала перевести (в головной фирме), и только после этого отправить дочерней компании.

При переводе шаблона перевод становится видимым на целевом языке только в том целевом проекте, для которого целевой язык был определен как язык проекта, но не в исходном проекте. Если документ на требуемом языке перевода отсутствует, документ отображается на языке оригинала.

В головной фирме исходный проект создается с использованием английского языка проекта, после чего выполняется перевод шаблонов на японский язык.

В дочерней компании в Японии создается целевой проект на японском языке проекта. После того, как дочерняя компания скопирует шаблон в целевой проект, шаблоны и соответствующие им документы появятся в целевом проекте на японском языке.

Среда перевода

Структура проекта, имя документа

Структура проекта, имя документа и имена URL, файлов и т.д., введенные на закладках, переводятся при помощи т ранзакция перевода SE63.

Можно также перевести структуру проекта без имен документов и имен URL в концептуальном проекте (транзакция SOLAR01). Для этого следует выбрать путь по меню Перейти к ® Перевод.

Документы Knowledge Warehouse

Перевод документов Knowledge Warehouse осуществляется с помощью функции перевода Knowledge Warehouse (транзакция SI80). Все документы, созданные на закладках Общая документация и Конфигурация в исходном проекте, помещаются системой в Knowledge Warehouse в контекст проекта, в папку SOLAR00. Для каждого проекта следует создать уникальный контекст.

Присвоения структуры проекта

Переводить имена операций, IMG-объекты и программы, присвоенные структуре проекта, не требуется. Эти имена и их переводы автоматически копируются из систем компонентов при передаче шаблона.

Предпосылки

· Создан шаблон.

· В системе перевода выполнена настройка среды перевода .

Перевод выполняется в той системе, из который экспортируется массовый запрос со всем шаблоном полностью. Это может быть система разработок, система консолидации или система перевода. Все записи языка переносятся только в этом массовом запросе для шаблона.

Выполнение

...

1. Выполните перевод структуры проекта и имен документов:

a. Для перевода только структуры проекта выберите структурный элемент в концептуальном проекте (транзакция SOLAR01) и выберите Перейти к ® Перевод.

b. Для перевода структуры проекта и имен документов, URL и файлов:

i. Выполните присвоение пакета или пакетов в проекте переводчику в данной системе перевода .

ii. Создайте рабочие списки для пакетов в проекте.

iii. После этого переводчик выполняет перевод присвоенных ему пакетов.

2. Перевод документов Knowledge Warehouse выполняется переводчиком в контексте проекта в папке SOLAR00.

3. После этого следует деблокировать шаблон в Управлении проектом и отправить его адресатам.

4. При каждом изменении структуры проекта и/или документации в переведенном шаблоне в головной фирме, перед передачей шаблона дочерним компаниям в головной фирме должен быть выполнен перевод измененных элементов.

Если шаблон был переведен, следует переводить также каждое изменение, поскольку в противном случае эти изменения не будут отображаться на языках проектов дочерних компаний.


 Управление решениями

Управление решениями

Цель использования

Операции SAP Solution Manager позволяют выполнять настройку, управление и контроль систем и бизнес-процессов в рамках определенного решения. Можно использовать как комплексные решения, так и отдельные системы, бизнес-процессы и компоненты программного обеспечения. Также существует возможность настройки и использования собственных методов поддержки решения.

Интеграция

SAP Solution Manager для оперативной обработки обеспечивает инфраструктуру для интеграции служб поддержки SAP и включенных в эти службы процедур системного администрирования.

Функциональные возможности

Имеются следующие возможности:

· просмотр обзора решений;

· создание и удаление решений;

· активация и деактивация решений.

Также имеется возможность выполнения самодиагностики одного или всех решений.

Операции

...

1. Создание нового решения

2. Активация и деактивация решения

3. Удаление решения

4. Выполнение самодиагностики SAP Solution Manager


 Навигация при оперативной обработке

Навигация при оперативной обработке

Структура

Настройка параметров операций

Область Настройка операций включает в себя данные и функции, необходимые для настройки систем и бизнес-процессов решения.

В области Настройка операций содержатся объекты, принадлежащие различным типам сервисов (например, SAP-технология, общая стратегия), которые присвоены данному решению (например, сервисы, документы и диаграммы).

Каждый тип сервиса (например, SAP-технология) содержит несколько подтипов (например, контроль, администрирование). Подтип может включать закладки, например:

· Рабочая область

Рабочая область представляет собой обзор всех релевантных для этой области объектов, например:

Ў Лучшие документы для данной темы, например:

§ упрощенная техническая реализация,

§ управление средой решения,

§ рекомендации по использованию функций SAP Solution Manager;

Ў Ссылки на сервисы;

Ў Ссылки на создание режимов, например:

§ администрирование,

§ система отчетов по уровню сервиса,

§ контроль бизнес-процессов.

· Графика решения

Графика решения служит для графического представления систем и системных компонентов решения, например:

Ў Контроль системы: графическое представление критических предупреждений;

Ў Администрирование центральной системы: просмотр открытых задач.

Операции

Область Операции включает в себя данные и функции, необходимые для выполнения задач по управлению и контролю в данном решении.

В области Операции содержатся объекты, принадлежащие различным типам сервисов (например, SAP-технология, общая стратегия), которые присвоены данному решению (например, сервисы, документы и диаграммы).

Каждый тип сервиса (например, SAP-технология) содержит несколько подтипов (например, контроль, администрирование). Подтип может включать закладки, например:

· Рабочая область

Рабочая область представляет собой обзор всех релевантных для этой области объектов, например:

Ў Ссылки на режимы:

§ предупреждение SAP EarlyWatch,

§ контроль системы,

§ система отчетов по уровню сервиса,

§ контроль бизнес-процессов.

· Графика решения

Графика решения служит для графического представления систем и системных компонентов решения, например:

Ў Контроль системы: графическое представление критических предупреждений;

Ў Администрирование центральной системы: просмотр открытых задач.

Для переключения между областями можно выбрать один из двух способов:

Ў ярлыки в левой области экрана,

Ў пунктПерейти к в верхней правой области экрана.

Также имеются следующие возможности:

§ переход к обзору активных решений;

§ открытие других активных решений;

§ установка параметров настройки решения.

Эти действия выполняются из области Настройка операций.


 Обзор активных решений

Обзор активных решений

Определение

В этом ракурсе представлены все активные решения в среде решений SAP Solution Manager. Если решения еще не выбраны, этот список пуст.

Использование

Из этого обзора можно выполнить следующее:

· создание нового решения;

· открытие существующего решения;

· деактивацию решений;

· активацию деактивированных решений;

· вызов функций контроля решений;

· настройку автоматического обновления.

При первом вызове транзакции SOLUTION_MANAGER происходит переход к обзору Активные решения. Если какое-либо из тих решений уже было открыто пользователем, переход к тому решению, которое вызывалось последним. Для перехода к обзору Активные решения выберите Перейти к ® Обзор сред решений.

Структура

Разверните решение для просмотра статуса проектов и компонентов решения. С этого экрана также можно перейти к некоторым областям контроля. Для просмотра обзора статусов всех решений выберите Развернуть решение.

Функции в обзоре статусов решений

Имя решения

Выбор имени решения для доступа к последней из вызывавшихся ранее областей.

Обновление

Обновление информации по статусу решения.

Приведены дата и время последнего обновления данных статуса. Информация по статусу каждого решения сохраняется в буфере и доступна только для просмотра.

Автоматическое обновление: можно задать интервал автоматического обновления для всех активных решений (в минутах). Этот интервал должен быть между 5 и 10 минутами. Для деактивации автоматического обновления задайте значение 0.

Статус

Показывает количество объектов (проектов, процессов или сервисов) с красным, желтым, зеленым или серым статусом.

Красный светофор обозначает серьезные ошибки или предупреждения. Продолжение выполнения системной операции практически невозможно.

Желтый светофор предупреждает о проблемах, на которые следует обратить внимание, но которые не являются в настоящее время критическими. Возможно продолжение выполнения системной операции.

Зеленый светофор означает, что данное значение находится в допустимых пределах.

Серый светофор говорит об отсутствии в системе информации относительно статуса данного объекта.

Внедрение/Расширение

Обзор проекта внедрения.

Ведение/Оптимизация

Настройка решения для анализа требований к проекту и отслеживания проблем.

Операции

План сервиса. Существует возможность планирования SAP-сервисов или заказа сервисов в SAP.

Компоненты/системы

Контроль систем компонентов.

Процессы

Контроль бизнес-процессов.


 Создание решения

Создание решения

Использование

Необходимо создать новое решение.

Предпосылки

При создании нового решения требуется указать номер клиента, номер инсталляции и трехзначный системный идентификатор. (Как правило, это идентификатор базы данных.) При помощи этих данных можно контролировать доступ к решениям путем ограничения доступа пользователей к решениям по определенному номеру клиента, номеру инсталляции или системному идентификатору.

Последовательность шагов

...

1. Выберите обзор активных решений.

Для вызова обзора из решения выберите Перейти к ® Обзор сред решений.

2. Выберите Нов.

Будет выполнен переход к экрану создания нового решения.

На этом экране представлена ссылка на информацию о правовых условиях и поля данных решения. Для просмотра правовых условий необходимы полномочия на доступ к SAP Service Marketplace.

3. Введите требуемые данные.

По умолчанию предлагается номер инсталляции и системный идентификатор (идентификатор базы данных) для системы SAP Solution Manager. Предложенные значения можно изменить.

4. Выберите день для выполнения режима предупреждений SAP EarlyWatch.

5. Задайте интервал обновления для графики контроля.

Этот интервал должен быть между 5 и 10 минутами.

6. Нажмите OK.

Будет создано новое решение и произойдет переход к области Настройка операций (путь: Общая стратегия ® Среда и бизнес-процессы решения).

7. Для присвоения решению систем выберите Обработка среды.

Будет выполнен переход к ведению системной среды (транзакция SMSY).

Результат

Теперь стало возможным присваивать решению системы, подлежащие контролю и управлению.


 Активация и деактивация решений

Активация и деактивация решений

Использование

Не используемые в настоящее время решения можно деактивировать.

Неактивные решения удаляются из обзора активных решений и выводятся для просмотра на отдельном экране. Для просмотра неактивных решений выберите Просмотр неактивных решений.

Неактивные решения можно в любое время активировать.

Последовательность шагов

Деактивация решений

...

1. Выберите решение.

2. Нажмите экранную кнопку Деактивировать.

При деактивации решения его данные сохраняются. Просмотр или изменение сервисов для этого решения невозможны. При выполнении фоновых заданий неактивные решения игнорируются. Таким образом, деактивация сокращает использование решениями системных ресурсов.

Решение будет включено в обзор деактивированных решений.

Активация решений

...

1. Выберите решение в обзоре неактивных решений.

2. Выберите кнопку Активировать.

Решение будет включено в обзор активных решений.


 Удаление решения

Удаление решения

Использование

Для улучшения обзора активных решений следует удалить те решения, необходимость в просмотре которых отсутствует.

Последовательность шагов

...

1. Запустите транзакцию ABAP-редактор (SE38).

2. Выполните программу RDSMOPDELETESOLUTIONS.

3. Выберите решение в справке по допустимым значениям ввода.

4. Подтвердите запрос подтверждения.

Появится список удаленных данных.

После ввода подтверждения в диалоговое окно система удаляет данные из базы данных.

Результат

Решение удалено из базы данных.


 Самодиагностика SAP Solution Manager

Самодиагностика SAP Solution Manager

Использование

Эта функция выявляет проблемы SAP Solution Manager и среды решения и позволяет принять соответствующие меры по их устранению.

Предпосылки

Было создано решение.

Функциональные возможности

Самодиагностика может выполняться на различных уровнях:

· для SAP Solution Manager,

· для SAP Solution Manager и решения.

Операции

...

1. Выберите транзакцию SOLUTION_MANAGER.

Будет выполнен переход к экрану SAP Solution Manager: Активные решения.

2. Выполните следующее:

Ў При необходимости выполнения самодиагностики SAP Solution Manager перейдите к шагу 3.

Ў При необходимости выполнения самодиагностики SAP Solution Manager и решения сначала следует выбрать требуемое решение.

3. Выберите Перейти к ® Самодиагностика.

Появится обзор всех журналов самодиагностики в системе.

4. Для просмотра подробного текста с более полной информацией по диагностике выберите для строки Подробный текст сообщения.

При помощи кнопок в легенде можно выбрать режим показа или скрытия сообщений по видам анализа. Можно, например, скрыть все виды анализа, которые служат только для просмотра информации.


 Контроль решения

Контроль решения

Использование

Функция "Контроль решения" используется для эффективного управления гетерогенными системными средами.

Управлению при помощи этой функции подлежат следующие элементы:

· системы и

· бизнес-процессы.

Этот унифицированный обзор гарантирует высокую эффективность и доступность всех бизнес-процессов между различными системами и системными компонентами.

Интеграция

Имеются следующие возможности:

· Индивидуальное конфигурирование решения и определение компонентов, подлежащих контролю (Системная среда SAP Solution Manager).

· Использование внешних инструментов управления и сервисов, предоставляемых SAP, например, службы SAP EarlyWatch, сервисов оптимизации и самообслуживания (План сервиса ).

· Обработка сообщений о проблемах (Служба поддержки).

Функциональные возможности

Контроль решения включает следующее:

· Система отчетов по уровню сервиса (на основе предупреждения SAPEarlyWatch)

Система отчетов по уровню сервиса обеспечивает непрерывный контроль и отчетность на основе еженедельных предупреждений SAP EarlyWatch.

· Контроль системы (включая управление системой)

Контроль системы обеспечивает контроль в реальном времени над всеми системами в решении на основе системы управления вычислительным центром (CCMS).

· Контроль бизнес-процессов

Контроль бизнес-процессов обеспечивает мониторинг всех бизнес-процессов в режиме реального времени на основе графического обзора. Как и контроль системы, эта функция базируется на системе управления вычислительным центром (CCMS).

Результат

Контроль решения позволяет осуществлять мониторинг решений в следующих целях:

· выполнение базовых бизнес-процессов в соответствии с приоритетами компании;

· предотвращение ситуаций недоступности системы и критических параметров производительности;

· управление эксплуатационными затратами, связанными с использованием данного решения.


 Использование предупреждения SAP EarlyWatch

Использование предупреждения SAP EarlyWatch

Цель использования

Этот процесс позволяет выявлять потенциальные проблемы на раннем этапе, предотвращать возникновение критических ситуаций и контролировать производительность систем. Предупреждение SAP EarlyWatch позволяет контролировать важнейшие бизнес-процессы и системы.

В SAP Solution Manager предупреждение SAP EarlyWatch является сервисом, предоставляемым SAP.

Предпосылки

Установлены RFC-соединения между спутниковыми системами и системой SAP Solution Manager, а также между SAP Solution Manager и SAP Service Marketplace.

При помощи отчетов RTCCTOOL выполнена проверка доступности необходимых инструментальных средств для режима SAP-сервиса (дополнения ST-A/PI).

Для всех спутниковых систем SAPактивирован контроль предупреждений и центральная система SAP Solution Manager, и в Центре управления сервисными данными (SDCC) спутниковых систем (SAP-нота 91488) настроен Автоматический диспетчер режимов (ASM).

Системы в среде решения в SAP Solution Manager настроены.

См.: Руководство по конфигурации: SAP Solution Manager 3.1.

Выполнение

...

1. В SAP Solution Manager выполняется конфигурирование плана предупреждения SAP EarlyWatch.

В параметрах настройки решения в SAP Solution Manager запланированы сервисные режимы.

По умолчанию устанавливается значение Понедельник. Это значение не подлежит изменению.

2. Коллекторы данных в спутниковых системах еженедельно агрегируют данные соответствующей анализу системы и производительности.

3. Система передает эти данные в SAP Solution Manager путем их выгрузки через Центр управления сервисными данными (SDCC).

4. Задание SM:EXEC SERVICES инициирует обработку данных в системном режиме.

5. Дальнейшая обработка выполняется в соответствии со следующими правилами, определенными SAP в системе:

Ў Красный сигнал: критический статус/ошибка

i. Проанализируйте отчет. Система SAP Solution Manager отправляет данные в SAP.

ii. Отдел поддержки SAP анализирует возникающие проблемы и в случае необходимости связывается с пользователями для обсуждения дальнейших действий.

iii. Если предупреждение рассматривается как критическое, необходимо согласовать дальнейшие действия с SAP.

iv. Необходимо предпринять указанные меры.

Ў Желтый сигнал: критический статус/предупреждение

...

i. Проанализируйте отчет.

Ў Серый сигнал: статус неизвестен

...

i. Проверьте причину, по которой системе не удалось определить системный статус.

Ў Зеленый сигнал: без ошибок

Система отправляет начальные и ежемесячные режимы SAP через SAP Service Marketplace независимо от анализа еженедельных отчетов по предупреждениям SAP EarlyWatch.


 Предупреждение SAP EarlyWatch

Предупреждение SAP EarlyWatch

Использование

Предупреждение SAP EarlyWatch является диагностическим сервисом, предназначенным для контроля решений SAP и внешних систем в SAP Solution Manager.

Интеграция

Предупреждение SAP EarlyWatch является предпосылкой для отчетности поуровню сервиса .

Предпосылки

Установлены RFC-соединения между спутниковыми системами и системой SAP Solution Manager, а также между SAP Solution Manager и SAP Service Marketplace.

При помощи отчета RTCCTOOL была выполнена проверка доступности необходимых инструментальных средств для режима SAP-сервиса (дополнения ST-A, ST-PI).

В Центре управления сервисными данными (SDCC) для всех спутниковых систем SAP и центрального решения SAP Solution Manager (SAP-нота 91488) настроен Автоматический диспетчер режимов (ASM).

Системы в среде решения в SAP Solution Manager настроены.

См.: Руководство по конфигурации: SAP Solution Manager 3.1.

Функциональные возможности

Следующие данные спутниковых систем фиксируются раз в неделю и передаются в SAP Solution Manager:

· Общий статус компонента;

· Конфигурация системы;

· Аппаратные средства;

· Разработки для повышения производительности;

· Среднее время реакции;

· Текущая системная нагрузка;

· Сообщения о неисправимых ошибках и прерывания процессов;

· Управление базой данных.

Система обрабатывает выгруженные данные. Этот отчет можно просмотреть в виде HTML-документа. Также можно создать отчет как документ Microsoft Word. Документы можно использовать в качестве отчетов по статусам. Эти отчеты могут использоваться для анализа и предотвращения возможных проблем.

Операции

...

1. Выполнение выгрузки предупреждения SAP EarlyWatch вручную

2. Создание отчета по предупреждению SAP EarlyWatch и просмотр подробных данных режима в SAP Solution Manager

3. Сохранение, восстановление и архивирование предупреждения SAP EarlyWatch в SAP Solution Manager


 Выполнение выгрузки предупреждения SAP EarlyWatch вручную

Выполнение выгрузки предупреждения SAP EarlyWatch вручную

Использование

При настройке предупреждения SAP EarlyWatchнеобходимо проверить функцию выгрузки данных.

Необходимо узнать фактический статус данных вне зависимости от еженедельных отчетов.

Последовательность шагов

I

1. Запустите транзакцию SOLUTION_MANAGER.

2. На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений SAP EarlyWatch.

3. Выберите закладку Рабочая область.

4. Выберите Создание сервисов.

5. Выберите Создание сервиса предупреждения SAP EarlyWatch для системы.

Создается начальный сервис предупреждения SAP EarlyWatch.

Созданное предупреждение SAP EarlyWatch появляется на закладке Рабочая область с пиктограммой Ожидание выгрузки данных.

6. На закладке Рабочая область выберите для системы предупреждение SAP EarlyWatch.

Появится экран, на котором поясняется дальнейшая процедура.

Сохраните номер сервисного режима.

7. Вызовите в системе Центр управления сервисными данными (транзакция SDCC).

8. Выберите Обновить режим.

Обновление может занять некоторое время.

9. Выберите номер режима.

10. Выберите Выгрузка .

11. Для немедленного запуска выгрузки выберите Немедленный запуск задания.

Начинается выполнение фонового задания выгрузки. Статус задания можно просмотреть в журнале заданий Выбор простых заданий (транзакция SM37).

12. Обновление статуса выполняется до появления зеленого светофора для сервиса.

Обновление может занять некоторое время.

После выгрузки зеленый светофор устанавливается для переноса данных. Во время выгрузки для переноса данных отображается пиктограмма Выполнение.

13. Обновите данные в SAP Solution Manager.

Успешно выгрузка обозначается соответствующей пиктограммой в обзоре SAP Solution Manager. После этого данные предупреждения становятся доступными в SAP Solution Manager.

14. Для обработки данных режима в SAP Solution Manager выберите ссылку на предупреждения SAP EarlyWatch.

См. описание.

При помощи кнопки Запуск обработки сервиса можно самостоятельно запустить фоновое задание.

Результат

В SAP Solution Manager можно просмотреть статус данных для систем. Данные производительности относятся к последней полной неделе. Все другие данные относятся как минимум к дате выгрузке.

Можно создать отчет по предупреждению SAP EarlyWatchв виде документа Microsoft Word или HTML или просмотреть режим в режиме просмотра предупреждения SAP EarlyWatch.


 Создание отчета по предупреждению SAP EarlyWatch, просмотр подробных данных, отправка электронного письма

Создание отчета по предупреждению SAP EarlyWatch, просмотр подробных данных, отправка электронного письма

Использование

Отчет SAP EarlyWatch содержит подробную информацию относительно системного статуса, производительности, конфигурации, системных операций, управления базой данных и трендов.

Предпосылки

Выполнена обработка режима.

Для создания отчета в HTML с графическими символами должен быть установлен сервер Интернет-графики (IGS).

Для автоматической отправки отчетов в HTML по электронной почте настроен SAPconnect (см. транзакцию Администрирование SAPconnect (системный статус), SCOT). Выполнялось ведение таблицы DSMOPSOLEMAILS:

...

1. Запустите транзакцию SOLUTION_MANAGER.

Выберите "Обработать ® Автоматическая отправка электронной почты".

2. Для добавления адреса электронной почты с целью автоматической отправки отчетов выберите Создать электронные адрес.

Появится диалоговое окно.

3. Введите требуемые данные.

Выбранный отчет отправляется на определенный адрес электронной почты.

См.: Руководство по конфигурации: SAP Solution Manager 3.1.

Последовательность шагов

Создание отчета SAP EarlyWatch

...

1. Запустите транзакцию SOLUTION_MANAGER.

На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений SAP EarlyWatch.

2. Выберите закладку Рабочая область.

Отчет по предупреждению SAP EarlyWatch может быть создан в следующих форматах:

...

· HTML-документ

a. Выберите ссылку на сервис.

b. Выберите тип отчета.

HTML-отчет можно отправить по электронной почте на собственный адрес и любому количеству других получателей (экранная кнопка Добавить получателя…).

В строку можно ввести только одного получателя.

· Документ Microsoft Word

...

a. Выберите пиктограмму Создание отчета в Microsoft Word.

b. Выберите тип отчета.

После создания отчета этот документ будет использоваться как приложение.

Документ можно отправить в виде электронного письма из Microsoft Word.

Просмотр подробной информации режима

...

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений SAP EarlyWatch.

3. Выберите закладку Рабочая область.

4. Выберите Просмотр режима .

5. Подтвердите информационное диалоговое окно.

Будет выполнен переход к экрану "Режим просмотра: предупреждение EarlyWatch".

На экране Средство просмотра EWA можно просмотреть все данные в иерархическом виде и без анализа.

6. Отчеты можно создавать в виде документов Microsoft Word или HTML.

Для локального сохранения HTML-документа выберите Перейти к ® HTML-документ ® Сохранить.

Результат

Можно просмотреть созданный отчет и на основе представленных в нем данных принять соответствующие меры.


 Сохранение, восстановление и архивация предупреждения SAP EarlyWatch

Сохранение, восстановление и архивация предупреждения SAP EarlyWatch

Использование

Необходимо сохранить сервисы/документы предупреждения SAP EarlyWatch.

Необходимо восстановить сервисы/документы предупреждения SAP EarlyWatch из репозитария в обзор для проверки данных предупреждения.

Последовательность шагов

Сохранение сервиса

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений SAP EarlyWatch.

3. Выберите закладку Рабочая область.

4. Выберите Сохранить сервис.

5. Выберите сервис.

6. Выберите Сохранить сервисы.

Вернитесь к обзорному экрану предупреждений SAP EarlyWatch. Перейдите к обзору сохраненных сервисов при помощи экранной кнопки Репозитарий.

Восстановление сервиса

...

1. Выберите Репозитарий.

2. Для восстановления предупреждения SAP EarlyWatch выберите Восстановление сервиса .

Выполняется переход назад к обзорному экрану. Восстановленный сервис предупреждения SAP EarlyWatch включается в обзор. Архивируйте режимы.

Архивация сервиса

Предпосылки

Для архивации режимов сначала их необходимо сохранить.

Необходимо наличие роли SAP_SV_SOLUTION_MANAGER илиSAP_SV_SOLUTION_MANAGER_EDIT.

Система архивации не является компонентом среды SAP. Необходимо установить внешнюю систему архивации (нота 546685).

Архивация режимов вручную

...

1. В репозитарии выберите Архивация сервисов.

2. Выберите дату и подтвердите введенные данные.

Выполняется архивация режимов, созданных до определенной даты, и их приложений. Архивированные режимы и документы физически удаляются из базы данных при помощи ежедневного задания RDARCH_CLEAN_DATABASE. После этого архивированные режимы открыть невозможно. Они доступны только для просмотра.

Автоматическая архивация режимов

Существует возможность планирования архивации режимов из репозитария.

...

1. Запланируйте задание RDARCH_ARCHIVE_DATA_SOLMAN при помощи транзакции SM37.

Задание можно запланировать так, чтобы оно выполнялось периодически, например, ежедневно или для архивации всех режимов, созданных ранее, чем за десять дней.

2. В ходе выполнения задания архивируются режимы в репозитарии, созданные ранее определенной даты, и их приложения.

Доступ к заархивированным режимам и документам

Любой режим в архиве является доступным.

Заархивированные режимы можно просмотреть, однако внести изменения в них невозможно. При архивировании режимы сохраняются во внешнем репозитарии и физически удаляются из базы данных. Это позволяет сократить размер базы данных.

Результат

Можно сохранять сервисы/документы предупреждений SAP EarlyWatch и восстанавливать их из репозитария. Также можно выполнить архивацию сервисов.


 Использование системы отчетов по уровню сервиса

Использование системы отчетов по уровню сервиса

Цель использования

Система отчетов по уровню сервиса представляет собой интерфейс между отделом IT и ответственным за бизнес-процесс.

Система отчетов по уровню сервиса обеспечивает выполнение обширного анализа. Эти отчеты позволяют анализировать данные между системами и бизнес-процессами в среде решения. Таким образом, можно быстро реагировать на появляющиеся риски и непрерывно совершенствовать IT-сервис.

Предпосылки

В SAP Solution Manager настроена функция предупреждений SAP EarlyWatch.

Выполнение

1. Совместно с IT-организацией определяется соглашение об уровне сервиса . Это соглашение включает:

Ў потребности в качестве сервиса IT, например, с точки зрения производительности и безопасности;

Ў однозначные и измеримые цели сервиса;

Ў структуры связи.

2. Отчеты по уровню сервиса планируются на основе соглашения об уровне сервиса. Создаются типы отчетов по уровню сервиса. Типы отчетов по уровню сервиса являются шаблонами для отчетов по уровню сервиса. Типы отчетов по уровню сервиса определяют содержимое и объем того или иного отчета по уровню сервиса.

3. Можно определить объем отчетности по уровню сервиса, например:

Ў какие бизнес-процессы и какие системы в решении анализируются;

Ў какие проверки и пороги предупреждений необходимы;

Ў как информация представляется в отчетах;

Ў типы отчетов.

4. Система создает соответствующие режимы отчетов по уровню сервиса, которые можно обработать с целью изменения подробной информации или добавления дополнительных данных.

5. Отчет по уровню сервиса отправляется соответствующим ответственным лицам.


 Система отчетов по уровню сервиса

Система отчетов по уровню сервиса

Использование

Система отчетов по уровню сервиса используется для оптимизации и упрощения долгосрочного контроля системы. Систему отчетов по уровню сервиса можно использовать для выполнения внутренних и внешних соглашений об уровне сервиса (SLA).

Интеграция

Система отчетов по уровню сервиса основана на функциональности предупреждений SAP EarlyWatch.

Система отчетов по уровню сервиса отражает суммарную информацию о предупреждениях, полученных в результате контроля бизнес-процессов.

В случае создания в проекте бизнес-процессов можно поместить их в систему отчетов по уровню сервиса с присвоенными системами и транзакциями.

Предпосылки

В SAP Solution Manager настроена среда решения.

Между SAP Solution Manager и спутниковыми системами установлены RFC-соединения.

Для всех систем в SAP Solution Manager настроено предупреждение SAP EarlyWatch.

Функциональные возможности

Функции системы отчетов по уровню сервиса:

· Система отчетов по уровню сервиса позволяет регулярно проверять определенные основные показатели эффективности (KPI), например, доступность производственного оборудования и пороги производительности.

· В зависимости от потребностей, для системы отчетов можно настраивать различные типы отчетов по уровню сервиса, планировать операции автоматического создания отчетов по уровню сервиса и выполнять их обработку в режимах.

· Можно просматривать отчеты по уровню сервиса в виде подробных отчетов HTML или отправлять их по почте в виде отчетов Microsoft Word.

Операции

...

1. Настройка отчета по уровню сервиса

2. Обработка режима отчетов по уровню сервиса

3. Настройка отчета по уровню сервиса

4. Сохранение, восстановление и архивация отчетов по уровню сервиса


 Настройка системы отчетов по уровню сервиса

Настройка системы отчетов по уровню сервиса

Использование

Настройка нового отчета по уровню сервиса.

Предпосылки

Во всех системах в среде решения настроена функция предупреждения SAP EarlyWatch.

Для включения данных контроля бизнес-процессов в отчет по уровню сервиса необходимо сконфигурировать в SAP Solution Manager функцию контроля бизнес-процессов.

Операции

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Настройка операций выберите Общая стратегия ® Управление уровнями сервиса.

Будет выполнен переход к обзорному экрану, в котором можно настроить новые отчеты по уровню сервиса и вызвать документы по наиболее успешной практике.

3. Выберите Уровень сервиса – Настройка системы отчетов.

Будет выполнен переход к экрану Режим изменения: Настройка SLR.

4. В режиме изменения можно выполнить следующие проверки:

a. Определение типа отчета по уровню сервиса

b. Ведение общих параметров настройки

c. Определение и ведение системы для типа отчетов по уровню сервиса

d. Определение и ведение бизнес-процессов

e. Определение бизнес-процессов на основе контроля бизнес-процессов

f. Обработка данных отчета по уровню сервиса вручную


 Режим изменения системы отчетов по уровню сервиса

Режим изменения системы отчетов по уровню сервиса

Определение

В режиме изменения режима настройки определяется объем системы отчетов по уровню сервиса.

Структура

Экран разделен на три области:

· Левый столбец:

список всех проверок, которые должны быть выполнены для настройки типа отчета по уровню сервиса.

Ў Определение отчета по уровню сервиса

Ў Общие параметры настройки для отчета по уровню сервиса

Ў Выбор систем для отчета по уровню сервиса

Ў Выбор бизнес-процессов для отчета по уровню сервиса

Ў Система отчетов по уровню сервиса на основе контроля бизнес-процессов

Подпозиции проверок можно просмотреть только после выполнения и сохранения данных проверки. При наличии в системе необходимых данных эти подпроверки могут быть частично сконфигурированы предварительно.

· Правая верхняя область экрана:

Пояснения по использованию, подготовке и выполнению процедуры проверки.

Для скрытия документации переместите эту рамку.

· Правая нижняя область экрана:

Таблицы для ведения в ходе проверки.


 Ведение общих параметров настройки

Ведение общих параметров настройки

Использование

Ведение общих атрибутов типа отчета.

Последовательность шагов

...

1. Выберите проверку Общие параметры настройки для отчета по уровню сервиса.

2. На закладке Данные клиента введите данные клиента.

Это данные отображаются на титульном листе отчета по уровню сервиса.

Выберите поле и введите данные.

3. Определите время и периодичность автоматического создания отчета на закладке Планирование отчета по уровню сервиса .

Например, необходимо запланировать выполнение отчета каждые 2 месяца во вторник. Выберите день недели Вторник, период 2 и периодичность Ежемесячно.

Планирование

Планирование | Период | Периодичность
Еженедельно | 1 | Еженедельно
Ежеквартально | 3 | Ежемесячно
Ежегодно | 12 | Ежемесячно

Периодичность Ежемесячно используется для агрегации еженедельных предупреждений SAP EarlyWatch. Для получения правильных результатов ежемесячных отчетов по уровню сервиса необходимо выполнять предупреждения SAP EarlyWatch еженедельно.

4. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.


 Определение систем для отчета по уровню сервиса

Определение систем для отчета по уровню сервиса

Использование

Необходимо определить системы, подлежащие анализу.

Последовательность шагов

...

1. Выберите проверку Выбор систем для отчета по уровню сервиса.

2. Выберите системы, данные которых подлежат анализу в отчете.

3. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

4. Разверните проверку Выбор систем для отчета по уровню сервиса.

5. Выберите проверку Содержание отчета для системы.

Система по умолчанию предлагает объем анализа в отчете по уровню сервиса.

6. Разверните проверку Содержание отчета для системы.

При помощи проверок Доступность системы и Пороги системной производительности можно откорректировать доступность систем или значения порогов согласно имеющимся потребностям.

Ў Значения доступности систем

i. На закладке Доступность введите значения порогов предупреждений.

Значения порогов по умолчанию необходимо сохранить.

ii. Выберите дату и время просмотра статистики в отчете по уровню сервиса.

iii. Сохраните введенные данные.

Ў Системные значения порогов

...

i. Определите время реакции.

Среднее время реакции в диалоговом режиме не должно быть меньше среднего времени реакции базы данных.

Если значения порогов предупреждений не определены, в отчете по уровню сервиса данные предупреждений не выводятся.

Эти параметры настройки необходимо установить до переноса режимов предупреждений SAP EarlyWatch из спутниковых систем, так как эти данные используются для следующих плановых режимов предупреждения SAP EarlyWatch.


 Выбор бизнес-процессов для отчета по уровню сервиса

Выбор бизнес-процессов для отчетапо уровню сервиса

Использование

Необходимо определить бизнес-процессы, подлежащие анализу.

Последовательность шагов

...

1. Выберите проверку Выбор бизнес-процессов для отчетности по уровню сервиса.

2. Выберите бизнес-процессы, необходимые для отчета по уровню сервиса.

Если бизнес-процесс уже определен в контроле бизнес-процессов, он вводится по умолчанию. В противном случае можно выбрать любой бизнес-процесс.

3. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Выполняется переход к подузлу проверки шагов бизнес-процесса. История среднего времени реакции активируется, и для анализа выбираются ошибки при проводке в транзакциях шагов бизнес-процесса.

a. Определите транзакцию для шага бизнес-процесса.

Имя транзакции шага бизнес-процесса можно проверить путем выбора в меню Система ® Статус в данной транзакции.

b. Определите для транзакции анализы Время реакции и Ошибки обновления.

Шаги бизнес-процессов, основанные на внешнем компоненте программного обеспечения, не отображаются.

4. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

5. В случае необходимости определите порог предупреждения для бизнес-процесса.

6. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

В случае определения бизнес-процессов в Контроле бизнес-процессов выполняется переход к связанной проверке.


 Выбор бизнес-процессов в контроле бизнес-процессов

Выбор бизнес-процессов в контроле бизнес-процессов

Использование

В контроле бизнес-процессов определяются бизнес-процессы, подлежащие анализу.

Предпосылки

Бизнес-процессы в среде решения созданы, скопированы из проекта и подлежат контролю в функции контроля бизнес-процессов.

При наличии сконфигурированной функции контроля бизнес-процессов устанавливается флажок в столбце С контролем БП.

В случае активации функции контроля бизнес-процессов для данного бизнес-процесса устанавливается флажок в столбце Активация контроля БП.

Последовательность шагов

...

1. Выберите проверку Система отчетов по уровню сервиса на основе контроля бизнес-процессов.

2. Из среды решения выберите продуктивные бизнес-процессы, которые необходимо включить в отчет по уровню сервиса.

3. Вручную установите статус анализа как Выполнено.

4. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Выполняется переход к подузлам процессов. Выберите проверку процесса.

Можно определить, какие функции контроля и шаги агрегации данных по бизнес-процессам необходимо включить в отчет по уровню сервиса.

5. Сохраните введенные данные.


 Обработка данных отчета по уровню сервиса вручную

Обработка данных отчета по уровню сервиса вручную

Использование

Необходимо обработать существующие данные.

Последовательность шагов

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Операции выберите Общая стратегия® Управление уровнями сервиса.

Пиктограмма Данные существуют в обзоре в рабочей области SAP Solution Manager указывает на то, что данные могут быть обработаны для настройки отчета по уровню сервиса.

В случае создания нового типа отчета система первоначально предоставляет сервисные данные вне зависимости от следующей плановой даты. Изменение типа отчета становится активным только на следующую плановую дату.

3. Выберите ссылку на отчет по уровню сервиса.

Появится экран, на котором поясняется дальнейшая процедура.

4. Выберите ссылку Запуск обработки сервиса.

5. Подтвердите запуск фонового задания.

6. Обновите обзор на закладке Рабочая область.


 Создание отчета по уровню сервиса

Создание отчета по уровню сервиса

Использование

Необходимо создать отчет по уровню сервиса и отправить его ответственному лицу.

Предпосылки

Данные режима обработаны.

Для автоматической отправки отчетов в HTML по электронной почте настроен SAPconnect (см. транзакцию Администрирование SAPconnect (системный статус), SCOT). Выполнялось ведение таблицы DSMOPSOLEMAILS:

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. Выберите Обработать ® Автоматическая отправка электронной почты.

3. Для добавления адреса электронной почты с целью автоматической отправки отчетов выберите Создать электронные адрес.

Появится диалоговое окно.

4. Введите требуемые данные.

Выбранный отчет отправляется на определенный адрес электронной почты.

См.: Руководство по конфигурации: SAP Solution Manager 3.1.

Последовательность шагов

Отчет по уровню сервиса можно создавать и просматривать различными способами.

· Из обзора системы отчетов по уровню сервиса

Ў Отчет HTML

Выберите ссылку на отчет по уровню сервиса.

Отчет можно отправить по электронной почте на собственный адрес и любому количеству других получателей (экранная кнопка Добавить получателя…). В строку можно ввести только одного получателя.

Ў Документ Microsoft Word

...

i. Выберите пиктограмму Создание отчета в Microsoft Word.

ii. Выберите отчет.

После создания отчета этот документ будет использоваться как приложение.

Документ можно отправить в виде электронного письма из Microsoft Word.

· Из данных режима отчетности по уровню сервиса

При помощи кнопок HTML-документ и Документ MS Word можно соответственно просмотреть отчет в виде HTML и создать отчет в формате Microsoft Word.

Для локального сохранения HTML-документа выберите Перейти к ® HTML-документ ® Сохранить.

Результат

Можно просмотреть созданный отчет по уровню сервиса и отправить его ответственному лицу.


 Сохранение, восстановление и архивация отчетов по уровню сервиса

Сохранение, восстановление и архивация отчетов по уровню сервиса

Использование

Отчеты по уровню сервиса, более не требуемые в обзоре, должны быть сохранены.

Сохраненные отчеты по уровню сервиса можно восстановить.

Отчеты по уровню сервиса можно заархивировать.

Последовательность шагов

Сохранение сервиса

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Операции выберите Общая стратегия® Управление уровнями сервиса.

Будет выполнен переход к рабочей области для всех отчетов по уровню сервиса.

3. Выберите Сохранить сервисы.

4. Выберите отчет по уровню сервиса, подлежащий сохранению.

5. Выберите Сохранить сервисы.

Выполняется переход назад к обзорному экрану. Переход к обзору сохраненных отчетов по уровню сервиса выполняется при помощи экранной кнопки Сохраненные отчеты.

Восстановление сервиса

...

1. Выберите экранную кнопку Сохранить.

Выполняется переход к обзору сохраненных отчетов по уровню сервиса.

2. Для восстановления отчета по уровню сервиса выберите Восстановить сервис.

Выполняется переход назад к обзорному экрану. Восстановленный отчет по уровню сервиса включается в обзор.

Архивация сервиса

Предпосылки

Для архивации отчетов сначала их необходимо сохранить.

Необходимо наличие роли SAP_SV_SOLUTION_MANAGER илиSAP_SV_SOLUTION_MANAGER_EDIT.

Система архивации не является компонентом среды SAP. Необходимо установить внешнюю систему архивации (нота 546685).

Архивация режимов вручную

...

1. В репозитарии выберите Архивация сервисов.

2. Выберите дату и подтвердите введенные данные.

Выполняется архивация отчетов, созданных до определенной даты, и их приложений. Архивированные отчеты и документы физически удаляются из базы данных при помощи ежедневного задания RDARCH_CLEAN_DATABASE. После этого архивированные отчеты открыть невозможно. Они доступны только для просмотра.

Автоматическая архивация режимов

Существует возможность планирования архивации отчетов из репозитария.

...

1. Запланируйте задание RDARCH_ARCHIVE_DATA_SOLMAN при помощи транзакции SM37.

Задание можно запланировать так, чтобы оно выполнялось периодически, например, ежедневно или для архивации всех отчетов, созданных ранее, чем за десять дней.

2. В ходе выполнения задания архивируются отчеты в репозитарии, созданные ранее определенной даты, и их приложения.

Доступ к заархивированным режимам и документам

Любой отчет в архиве является доступным.

Заархивированные режимы можно просмотреть, однако внести изменения в них невозможно. При архивировании отчеты сохраняются во внешнем репозитарии и физически удаляются из базы данных. Это позволяет сократить размер базы данных.

Результат

Отчеты по уровню сервиса можно сохранять и восстанавливать их из репозитария. Отчеты по уровню сервиса можно заархивировать.


 Обработка режима отчета по уровню сервиса

Обработка режима отчета по уровню сервиса

Использование

Для отчета по уровню сервиса необходимы подробные данные режима. Следует выполнить обработку режима для добавления дополнительной информации об ответственном за бизнес-процесс.

Последовательность шагов

Straten ...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Операции выберите Общая стратегия® Управление уровнями сервиса.

Будет выполнен переход к рабочей области для всех отчетов по уровню сервиса.

3. Выберите Обработка режима.

Выполняется переход к экрану Режим изменения: система отчетов по уровню сервиса .

Можно определить обработчиков предупреждения.

a. Выберите проверку Последующая обработка предупреждений EW.

§ После обработки предупреждения установите флажок Обработано.

§ При необходимости отложить обработку предупреждения введите дату в столбце Отложено до.

b. Сохраните введенные данные.

При сохранении заполняются оставшиеся поля.


 Контроль системы

Контроль системы

Использование

Функция "Контроль системы" позволяет контролировать системы в режиме реального времени.

Интеграция

Контроль системы базируется на концепции архитектуры мониторинга .

Предпосылки

Было создано решение.

Между SAP Solution Manager и спутниковыми системами установлены RFC-соединения.

· Для создания RFC-соединения в системной среде (транзакция SMSY) установлен флажок Присвоение RFC-адреса для контроля системы.

Выполните следующие действия:

...

i. Выберите систему SAP Solution Manager компонентов среды.

ii. Создайте RFC-соединение на закладке Манданты.

iii. Установите флажок Присвоение RFC-адреса для контроля системы.

· В системной среде SAP Solution Manager (транзакция SMSY) введены все необходимые данные относительно балансирования нагрузки.

Выполните следующие действия:

...

i. Выберите систему SAP Solution Manager компонентов среды.

ii. Создайте RFC-соединение на закладке Манданты.

iii. Определите Атрибуты RFC-адреса .

Операции

...

1. Настройка контроля системы

2. Настройка пользовательских предупреждений

3. Просмотр предупреждений в графике предупреждений

4. Сброс предупреждений


 Режим изменения контроля системы

Режим изменения контроля системы

Определение

В режиме изменения в ходе режима настройки контроля системы определяются системы и пороги контроля предупреждений.

Структура

Экран разделен на три области:

· Левый столбец:

список всех проверок, которые должны быть выполнены для настройки контроля системы для решения.

Ў Проверки для всех систем

...

i. Активация контроля

ii. Настройка RFC-соединений для контроля

iii. Копирование настройки

Ў Специфичные для системы подпроверки

...

i. Настройка контроля для системы SAP

ii. Пользовательские предупреждения

Ў Дополнительные компоненты аппаратных средств (необязательно)

Ў Дополнительные компоненты программного обеспечения (необязательно)

Виды проверок, специфичных для системы, определяется согласно конфигурации среды решения.

Подпозиции проверок можно просмотреть только после выполнения и сохранения данных проверки. При наличии в системе необходимых данных эти подпозиции частично конфигурируются предварительно.

· Правая верхняя область экрана:

Пояснения по использованию, подготовке и выполнению процедуры проверки.

Для скрытия документации переместите эту рамку.

· Правая нижняя область экрана:

Таблицы для ведения в ходе проверки.


 Настройка контроля системы

Настройка контроля системы

Использование

Необходимо определить предупреждения CCMS, отображаемые в графике предупреждений SAP Solution Manager.

Операции

1. Запустите транзакцию SOLUTION_MANAGER.

2. На экране Настройка операций выберите SAP-технология ® Контроль.

3. Выберите закладку Рабочая область.

Будет выполнен переход к обзорному экрану, с которого можно перейти к настройке контроля системы в режиме изменения и вызвать документы по наиболее успешной практике.

4. Выберите Настройка контроля системы.

Будет выполнен переход к экрану Режим изменения: Контроль решения.

5. В режиме изменения можно выполнить следующие проверки:

a. выбор активных систем;

b. RFC – проверка соединения для контроля системы;

c. выполнение проверок, специфичных для систем и системных компонентов;

d. копирование настройки по умолчанию;

e. вставка дополнительных компонентов аппаратных средств (необязательно);

f. вставка дополнительных компонентов программного обеспечения (необязательно).


 Выбор активных систем

Выбор активных систем

Использование

Необходимо выбрать системы, подлежащие контролю.

Последовательность шагов

...

1. Выберите проверку Активация контроля.

По умолчанию активируются все системы.

2. Для деактивации систем, не подлежащих контролю, снимите флаг Активно?.

В список включаются только ABAP-системы.

3. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.


 Проверка RFC-соединения для контроля системы

Проверка RFC-соединения для контроля системы

Использование

Необходимо проверить доступность выбранных систем. Если RFC-соединение между системами не было определено перед настройкой контроля системы, статус этой проверки имеет красный цвет.

Последовательность шагов

Критический (красный) статус

...

1. Вызовите транзакцию Системная среда SAP Solution Manager (SMSY).

2. Создайте RFC-соединение на закладке Манданты.

3. Установите флажок Присвоение RFC-адреса для контроля системы.

4. Сохраните введенные данные.

Система определить эту проверку как некритическую в данном режиме.

Некритический (зеленый) статус

...

1. В режиме настройки контроля системы SAP Solution Manager выберите проверку Настройка RFC-соединений для контроля.

2. Проверьте записи таблицы.

3. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.


 Настройка проверки, специфичной для системы

Настройка проверки, специфичной для системы

Использование

Для систем необходимо настроить предупреждения.

Последовательность шагов

...

1. Для настройки предупреждений для системы выберите для нее проверку Система SAP.

Проверка Система SAP структурирована в соответствии с конфигурацией системной среды решения.

2. Для обеспечения доступности справки по допустимым значениям ввода для предупреждений CCMS в качестве пользовательских предупреждений в SAP Solution Manager перейдите на закладку Контекст CCMS.

3. В справке по допустимым значениям ввода выберите контекст CCMS.

4. В проверках можно активировать или деактивировать предупреждения.

a. Выберите проверку.

b. Для всех предупреждений, которые необходимо поместить в графику предупреждений или удалить из нее, установите или снимите флаг Активно?.

Для всех предупреждений, соответствующих локальным значениям CCMS, можно загрузить кофигурацию по умолчанию, предварительно определенную в SAP. В проверке Система SAP выберите Загрузить значения по умолчанию для системы R/3.

Символ перед каждой проверкой указывает на доступность предупреждений в дереве мониторинга CCMS. Значения символов поясняются в легенде.

Доступность предупреждений

Символ | Примечание
 | Предупреждение доступно: имя предупреждения было найдено в элементе дерева мониторинга локальной CCMS.
 | Предупреждение больше не доступно: имя предупреждения было найдено ранее в элементе дерева мониторинга локальной CCMS, но на данный момент отсутствует.
 | Предупреждение недоступно: имя предупреждения отсутствует в элементе дерева мониторинга локальной CCMS.
 | Предупреждение недоступно: имя предупреждения отсутствует в элементе дерева мониторинга локальной CCMS. Предупреждение деактивировано.

c. Для просмотра или изменения атрибутов активного предупреждения выберите Свойства.

Будет выполнен переход к системной транзакции Контроль: свойства и методы (RZ20). С помощью опций Следующий объект выбора и Предыдущий объект выбора можно переключаться между атрибутами активных предупреждений.

d. При необходимости установки настроек только для конкретного предупреждения, а не для группы настроек CCMS, присвоенной предупреждению, установите флаг в столбце Специфично для ид. транзакции.

В случае отметки предупреждения Специфично для ид. транзакции система игнорирует определенные параметры настройки предупреждения при копировании настроек в другие системы в дальнейшем.

e. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.


 Копирование настройки

Копирование настройки

Использование

Необходимо скопировать настройку предупреждений из одной системы или системного компонента в другую.

Последовательность шагов

...

1. Выберите проверку Копирование настройки.

2. В столбце Контекст выберите компонент, для которого необходимо скопировать параметры настройки предупреждения.

3. В качестве исходной системы выберите систему/системный компонент, который подлежащий копированию.

4. В качестве целевой системы выберите систему/системный компонент, в который необходимо выполнить копирование.

5. Для копирования системы с компонентами выберите Развернуть системы. Соответствующие поля заполняются автоматически.

Копирование настройки возможно только в случае того же вида базы данных в исходных и целевых системах/системных компонентах.

6. Для копирования пороговых значений установите флаг в столбце Пороговые значения.

7. Для установки пороговых значений для каждого предупреждения в целевой системе установите флаг в столбце Специфично для ид. транзакции.

8. Выберите Скопировать.

При возникновении противоречий система отправляет по соответствующему адресу сообщение об ошибке. Можно устранить ошибки вручную или выбрать Устранить противоречия для автоматической корректировки.

9. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.


 Вставка дополнительных компонентов аппаратных средств

Вставка дополнительных компонентов аппаратных средств

Использование

Необходимо присвоить предупреждения CCMS внешней ABAP-системы серверу аппаратных средств в системной среде решения, находящемуся в графике предупреждений.

Последовательность шагов

...

1. Выберите проверку Дополнительные компоненты аппаратных средств.

2. Выберите сервер аппаратных средств, для которого необходимо настроить предупреждения.

3. Выберите центральную систему контроля в столбце Центральная система контроля.

4. Для активации контроля установите флаг Контролировать.

5. Сохраните введенные данные путем выбора Сохранить + след. без проверки.

Осуществляется переход к следующей необработанной проверке.

6. Выберите проверку Компоненты аппаратных средств.

7. Для пользовательских предупреждений выберите Контекст CCMS.

8. Выберите проверку Настройка контроля.

9. Активируйте или деактивируйте предупреждения.

10. Выполните ведение пороговых значений.

11. Сохраните введенные данные.


 Вставка компонентов программного обеспечения

Вставка компонентов программного обеспечения

Использование

Необходимо присвоить предупреждения CCMS компоненту программного обеспечения для их отображения в графике предупреждений.

Последовательность шагов

...

1. Выберите проверку Дополнительные компоненты программного обеспечения.

2. Выберите вид и имя компонента программного обеспечения, для которого необходимо настроить предупреждения.

3. Выберите проверку Определение центральной системы контроля.

4. В столбце Центральная система контроля выберите систему с присвоенным контекстом контроля.

5. Для активации справки по допустимым значениям ввода для пользовательских предупреждений выберите Контекст CCMS.

6. Сохраните введенные данные.


 Просмотр предупреждений

Просмотр предупреждений

Использование

Необходимо просмотреть текущий статус систем. Необходимо просмотреть все открытые, т.е. еще не обработанные, предупреждения.

Предпосылки

Для системной среды решения настроена функция контроля системы.

Последовательность шагов

Выберите Создать.

1. Запустите транзакцию SOLUTION_MANAGER.

2. На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений.

3. Выберите закладку Графика решения.

На закладке Графика решения отображается графический обзор групп систем в системной среде решения, разделенный на группы систем, серверы и инстанции.

4. Просмотреть предупреждения в системах и системных компонентах можно двумя способами:

Ў Путем выбора соответствующего символа напротив одного из ее компонентов можно просмотреть все предупреждения в системе. Отсюда можно перейти к предупреждениям системных компонентов.

Ў Путем выбора ссылки компонента непосредственно можно перейти к графическому ракурсу подробных системных данных компонента и отсюда выполнять дальнейшую навигацию.

Выполнен переход к ракурсу выбранного текущего предупреждения. Этот ракурс отражает текущий статус систем и компонентов.

Просмотр предупреждений в SAP Solution Manager совпадает с контролем предупреждений CCMS в спутниковых системах. Выводится самое критическое предупреждение для всех элементов узла. Например, при наличии красного статуса у одного или нескольких компонентов системы системе соответствует красная пиктограмма.

5. Выберите Открытые предупреждения.

Этот ракурс отражает все еще не обработанные предупреждения и время их появления.

Статус выделен цветом самого критического предупреждения, которое еще не было обработано. Этот обзор не обязательно отражает текущий статус системы.

При возможности перехода к обработке предупреждения необходимо выполнить переход к поддерживаемому методу анализа предупреждений в системе.

Результат

Можно просматривать и контролировать текущий статус систем. Можно выполнить анализ еще не обработанных предупреждений, их обработку или сброс.


 Сброс предупреждения

Сброс предупреждения

Использование

Необходимо сбросить предупреждение для определенного периода во время его анализа и обработки.

Последовательность шагов

...

1. На экране Операции выберите SAP-технология ® Контроль.

Будет выполнен переход к обзору всех сервисов предупреждений.

2. Выберите закладку Графика решения.

3. Перейдите к обзору всех еще не обработанных предупреждений Открытые предупреждения.

4. Выберите предупреждение, подлежащее сбросу.

5. Выберите Сброс предупреждений.

6. Определите период, для которого необходимо выполнить сброс выбранного предупреждения.

7. Подтвердите введенные данные.

Результат

Для данного периода предупреждение не отображается.


 Определение пользовательских предупреждений

Определение пользовательских предупреждений

Использование

В решении необходимо определить предупреждение для системы, не входящей в контроль системы SAP Solution Manager.

Предпосылки

Предупреждение:

· не предлагается по умолчанию для активации в контроле системы SAP Solution Manager;

· находится в спутниковой системе CCMS.

В системной проверке выбран контекст CCMS.

Последовательность шагов

...

1. Вызовите транзакцию SOLUTION_MANAGER.

2. На экране Настройка операций выберите SAP-технология ® Контроль.

3. Выберите закладку Рабочая область.

Будет выполнен переход к обзорному экрану, из которого можно перейти к настройке контроля системы. Также можно вызвать документы по наиболее успешной практике, описывающие способы настройки контроля системы.

4. Выберите Настройка контроля системы.

Будет выполнен переход к экрану Режим изменения: Контроль решения.

5. Выберите проверку Определенные пользователем предупреждения для системы, инстанции или серверы.

6. Выберите предупреждение из справки по допустимым значениям ввода для столбца Полное имя предупреждения.

Полное имя предупреждения представляет собой имя элемента дерева мониторинга в локальной CCMS.

Система предлагает все предупреждения в контексте CCMS, определенном в проверке на системном уровне <система SAP> <SID>.

Если справка по допустимым значениям ввода пуста, проверьте, что выбранный контекст CCMS существует и доступен. При наличии системы справка по допустимым значениям ввода доступна. В противном случае проверьте RFC-соединение.

7. В столбце Имя предупреждения введите имя предупреждения.

Имя предупреждения в таблице можно перезаписать.

8. Активируйте контроль для предупреждения путем установки флага Активно?

Атрибуты предупреждений, например, методы анализа для предупреждений, можно просматривать и изменять в локальной системе CCMS. Выберите Свойства.

...

9. Сохраните введенные данные.

Результат

В графике предупреждений SAP Solution Manager и обзоре предупреждений можно просмотреть определенные пользователем предупреждения спутниковых систем.


 Администрирование центральной системы

Администрирование центральной системы

Использование

В администрировании центральной системы централизованно решаются задачи для систем в решении.

Предпосылки

Системы в среде решения в SAP Solution Manager настроены.

В системной среде решения настроены RFC-соединения между SAP Solution Manager и спутниковыми системами.

Функциональные возможности

Имеются следующие возможности:

· настройка задач для систем в решении;

· обработка задач;

· создание журналов задач.

Операции

...

1. Начальная настройка администрирования центральной системы

2. Контроль и обработка задач в режиме администрирования центральной системы

3. Настройка пользовательских задач

4. Использование графического представления


 Настройка администрирования центральной системы

Настройка администрирования центральной системы

Использование

Все проверки для режима в SAP предоставляются при неактивной опции Периодичность задач. Необходимо выполнить начальную настройку.

Предпосылки

Была создана системная среда решения.

В системной среде решения настроены RFC-соединения между SAP Solution Manager и спутниковыми системами.

Операции

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Настройка операций выберите SAP-технология ® Администрирование.

Будет выполнен переход к обзорному экрану, из которого можно вызвать Документы по наиболее успешной практике.

3. Выберите Администрирование центральной системы.

Будет выполнен переход к экрану Режим изменения: Контроль решения.

4. Надлежащим образом обработайте следующие проверки в режиме:

...

a. Выбор рабочей области администрирования и контроля

b. Ракурс задач: основные данные

c. Настройка отчетов

d. Копирование настройки

e. Основные данные пользовательских задач

f. Проверка RFC-адресов

g. Настройка журнала задач и истории журнала задач

h. Настройка резервирования и обработка апгрейда ST-SER

i. Титульный лист


 Администрирование центральной системы: режим изменения

Администрирование центральной системы: режим изменения

Определение

Режимом называется среда, разработанная специально для упрощения настройки и обработки функций для какого-либо раздела, например:

· режима контроля решения (контроля системы): установка и обработка контроля решения;

· режима сервиса (например, антивирусной проверки): процедура сервиса; считывание и анализ данных системой.

Использование

В режиме изменения в режиме выполните следующее:

· определение объема администрирования центральной системы для решения;

· контроль и обработку настройки задач.

Структура

Экран разделен на три области:

· Левый столбец – общие проверки и список групп задач.

Ў Список всех проверок, которые должны быть выполнены для настройки администрирования центральной системы для решения:

§ Выбор рабочей области администрирования и контроля

§ Ракурс задач: основные данные

§ Настройка отчетов

§ Копирование настройки

§ Основные данные пользовательских задач

§ Проверка RFC-адресов

§ Настройка журнала задач и истории журнала задач

§ Настройка резервирования и обработка апгрейда ST-SER

§ Титульный лист

Ў После обработки первой проверки Выбор рабочей области администрирования и контроля система динамически создает следующие проверки для систем со списками групп задач:

§ Общая группа задач базисного администрирования

§ Группа задач по управлению базами данных

§ Группа задач по контролю за производительностью

§ Группа задач по администрированию компонентов, например, для администрирования mySAP CRM

§ Группа пользовательских задач

· Правая верхняя область экрана:

Пояснения по использованию, подготовке и выполнению процедуры проверки.

Для скрытия документации переместите эту рамку.

· Правая нижняя область экрана:

Выполните ведение таблиц для каждой проверки.


 Выбор рабочей области администрирования и контроля

Выбор рабочей области администрирования и контроля

Использование

Необходимо определить системы, подлежащие администрированию.

Необходимо выбрать ракурс списка группы задач по умолчанию.

Последовательность шагов

Выбор систем

...

1. Выберите проверку Выбор рабочей области администрирования и контроля.

2. Выберите закладку Таблица систем SAP.

3. Отметьте системы, администрирование которых необходимо выполнить в режиме.

4. Сохраните введенные данные.

Будут созданы специфичные для компонента задачи по администрированию согласно различным видам систем.

Выбор ракурса по умолчанию

...

1. Выберите закладку Рабочая область администрирования и контроля.

2. Установите флаг для выбора ракурса по умолчанию.

Выбор ракурса определяет способ отображения системой списка групп задач и соответствующих задач.

Проверка Копирование настройки появляется только в случае выбора ракурса ENTIRE.

Ракурсы списка задач по умолчанию

Ракурс | Описание
ENTIRE (Все) | Система выводит все открытые и выполненные задачи.
TASK WORKLIST (Рабочий список задач) | Система выводит все открытые задачи.
DAILY (Ежедневные) | Система выводит все открытые ежедневные задачи.

3. Сохраните введенные данные.


 Ракурс задач: основные данные

Ракурс задач: основные данные

Использование

Необходимо определить собственные ракурсы списка групп задач.

Последовательность шагов

...

1. Выберите проверку Ракурс задач: основные данные.

2. Для создания нового ракурса выберите символ Добавить строки в Таблице основных вариантов.

Варианты по умолчанию можно изменить. При этом существующий вариант перезаписывается.

3. Введите имя.

4. Установите атрибуты ракурса в соответствующих столбцах.

5. Сохраните введенные данные.

Для активации ракурса отметьте его в проверке Выбор рабочей области администрирования и контроля.


 Настройка отчетов

Настройка отчетов

Использование

Необходимо определить содержимое специфичных для клиента отчетов.

Предпосылки

Задачи отмечены как выполненные. Выполненные задачи занесены в историю журнала задач.

Последовательность шагов

...

1. Выберите проверку Настройка отчетов.

2. На закладке Определение систем SAP для истории журнала задач выберите системы, информацию о которых необходимо включить в отчет.

3. Сохраните введенные данные.

4. Перейдите к закладке История журнала задач.

Появятся все включаемые в отчет записи, в той же последовательности, в которой они войдут в отчет.

Для просмотра истории журнала задач в виде HTML-документа выберите История журнала задач.

5. Выберите закладку Определение содержимого для истории журнала задач.

6. Для включения в отчет задач с примечаниями установите соответствующий флаг.

7. При необходимости включения в отчет только задач с примечаниями можно определить период времени в столбцах Дата начала журналов задач и Дата окончания журналов задач.

Вывод записей без примечаний можно ограничить путем настройки проверки Настройка журнала задач и истории журнала задач.

8. Сохраните введенные данные.


 Копирование стандартных настроек

Копирование стандартных настроек

Использование

Для копирования стандартных и пользовательских задач из одной системы в другую в системной среде решения необходимо скопировать задачи и соответствующую Периодичность задач.

Предпосылки

В проверке Выбор рабочей области администрирования и контроля выбран ракурс ENTIRE.

Последовательность шагов

...

1. Выберите проверку Копирование настройки.

2. Из справки по допустимым значениям ввода для столбца Исходная система выберите систему, подлежащую копированию.

3. Из справки по допустимым значениям ввода для столбца Целевая система выберите целевую систему.

4. Подтвердите диалоговое окно.

5. Сохраните введенные данные.


 Проверка RFC-соединений

Проверка RFC-соединений

...

Предпосылки

В системной среде решения настроены RFC-соединения между спутниковыми системами и SAP Solution Manager (транзакция: SMSY).

Последовательность шагов

1. Выберите проверку Проверка RFC-адресов.

Таблица содержит все подлежащие администрированию системы.

2. Из справки по допустимым значениям ввода для столбца RFC-адрес выберите RFC-соединение для целевой системы.

3. Сохраните введенные данные.


 Настройка журнала задач и истории журнала задач

Настройка журнала задач и истории журнала задач

Использование

Необходимо определить объем журналов задач, выделяемый на одну задачу, и объем истории журнала задач.

Последовательность шагов

...

1. Выберите закладку Определение размера журнала задач.

2. Определите количество записей для одной задачи, выводимое системой в журнале задач.

При наличии в журнале задач большего количества записей более старые записи будут удалены.

3. Выберите закладку Определение размера истории журнала задач.

4. Введите количество дней, для которого в системном журнале задач должны отображаться записи с примечаниями.

При сохранении проверки система удаляет записи истории журнала задач. Система автоматически реорганизует историю журнала задач.

5. Сохраните введенные данные.


 Сохранение данных клиента перед апгрейдом

Сохранение данных клиента перед апгрейдом

Использование

Необходимо сохранить данные клиента перед апгрейдом для обеспечения их доступности после апгрейда.

Необходимо сохранить настройки клиента независимо от апгрейда.

Последовательность шагов

Сохранение данных

...

1. Выберите проверку Настройка резервирования и обработка апгрейда ST-SER.

2. Введите собственный код резервирования/восстановления.

3. Выберите данные, подлежащие сохранению.

4. Выберите Резервирование.

5. Сохраните введенные данные.

Активация данных

...

1. Выберите Компоненты режима ® Повторная инициализация.

2. Выберите проверку Выбор рабочей области администрирования и контроля.

3. Отметьте все релевантные системы.

4. Выберите проверку Настройка резервирования и обработка апгрейда ST-SER.

5. Введите собственный код резервирования/восстановления.

6. Выберите Восстановить.

Сохраненные данные будут активированы повторно.

7. Сохраните введенные данные.

Удаление данных

...

1. Из справки по допустимым значениям ввода выберите код резервирования/восстановления.

2. Выберите Удалить резервные данные.

3. Сохраните введенные данные.


 Определение системных данных и начальная настройка задач

Определение системных данных и начальная настройка задач

Использование

Необходимо определить частоту появления задачи в рабочем списке.

Предпосылки

Настроена проверка Выбор рабочей области администрирования и контроля.

...

Последовательность шагов

Определение системных данных

...

1. Выберите проверку <SID; номер инсталляции; nn> системы, подлежащей администрированию.

2. Вид системы определяется на закладке Вид системы.

3. Компоненты в системе определяются на закладке Задействованные компоненты.

Эта таблица может быть обработана только при условии, что данная система является бэкэнд-системой R/3.

4. Для получения значений по умолчанию для периодичности задач выберите Загрузить периодичность по умолчанию.

5. Сохраните введенные данные.

Определение периодичности задач

...

1. Разверните проверку более высокого уровня для групп задач.

Появится список групп задач.

2. Выберите проверку группы задач.

3. Определите периодичность в справке по допустимым значениям ввода для задачи.

При настройке администрирования системы периодичность задачи в списке задач изначально устанавливается как неактивно.

4. Сохраните введенные данные.


 Настройка титульного листа отчета

Настройка титульного листа отчета

Предпосылки

Создание отчета в Microsoft Word.

Последовательность шагов

...

1. Выберите проверку Титульный лист.

2. Введите имя отчета, город и страну.

3. Сохраните введенные данные.


 Создание пользовательских задач

Создание пользовательских задач

Использование

Необходимо определить задачи, не входящие в список задач.

В проверке Копирование настройки можно скопировать пользовательские задачи в другие системы решения.

Последовательность шагов

Проверка: Основные данные пользовательских задач

...

1. Выберите проверку Основные данные пользовательских задач.

2. На закладке Группы задач выберите символ Добавить строки.

3. Введите имя группы.

4. Из справки по допустимым значениям ввода для столбца Вид операции выберите вид группы операций.

Виды операций

Вид операции | Описание
Функция | Имя функционального модуля
Программа | Имя программы
Транзакция | Код транзакции

5. Определите операцию в столбце Операция.

Описание группы: RFC-адреса

Вид операции: Транзакция

Операция: SM59

6. Сохраните введенные данные.

7. Перейдите к закладке Пользовательская задача.

8. Из справки по допустимым значениям ввода для столбца Группа выберите группу.

9. В столбце Задача выполните присвоение задачи этой группе.

Группа: RFC-адреса

Задача: Проверка RFC-соединения

10. Сохраните введенные данные.

Проверка: Системный уровень <SID> <номер инсталляции> <вид системы>

...

1. Выберите системную проверку, которой необходимо присвоить задачу.

2. Перейдите к закладке Пользовательские задачи.

3. Из справки по допустимым значениям ввода выберите задачу и группу.

4. Сохраните введенные данные.

В системах с этой группой будет создана подпроверка пользовательских задач.

Проверка: Группа пользовательских задач

...

...

1. Выберите подпроверку Группа пользовательских задач с введенным ранее именем группы.

RFC-адреса

2. Настройте пользовательскую задачу.

3. Сохраните введенные данные.


 Обработка открытых задач

Обработка открытых задач

Использование

Открытые задачи в режиме необходимо выполнять регулярно.

Предпосылки

Настройка режима выполнена ранее.

Последовательность шагов

Существует два способа обработки открытых задач.

· В режиме:

...

a. Разверните проверку систем, для которых необходимо обработать задачу.

b. Разверните проверку администрирования, для которой необходимо обработать задачу.

c. Выберите проверку для открытой группы задач.

d. Выполните выбранную задачу. В указанной системе транзакция выполняется путем нажатия экранной кнопки <Запуск xx>.

e. После выполнения задачи установите соответствующий флаг в столбце Выполнено.

Можно установить статус для одной или нескольких задач одновременно.

§ Для одной задачи:

Статус "выполнено" устанавливается путем установки флага в столбце Выполнено для задачи.

§ Для нескольких задач:

Статус устанавливается в строке статусов с помощью экранных кнопок.

Статус в строке статусов

Статус | Описание
Автоматическая оценка | Система определяет статус группы задач в соответствии со статусами входящих в нее задач.
Все задачи выполнены | Необходимо установить статус Выполнено для всех задач в таблице. Для всех задач в группе задач система устанавливает статус Выполнено.
Критическая проблема | Для группы задач вручную устанавливается статус Критический. Далее статус передается на системный уровень. При установке этого статуса автоматическая оценка для данной группы задач деактивируется. Требуется вручную сбросить этот статус для его изменения на Автоматическую оценку.

f. Введите примечание в столбце Примечание журнала .

После выполнения проверки Настройка журнала задач и истории журнала задач в отчете режима будут выведены задачи с примечаниями.

g. На закладке Дополнительные примечания журнала можно ввести дополнительные примечания.

Примечания в отчете не выводятся.

h. Описания специфичных для клиента задач можно ввести на закладке Специфичные для компании задачи.

i. Сохраните введенные данные.

Проверка получает статус Задача выполнена.

В режиме изменения в режиме может находиться только один пользователь. Изменения, внесенные в режиме просмотра, сохраняются только временно.

· Из графического представления


 Работа в графическом представлении

Работа в графическом представлении

Использование

Необходимо обработать открытые задачи в графическом представлении.

Предпосылки

Была создана системная среда решения.

В системной среде решения настроены RFC-соединения между SAP Solution Manager и спутниковыми системами.

Последовательность шагов

...

1. Запустите транзакцию SOLUTION_MANAGER.

2. В области Операции выберите SAP-технология ® Администрирование.

Будет выполнен переход к обзорному экрану, из которого можно вызвать Документы по наиболее успешной практике.

3. Выберите закладку Графика решения.

На закладке Графика решения отображается графический обзор групп систем в системной среде решения, разделенный на группы систем, серверы и инстанции.

При наличии открытых задач для системы отображается соответствующая пиктограмма.

4. Выберите пиктограмму открытых задач.

Будет выполнен переход к списку открытых задач.

5. Выберите задачу для обработки.

Будет выполнен переход в режим изменения.

6. Выполните обработку открытых задач.

7. Сохраните введенные данные.

Результат

После обработки задача удаляется из списка задач в графическом представлении.


 Служба поддержки

Служба поддержки

Использование

Эта функция используется для обработки внутренних сообщений поддержки и при необходимости передачи данных в SAP-поддержку.

Интеграция

Служба поддержки использует функции CRM и является неотъемлемой частью SAP Solution Manager.

Члены проектной группы могут создавать сообщения, централизованно обрабатываемые в службе поддержки на всех фазах проекта, например, концептуальном проекте и в течение фазы тестирования. Внутренние клиенты, т.е. конечные или ключевые пользователи, также могут создавать сообщения поддержки в любой SAP-системе. Эти сообщения поддержки обрабатываются централизованно в службе поддержки SAP Solution Manager.

Предпосылки

· Служба поддержки сконфигурирована в соответствии с руководством по конфигурации Cлужба поддержки и отслеживание проблем.

· В настройке службы поддержки установлены критерии, в соответствии с которыми входящее сообщение поддержки присваивается единице поддержки, например: приоритет, категория, регион автора. По умолчанию система присваивает сообщение поддержки отделу поддержки для компонента SAP. См. SAP-ноту 616946.

· В зависимости от функции, предоставляются следующие полномочия:

Роли и полномочия для службы поддержки и отслеживания проблем

Функция | Роль/полномочия
Конфигурация и администрирование службы поддержки | SAP_SOL_SERVTRANS_ADMIN SAP_SV_FDB_NOTIF_BC_ADMIN
Обработка сообщений поддержки и проблем (Проблемы и первоочередные задачи) | SAP_SOL_SERVTRANS
Создание сообщений и записей проблем в SAP Solution Manager | SAP_SOL_SERVTRANS_CREATE
Создание сообщений спутниковых систем по пути Справка ® Создание сообщений поддержки | SAP_SOL_SERVTRANS_CREATE Объект полномочий S_RFC, профиль S_RFC_VERS с операцией Выполнить для объекта SAPSMO*

Для получения дальнейшей информации о полномочиях для службы поддержки и отслеживания проблем см. руководство по конфигурации Служба поддержки и отслеживание проблем.

Функциональные возможности

Централизованное управление сообщениями поддержки

· Прямое создание сообщений поддержки из любой транзакции.

· Автоматический сбор важных данных о системе, в которой было создано сообщение поддержки, например, номера инсталляции, установленных компонентов программного обеспечения, операционной системы, транзакции, номера экрана.

· Автоматическое присвоение сообщения поддержки уровню поддержки.

· Центральная обработка сообщений в SAP Solution Manager:

Ў просмотр данных клиента, описания проблемы, приоритета, присоединенных документов, соглашений об уровне сервисного обслуживания (SLA);

Ў присвоение обработчика;

Ў отправка сообщений автору и другим обработчикам;

Ў перенос сообщения к другим обработчикам или отделам поддержки;

Ў создание документов и URL;

Ў присоединение документов;

Ў присвоение и контроль статуса;

Ў создание рабочего списка с условиями выбора.

Поиск и импорт SAP-нот

· Поиск SAP-нот в SAP Service Marketplace.

· Импорт SAP-нот при помощи SAP Notes Assistant:

Ў автоматическая корректировка исходного текста ABAP;

Ў адаптация изменений к уже импортированным пакетам поддержки;

Ў просмотр всех SAP-нот, импортированных в систему при помощи SAP Notes Assistant.

Внутренняя база данных решений

Решения проблем можно найти во внутренней базе данных решений. База данных решений поставляется без симптомов и решений. Внутренняя база данных решений создается при помощи функций Обработать симптомы и решения (IS01) и Обновить индекс базы данных решений (IS02). Для получения дополнительной информации о создании собственной базы данных решений см. http://help.sap.com/ ® SAP Управление связями с клиентами. ® SAP CRM 3.1 ® Поиск „сервиса клиентов (CS), базы данных решений" ® База данных решений в меню Поиск.

Интерфейс с SAP-поддержкой

Служба поддержки является интерфейсом с SAP-сервисом и поддержкой. В службе поддержки можно переносить сообщения в систему SAP и получать решения проблем.

См. также:

Для получения дополнительной информации о функциональных возможностях CRM см. http://help.sap.com/ ® SAP Управление связями с клиентами. ® SAP CRM 3.1.


 Использование службы поддержки

Использование службы поддержки

Цель использования

С помощью этого процесса внутренние клиенты или конечные или ключевые пользователи могут создавать сообщения о проблемах непосредственно из транзакции. Это упрощает взаимодействие со службой поддержки. Внутренняя служба поддержки может включать несколько отделов поддержки.

Ответственный за проблему обработчик службы поддержки может выполнять ввод симптомов во внутреннюю базу данных решений и поиск решений. Также можно выполнить поиск SAP-нот в SAP Service Marketplace. Если решение проблемы не найдено, обработчик может перенести сообщение о проблеме в последующие единицы поддержки или в SAP-поддержку и контролировать динамику обработки сообщения в службе поддержки.

Предпосылки

Служба поддержки сконфигурирована в соответствии с руководством по конфигурации Cлужба поддержки и отслеживание проблем.

Выполнение

...

Клиент или конечный или ключевой пользователь создает сообщение поддержки в меню транзакции по пути Справка ® Создание сообщения поддержки; или сотрудник службы поддержки создает сообщение поддержки непосредственно в SAP Solution Manager на закладке Сообщения или Служба поддержки ® Создание сообщения.

1. Система автоматически выполняет сбор системных данных для сообщения поддержки.

2. Сообщение поддержки поступает в службу поддержки.

a. Система автоматически присваивает сообщение поддержки соответствующему уровню поддержки, например, согласно компоненту SAP, приоритету или типу сообщения поддержки.

b. Система автоматически определяет соответствующих бизнес-партнеров, например, клиента, ключевого пользователя или группу обработчиков.

c. Система создает сервисную операцию в SAP Solution Manager.

d. При соответствующей пользовательской настройке система проверяет наличие контрактов для данной инсталляции и клиента. Такой контракт может, например, содержать соглашение об уровне сервисного обслуживания (SLA), гарантирующее клиенту определенные услуги, например, максимальное время реакции.

При наличии контракта выберите релевантную статью контракта, например, "Поддержка", "Консалтинг" или "Разработка".

3. В сообщении поддержки ответственный член отдела поддержки определяет себя в качестве обработчика.

4. В собственной базе данных решений клиента выполните поиск решения проблемы, описанной клиентом.

5. При отсутствии решения в базе данных решений клиента выполните поиск SAP-нот в SAP Service Marketplace.

В случае обнаружения релевантной SAP-ноты выполните ее присвоение сообщению поддержки. При помощи SAP Note Assistant можно импортировать и тестировать соответствующие SAP-ноты с исправлениями текста непосредственно в системе разработок и тестирования. После тестирования выполните перенос изменений в систему обеспечения качества или продуктивную систему. Любые нежелательные изменения можно легко отклонить при помощи SAP Note Assistant.

6. При отсутствии решения в SAP Service Marketplace включите в клиентское сообщение внутреннее примечание с подробной информацией о мерах, предпринятых для поиска решения, и далее перенесите сообщение о проблеме в соответствующие единицы поддержки.

7. Если следующий отдел поддержки также не может решить проблему, включите в сообщении о проблеме информацию для SAP с соответствующими приложениями и отправьте сообщение о проблеме в SAP-поддержку (фронтэнд SAPNet R/3).

8. В SAP-поддержке выполняется обработка сообщения, после чего оно отправляется назад с предложенным решением или дальнейшим вопросом и обновленным статусом.

Статус сообщения поддержки можно контролировать в любое время в службе поддержки.

9. Соответствующие члены внутренней группы поддержки, например, центров компетенции клиента, тестируют и анализируют предложенное решение.

10. Член внутренней группы поддержки поставляет решение пользователю, сообщившему о проблеме, по одному из имеющихся каналов связи.

11. Пользователь, сообщивший о проблеме, тестирует и подтверждает решение.

12. Обработчик службы поддержки закрывает сообщение и формулирует найденное решение для внутренней базы данных решений при наличии возможности его использования другими сотрудниками службы поддержки.


 Обработка сообщений в службе поддержки

Обработка сообщений в службе поддержки

Использование

Сообщения, созданные персоналом или клиентами, необходимо обработать в службе поддержки SAP Solution Manager.

Предпосылки

Наличие роли SAP_SOL_SERVTRANS.

Последовательность шагов

...

1. В меню SAP Easy Access выберите Инструменты ® SAP Solution Manager ® Операция решения (SOLUTION_MANAGER).

2. Выберите системную среду решения.

3. Выберите Служба поддержки.

4. Просмотрите сообщение:

Ў Для просмотра списка открытых сообщений поддержки выберите путь Все открытые сообщения ® Выполнить в справке по допустимым значениям ввода.

Ў Для поиска сообщения:

i. Выберите экранную кнопку Запуск контроля транзакции и задайте критерии выбора.

Будет выполнен переход к транзакции Контроль сервисных операций (CRM_DNO_SERVICE_MONITOR).

ii. Выберите сообщение и затем Подробно.

Появится подробный экран сообщения.

5. Для просмотра всех подробных данных сообщения можно выбрать кнопку со стрелкой Показать минимум.

Для настройки просмотра сообщения со всеми подробными данными для пользователя выберите закладку Дополнительная информация ® Параметры настройки ® Общее и в области экрана Локатор установите флаг Сузить для вида просмотра.

6. Для обработки сообщения выберите экранную кнопку Изменить.

7. В области экрана Ссылка выберите обработчика сообщения в справке по допустимым значениям ввода.

8. Выберите экранную кнопку Переменные данные.

9. Выполните обработку сообщения. Имеются следующие возможности:

Ў загрузка документов

Ў создание документов и URL

Ў поиск решений во внутренней базе данных решений

Ў поиск решений в SAP Service Marketplace

Ў автоматический импорт SAP-нот с руководством по корректурам:

i. При наличии подходящей SAP-ноты с автоматически импортируемым руководством по корректурам выполните ее присвоение сообщению поддержки в SAP Service Marketplace.

ii. Вернитесь к службе поддержки.

iii. Выберите SAP-ноту.

iv. В режиме изменения выберите экранную кнопку Note Assistant.

v. Определите RFC-соединение с системой разработок и тестирования, в которую необходимо импортировать SAP-ноту.

vi. Импортируйте ноту. Для получения дополнительной информации см. справку SAP Note Assistant.

vii. Выполните тестирование изменений.

viii. Выполните перенос изменений в систему обеспечения качества или продуктивную систему.

Любые нежелательные изменения можно отклонить при помощи SAP Note Assistant.

Ў отправка сообщений автору и другим обработчикам;

Ў перенос сообщения поддержки к другим обработчикам и в SAP

10. Выберите экранную кнопку Быстрый ввод и присвойте сообщению статус.

11. Сохраните изменения.


 Поиск решения к сообщению поддержки

Поиск решения к сообщению поддержки

Использование

Сообщения, созданные персоналом или клиентами, необходимо обработать в службе поддержки SAP Solution Manager.

Предпосылки

На подробном экране сообщения поддержки выполнен переход к транзакции Контроль сервисных операций.

Последовательность шагов

...

Поиск решения в SAP Service Marketplace

...

1. Перейдите в режим изменения.

2. Для поиска SAP-нот в SAP Service Marketplace выберите экранную кнопку Поиск нот на закладке SAP-ноты.

Будет выполнен переход к SAP Service Marketplace.

3. Войдите в систему SAP Service Marketplace.

4. Выполните поиск SAP-нот по маске поиска.

5. Выполните присвоение найденной SAP-ноты сообщению поддержки, скопируйте номер ноты и краткий текст SAP-ноты на закладку SAP-ноты.

Для просмотра присвоенной SAP-ноты выберите SAP-ноту и затем Просмотр ноты.

SAP-ноты с руководством по корректурам можно автоматически импортировать в системы. Для получения дополнительной информации см. Обработка сообщений в службе поддержки.

6. Выйдите из SAP Service Marketplace путем закрытия окна браузера.

Поиск решения в базе данных решений

При отсутствии подходящей SAP-ноты для проблемы выполните поиск решения проблемы, уже задокументированного в базе данных решений.

...

1. Перейдите в режим изменения.

2. На закладке База данных решений выберите экранную кнопку Поиск в базе данных решений.

В качестве критерия поиска по умолчанию используется краткий текст сообщения поддержки.

3. Задайте критерии поиска и выберите Дальше.

Система выводит существующие симптомы и решения для сообщения поддержки. Эти решения можно скопировать в сообщение поддержки.


 Передача сообщения поддержки в SAP

Передача сообщения поддержки в SAP

Использование

При невозможности обработки сообщения поддержки и отсутствии решения в SAP-нотах или базе данных решений необходимо выполнить передачу этого сообщения поддержки в SAP-поддержку.

Предпосылки

На подробном экране сообщения поддержки выполнен переход к транзакции Контроль сервисных операций.

Последовательность шагов

...

1. На закладке Обзор введите информацию для SAP.

2. На закладке Документы присоедините документы для сообщения поддержки.

3. Выберите экранную кнопку Операция.

4. Из раскрывающегося списка выберите Отправить сообщение в SAP.

5. Сохраните изменения.

При сохранении система отправляет сообщение поддержки.

Результат

Процедуру можно контролировать на закладке Атрибуты SAP:

· Выводится номер сообщения процедуры фронтэнда SAPNet R/3.

· Изменяемый статус можно контролировать.


Glossary

Finding terms

To search for a glossary term, enter the term in the text field of the Index tab.

To search for a term in the full text, enter the term in the text field of the Search tab, and press Enter or the pushbutton List Topics.

Displaying terms

To display a term highlighted in the list box, double-click on it or press the pushbutton Display.


HTML Help Viewer Help

Use

With the HTML Help Viewer you can view the SAP Library in file format Compiled HTML (*.CHM).

Features

The HTML Help Viewer comprises:

  • A topic window for displaying the current help document.
  • A navigation window for displaying the current table of contents, the keyword search and the full-text search. (The navigation window can be hidden or shown: Hide/Show.)
  • A toolbar containing navigation and print functions, etc.

If you go to other help files while navigating through the online help, other HTML Help Viewer instances are opened. These instances can be closed individually. If you close the initial instance, all viewer instances are closed.

To go to the first page of the SAP Library, choose Home. You have access to the entire documentation from there: SAP Library, Glossary, Implementation Guide (IMG) and Release Notes.

Finding Help Documents

To find help documents:

  • Navigate in the table of contents tree structure (Contents tab)
    • To expand or collapse all branches of the table of contents tree, click the right-hand mouse key in the navigation window and choose Expand all or Collapse all in the context menu.
    • To move backwards and forwards in a navigation path, choose Back or Forward in the toolbar. This applies to the navigation path within an HTML Help Viewer instance.
    • To display only the entries for particular info classes in the table of contents, click the right-hand mouse key in the navigation window and choose Customize... in the context menu. Specify in the following dialog which info classes are to appear in the table of contents.
  • Perform a keyword search (Index tab)

The complete index is displayed if you are in the SAP Library; the index of the current help file is displayed if you are in another help file. No Index tab is displayed if no index exists for the current help file.

Loading the complete SAP Library index (approx. 8 MB) can take several minutes, depending on the configuration of your PC.

Select an entry in the list of keywords and choose Display.
If the selected keyword is assigned to only one help document, that document is displayed. Otherwise a list of documents found is offered for selection.

As Release Notes and IMG have no index, only full-text search is possible for them.
  • Perform a full-text search (Search tab)

Enter a search request and choose List Topics.
All documents are searched if you are in the SAP Library; only the documents in the current help file are searched if you are in another help file. The documents found are listed for selection.

To make complex searches:
    • Use the place holder ? for single characters and * for character strings in search terms.
    • Match similar words
    • Combine search terms with the operators:
      • AND (all terms appear in the document)
      • OR (at least one of the terms appears in the document)
      • NOT (the term does not appear in the document)
      • NEAR (the terms occur close together, such as in the same sentence in the document)
    • Restrict the search to document titles (Search titles only)
    • Restrict the search to the set of documents found in the previous search (Search previous results)

A global search in the SAP Library, in particular full-text search, requires a large amount of main memory. Global full-text search should only be used if the help files are on the local hard disk.

Finding the Current Help Document in the Table of Contents

If you found the current topic by search or hyperlink, the position of the topic in the table of contents is not displayed. To find the topic in the table of contents, choose Locate in the HTML Help Viewer toolbar.

If you found the current topic by a global (full-text or keyword) search in the SAP Library, the help file containing the topic must first be found. Click on the Locate icon [image] in the topic title. Then choose Locate in the toolbar to expand the help file table of contents and find the position of the topic.

Printing Help Documents

You can print individual help documents or several documents at the same time:

  • To print the current topic, choose Print with the option Print the selected topic.
  • To print the current topic and all its subtopics, choose Print with the option Print the selected heading and all subtopics.


SAP Library

 Entering home page
SAP Library
SAP R/3 Enterprise, March 2003
mySAP Technology Components, Release 6.20 (Support Package 09), September 2002
SAP Library

Glossary

Getting Started

© Copyright 2003 SAP AG
All rights reserved.
Leaving home page


Broken link

 Entering content frame

flash Error: Broken link

You tried to follow a link that points to an unknown target document.

 Leaving content frame